Subject: [BEHAVE] Multicast translation draft

From: Stig Venaas <[email-masked]>
Date: Tue, 20 Jan 2009 11:11:52 +0100

A while ago I submitted the draft draft-venaas-behave-mcast46-00
describing an IPv4 - IPv6 multicast translator solution.

I would appreciate any feedback on the draft,

Stig
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: <[email-masked]>
Date: Tue, 20 Jan 2009 19:47:12 +0900

Hi Stig,

Sorry, I have not read it yet, but is it different idea of mine?

http://www.ietf.org/internet-drafts/draft-miyata-v6ops-snatpt-02.txt

See,

11.8 Multicast Translation

Regards,

------------------------------------
Hiroshi Miyata,
Ubiquitous Field Computing Research Center,
Corporate R&D Headquaters,
Yokogawa Electric Corp.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Stig Venaas
> Sent: Tuesday, January 20, 2009 7:12 PM
> To: [email-masked]
> Subject: [BEHAVE] Multicast translation draft
>
> A while ago I submitted the draft
> draft-venaas-behave-mcast46-00 describing an IPv4 - IPv6
> multicast translator solution.
>

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 28 Jan 2009 12:52:11 -0800

> Sent: Tuesday, January 20, 2009 2:12 AM
> To: [email-masked]

This draft feels quite complete.  

I wrote draft-wing-behave-learn-prefix-00.txt which was 
primarily aimed at the following problem:  I imagine it could 
be common for the multicast application running on the IPv6-only
host to only learn an IPv4 multicast address (via an
electronic program guide, SDP, or whatever other means it
might learn of multicast addresses).  But the draft requires
the IPv6-only host join the IPv6 multicast group which requires
the IPv6-only host somehow know the IPv6 prefix associated
with that IPv4 address and the SSM/ASM mapping between IPv6
and IPv4.  If I'm on track with my imagination then a discussion
of this might be helpful.  

BEHAVE working group:  is there interest in this draft?

-d

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 28 Jan 2009 12:52:17 -0800

Yes, Stig's draft has more specific detail of the IPv4/IPv6 mapping between
the multicast domains.

-d

> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Tuesday, January 20, 2009 2:47 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [BEHAVE] Multicast translation draft
> 
> Hi Stig,
>