Subject: [BEHAVE] Learning the IPv6 Prefix of a NAT64 (draft-wing-behave-learn-prefix-01)

From: "Dan Wing" <[email-masked]>
Date: Tue, 17 Mar 2009 08:58:30 -0700

Last week I submitted a new version of "Learning the IPv6 Prefix of a NAT64",
http://tools.ietf.org/html/draft-wing-behave-learn-prefix-01.  It describes
how an application can learn the prefix of its NAT64 via DNS or via DHCP.  The
DNS query would be sent to its DNS server, which is its DNS64 if the service
provider is running a DNS64+NAT64.  DHCP is per-interface.  Both the DNS and
DHCP methods allow the host to choose different NAT64s for different purposes
(cost, performance, type of link).

The significant change in this version is that a DNS NAPTR query is sent,
rather than querying for a TXT record.

I do not intend to present this document in San Francisco.  Rather, this
document exists to show it is possible for applications to learn the NAT64
prefix if they need to construct synthetic IPv6 addresses themselves.  So far,
only three applications have been identified which might benefit from this
functionality:  DNSSEC, BitTorrent, and SIP.

Comments welcome.

-d

---

From: wangxuewei <[email-masked]>
Date: Thu, 19 Mar 2009 17:03:22 +0800

hi,

read through your draft draft-wing-behave-learn-prefix-01 ,the IPv6 prefix and the prefix length can be learned using DNS or DHCP.

what i think is there exists another method of learning the prefix and length by Router Advertisement (RA) message, for the IPv6 host attaches to the same multicast link as AFT, AFT can directly periodically advertise(or in response to valid Router Solicitations) RA messages containing the /96 prefix and length to the IPv6 host. 

For the IPv6 host attaches to the different multicast link with AFT, we can make AFT use dynamic routing protocol (OSPF?ISIS etc) to announce the /96 prefix and length to edge routers in the IPv6 domain, thus edge routers in the IPv6 domain obtain the /96 prefix and length, they can periodically advertise(or in response to valid Router Solicitations) RA messages containing the /96 prefix and length.

how do you think this method ? 
thanks

Xuewei Wang
  ----- Original Message ----- 
  From: Dan Wing 
  To: [email-masked] 
  Sent: Tuesday, March 17, 2009 11:58 PM
  Subject: [BEHAVE] Learning the IPv6 Prefix of a NAT64(draft-wing-behave-learn-prefix-01)

  Comments welcome.

  -d

  _______________________________________________
  Behave mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Sat, 21 Mar 2009 15:50:35 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of wangxuewei
> Sent: Thursday, March 19, 2009 2:03 AM
> To: Dan Wing; [email-masked]
> Subject: Re: [BEHAVE] Learning the IPv6 Prefix of a 
> NAT64(draft-wing-behave-learn-prefix-01)
> 
> hi,
> 
> read through your draft draft-wing-behave-learn-prefix-01 
> ,the IPv6 prefix and the prefix length can be learned using 
> DNS or DHCP.
>  
> what i think is there exists another method of learning the 
> prefix and length by Router Advertisement (RA) message, for 
> the IPv6 host attaches to the same multicast link as AFT, AFT 
> can directly periodically advertise(or in response to valid 
> Router Solicitations) RA messages containing the /96 prefix 
> and length to the IPv6 host. 

That seems reasonable.

> For the IPv6 host attaches to the different multicast link 
> with AFT, we can make AFT use dynamic routing protocol 
> (OSPF、ISIS etc) to announce the /96 prefix and length to edge 
> routers in the IPv6 domain, thus edge routers in the IPv6 
> domain obtain the /96 prefix and length, they can 
> periodically advertise(or in response to valid Router 
> Solicitations) RA messages containing the /96 prefix and length.

Today, at least, dynamic routing protocols aren't propagated to subscribers.
Is that expected to change with IPv6, or would most subscribers use default
routes as with today's IPv4?  

-d

> 	From: Dan Wing <mailto:[email-masked]>  
> 	To: [email-masked]

---

From: wangxuewei <[email-masked]>
Date: Wed, 25 Mar 2009 10:03:08 +0800

Perhaps you misunderstand my meanings. 

AFT serving as router uses dynamic routing protocol to pass the prefix and length to edge routers, 
and edge routers use RA message to pass the prefix and length to subscribes.
The purpose of this process is to make IPv6 hosts learn the prefix and length, not learn the route from host to AFT.

As for the route,subscribers can use default routes as with today's IPv4 to edge routers.

Xuewei Wang
  ----- Original Message ----- 
  From: Dan Wing 
  To: 'wangxuewei' ; [email-masked] 
  Sent: Sunday, March 22, 2009 6:50 AM
  Subject: RE: [BEHAVE] Learning the IPv6 Prefix of a NAT64(draft-wing-behave-learn-prefix-01)

  That seems reasonable.

  -d