Subject: [BEHAVE] [Fwd: I-D Action:draft-miyata-behave-prefix64-02.txt]

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 09 Mar 2009 11:02:49 +0100

I have submitted a new version of this one, cause i missed one set of 
comments is received in the previous one

sorry for the confusion

regards, marcelo

-------- Mensaje original --------
Asunto: 	I-D Action:draft-miyata-behave-prefix64-02.txt
Fecha: 	Mon, 9 Mar 2009 02:45:02 -0700 (PDT)
De: 	[email-masked]
Responder a: 	[email-masked]
Para: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : PREFIX64 Comparison
	Author(s)       : H. Miyata, M. Bagnulo
	Filename        : draft-miyata-behave-prefix64-02.txt
	Pages           : 24
	Date            : 2009-03-09

This draft compares different IPv6 prefix formats that can be used by
IPv6-IPv4 translator to represent IPv4 addresses in the IPv6
Internet.  The goal of the draft is asses the benefits and problems
of each proposed format and make a recommendation about which prefix
to use in the different scenarios considered.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-miyata-behave-prefix64-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Tue, 10 Mar 2009 09:21:29 +0100

Dear authors,

Thank you for this draft.

Some quite generic comments:

Do you think the scope of this document can be enlarged, keeping the focus on how to choose Prefix64? 
I'm thinking of some IPv4 into IPv6 encapsulation scenarios (and not only translation scenarios). 
In these scenarios you build the IPv6 destination address of the IPv6 packet that will encapsulate an IPv4 packet, based only on the information of the IPv4 packet (mainly A+P). The encapsulation is then stateless. 
Typically, the IPv6 destination address has the generic format you provide in Fig 2.1. 
Examples can be found in I-D.boucadair-behave-ipv6-portrange and in I-D.despres-sam-scenarios.

In some cases, the IPv4 address may be represented differently as simply the rough 32 bits. This is in order to force the total prefix length (PREFIX64+IPv4 address+extra info) to stay within a given boundary (e.g. /64). Space concern can be important when you need to put not only an IPv4 address but also a port information in the IPv6 address. Example of construction can be found in I-D.despres-sam.

In the first Figure in section "5.1.  IPv6 Routing system scalability":
I don't see why, and how, the IPv4 site is connected to an IPv6 ISP, and precisely to the very one that connects the IPv6 site it communicates with?

Regards,

Pierre

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de marcelo bagnulo braun
Envoyé : lundi 9 mars 2009 11:03
À : Behave WG
Objet : [BEHAVE] [Fwd: I-D Action:draft-miyata-behave-prefix64-02.txt]

sorry for the confusion

regards, marcelo

---

From: <[email-masked]>
Date: Tue, 10 Mar 2009 17:32:20 +0900

Hi Pierre,

Thanks for your comments and proposal.

This is very quick reply to your first proposal.

Unfortunately, I think the work should be proceeded separately.
Sinced the context is different, the analysis should be different.
It eventually accelerate the discussion.

Regards,

------------------------------------
Hiroshi Miyata,
Ubiquitous Field Computing Research Center,
Corporate R&D Headquaters,
Yokogawa Electric Corp.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Tuesday, March 10, 2009 5:21 PM
> To: [email-masked]; [email-masked]; Miyata, Hiroshi 
> ([email-masked])
> Subject: RE: [BEHAVE] [Fwd: I-D 
> Action:draft-miyata-behave-prefix64-02.txt]
> 
> Dear authors,
> 
> Do you think the scope of this document can be enlarged, 
> keeping the focus on how to choose Prefix64? 
> In these scenarios you build the IPv6 destination address of 
> the IPv6 packet that will encapsulate an IPv4 packet, based 
> only on the information of the IPv4 packet (mainly A+P). The 
> encapsulation is then stateless. 
> In some cases, the IPv4 address may be represented 
> differently as simply the rough 32 bits. This is in order to 
> force the total prefix length (PREFIX64+IPv4 address+extra 
> info) to stay within a given boundary (e.g. /64). Space 
> concern can be important when you need to put not only an 
> IPv4 address but also a port information in the IPv6 address. 
> Example of construction can be found in I-D.despres-sam.
> 
> I don't see why, and how, the IPv4 site is connected to an 
> IPv6 ISP, and precisely to the very one that connects the 
> IPv6 site it communicates with?
> 
> 
> Regards,
> 
> Pierre
>  
> 
> De : [email-masked] [mailto:[email-masked]] 
> De la part de marcelo bagnulo braun Envoyé : lundi 9 mars 
> 2009 11:03 À : Behave WG Objet : [BEHAVE] [Fwd: I-D 
> Action:draft-miyata-behave-prefix64-02.txt]
> 
> I have submitted a new version of this one, cause i missed 
> one set of comments is received in the previous one
> 
> sorry for the confusion
> 
> regards, marcelo
> 
> 
> Internet.  The goal of the draft is asses the benefits and 
> problems of each proposed format and make a recommendation 
> about which prefix to use in the different scenarios considered.
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
> 
> 
>

---

From: <[email-masked]>
Date: Tue, 10 Mar 2009 10:08:49 +0100

Well, as far as Prefix64 is concerned, I don't think the two contexts and analyses would be that different.
How you retrieve, know, which Prefix64 to select, seems quite independent on what the packet bears.
Once the IPv6 packet is formed, whether it carries an IPv4 packet or a TCP segment (or whatsoever), the routing issues apply in the same way.

Pierre

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mardi 10 mars 2009 09:32
À : LEVIS Pierre RD-CORE-CAE; [email-masked]; [email-masked]
Objet : RE: [BEHAVE] [Fwd: I-D Action:draft-miyata-behave-prefix64-02.txt]

Hi Pierre,

Regards,

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 10 Mar 2009 12:00:08 +0100

Hi Pierre,

> Do you think the scope of this document can be enlarged, keeping the focus on how to choose Prefix64? 
that makes perfect sense to me
I mean, if we decide to go for a WK prefix, then this can be used for 
any other usage that needs an IPv4 address representation in IPv6 
address space.

> Examples can be found in I-D.boucadair-behave-ipv6-portrange and in I-D.despres-sam-scenarios.
right, so what would be the differences between using a WK prefix and a 
LIR prefix in this case?

> In some cases, the IPv4 address may be represented differently as simply the rough 32 bits. This is in order to force the total prefix length (PREFIX64+IPv4 address+extra info) to stay within a giv…

Do you think the potential issue is the number of bit that you need? 
I.e. having a shorter prefix could be more useful and this is harder to 
achieve with a LIR prefix? or are you thinking in something else?

> I don't see why, and how, the IPv4 site is connected to an IPv6 ISP, and precisely to the very one that connects the IPv6 site it communicates with?
right, i should have included a NAT64 box between the IPv4 site and the 
IPv6 ISP
sorry for that
the point here is that the IPv4 site has servers that want to be 
reachabel from the IPv6 internet, make sense now?

Regards,marcelo

---

From: <[email-masked]>
Date: Wed, 11 Mar 2009 08:51:35 +0900

Hi Pierre,

Maybe it is true that those are not different.
My point is it is better to discuss forcusing on each nature, purpose etc... purely.
And, as the conclusion, if we concluded both has very similar nature, those 
could be conbined or refered each other.
Making two things always delays the progress.
Of course if you think both are almost same, then you can refer to ours.

I think it is the simplest way and make things speedy.
I am not negative combining them itself if it is reasonable.
What I am concerning is "Speed".

How do you think?

> Sent: Tuesday, March 10, 2009 6:09 PM
> To: Miyata, Hiroshi ([email-masked]); 
> [email-masked]; [email-masked]
> Well, as far as Prefix64 is concerned, I don't think the two 
> contexts and analyses would be that different.
> Once the IPv6 packet is formed, whether it carries an IPv4 
> packet or a TCP segment (or whatsoever), the routing issues 
> apply in the same way.
> 
> Pierre
> 
> 
> 
> De : [email-masked] 
> [mailto:[email-masked]] Envoyé : mardi 10 mars 2009 
> 09:32 À : LEVIS Pierre RD-CORE-CAE; [email-masked]; 
> [email-masked] Objet : RE: [BEHAVE] [Fwd: I-D 
> Ubiquitous Field Computing Research Center, Corporate R&D 
> Headquaters, Yokogawa Electric Corp.
> 
>  
> 
> > I'm thinking of some IPv4 into IPv6 encapsulation scenarios 
> (and not 
> > only translation scenarios).
> > In these scenarios you build the IPv6 destination address 
> of the IPv6 
> > packet that will encapsulate an IPv4 packet, based only on the 
> > information of the IPv4 packet (mainly A+P). The 
> encapsulation is then 
> > stateless.
> > In some cases, the IPv4 address may be represented differently as 
> > simply the rough 32 bits. This is in order to force the 
> total prefix 
> > length (PREFIX64+IPv4 address+extra
> concern can be 
> > important when you need to put not only an

---

From: <[email-masked]>
Date: Wed, 11 Mar 2009 06:51:34 +0100

Hi all,

I fully agree with Pierre that there is no difference between the both (which should be teated simultaneousily).

Cheers
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 11 mars 2009 00:52
À : LEVIS Pierre RD-CORE-CAE; [email-masked]; [email-masked]
Objet : Re: [BEHAVE] [Fwd: I-D Action:draft-miyata-behave-prefix64-02.txt]

Hi Pierre,

And, as the conclusion, if we concluded both has very similar nature, those could be conbined or refered each other.

How do you think?

------------------------------------
Hiroshi Miyata,
Ubiquitous Field Computing Research Center, Corporate R&D Headquaters, Yokogawa Electric Corp.

> To: Miyata, Hiroshi ([email-masked]); [email-masked]; 
> [email-masked]
> Once the IPv6 packet is formed, whether it carries an IPv4 packet or a 
> TCP segment (or whatsoever), the routing issues apply in the same way.
> 
> Pierre
> 
> 
> 
> Ubiquitous Field Computing Research Center, Corporate R&D Headquaters, 
> Yokogawa Electric Corp.
> 
>  
> 
> > De : [email-masked] [mailto:[email-masked]] De la 
> > part de marcelo bagnulo braun Envoyé : lundi 9 mars
> > I have submitted a new version of this one, cause i missed one set 
> > of comments is received in the previous one
> > 
> > sorry for the confusion
> > 
> > regards, marcelo
> > 
> > 
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: <[email-masked]>
Date: Wed, 11 Mar 2009 11:47:46 +0100

I understand your point, 
However, on the other hand, we could lose time if we only confront the two tracks at the end.
For me the important point is: if there are two tracks followed separatly for Prefix64 issues: one for translation, one for encapsulation, the two should evolve and exchange quite closely.

Pierre

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 11 mars 2009 00:52
À : LEVIS Pierre RD-CORE-CAE; [email-masked]; [email-masked]
Objet : RE: [BEHAVE] [Fwd: I-D Action:draft-miyata-behave-prefix64-02.txt]

Hi Pierre,

How do you think?

---

From: MIYATA HIROSHI <[email-masked]>
Date: Fri, 13 Mar 2009 10:37:30 +0900

Pierre,

I got your point.
It is natural that if the purpose and/or nature are not same, the
discussion should be separated.
But if those are the same they must be discussed together.
Anyway, let's meet and talk at SFO. ;-)

...miyata

On 2009/03/11, at 19:47, <[email-masked]> <[email-masked] 
 > wrote:

> For me the important point is: if there are two tracks followed  
> separatly for Prefix64 issues: one for translation, one for  
> encapsulation, the two should evolve and exchange quite closely.
>
>
> Pierre
>