Subject: Re: [BEHAVE] Where is the definition of IPv6 only host forNAT64/DNS64

From: Cameron Byrne <[email-masked]>
Date: Fri, 17 Jul 2009 09:41:53 -0700 (PDT)

> 
> > Given that we (mobile operators) are already out of
> IPv4 address
> 
> Why don't you request more?
> 
ARIN issued a statement saying that we cannot bet our business on IPv4 addresses being available, and they require and business officer to attest to the request

https://www.arin.net/knowledge/about_resources/ceo_letter.pdf

I use 5 /8's of illegal IPv4 space today, so scale, timing, and RIR justification process is an issue to just requesting more space.  It is possible that simply requesting more space will work tactically for today, but i don't believe it will work for the proverbial tomorrow.  Mobile users growth is huge. Machine to machine communication on mobile networks is huge.

Perpetuating the IPv4 exhaustion is not the right answer the IETF wants to take, right?  As good stewards of the Internet, we should try to be prudent with the IPv4 public space while building the bridge to IPv6.  And so, our public space is generally only allocated to subscribers that require public space, NAT pools, load balancers, and elements of the architecture that require it for correct data roaming operations.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 20 Jul 2009 16:48:35 +0200

On 17 jul 2009, at 18:41, Cameron Byrne wrote:

> ARIN issued a statement saying that we cannot bet our business on  
> IPv4 addresses being available,

They're still available now.

> and they require and business officer to attest to the request

> https://www.arin.net/knowledge/about_resources/ceo_letter.pdf

So? Big deal.

> I use 5 /8's of illegal IPv4 space today,

And your customers think that's ok?

> Perpetuating the IPv4 exhaustion is not the right answer the IETF  
> wants to take, right?

Of course it is! If half the people act like we're out already and  
then the other half get to point at the unused space and stick their  
heads in the sand, we're never going to get anywhere. We need to use  
up the remaining address space and then we can finally bury IPv4 and  
move on with our lives.

---

From: Cameron Byrne <[email-masked]>
Date: Mon, 20 Jul 2009 08:22:58 -0700 (PDT)

> And your customers think that's ok?
Customers don't know and don't care as long as the service works.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 20 Jul 2009 17:31:47 +0200

> Customers don't know and don't care as long as the service works.

Hm, if you don't give those 84 million addresses to customers, what  
else do you need them for??

Of course the customers will know soon enough when one of these blocks  
starts being used legitimately.