Subject: [BEHAVE] Terminology question for draft-xli-behave-v4v6-prefix-00

From: Dong Zhang <[email-masked]>
Date: Thu, 23 Jul 2009 16:00:56 +0800

Hi Xing

I'm quite confused with the terminology when I read the draft.
The draft shows:
IPG4:  The global IPv4 addresses
ISP4:  The ISP's IPv4 prefix
ISP6:  The ISP's IPv6 prefix
IPG4prefix:  The IPv6 address representation of IPG4
ISP4prefix:  The IPv6 address representation of ISP4.

I have some questions:
1) Is IPG4prefix a prefix or an address? According to the definition, the IPv6 address representation of IPG4, I guess it is an address. But why you include the word "prefix" in it?
2)In figure 4, Represent the IPv6 addresses in IPv4 (stateful)
                    +--+--+--+--+--+--+--+--+--+--+
      ISP6prefix|               ISP6                         |
                    +--+--+--+--+--+--+--+--+--+--+
                     \                                           /
                        \                                     /
                          Mapping is based on session
                                   initiated states
                                       \  /
                                        \/
                                     -+-+-+
                                     |IPv4|
                                     |pool|
                                     -+-+-+
Now that ISP6 is a prefix, what do you mean here?

I feel that the terminology is not clear. And the naming has no rules. IMHO, it isn't convenient for understanding.
Could you please explain these more clearly?  

Thank you very much.
B.R.

2009-07-23 

Dong Zhang

---

From: Xing Li <[email-masked]>
Date: Fri, 24 Jul 2009 12:24:56 +0800

Dong Zhang 写道:

thanks for the comments.

(1) we will try to unify the terminology in the framework document based
on the comments from the community.
(2) in the current draft, we are saying Internet operator's language, so
a prefix is a collection of the IP address defined by network id and
prefix length. for example 166.111.0.0/16 is a prefix and it is a class
B address in IPv4.

regards,

xing

> 1) Is IPG4prefix a prefix or an address? According to the definition,
> the IPv6 address representation of IPG4, I guess it is an address. But
> why you include the word "prefix" in it?
> I feel that the terminology is not clear. And the naming has no rules.
> IMHO, it isn't convenient for understanding.
> ------------------------------------------------------------------------
> *Dong Zhang*