Subject: Re: [BEHAVE] should nat64 keep track of TCP seq numbers?

From: Cameron Byrne <[email-masked]>
Date: Fri, 10 Jul 2009 09:40:30 -0700 (PDT)

> Tracking TCP actions is heavy burden for NAT64 box. To
> lighten it,  the
> aging-time of a flow may be used usually.
> So it is enough to keep track of SYN flying.
> 

Agreed. The simpler the better.  In many NAT44 deployments i have seen, we have to turn off strict sequence number tracking since many TCP stacks have flaws that the NAT44 exposes if it is tracking sequence numbers, especially on mobile devices.

---

From: Reinaldo Penno <[email-masked]>
Date: Sat, 11 Jul 2009 02:29:32 -0400

Hello Cameron,

Interesting the mobile devices statement regarding sequence numbers. I would like to read more on this topic. Do you have any reference or it is just based on deployment experience? 

thanks,

Reinaldo
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Cameron Byrne [[email-masked]]
Sent: Friday, July 10, 2009 9:40 AM
To: 'marcelo bagnulo braun'; 'Behave WG'; 郭大勇
Subject: Re: [BEHAVE] should nat64 keep track of TCP seq numbers?

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave