Subject: Re: [BEHAVE] Comments on draft-v6v4-xlate-stateful-07 // Re: WGLC for translation documents (6 documents)

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 06 Jan 2010 13:24:28 +0100

Hi Xiangsong,

Thanks for the review, see my replies below.

Xiangsong Cui escribió:
> Dear chairs and all,
>
> I have read the draft behave-v6v4-xlate-stateful-07, and I have some 
> comments.
>
> Technical comments, (similar to DNS64 draft)
> section 3.2.4
>         The NAT64 to create the IPv6 address to be included in the
>         destination address field of the outgoing IPv6 packets from the
>          ^^^^^^^^
>         IPv4 address included in the destination address field of the
>                                                     ^^^^^^^^
>         incoming IPv4 packet.
> =>     The NAT64 to create the IPv6 address to be included in the
>         source address field of the outgoing IPv6 packets from the
>         IPv4 address included in the source address field of the
>         incoming IPv4 packet.
> right?
>
correct, fixed
>
> Editorial comments:
> page 6, two interfaces, an IPv4 interface connected to the the IPv4 
> network,
> =>       two interfaces, an IPv4 interface connected to the IPv4 network,
>
fixed
> page 14, result of the flow of packets as described in the Section 3.2 
> but the
> =>          result of the flow of packets as described in the Section 
> 3.2 but they
>
fixed
> page 15, (1st)      For each Session Table Entry (STE), there are then 
> five columns:
> =>        For each TCP or UDP Session Table Entry (STE), there are 
> then five columns:
>
done

> (2nd)     For each Session Table Entry (STE), there are then six columns:
> =>         For each ICMP Query Session Table Entry (STE), there are 
> then six columns:
>
done

> a incoming => an incoming,
> a ICMP    => an ICMP
>

fixed.

Thanks, marcelo

>
> Others are OK, thanks the authors for the good job.
>
> Regards
> Xiangsong
>
> ----- Original Message ----- From: "Dan Wing" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, December 18, 2009 3:47 PM
> Subject: [BEHAVE] WGLC for translation documents (6 documents)
>
>
>> We appear ready to start the working group last call for our set of 
>> IPv6/IPv4
>> translation documents.  This is a two-week WGLC.
>>
>> We need 5 reviewers to say a document is ready before we will forward 
>> the
>> documents to the IESG.  A few people have already volunteered, but we 
>> need
>> more!  Please see 
>> http://trac.tools.ietf.org/wg/behave/trac/wiki/WikiStart.
>> If you are already reading the document, this is easy -- just email 
>> the chairs
>> after your review.
>>
>> The documents starting WGLC are:
>>
>> http://tools.ietf.org/html/draft-ietf-behave-v6v4-framework-04
>> http://tools.ietf.org/html/draft-ietf-behave-v6v4-xlate-05
>> http://tools.ietf.org/html/draft-ietf-behave-v6v4-xlate-stateful-07
>> http://tools.ietf.org/html/draft-ietf-behave-dns64-05
>> http://tools.ietf.org/html/draft-ietf-behave-address-format-03
>> http://tools.ietf.org/html/draft-ietf-behave-ftp64-00
>>
>> This is a two week WGLC finishing on December 31.  Please send 
>> substantive
>> review comments to [email-masked] and (if possible) send editorial 
>> comments
>> only to the authors at [email-masked].
>>
>> Thanks,
>> -Dan and Dave
>>
>> _______________________________________________
>> Behave mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/behave
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 20 Jan 2010 13:46:05 +0100

Thanks for the review

replies below...

Xiangsong Cui escribió:
> Dear chairs and all,
>
> I have read the draft  ietf-behave-dns64-05, I have some comments.
>
> Technical comments:
> section 5.2, the second paragraph,
>      The same algorithm to create an IPv6 address from an IPv4 address
>      MUST be used by both the DNS64 to create the IPv6 address to be
>      returned in the synthetic AAAA RR from the IPv4 address contained
>      in original A RR, and by the IPv6/IPv4 translator to create the
>      IPv6 address to be included in the destination address field of
>                                                           ^^^^^^^^^^^^^^
>      the outgoing IPv6 packets from the IPv4 address included in the
>      destination address field of the incoming IPv4 packet.
>
> in my understanding, the *destination address* with remark should be 
> *source address*, is that right?
>

right, in both occurrences of the destination in the paragraph above.
> Some typos comments,
>
> section 2,
>     The main different in the nature of the two types of prefixes is that
> =>The main difference in the nature of the two types of prefixes is that
>
ok
> Section 5.2
>     of IPv4 addresses defined Section 2 of
> => of IPv4 addresses defined in Section 2 of
>
ok
> whole document,
> a AAAA  => an AAAA
see Dave's replies
changed all of them to a AAAA

regards, marcelo

> Others are OK, thanks the authors for the good job!
>
> Regards
> Xiangsong
>