Subject: [BEHAVE] Address Persistence between Static and Dynamic bindings in stateful NAT64

From: Reinaldo Penno <[email-masked]>
Date: Thu, 7 Jan 2010 18:18:23 -0500

I would like to post the question if address persistence should be used across static and dynamic bindings.

For example, if there is a static/UPnP/NAT-PMP binding mapping an IPv4 address to an IPv6 address (as in port/address forwarding), do all dynamic sessions from this same IPv6 address need to use the same public IPv4 address on the outside?

Thanks,

Reinaldo

---

From: Cameron Byrne <[email-masked]>
Date: Thu, 7 Jan 2010 15:28:29 -0800

> For example, if there is a static/UPnP/NAT-PMP binding mapping an IPv4 address to an IPv6 address (as in port/address forwarding), do all dynamic sessions from this same IPv6 address need to use th…

Yes.

Some SSL VPN products from certain vendors do multiple independent TCP
transaction during the authentication process, and when the source
address changes across these TCP transaction, the SSL VPN fails to
proper authenticate.  It must be using the source IP address as the
"key" across these different TCP transaction.

> Thanks,
>
> Reinaldo
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>