Subject: [BEHAVE] Avoiding the terminology confusion with NAT66

From: Rémi Després <[email-masked]>
Date: Tue, 3 Aug 2010 23:11:08 +0200

Le 3 août 2010 à 22:49, Dan Wing a écrit :
...
>>> If the industry (IETF and the press and authors of books) are going
>> to
>>> overload the meaning of NAT66 to include Port Address Translation, it
>>> will have the same negative effect as the overloaded NAT(44) name.
>> 
>> In my understanding, this overloading is already here, and is
>> unavoidable.
>> It is downloading a natural and popular meaning that is IMHO a mistake.
> 
> If so, I encourage Margaret and Fred to not use NAT66 for their 
> specification.  Rather, "IPv6 Prefix Rewriting".  "6pr" almost rolls off
> the tongue.

+1 for this new name

Other names could do it too, e.g. PT66 for prefix translation, or SPT for Stateless Prefix Translation, whatever Margaret and:or the majority would prefer, provided it isn't NAT66.

Regards,
RD

---

From: Randy Bush <[email-masked]>
Date: Tue, 03 Aug 2010 23:43:25 +0200

>> specification.  Rather, "IPv6 Prefix Rewriting".  "6pr" almost rolls
>> off the tongue.
> Other names could do it too, e.g. PT66 for prefix translation, or SPT
> for Stateless Prefix Translation, whatever Margaret and:or the
> majority would prefer, provided it isn't NAT66.

since we're into deceptive marketing, why not call it chocolate ice
cream?

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 05 Aug 2010 17:46:26 -0700

> I think it's the other way around.  To use your example, NAT66 is a
> name many people are using to describe all flavors of ice cream.
> Margaret's draft is a particular flavor of ice cream.  It would be
> better to call it chocolate ice cream :-)

if it translates addresses, that is sufficiently significant that NAT
should be in the name.  so chocoNAT is fine with me.  or maybe cocoNAT

randy

---

From: Bob Hinden <[email-masked]>
Date: Thu, 5 Aug 2010 14:40:38 -0700

Randy,

> since we're into deceptive marketing, why not call it chocolate ice

I think it's the other way around.  To use your example, NAT66 is a name many people are using to describe all flavors of ice cream.  Margaret's draft is a particular flavor of ice cream.  It would be better to call it chocolate ice cream :-)

Bob

---

From: Bob Hinden <[email-masked]>
Date: Thu, 5 Aug 2010 18:39:52 -0700

> should be in the name.  so chocoNAT is fine with me.  or maybe cocoNAT

How about pomegraNATe :-)

Bob

---

From: Rémi Després <[email-masked]>
Date: Sat, 7 Aug 2010 14:29:23 +0200

Le 5 août 2010 à 23:40, Bob Hinden a écrit :

> I think it's the other way around.  To use your example, NAT66 is a name many people are using to describe all flavors of ice cream.  

Right

> Margaret's draft is a particular flavor of ice cream.  

> It would be better to call it chocolate ice cream :-)

+1 ;-)

RD

---

From: Mark Smith <[email-masked]>
Date: Sat, 7 Aug 2010 01:28:05 +0930

On Thu, 5 Aug 2010 18:39:52 -0700

> How about pomegraNATe :-)

DefiNATely!

---

From: Simon Leinen <[email-masked]>
Date: Fri, 06 Aug 2010 21:40:08 +0200

> How about pomegraNATe :-)

As in "Prefix-Only Modification for Enhanced Guidance,
which Ran^Hdicals Accuse of Nasty Address-Torturing Evilness"?
-- 
Simon.