Subject: [BEHAVE] [behave] address format draft

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 17 Feb 2011 08:23:34 -0800 (PST)

Hi Med,
  I read draft-qin-softwire-dslite-multicast. 
Qualifying this draft as encapsulation draft IMHO is wrong. It does translation 
for IGMP into MLD but it uses encapsulation for multicast data.

As such it is hybrid.

That is why (due to translation) you need address translation not due to 
encapsulation.

Take away for your address format I-D: there is no case for encapsulation, but 
there is only for translation. 

Regards,

Behcet

---

From: Jacni Qin <[email-masked]>
Date: Fri, 18 Feb 2011 09:23:18 +0800

Hi Behcet,

I'd rather not argue which category the mDS-Lite draft should be of, there
were similar stories.
While the RFC6052 is for both translation and encapsulation, see Section1.1

Cheers,
Jacni

On Fri, Feb 18, 2011 at 12:23 AM, Behcet Sarikaya
<[email-masked]>wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 18 Feb 2011 01:44:42 +0000

Hi Behcet,

The mcast address format draft discusses how to embed an IPv4 group
address in an IPv6 group address. It doesn't discuss how IPv4-IPv6
multicast should be implemented. We reference
"draft-qin-softwire-dslite-multicast" in the draft because it requires a
standard format to embed the IPv4 multicast address to make the
encapsulation possible. This is also true for the mesh-multicast draft.

Regards,
Yiu

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 18 Feb 2011 08:10:39 -0800 (PST)

My comment was referring to the S bit the draft had in -00.
I said that is not needed.

Having looked at -01, I realize that S bit has been abandoned. I am OK with it.

I suggest that any discussion on encapsulation in 

draft-boucadair-behave-64-multicast-address-format

be simply removed.

Regards,

Behcet

>
>Hi Behcet,
>
>I'd rather not argue which category the mDS-Lite draft should be of, there were 

>similar stories.
>On Fri, Feb 18, 2011 at 12:23 AM, Behcet Sarikaya <[email-masked]> 
>wrote:
>
>Hi Med,

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 18 Feb 2011 08:12:27 -0800 (PST)

> encapsulation possible. This is also true for the mesh-multicast  draft.

Yiu, please see my comments to Jacni.

Regards,

Behcet

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 18 Feb 2011 16:14:15 +0000

Behcet,

I read the reply. I think in 00 and 01 we listed the reference for
motivation behind this draft. I am ok to remove them when this becomes a
WG item.

Regards,
Yiu