Subject: [BEHAVE] IPR on draft-donley-behave-deterministic-cgn

From: Chris Donley <[email-masked]>
Date: Wed, 5 Oct 2011 16:08:23 -0600

The WG should be aware of IPR on draft-donley-behave-deterministic-cgn, https://datatracker.ietf.org/ipr/1617

Chris

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 5 Oct 2011 17:17:36 -0500

Hi, Chris.

> The WG should be aware of IPR on draft-donley-behave-deterministic-cgn, https://datatracker.ietf.org/ipr/1617

Thanks for pointing this out.  Can you also provide a pointer to details of your patent application?  After quickly reading the draft, it's not clear to me what novel technique you're claiming.  Additional clarity would be appreciated.

Cheers,
-Benson

---

From: Chris Donley <[email-masked]>
Date: Wed, 5 Oct 2011 17:11:03 -0600

Benson,

I guess the patent app hasn't made it to the USPTO website yet (the app number is in the disclosure - I think you should be able to read it once the patent office posts it). From a high level, it claims deterministic nat mappings with an overflow pool,  geolocation–aware 'outside' address bindings, and an application to reverse the algorithm and identify a user when presented with the IP address and port.

Chris
--
Chris Donley
CCIE, CISSP, SCiPM
Project Director - Network Protocols
CableLabs®
858 Coal Creek Circle
Louisville, CO 80027
303-661-3480 (v)
303-661-9199 (f)

From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Wed, 5 Oct 2011 16:17:36 -0600
To: Chris Donley <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>'" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [BEHAVE] IPR on draft-donley-behave-deterministic-cgn

Hi, Chris.

Cheers,
-Benson