Subject: Re: [BEHAVE] Last Call: <draft-ietf-behave-v4v6-bih-06.txt>

From: Linfeng Zheng <[email-masked]>
Date: Fri, 14 Oct 2011 13:59:57 +0800

> -----Original Message-----
> From: GangChen [mailto:phdgang <phdgang> at gmail.com]
> Sent: Friday, September 30, 2011 2:53 AM
> To: Dan Wing
> Cc: Hui Deng; behave at ietf.org; ietf at ietf.org; softwires at ietf.org;
> Cameron Byrne
> Subject: Re: [BEHAVE] Last Call: <draft-ietf-behave-v4v6-bih-06.txt>
> (Dual Stack Hosts Using "Bump-in-the-Host" (BIH)) to Proposed Standard
>
> >>
> >> Option 1:
> >>
> >> +---------------+
> >> |BIH(FTP sever) |----------NAT64-------FTP Client
> >> +---------------+
> >>
> >>
> >> Option 2:
> >>
> >> +---------------+
> >> |BIH(FTP sever) |--------------FTP Client
> >> +---------------+
> >>
> >> In the case of Option 1, it can't work since NAT64 couldn't support
> >> IPv4 initiated session
> >
> > I agree it would fail with a passive-mode transfer.  But it should
> > work with an active-mode transfer.
> >
>
>> In an active-mode transfer, IPv4 client needs initiate the TCP
>> connection to a port on the FTP sever in advance. Afterwards, FTP
>> server connects back to the client.
>> I'm not sure how could NAT64 support the first step (i.e. IPv4
>> initiated TCP connection)?

>Static mapping in the NAT64, for the FTP control channel (port
>21 or an alternate port).  That could be done by the user's
>profile (draft-cheng-behave-nat-fwd-port-radius-ext), PCP, or
>a web portal that manages the NAT64's configuration.

Would HI-NAT works?

>-d

> Many thanks
> Gang

Thanks, John

郑林峰 John Linfeng Zheng
电话（Tel): 86-25-8577-1689
手机（Mobile): 15195762065

---

From: Linfeng Zheng <[email-masked]>
Date: Fri, 14 Oct 2011 14:03:12 +0800

I means Host-initiated NAT464.

I had a draft http://tools.ietf.org/id/draft-zheng-host-initiated-nat-01.txt,
expired though.

It seems work for active-tranfer, too.

- John CCIE#8670

---------- 已转发邮件 ----------
发件人： Linfeng Zheng <[email-masked]>
日期： 2011年10月14日 下午1:59
主题： Re: [BEHAVE] Last Call: <draft-ietf-behave-v4v6-bih-06.txt>
收件人： [email-masked]

Would HI-NAT works?

Thanks, John

郑林峰 John Linfeng Zheng
电话（Tel): 86-25-8577-1689
手机（Mobile): 15195762065

-- 
光明所结的果子就是一切良善、公义、诚实。       弗5:9

郑林峰 John Linfeng Zheng
电话（Tel): 86-25-8577-1689
手机（Mobile): 15195762065