Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6145 (3061)

From: "Gokhale, Gandhar" <[email-masked]>
Date: Thu, 5 Jan 2012 13:57:15 +0530

Hello,

I've submitted 3 errata on RFC 6145 (eid: 3059, 3060 & 3061) on December 23rd, 2011. They are in reported state. I wonder if something needs to be done from my side for these to move to next state (approved/rejected etc). Please let me know when these will be taken up for conclusion.

Thanks and Regards,
Gandhar Gokhale
________________________________________
From: RFC Errata System [[email-masked]]
Sent: Friday, December 23, 2011 4:49 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Gokhale, Gandhar; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC6145 (3061)

The following errata report has been submitted for RFC6145,
"IP/ICMP Translation Algorithm".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6145&eid=3061

--------------------------------------
Type: Technical
Reported by: Gandhar Gokhale <[email-masked]>

Section: 5.1.1

Original Text
-------------
Fragment Offset:  Copied from the Fragment Offset field of the IPv6 Fragment Header.

Corrected Text
--------------
Fragment Offset:  If the Next Header field of the Fragment Header is not an extension header (except ESP) then Fragment Offset MUST be copied from the Fragment Offset field of the IPv6 Fragment Header. If the Next Header field of the Fragment Header is an extension header (except ESP) then the packet SHOULD be dropped and logged.

Notes
-----
If the fragmentable part (as described in RFC 2460) of the original unfragmented IPv6 packet had extension headers then the translator can not calculate the offset of the IPv4 fragment for non-initial fragments. If extension headers are present in the fragmentable part then the fragment offset value of the IPv6 header includes length of the extension headers also. Since translator strips of the IPv6 extension headers the fragment offset value set by the sender of IPv6 fragments can not match that received by the IPv4 receiver and the reassembly will fail. For non-initial fragments the translator does not have the knowledge of this delta when there is no state maintained.

The legth issue stated in erratum 2 is not in itself sufficient to advocate packet drop. However, the offset issue is sufficient to advocate packet drop as the reassembly is bound to fail. Therefore I'm putting a SHOULD in both cases.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC6145 (draft-ietf-behave-v6v4-xlate-23)
--------------------------------------
Title               : IP/ICMP Translation Algorithm
Publication Date    : April 2011
Author(s)           : X. Li, C. Bao, F. Baker
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Alice Hagens <[email-masked]>
Date: Thu, 5 Jan 2012 10:28:47 -0500

Greetings,

On your side, there is no further action beyond participating (via email) if there is discussion of the errata triggered by the initial mail. 

For RFCs from the IETF stream, the IESG reviews errata and marks them Verified, Rejected, or Held for Document Update. This is described on the following pages:

- How to Report Errata
  http://www.rfc-editor.org/how_to_report.html

- IESG Processing of RFC Errata for the IETF Stream
  http://www.ietf.org/iesg/statement/errata-processing.html

Please let us know if you have further questions.

Thank you.
RFC Editor/ah

---

From: "Gokhale, Gandhar" <[email-masked]>
Date: Wed, 18 Jan 2012 17:33:53 +0530

Hi Alice,
I notice that these errata are still in the Reported state only. I'm wondering why no attention is being given to them. Is there any process to raise the visibility of? Our implementation is dependent on these changes.

Thanks and regards,
Gandhar Gokhale

-----Original Message-----
From: Alice Hagens [mailto:[email-masked]] 
Sent: Thursday, 05 January, 2012 8:59 PM
To: Gokhale, Gandhar
Cc: [email-masked]; RFC Editor
Subject: Re: [Technical Errata Reported] RFC6145 (3061)

Greetings,

- How to Report Errata

Thank you.
RFC Editor/ah