Subject: [BEHAVE] Why is draft-ietf-tsvwg-natsupp not normative in draft-ietf-behave-sctpnat?

From: Martin Stiemerling <[email-masked]>
Date: Thu, 7 Mar 2013 15:59:09 +0100

Hi,

I wonder why draft-ietf-tsvwg-natsupp is not normative in
draft-ietf-behave-sctpnat?

Especially when I read in draft-ietf-behave-sctpnat-08.txt, Section 6,
page 7:
"In this case the INIT SHOULD be dropped by the NAT and an ABORT SHOULD 
be sent back to the SCTP host with the M-Bit set and an appropriate 
error cause (see [I-D.ietf-tsvwg-natsupp] for the format)."

Thanks,

   Martin

-- 
[email-masked]

NEC Laboratories Europe
NEC Europe Limited
Registered Office:
Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB
Registered in England 2832014

---

From: Dan Wing <[email-masked]>
Date: Fri, 8 Mar 2013 08:07:40 -0800

> draft-ietf-behave-sctpnat?

Yes, tsvwg-natsupp should now be a normative reference.

> "In this case the INIT SHOULD be dropped by the NAT and an ABORT SHOULD be sent back to the SCTP host with the M-Bit set and an appropriate error cause (see [I-D.ietf-tsvwg-natsupp] for the format)."

draft-ietf-behave-sctpnat also needs to be clarified on the source address of that ABORT message -- it seems it needs to be sent with the source address of the SCTP server. 

-d

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 10 Mar 2013 09:22:30 -0400

> Yes, tsvwg-natsupp should now be a normative reference.
Correct. It will be in the next revision.
> draft-ietf-behave-sctpnat also needs to be clarified on the source address of that ABORT message -- it seems it needs to be sent with the source address of the SCTP server. 
Correct. I added
The source address of the packet containing the ABORT chunk MUST be the
destination address of the packet containing the INIT chunk.

This will be in the next rev.

Thanks for the comments.

Best regards
Michael