Subject: [BEHAVE] NAT logging for DS-Lite

From: Tom Taylor <[email-masked]>
Date: Fri, 19 Apr 2013 16:03:34 -0400

I think we have to add a parameter to the session records for logging at 
the DS-Lite AFTR. Since the source IPv4 address may not be unique, the 
IPv6 tunnel address should also be logged.

Is there enough deployment of GW-initiated DS-Lite that we should be 
considering other types of tunnel identifier too?

Tom Taylor

---

From: Dan Wing <[email-masked]>
Date: Mon, 22 Apr 2013 12:10:32 -0700

On Apr 19, 2013, at 1:03 PM, Tom Taylor <[email-masked]> wrote:

> I think we have to add a parameter to the session records for logging at the DS-Lite AFTR. Since the source IPv4 address may not be unique, the IPv6 tunnel address should also be logged.

For DS-Lite, I don't see a need to log the inside IPv4 address at all.  The requirement is not to log which host within a subscriber's home caused a mapping, rather the requirement is to identify the subscriber.  The IPv6 address, or rather the first 64 bits of the IPv6 address, are plenty sufficient for that.  If all the subscribers using the DS-Lite have the same IPv6 prefix, the IPv6 prefix doesn't need to be logged (which would be pretty common with most DS-Lite deployments which are for an ISP's own subscribers, and not an Internet-facing service).

-d

> 
> Is there enough deployment of GW-initiated DS-Lite that we should be considering other types of tunnel identifier too?
> 
> Tom Taylor
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave