Subject: [BEHAVE] nat-mib-06: separate MIB modules

From: "ietfdbh" <[email-masked]>
Date: Thu, 2 May 2013 19:14:47 -0400

Hi,

I would like to suggest a change.
If I understand correctly, this document deprecates the entire RFC4008
NAT-MIB, and proposes a completely new MIB under the same name.
I think this is sub-optimal.
In NMS applications that support multiple devices, some of which support
RFC4008 and some of which support this new MIB module, it will be
potentially confusing to call them by the same name.
You really have two completely different MIB modules that you are trying to
sell under the same name.
I think that is not a good idea.

I recommend writing an RFC4008bis document to deprecate the RFC4008 NAT-MIB.
Then put your proposed new MIB objects into a separate MIB module, using a
different name for the newly designed MIB for managing NATs
(maybe NEW-NAT-MIB, but I'd hope for something that more accurately
describes the modified purpose of the MIB, maybe NAT-MONITORING-MIB)
Put this in a separate RFC.

I think that would be a much cleaner solution, and much more obvious what
you are doing here.

David Harrington
[email-masked]
+1-603-828-1401

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Simon Perreault
Sent: Wednesday, May 01, 2013 4:31 AM
To: [email-masked]
Subject: Re: [BEHAVE] I-D Action: draft-ietf-behave-nat-mib-06.txt

Group,

This version fixes MIB syntax issues and updates the security considerations
section according to the recommended boilerplate.

As far as we know this is ready for WGLC.

Simon

Le 2013-05-01 10:28, [email-masked] a écrit :
>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>   This draft is a work item of the Behavior Engineering for Hindrance
Avoidance Working Group of the IETF.
>
> 	Title           : Additional Managed Objects for Network Address
Translators (NAT)
> 	Author(s)       : Simon Perreault
>                            Tina Tsou
>                            Senthil Sivakumar
> 	Filename        : draft-ietf-behave-nat-mib-06.txt
> 	Pages           : 82
> 	Date            : 2013-05-01
>
> Abstract:
>     This memo defines a portion of the Management Information Base (MIB)
>     for devices implementing Network Address Translator (NAT) function.
>     This MIB module may be used for monitoring of a device capable of NAT
>     function.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-behave-nat-mib
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-behave-nat-mib-06
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-behave-nat-mib-06
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

--
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Simon Perreault <[email-masked]>
Date: Fri, 03 May 2013 09:51:42 +0200

David,

What you're proposing is exactly what we had been doing initially. It 
was then suggested to us that we should change to what we have 
currently, which we did. We authors are not MIB doctors, and I don't 
think any one of us really cares which technical form this has. We just 
need the functionality.

Going from one form to another is quite a bit of work, so you'll 
understand we want to be certain that this time we won't be told to go 
back again in the later stages of publication. I'm thinking about IESG 
review here.

So if we could get some early feedback from an AD about which way we are 
expected to go, that would be great.

Thanks,
Simon

---

From: "ietfdbh" <[email-masked]>
Date: Fri, 3 May 2013 15:05:31 -0400

I've asked the other MIB Doctors their opinion.
I'm pretty sure Benoit will see the discussion and can provide guidance.

David Harrington
[email-masked]
+1-603-828-1401

-----Original Message-----
From: Simon Perreault [mailto:[email-masked]] 
Sent: Friday, May 03, 2013 3:52 AM
To: ietfdbh
Cc: [email-masked]; [email-masked]
Subject: Re: nat-mib-06: separate MIB modules

David,

What you're proposing is exactly what we had been doing initially. It was
then suggested to us that we should change to what we have currently, which
we did. We authors are not MIB doctors, and I don't think any one of us
really cares which technical form this has. We just need the functionality.

Going from one form to another is quite a bit of work, so you'll understand
we want to be certain that this time we won't be told to go back again in
the later stages of publication. I'm thinking about IESG review here.

Thanks,
Simon

Le 2013-05-03 01:14, ietfdbh a écrit :
> You really have two completely different MIB modules that you are 
> trying to sell under the same name.
> Then put your proposed new MIB objects into a separate MIB module, 
> using a different name for the newly designed MIB for managing NATs 
> I think that would be a much cleaner solution, and much more obvious 
> what you are doing here.