Subject: [BEHAVE] draft-meng-behave-napgt can be met by PCP port set

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Mon, 29 Jul 2013 13:33:35 +0000

After watching this presentation that generated some ML discussion, it seems to me requirements can be fully met with PCP port set.

Thanks,

Reinaldo

---

From: Qiong <[email-masked]>
Date: Tue, 30 Jul 2013 11:16:02 +0800

Hi Reinaldo,

Yes, I agree with you. This can be achieved by PCP port-set.

Best wishes
Qiong

On Mon, Jul 29, 2013 at 9:33 PM, Reinaldo Penno (repenno) <[email-masked]
> wrote:

>  After watching this presentation that generated some ML discussion, it
> seems to me requirements can be fully met with PCP port set.
>
>  Thanks,
>
>  Reinaldo
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>
>

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/ *
===============================================

---

From: [email-masked]
Date: Tue, 30 Jul 2013 16:16:58 +0800

Hi Qiong, Reinaldo,
  Although port preservation could be achieved by PCP port-set, but how 
can port-set
ensure the port remaining the same before and after the NAT translation? 
That is the 
behavior of port assignment of NAT and it is the very requirement of the 
scenario.
 
Thanks,
Wei

> After watching this presentation that generated some ML discussion, 
> it seems to me requirements can be fully met with PCP port set.
> 
> Thanks,
> 
> Reinaldo
> 

> lightweight 4over6: http://sourceforge.net/projects/laft6/
> PCP-natcoord: http://sourceforge.net/projects/pcpportsetdemo/

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Tue, 30 Jul 2013 08:41:53 +0000

Also possible with port set. It would be good to get your review of the PCP port set draft since you have a concrete use-case.

From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, 30 Jul 2013 16:16:58 +0800
To: Qiong <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Reinaldo Penno <[email-masked]<mailto:[email-masked]>>
Subject: Re: Re: [BEHAVE] draft-meng-behave-napgt can be met by PCP port set

Hi Qiong, Reinaldo,
  Although port preservation could be achieved by PCP port-set, but how can port-set
ensure the port remaining the same before and after the NAT translation? That is the
behavior of port assignment of NAT and it is the very requirement of the scenario.

Thanks,
Wei

> On Mon, Jul 29, 2013 at 9:33 PM, Reinaldo Penno (repenno) <[email-masked]<mailto:[email-masked]>
> > wrote:
> [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

---

From: Simon Perreault <[email-masked]>
Date: Tue, 30 Jul 2013 11:08:23 +0200

Le 2013-07-30 10:41, Reinaldo Penno (repenno) a écrit :
> Also possible with port set.

+1

> It would be good to get your review of the
> PCP port set draft since you have a concrete use-case.

+1

Simon

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca