Subject: [BEHAVE] v6 content for IPv4-only clients

From: Branimir Rajtar <[email-masked]>
Date: Mon, 1 Jul 2013 07:59:25 +0000

Hello everybody,

Just wanted to let you know my colleagues and me just posted a new draft describing how IPv4-only clients can access content available only on IPv6. Please take a look and comment:
http://datatracker.ietf.org/doc/draft-rfvlb-behave-v6-content-for-v4-clients/

Kind Regards,
Branimir

<HTML><P><FONT face=Arial color=#999999 size=1>

IZJAVA O ODRICANJU ODGOVORNOSTI: Sadržaj ove poruke i eventualno priloženih datoteka je povjerljiv i namijenjen je samo osobama ili subjektima koji su navedeni u adresi. Ukoliko ste primili ovu poruku greškom, molimo Vas, obavijestite pošiljatelja, a poruku i sve njene privitke odmah, bez čitanja, trajno uklonite s računala. Bilo kakvo prenošenje, kopiranje ili distribucija informacija sadržanih u poruci trećim osobama je zabranjeno i može biti zakonski kažnjivo. Sadržaj, stavovi i mišljenja izneseni u poruci su autorovi i ne predstavljaju nužno stavove HT - Hrvatskih telekomunikacija d.d. HT ne prihvaća nikakvu odgovornost za eventualnu štetu nastalu primitkom ove poruke i priloga sadržanih u poruci.

</FONT></P><P><FONT face=Arial color=#999999 size=1>

 DISCLAIMER:The contents of this email as well as any files attached to it are confidential and intended solely for individuals or entities which they are addressed to. If you have received this email message in error, please notify the sender and permanently remove the message and all attached files from the computer. Any disclosure, copying or distribution of all or a part of information contained herein to or by third parties is prohibited and may be unlawful. Please note that any views or opinions presented in this message are solely those of the author and do not necessarily represent the views and opinions of Croatian Telecom Inc. Croatian Telecom Inc. accepts no liability for any potential damage caused by this message and files attached to it.

</FONT></P></HTML>

---

From: Dan Wing <[email-masked]>
Date: Mon, 1 Jul 2013 10:18:44 -0700

> http://datatracker.ietf.org/doc/draft-rfvlb-behave-v6-content-for-v4-clients/

The document says:

  1.2.  Covered Scenarios

   As described in [RFC6144], there are multiple scenarios for IPv4/IPv6
   translation.  This document covers mainly Scenario 4: An IPv4 Network
   to the IPv6 Internet, but is not limited to be used for the following
   scenarios as well:

   o  Scenario 2: The IPv4 Internet to an IPv6 Network

   o  Scenario 6: An IPv4 Network to an IPv6 Network

   These scenarios are not subject of this draft and can be elaborated
   in future documents, if deemed necessary.

I don't think Scenario 2 is solvable with the approach described in draft-rfvlb-behave-v6-content-for-v4-clients, because draft-rfvlb-behave-v6-content-for-v4-clients describes assigning IPv4 addresses from RFC1918 space.  If public space were to be assigned instead of RFC1918 space, public IPv4 space would be consumed at the same rate as running a normal dual-stack server, so nothing is gained compared to operating a normal dual-stack server.

It would be helpful to include a network diagram showing the location of the DNS proxy (which is a new function), the NAT46 function, and the Internet. I have a topology in my head, and I believe my topology is accurate, but I can't be sure until I see a diagram of where these elements would be located.  Thanks.

-d

---

From: Branimir Rajtar <[email-masked]>
Date: Tue, 2 Jul 2013 07:45:11 +0000

Hi,

Thanks for your review, your comments make sense - once I gather all other comments, I'll remove Scenario 2 from the document and include a network diagram.

Branimir

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Monday, July 01, 2013 7:19 PM
To: Branimir Rajtar
Cc: [email-masked]
Subject: Re: [BEHAVE] v6 content for IPv4-only clients

The document says:

  1.2.  Covered Scenarios

-d

</FONT></P></HTML>