Subject: [BEHAVE] Fwd: New Version Notification for draft-perrault-behave-natv2-mib-00.txt

From: Tom Taylor <[email-masked]>
Date: Sun, 18 Jan 2015 22:57:07 -0500

Several months' work, almost done. A couple of sections need work, as 
indicated in the document, but there's lots to review including the 
complete MIB module definition.

This is a major rewrite from the draft-ietf-behave-nat-11 version of
NAT MIB. Reworking was needed to address all the issues outstanding 
against that document. I suppose the next step is to send out a series 
of messages walking through all the changes from
draft-ietf-behave-nat-11 and how they respond to the open issues.

I look forward to any comments on the new document.

Tom Taylor

-------- Forwarded Message --------
Subject: New Version Notification for draft-perrault-behave-natv2-mib-00.txt
Date: Sun, 18 Jan 2015 19:45:03 -0800
From: [email-masked]
....

A new version of I-D, draft-perrault-behave-natv2-mib-00.txt
has been successfully submitted by Tom Taylor and posted to the
IETF repository.

Name:		draft-perrault-behave-natv2-mib
Revision:	00
Title:		Definitions of Managed Objects for Network Address Translators (NAT)
Document date:	2015-01-18
Group:		Individual Submission
Pages:		80
URL: 
http://www.ietf.org/internet-drafts/draft-perrault-behave-natv2-mib-00.txt
Status: 
https://datatracker.ietf.org/doc/draft-perrault-behave-natv2-mib/
Htmlized: 
http://tools.ietf.org/html/draft-perrault-behave-natv2-mib-00

Abstract:
    This memo defines a portion of the Management Information Base (MIB)
    for devices implementing the Network Address Translator (NAT)
    function.  The new MIB module defined in this document, NATV2-MIB, is
    intended to replace module NAT-MIB (RFC 4008).  NATV2-MIB is not
    backwards compatible with NAT-MIB, for reasons given in the text of
    this document.  A companion document deprecates all objects in NAT-
    MIB.  NATV2-MIB can be used for monitoring of NAT instances on a
    device capable of NAT function.  Compliance levels are defined for
    three application scenarios: basic NAT, pooled NAT, and carrier-grade
    NAT (CGN).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Fuyu (Eleven)" <[email-masked]>
Date: Tue, 27 Jan 2015 07:50:14 +0000

Hi Tom, 

Some comments for the draft-perrault-behave-natv2-mib-00.txt, I think they are typos:)

natv2PoolIndex OBJECT-TYPE
       SYNTAX Natv2PoolId
       MAX-ACCESS not-accessible
       STATUS current
       DESCRIPTION
           "Index of an address pool, unique for a given NAT instance.
            It is up to the agent implementation to determine and
            operate upon only those values that correspond to
            provisioned pools."
       ::= { natv2PoolEntry 2 }

In this object, I think the SYNTAX should be Natv2PoolIndex. It doesn't define Natv2PoolId in the draft-perrault-behave-natv2-mib-00.txt.

natv2PortMapExternalPool OBJECT-TYPE
       SYNTAX Natv2PoolIndexOrZero
       MAX-ACCESS read-only
       STATUS current
       DESCRIPTION
           "Index of the address pool in the external realm from which
            the mapped external address given in
            natv2AddressMapExternalAddress was taken. Zero if the
            implementation does not support address pools but has chosen
            to support this object, or if no pool was configured for the
            given external realm."
       ::= { natv2AddressMapEntry 11 }

The name of this object should be natv2AddressMapExternalPool.

Cheers 
Yu

-----Original Message-----
From: Behave [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Monday, January 19, 2015 11:57 AM
To: [email-masked]; [email-masked]; David Harrington; Spencer Dawkins
Subject: [BEHAVE] Fwd: New Version Notification for draft-perrault-behave-natv2-mib-00.txt

Several months' work, almost done. A couple of sections need work, as indicated in the document, but there's lots to review including the complete MIB module definition.

This is a major rewrite from the draft-ietf-behave-nat-11 version of NAT MIB. Reworking was needed to address all the issues outstanding against that document. I suppose the next step is to send out a series of messages walking through all the changes from
draft-ietf-behave-nat-11 and how they respond to the open issues.

Tom Taylor

-------- Forwarded Message --------
Subject: New Version Notification for draft-perrault-behave-natv2-mib-00.txt
Date: Sun, 18 Jan 2015 19:45:03 -0800
From: [email-masked]
....

A new version of I-D, draft-perrault-behave-natv2-mib-00.txt
has been successfully submitted by Tom Taylor and posted to the IETF repository.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Tom Taylor <[email-masked]>
Date: Tue, 27 Jan 2015 08:42:34 -0500

Thank you very much.

Tom