Subject: [BEHAVE] [IANA #830007] Protocol Action: 'Deprecation of MIB Module NAT-MIB (Managed Objects for Network Address Translators (NAT))' to Proposed Standard (draft-perrault-behave-deprecate-nat-mib-v1-04.txt)

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 01 Jul 2015 23:26:00 +0000

Dear Authors:

ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED 

We've completed the IANA Actions for the following RFC-to-be:

draft-perrault-behave-deprecate-nat-mib-v1-04

IANA has updated the mib-2 registration associated with value 123 to read as follows:

123	natMIB (OBSOLETE)	NAT-MIB	[RFC-perrault-behave-deprecate-nat-mib-v1-05]

Please see
http://www.iana.org/assignments/smi-numbers

Please let us know whether the above IANA Actions look OK. As soon as we receive your confirmation, we'll notify the RFC Editor that this document's IANA Actions are complete. (If this document has a team of authors, one reply on behalf of everyone will suffice.)

We'll update the reference when the RFC Editor notifies us that they've assigned a number.

Thanks,

Amanda Baber
IANA Senior Specialist
ICANN

---

From: Tom Taylor <[email-masked]>
Date: Wed, 1 Jul 2015 20:08:42 -0400

Looks ggood, thank you.

Tom Taylor

---

From: Tina TSOU <[email-masked]>
Date: Thu, 2 Jul 2015 00:55:12 +0000

Dear all,

It looks good to me too.

Thank you for your great work.

Thank you,
Tina

-----Original Message-----
From: Tom Taylor [mailto:[email-masked]] 
Sent: Thursday, July 02, 2015 10:09 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [IANA #830007] Protocol Action: 'Deprecation of MIB Module NAT-MIB (Managed Objects for Network Address Translators (NAT))' to Proposed Standard (draft-perrault-behave-deprecate-nat-mib-v1-04.txt)

Looks ggood, thank you.

Tom Taylor

---

From: David Harrington <[email-masked]>
Date: Fri, 3 Jul 2015 21:30:28 -0400

Hi Amanda, 

This is not correct.

the status for natMIB is DEPRECATED, not OBSOLETE

"       REVISION     "201506240000Z"
   -- RFC Ed.: set to publication date
        DESCRIPTION
                "Deprecation of all objects, published as RFC yyyy.
                 See NAT-MIB-V2 in RFCzzzz for recommended replacement."

The format for deprecated assignments is
123	natMIB	NAT-MIB (DEPRECATED)	[RFC-perrault-behave-deprecate-nat-mib-v1-05]

Here is the entry for  {mib-2 68} for an example of another deprecated MIB module under mib-2.
68	vrrpMIB	VRRP MIB (DEPRECATED)	[Bob_Hinden][RFC6527]

Under ifTypes, there are multiple deprecated assignments (7, 11, 62, 69, 117, 184, 205, 230) that also follow this format.

David Harrington
[email-masked]

On Jul 1, 2015, at 8:55 PM, Tina TSOU <[email-masked]> wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 06 Jul 2015 17:24:12 +0000

Hi David, all,

The IANA Considerations section says, "IANA is requested to mark that identifier as OBSOLETE and to update the reference from [RFC4008] to the present document."

Should the IANA Considerations section be updated, or should the MIB be updated?

thanks,
Amanda

On Sat Jul 04 01:41:11 2015, [email-masked] wrote:
> Under ifTypes, there are multiple deprecated assignments (7, 11, 62,
> 69, 117, 184, 205, 230) that also follow this format.
> 
> David Harrington
> [email-masked]
> 
> 
> 
> > Subject: Re: [IANA #830007] Protocol Action: 'Deprecation of MIB
> > Module NAT-MIB (Managed Objects for Network Address Translators
> > (NAT))' to Proposed Standard (draft-perrault-behave-deprecate-nat-
> > mib-v1-04.txt)
> >
> > Looks ggood, thank you.
> >
> > Tom Taylor
> >
> >> Please let us know whether the above IANA Actions look OK. As soon
> >> as we receive your confirmation, we'll notify the RFC Editor that
> >> this document's IANA Actions are complete. (If this document has a
> >> team of authors, one reply on behalf of everyone will suffice.)
> >>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 06 Jul 2015 19:40:34 +0000

Hi,

Simon's address is bouncing when I write to the [email-masked] address.

thanks,
Amanda

On Mon Jul 06 19:37:41 2015, [email-masked] wrote:
> 
> 
> From: Mail Delivery System <MAILER-
> [email-masked]<mailto:[email-masked]>>
> Date: Monday, July 6, 2015Anno Domini at 10:24 AM
> To: "expand-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:expand-draft-perrault-behave-deprecate-
> [email-masked]>" <expand-draft-perrault-behave-
> [email-masked]<mailto:expand-draft-
> [email-masked]>>
> Subject: Undeliverable: [IANA #831872] Re: [BEHAVE] Protocol Action:
> 'Deprecation of MIB Module NAT-MIB (Managed Objects for Network
> Address Translators (NAT))' to Proposed Standard (draft-perrault-
> behave-deprecate-nat-mib-v1-04.txt)
> 
> 
> Delivery has failed to these recipients or groups:
> 
> expand-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:expand-draft-perrault-behave-deprecate-
> [email-masked]>
> The email address you entered couldn't be found. Please check the
> recipient's email address and try to resend the message. If the
> problem continues, please contact your helpdesk.
> 
> 
> The following organization rejected your message: jazz.viagenie.ca.
> 
> 
> 
> 
> 
> 
> 
> Diagnostic information for administrators:
> 
> Generating server: ietfa.amsl.com
> 
> expand-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:expand-draft-perrault-behave-deprecate-
> [email-masked]>
> jazz.viagenie.ca
> Remote Server returned '<jazz.viagenie.ca #5.1.1 smtp; 550 5.1.1
> <[email-masked]<mailto:[email-masked]>>:
> Recipient address rejected: User unknown in local recipient table>'
> 
> Original message headers:
> 
> Return-Path: <[email-masked]<mailto:[email-masked]>>
> Received: by ietfa.amsl.com (Postfix, from userid 65534)
>         id A18011B3002; Mon,  6 Jul 2015 10:24:41 -0700 (PDT)
> X-Original-To: xfilter-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:xfilter-draft-perrault-behave-deprecate-
> [email-masked]>
> Delivered-To: xfilter-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:xfilter-draft-perrault-behave-deprecate-
> [email-masked]>
> Received: from localhost (ietfa.amsl.com [127.0.0.1])
>  by ietfa.amsl.com (Postfix) with ESMTP id 77D061B2FFA
>  for <xfilter-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:xfilter-draft-perrault-behave-deprecate-
> [email-masked]>>;
>  Mon,  6 Jul 2015 10:24:41 -0700 (PDT)
> X-Virus-Scanned: amavisd-new at amsl.com
> X-Spam-Flag: NO
> X-Spam-Score: -0.1
> X-Spam-Level:
> X-Spam-Status: No, score=-0.1 tagged_above=-999 required=5
>  tests=[BAYES_00=-1.9, MISSING_HEADERS=1.021, SPF_NEUTRAL=0.779]
>  autolearn=no
> Received: from mail.ietf.org ([4.31.198.44])
>  by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
>  with ESMTP id ETFcYHK3NWjB
>  for <xfilter-draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:xfilter-draft-perrault-behave-deprecate-
> [email-masked]>>;
>  Mon,  6 Jul 2015 10:24:40 -0700 (PDT)
> Received: from zinfandel.tools.ietf.org (zinfandel.tools.ietf.org
>  [IPv6:2001:1890:123a::1:2a])
>  (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128
> bits))
>  (No client certificate requested)
>  by ietfa.amsl.com (Postfix) with ESMTPS id 471C11B2FE3
>  for <draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>>;
>  Mon,  6 Jul 2015 10:24:40 -0700 (PDT)
> Received: from smtp01.icann.org ([192.0.33.81]:38001
> helo=smtp1.lax.icann.org)
>  by zinfandel.tools.ietf.org with esmtps
>  (TLS1.0:DHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.82_1-5b7a7c0-XX)
>  (envelope-from <[email-masked]<mailto:[email-masked]>>)
> id 1ZCA8F-0004Ze-6S
>  for draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>;
>  Mon, 06 Jul 2015 10:24:40 -0700
> Received: from request3.lax.icann.org (request1.lax.icann.org
> [10.32.11.221])
>  by smtp1.lax.icann.org (8.13.8/8.13.8) with ESMTP id t66HOClX011953
>  for <draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>>;
>  Mon, 6 Jul 2015 17:24:12 GMT
> Received: by request3.lax.icann.org (Postfix, from userid 48)
>  id B7FAAC207BE; Mon,  6 Jul 2015 17:24:12 +0000 (UTC)
> RT-Owner: Nobody
> From: Amanda Baber via RT <[email-masked]<mailto:drafts-
> [email-masked]>>
> Reply-To: <[email-masked]<mailto:[email-masked]>>
> In-Reply-To: <78FF46EF-42AF-4B12-A255-
> [email-masked]<mailto:78FF46EF-42AF-4B12-A255-
> [email-masked]>>
> References: <[email-masked]<mailto:RT-Ticket-
> [email-masked]>> <[email-masked]<mailto:RT-Ticket-
> [email-masked]>>
>  <[email-masked]<mailto:[email-masked]>>
>  <[email-masked]<mailto:rt-4.2.9-
> [email-masked]>>
>  <[email-masked]<mailto:[email-masked]>>
>  <C0E0A32284495243BDE0AC8A066631A818BFB83E@szxeml557-
> mbs.china.huawei.com<mailto:C0E0A32284495243BDE0AC8A066631A818BFB83E@szxeml557-
> mbs.china.huawei.com>>
>  <[email-masked]<mailto:78FF46EF-
> [email-masked]>>
> Message-ID: <rt-4.2.9-8025-1436203452-88.831872-7-
> [email-masked]<mailto:[email-masked]>>
> X-RT-Loop-Prevention: IANA
> X-RT-Ticket: IANA #831872
> X-Managed-BY: RT 4.2.9 (http://www.bestpractical.com/rt/)
> X-RT-Originator: [email-masked]<mailto:[email-masked]>
> CC: <draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>>
> Content-Type: text/plain; charset="utf-8"
> X-RT-Original-Encoding: utf-8
> Precedence: bulk
> Date: Mon, 6 Jul 2015 17:24:12 +0000
> MIME-Version: 1.0
> Content-Transfer-Encoding: 8bit
> X-SA-Exim-Connect-IP: 192.0.33.81
> X-SA-Exim-Rcpt-To: draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>
> X-SA-Exim-Mail-From: [email-masked]<mailto:iana-
> [email-masked]>
> Subject: [IANA #831872] Re: [BEHAVE] Protocol Action: 'Deprecation of
> MIB
> (NAT))' to
>  Proposed Standard (draft-perrault-behave-deprecate-nat-mib-v1-04.txt)
> X-SA-Exim-Version: 4.2.1 (built Mon, 26 Dec 2011 16:24:06 +0000)
> X-SA-Exim-Scanned: Yes (on zinfandel.tools.ietf.org)
> Resent-To: <draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>>
> List-ID: <draft-perrault-behave-deprecate-nat-mib-
> [email-masked]<mailto:draft-perrault-behave-deprecate-nat-mib-
> [email-masked]>>
> Resent-Message-ID:
> <[email-masked]<mailto:[email-masked]>>
> Resent-Date: Mon, 6 Jul 2015 10:24:40 -0700
> Resent-From: <[email-masked]<mailto:[email-masked]>>
> Archived-At: <http://mailarchive.ietf.org/arch/msg/draft-perrault-
> behave-deprecate-nat-mib-v1.all@tools/r0hzmvTDt5eJO6x6K-bvQO1bCfE>
>

---

From: Simon Perreault <[email-masked]>
Date: Mon, 06 Jul 2015 16:24:22 -0400

> Simon's address is bouncing when I write to the [email-masked] address.

My contact info in the draft should be updated to:

Simon Perreault
Jive Communications
Québec, QC
Canada
E-mail: [email-masked]

Simon

---

From: Tom Taylor <[email-masked]>
Date: Mon, 6 Jul 2015 16:24:52 -0400

I'd go with David as expert: the IANA Considerations section should be 
updated.

Tom

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Tue, 07 Jul 2015 20:40:27 +0000

Hi all,

Can one of you confirm that this is correct?

See

If so, I'll send the RFC Editor a note about the change. 

thanks,
Amanda

On Mon Jul 06 20:25:15 2015, [email-masked] wrote:
> > The IANA Considerations section says, "IANA is requested to mark that
> > identifier as OBSOLETE and to update the reference from [RFC4008] to
> > the present document."
> >
> >> Here is the entry for  {mib-2 68} for an example of another
> >> deprecated
> >> MIB module under mib-2.
> >>>> IANA has updated the mib-2 registration associated with value 123
> >>>> to
> >>>> read as follows:
> >>>>
> >>>> 123  natMIB (OBSOLETE)       NAT-MIB [RFC-perrault-behave-
> >>>> deprecate-
> >>>> nat-mib-v1-05]
> >>>>
> >>>> Please see

---

From: David Harrington <[email-masked]>
Date: Mon, 13 Jul 2015 08:38:02 -0400

Hi,

I believe the IANA Considerations should be updated to reflect the deprecation intent.

David Harrington
[email-masked]

On Jul 6, 2015, at 4:24 PM, Tom Taylor <[email-masked]> wrote:

> I'd go with David as expert: the IANA Considerations section should be updated.
> 
> Tom
>

---

From: David Harrington <[email-masked]>
Date: Mon, 13 Jul 2015 08:46:23 -0400

correct

David Harrington
[email-masked]

---

From: Tom Taylor <[email-masked]>
Date: Mon, 13 Jul 2015 11:27:41 -0400

Done in version -06.

Tom

>>> Should the IANA Considerations section be updated, or should the MIB be updated?
...