Subject: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

From: [email-masked]
Date: Wed, 22 Oct 2014 20:03:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the BGP Enabled Services Working Group of the IETF.

        Title           : Virtual Subnet: A L3VPN-based Subnet Extension Solution
        Authors         : Xiaohu Xu
                          Robert Raszuk
                          Susan Hares
                          Yongbing Fan
                          Christian Jacquenet
                          Truman Boyes
                          Brendan Fee
	Filename        : draft-ietf-l3vpn-virtual-subnet-02.txt
	Pages           : 14
	Date            : 2014-10-22

Abstract:
   This document describes a Layer3 Virtual Private Network (L3VPN)-
   based subnet extension solution referred to as Virtual Subnet, which
   can be used for building Layer3 network virtualization overlays
   within and/or across data centers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-l3vpn-virtual-subnet/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-l3vpn-virtual-subnet-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-l3vpn-virtual-subnet-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Thu, 23 Oct 2014 04:07:32 +0000

Hello Authors,

     I understand that the /32 routes (host routes) are locally maintained by the routers after ARP resolution. But how is that exported through BGP? 

   Referring to vrf_A on PE1 of Figure 2) how is 1.1.1.3/32 learnt over BGP.? I need a better clarity here...

Regards
Somasundaram

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, October 23, 2014 8:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 23 Oct 2014 07:13:12 +0000

Hi Somasundaram,

Those locally connected /32 host routes are redistributed into BGP. It's an implementation issue.

Best regards,
Xiaohu

> From: BESS [mailto:[email-masked]] On Behalf Of S, Somasundaram
> (Somasundaram)
> Sent: Thursday, October 23, 2014 12:08 PM
> To: [email-masked]
> Subject: Re: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt
> 
> Hello Authors,
> 
> 
>      I understand that the /32 routes (host routes) are locally maintained by
> the routers after ARP resolution. But how is that exported through BGP?
>

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Thu, 23 Oct 2014 07:31:32 +0000

Hi Xu, Do you mean to say that "hosts for which arp is learnt will have to redistributed to BGP" and that BGP implementation will have to take care of this support (through some policy or do it automatically)? 

Regards
Somasundaram

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 12:43 PM
To: S, Somasundaram (Somasundaram); [email-masked]
Subject: RE: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

Hi Somasundaram,

Best regards,
Xiaohu

>      I understand that the /32 routes (host routes) are locally 
> maintained by the routers after ARP resolution. But how is that exported through BGP?
> 
>    Referring to vrf_A on PE1 of Figure 2) how is 1.1.1.3/32 learnt 
> over BGP.? I need a better clarity here...
> 
> Regards
> Somasundaram
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 23 Oct 2014 07:37:00 +0000

> From: S, Somasundaram (Somasundaram)
> [mailto:[email-masked]]
> Sent: Thursday, October 23, 2014 3:32 PM
> To: Xuxiaohu; [email-masked]
> Hi Xu, Do you mean to say that "hosts for which arp is learnt will have to
> redistributed to BGP" and that BGP implementation will have to take care of this
> support (through some policy or do it automatically)?

Exactly.

Best regards,
Xiaohu

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Thu, 23 Oct 2014 07:56:27 +0000

Can this information be included in the draft?

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 1:07 PM
To: S, Somasundaram (Somasundaram); [email-masked]
Subject: RE: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

> Hi Xu, Do you mean to say that "hosts for which arp is learnt will 
> have to redistributed to BGP" and that BGP implementation will have to 
> take care of this support (through some policy or do it automatically)?

Exactly.

Best regards,
Xiaohu

> > maintained by the routers after ARP resolution. But how is that 
> > exported
> through BGP?
> >

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 23 Oct 2014 09:54:32 +0000

Sound reasonable, Would you please offer some concrete text?

Best regards,
Xiaohu

> Sent: Thursday, October 23, 2014 3:56 PM
> > >         Title           : Virtual Subnet: A L3VPN-based Subnet
> Extension
> > > Solution
> > >         Authors         : Xiaohu Xu
> > >                           Robert Raszuk
> > >                           Susan Hares
> > >                           Yongbing Fan
> > >                           Christian Jacquenet
> > >                           Truman Boyes
> > >                           Brendan Fee

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Mon, 27 Oct 2014 03:32:16 +0000

Additionally for this proposed model to hold good, 
1: Arp for a hosts will have to be learnt on a PE connected to it immediately..
2:An arp entry will have to refreshed periodically...

Else the model is broken.
 
-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 3:25 PM
To: S, Somasundaram (Somasundaram); [email-masked]
Subject: RE: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

Best regards,
Xiaohu

> > have to redistributed to BGP" and that BGP implementation will have 
> > to take care of this support (through some policy or do it automatically)?
> 
> Exactly.
> 
> Best regards,
> Xiaohu
> 
> > Regards
> > Somasundaram
> >

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 27 Oct 2014 03:59:53 +0000

Yes, your observation is correct.

> Sent: Monday, October 27, 2014 11:32 AM

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Mon, 27 Oct 2014 04:07:10 +0000

Believe this has to go down as a limitation.?

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Monday, October 27, 2014 9:30 AM
To: S, Somasundaram (Somasundaram); [email-masked]
Subject: RE: [bess] I-D Action: draft-ietf-l3vpn-virtual-subnet-02.txt

> > > have to redistributed to BGP" and that BGP implementation will 
> > > have to take care of this support (through some policy or do it automatically)?
> >
> > Exactly.
> >
> > Best regards,
> > Xiaohu
> >
> > > Regards
> > > Somasundaram
> > >
> > > >    Referring to vrf_A on PE1 of Figure 2) how is 1.1.1.3/32 
> > > > learnt over BGP.? I need a better clarity here...
> > > >
> > > > Regards
> > > > Somasundaram
> > > >
> > > > A New Internet-Draft is available from the on-line 
> > > > Internet-Drafts
> directories.
> > > > http://www.ietf.org/rfcdiff?url2=draft-ietf-l3vpn-virtual-subnet
> > > > -0
> > > > 2
> > > >
> > > >
> > > > Please note that it may take a couple of minutes from the time 
> > > > of submission until the htmlized version and diff are available at tools.ietf.org.
> > > >