Subject: Re: [bess] WG adoption poll - draft-fang-l3vpn-virtual-pe-05

From: Robert Raszuk <[email-masked]>
Date: Mon, 20 Oct 2014 09:55:12 +0200

Support.

Thx,
R.

PS. I am not sure why this poll still is under old mailer address ..
adding BESS :)

On Sun, Oct 19, 2014 at 9:00 PM, Martin Vigoureux
<[email-masked]> wrote:
> Hello Working Group,
>
> This email starts a two-week poll on adopting
> draft-fang-l3vpn-virtual-pe-05 [1].
>
> Please send comments to the list and state if you support adoption or
> not (in both cases please also state the reasons).
>
> This poll runs until November the 3rd.
>
>
> Coincidentally, we remind you to check and then state on this list if you
> are aware, or not, of any undisclosed IPR (according to IETF IPR rules, see
> RFCs 3979, 4879, 3669 and 5378 for more details) relating to
> draft-fang-l3vpn-virtual-pe-05
>
> If you are listed as a document author or contributor please respond to
> this email and state whether or not you are aware of any relevant
> IPR. The response needs to be sent to the L3VPN WG mailing list. The
> document will not advance to the next stage until a response has been
> received from each author and contributor.
>
> If you are on the L3VPN WG email list but are not listed as an author or
> contributor, then please explicitly respond only if you are aware of any
> IPR that has not yet been disclosed in conformance with IETF rules.
>
> Thank you
>
> M&T
>
> ---
> [1] http://tools.ietf.org/html/draft-fang-l3vpn-virtual-pe-05
>
>

---

From: Thomas Morin <[email-masked]>
Date: Wed, 22 Oct 2014 16:10:24 +0200

Hi working group,

Let me chime a different bell...

(Please note well that this feedback is sent without my co-chair hat. I 
won't participate as a chair in the adoption decision on this draft.)

Let me quote the document: "A virtual PE (vPE) is a BGP/MPLS L3/L2 VPN 
PE software instance which may reside in any network or computing 
devices.". You can pretty much ignore the 'software' part of the 
definition since the document does obviously not ban the implementation 
of the forwarding plane in hardware.  What do we end up with ?  Answer: 
a virtual PE is... a PE !

So the notion presented by this document under the "virtual PE" name is 
merely an implementation choice that can be applied to RFC4364 and 
E-VPN. That explains why the amount of useful technical content in the 
document is so reduced (i.e. information that it neither obvious or 
already present elsewhere). I doubt that the document will be of any 
help to implementors or deployers.

Similarly, I doubt that it is very helpful to implementors or deployers 
to list all the split/no-split combinations for the control planes and 
dataplanes components; and furthermore nothing in that is really 
specific to BESS (e.g. it could apply equally to e.g. non-VPN BGP, or to 
some other routing protocol).

Don't misunderstand me, I think that the idea of implementing VRFs on 
the servers hosting VMs, is great. However, I don't think that a 
technical document is missing to facilitate the implementation of such 
an approach. It can be argued that an Informational RFC can be produced 
to promote the idea, but I would also challenge this: the IETF is not a 
marketing venue. [I would add that, even if it was, a 20+ pages RFC may 
not be the most efficient way to market an idea. People have been able 
to build solutions relying on this approach without a new RFC, and able 
to claim that their solution is based on IETF standard RFCs.]

Promoting the idea of an "SDN" implementation of PE functions (whatever 
that means) and/or organic data-plane/control-plane separation is yet 
another question, but if we were to adopt a document to promote this, at 
least I would expect the document to spell out the motivations and avoid 
just throwing I2RS references around.

At this point I'm leaving aside comments that could be made on details 
on the content, but I think that if this document was to be moved 
forward, a fair amount of clarification and editorial work would be 
needed. Given what I explained above, I don't think it would be worth to 
spend energy on that.

Overall, I don't think that BESS should adopt this document.

-Thomas

Sun Oct 19 2014 21:00:51 GMT+0200 (CEST), Martin Vigoureux:
> Coincidentally, we remind you to check and then state on this list if 
> you are aware, or not, of any undisclosed IPR (according to IETF IPR 
> rules, see RFCs 3979, 4879, 3669 and 5378 for more details) relating 
> to draft-fang-l3vpn-virtual-pe-05
>

---

From: "Wang, Wen" <[email-masked]>
Date: Wed, 22 Oct 2014 22:45:02 +0000

Support.

Wen

From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Coincidentally, we remind you to check and then state on this list if you are aware, or not, of any undisclosed IPR (according to IETF IPR rules, see RFCs 3979, 4879, 3669 and 5378 for more details) relating to draft-fang-l3vpn-virtual-pe-05

If you are listed as a document author or contributor please respond to
this email and state whether or not you are aware of any relevant
IPR. The response needs to be sent to the L3VPN WG mailing list. The document will not advance to the next stage until a response has been
received from each author and contributor.

Thank you

M&T

---

---

From: [email-masked]
Date: Thu, 23 Oct 2014 07:41:17 -0700

I am not aware of related IPR.
 
Ning So
972-955-0914

________________________________
 From: "Wang, Wen" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Wednesday, October 22, 2014 5:45 PM
Subject: Re: [bess] WG adoption poll - draft-fang-l3vpn-virtual-pe-05

Support.
 
Wen
 
From: Martin Vigoureux <[email-masked]>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]

Hello Working Group,

Thank you

M&T

---
 
_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 23 Oct 2014 11:02:49 -0400

Hi, Thomas and BESS -

I generally agree with the sentiment expressed below. That's not to say
that I object to adoption, because ongoing work on the text might result in
something useful. And it certainly could be helpful to have an architecture
document like this to help drive more detailed technical work.

Of course, just because we adopt a draft does not mean that we must publish
it. I would support adoption of this draft with an understanding of its
role in further development activities, and an acknowledgement that it
could be expired and dropped if it doesn't result in useful work.

Cheers,
-Benson
On Oct 22, 2014 10:12 AM, "Thomas Morin" <[email-masked]> wrote:

> Let me quote the document: "A virtual PE (vPE) is a BGP/MPLS L3/L2 VPN PE
> software instance which may reside in any network or computing devices.".
> You can pretty much ignore the 'software' part of the definition since the
> document does obviously not ban the implementation of the forwarding plane
> in hardware.  What do we end up with ?  Answer: a virtual PE is... a PE !
>
> merely an implementation choice that can be applied to RFC4364 and E-VPN.
> That explains why the amount of useful technical content in the document is
> so reduced (i.e. information that it neither obvious or already present
> elsewhere). I doubt that the document will be of any help to implementors
> or deployers.
>
> Similarly, I doubt that it is very helpful to implementors or deployers to
> list all the split/no-split combinations for the control planes and
> dataplanes components; and furthermore nothing in that is really specific
> to BESS (e.g. it could apply equally to e.g. non-VPN BGP, or to some other
> routing protocol).
>
> Don't misunderstand me, I think that the idea of implementing VRFs on the
> servers hosting VMs, is great. However, I don't think that a technical
> document is missing to facilitate the implementation of such an approach.
> It can be argued that an Informational RFC can be produced to promote the
> idea, but I would also challenge this: the IETF is not a marketing venue.
> [I would add that, even if it was, a 20+ pages RFC may not be the most
> efficient way to market an idea. People have been able to build solutions
> relying on this approach without a new RFC, and able to claim that their
> solution is based on IETF standard RFCs.]
>
> At this point I'm leaving aside comments that could be made on details on
> the content, but I think that if this document was to be moved forward, a
> fair amount of clarification and editorial work would be needed. Given what
> I explained above, I don't think it would be worth to spend energy on that.
>

---

From: "Chris Lewis (chrlewis)" <[email-masked]>
Date: Thu, 23 Oct 2014 16:55:59 +0000

>From the BESS Charter I see

"The BGP Enabled Services (BESS) working group is responsible for
defining, specifying, and extending network services based on BGP"

There are two virtual PE models I am aware of. The first is the multi-tenant model that does not change operations at all, merely moves the VPN function as is from a physical device to a virtual device. The second is the single tenant model, which is a PE per customer location. The difference this model introduces is an explosion in the nmber of PEs and the associated building of router reflector hierarchies. Neither, as far as I can see require any changes to the BGP protocol. Certainly there are some new ways to provision things (orchestration).

As a new participant to this group I may be missing much and need to be educated. However if the group is about extending BGP to support new services I am unclear why a virtual PE demands something new and if it does, should not the draft specify that?

Chris

On Oct 23, 2014, at 10:02 AM, Benson Schliesser <[email-masked]>
 wrote:

> Hi, Thomas and BESS -
> 
> I generally agree with the sentiment expressed below. That's not to say that I object to adoption, because ongoing work on the text might result in something useful. And it certainly could be helpful to have an architecture document like this to help drive more detailed technical work.
> 
> Of course, just because we adopt a draft does not mean that we must publish it. I would support adoption of this draft with an understanding of its role in further development activities, and an acknowledgement that it could be expired and dropped if it doesn't result in useful work.
> 
> Cheers,
> -Benson
> 
> (Please note well that this feedback is sent without my co-chair hat. I won't participate as a chair in the adoption decision on this draft.)
> 
> Let me quote the document: "A virtual PE (vPE) is a BGP/MPLS L3/L2 VPN PE software instance which may reside in any network or computing devices.". You can pretty much ignore the 'software' part of the definition since the document does obviously not ban the implementation of the forwarding plane in hardware.  What do we end up with ?  Answer: a virtual PE is... a PE !
> 
> So the notion presented by this document under the "virtual PE" name is merely an implementation choice that can be applied to RFC4364 and E-VPN. That explains why the amount of useful technical content in the document is so reduced (i.e. information that it neither obvious or already present elsewhere). I doubt that the document will be of any help to implementors or deployers.
> 
> Similarly, I doubt that it is very helpful to implementors or deployers to list all the split/no-split combinations for the control planes and dataplanes components; and furthermore nothing in that is really specific to BESS (e.g. it could apply equally to e.g. non-VPN BGP, or to some other routing protocol).
> 
> Don't misunderstand me, I think that the idea of implementing VRFs on the servers hosting VMs, is great. However, I don't think that a technical document is missing to facilitate the implementation of such an approach. It can be argued that an Informational RFC can be produced to promote the idea, but I would also challenge this: the IETF is not a marketing venue. [I would add that, even if it was, a 20+ pages RFC may not be the most efficient way to market an idea. People have been able to build solutions relying on this approach without a new RFC, and able to claim that their solution is based on IETF standard RFCs.]
> 
> Promoting the idea of an "SDN" implementation of PE functions (whatever that means) and/or organic data-plane/control-plane separation is yet another question, but if we were to adopt a document to promote this, at least I would expect the document to spell out the motivations and avoid just throwing I2RS references around.
> 
> At this point I'm leaving aside comments that could be made on details on the content, but I think that if this document was to be moved forward, a fair amount of clarification and editorial work would be needed. Given what I explained above, I don't think it would be worth to spend energy on that.
>

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 23 Oct 2014 18:00:07 +0000

For me the key question we should answer is if it does help developers implement vPE even if there is no new protocol extensions required.

From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Thursday 23 October 2014 17:02
To: Thomas Morin <[email-masked]<mailto:[email-masked]>>
Cc: L3VPN <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] WG adoption poll - draft-fang-l3vpn-virtual-pe-05

Hi, Thomas and BESS -

Cheers,
-Benson

On Oct 22, 2014 10:12 AM, "Thomas Morin" <[email-masked]<mailto:[email-masked]>> wrote:
Hi working group,

-Thomas

Thank you

M&T

---

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 23 Oct 2014 18:15:15 +0000

Thomas,

	 Maybe this should be viewed as a clearinghouse on technologies, approaches etc... that can be utilized when virtualizing. Not sure how that fits..

Jim Uttaro

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Thomas Morin
Sent: Wednesday, October 22, 2014 10:10 AM
To: Martin Vigoureux; L3VPN; [email-masked]
Subject: Re: [bess] WG adoption poll - draft-fang-l3vpn-virtual-pe-05

Hi working group,

-Thomas

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 23 Oct 2014 21:41:05 +0000

Yes/Support
Very useful draft for both transport and cloud SDN.
BR
Daniele
---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---

---

From: Luyuan Fang <[email-masked]>
Date: Fri, 24 Oct 2014 01:21:24 +0000

FW my reply previously sent to L3VPN mailing list.
Luyuan

From: Luyuan Fang
Sent: Sunday, October 19, 2014 7:05 PM
To: [email-masked]'
Cc: [email-masked]'
Subject: RE: WG adoption poll - draft-fang-l3vpn-virtual-pe-05

Hi Martin and Thomas,
I support, as co-author.
I’m not aware of relevant IPRs.
Thanks,
Luyuan
---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 24 Oct 2014 07:26:56 -0400

I also support WG adoption for the draft.

Thanks,
Andy

On Thu, Oct 23, 2014 at 5:41 PM, Daniele Ceccarelli <
[email-masked]> wrote:

> From: *Martin Vigoureux* <[email-masked]>

---

From: <[email-masked]>
Date: Fri, 24 Oct 2014 13:49:32 +0200

I support the adoption, as a co-author. I am not aware of any relevant IPR.
Thanks,
Manuel
---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---

---

From: "Wang, Wen" <[email-masked]>
Date: Fri, 24 Oct 2014 13:19:06 +0000

Support, not aware of IPR.

Wen

---

From: "Sami Boutros (sboutros)" <[email-masked]>
Date: Fri, 24 Oct 2014 15:56:08 +0000

Support.

Thanks,

Sami

Hello Working Group,

Thank you

M&T

---

---

From: Bruno Rijsman <[email-masked]>
Date: Fri, 24 Oct 2014 18:06:41 +0000

-- Bruno
---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---

---

From: Lucy yong <[email-masked]>
Date: Fri, 24 Oct 2014 21:47:53 +0000

Support!
Lucy
---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Fri, 31 Oct 2014 02:14:25 +0000

---------- Forwarded message ----------
From: NAPIERALA, MARIA H <[email-masked]<mailto:[email-masked]>>
Date: Mon, Oct 20, 2014 at 9:22 AM
Subject: RE: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

I am not aware of any related IPR.

Support as a co-author.

Maria

> From: L3VPN [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Martin
> Vigoureux
> Sent: Sunday, October 19, 2014 3:01 PM
> rules, see RFCs 3979, 4879, 3669 and 5378 for more details) relating to

---

From: "Dhananjaya Rao (dhrao)" <[email-masked]>
Date: Sat, 1 Nov 2014 00:57:09 +0000

- Dhananjaya

---------- Forwarded message ----------
From: Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 19, 2014 at 3:00 PM
Subject: WG adoption poll - draft-fang-l3vpn-virtual-pe-05
To: [email-masked]<mailto:[email-masked]>

Hello Working Group,

Thank you

M&T

---