Subject: [bess] IANA's comments on draft-ietf-l3vpn-end-system

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Dec 2014 13:03:59 -0000

Hi,

I don't seem to have seen a copy of IANA's review comments on this draft. sorry
if that is my mail system screwing up.

IANA's comments are entered in the tracker and read as follows.

My response will be in a response to this email.

Cheers,
Adrian

> IESG/Authors/WG Chairs:
>
> IANA has reviewed draft-ietf-l3vpn-end-system-04.  Authors should review
> the comments and/or questions below.  Please report any inaccuracies and 
> respond to any questions as soon as possible.
>
> IANA's reviewer has the following comments/questions:
>
> IANA has a question about the IANA Considerations section of this document.
>
> Previously, an early assignment has been made to support this draft. The
> original request for an assignment is below:
>
>> <begin request="">
>> Contact Name:
>> Thomas Morin
>>
>> Contact Email:
>> [email-masked]
>>
>> Type of Assignment:
>> Assignement of a BGP parameter in a FCFS registry.
>>
>> Registry:
>> BGP Tunnel Encapsulation Attribute Tunnel Types
>>
>> See: https://www.iana.org/assignments/bgp-parameters
>>
>> Description:
>> Needed for draft-ietf-l3vpn-end-system, to allow the use of an 
>> MPLS-over-UDP encapsulation as specified in draft-ietf-mpls-in-udp .
>>
>> No value has been proposed yet, next available value 13 would be fine.
>>
>> Additional Info:
>> draft-ietf-l3vpn-end-system
>> </end>
>
> IANA Question --> The IANA Considerations section said "This document has
> no IANA actions."  and, as a result, the assignment made through the request
> above would not be made permanent. Is this the author's intent? If not, could
> the draft be revised to indicate that the assignment made based on the request
> above be changed from an initial assignment to a permanent assignment.
>
> Note:  The actions requested in this document will not be completed until the
> document has been approved for publication as an RFC. This message is only
> to confirm what actions will be performed.  
>
> Please note that IANA cannot reserve specific values. However, early
allocation
> is available for some types of registrations. For more information, please see
> RFC 7120.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Dec 2014 13:20:26 -0000

Hi,
 
Replying to myself and keeping the same IANA tracking number.
 
> > above be changed from an initial assignment to a permanent assignment.
 
How do you mean?
The registry is FCFS for which *any* document is sufficient.
The assignment has been made and is as permanent as any FCFS assignment ever is.
 
> > allocation is available for some types of registrations. For more
information,
> > please see RFC 7120.
 
Yes, but this is a FCFS registry to which 7120 does not apply, and nor does
"reservation of values".
With FCFS the value is assigned when requested and that's it.
 
Now, it is a different question whether this document should ask for the
registry to be updated to point to the consequent RFC instead of the I-D.
 
I think that might be valuable. So the IANA section should read...
 
   IANA has previously made an allocation from the "BGP Tunnel Encapsulation
   Attribute Tunnel Types" registry that reads:
 
   Value  | Name                      | Reference
   --------+---------------------------+-------------------------------
       13  | MPLS in UDP Encapsulation | [draft-ietf-l3vpn-end-system]
 
   IANA is requested to change the reference to point to the RFC number
   of this document when it is published.
   
Cheers,
Adrian

---

From: Thomas Morin <[email-masked]>
Date: Tue, 09 Dec 2014 16:01:37 +0100

Hi IANA,

Let me simply state that I agree with Adrian's analysis and suggestion.

-Thomas,
(as shepherd of this draft, and as the one who took the action of 
registering the code point)

Tue Dec 09 2014 14:20:26 GMT+0100 (CET), Adrian Farrel:
> > > IANA has reviewed draft-ietf-l3vpn-end-system-04.Authors should review
>
> > > the comments and/or questions below.Please report any inaccuracies and
>
> > > no IANA actions."and, as a result, the assignment made through the 
> request
>
> Yes, but this is a FCFS registry to which 7120 does not apply, and nor 
> does "reservation of values".
>
> Now, it is a different question whether this document should ask for 
> the registry to be updated to point to the consequent RFC instead of 
> the I-D.
>
> Value| Name| Reference
> 13| MPLS in UDP Encapsulation | [draft-ietf-l3vpn-end-system]
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Tue, 9 Dec 2014 17:17:26 +0000

Hi Adrian,

> IANA's comments are entered in the tracker and read as follows.

My mistake.  I had a typo in the [email-masked] email address:

Delivery has failed to these recipients or groups:

[email-masked]<mailto:[email-masked]>
The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk.

However, it also said that [email-masked] address does not exist:

[email-masked]<mailto:[email-masked]>
The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk.

The following organization rejected your message: pechora3.icann.org, zinfandel.tools.ietf.org.

Has that address been set-up?

Thanks,
~pl

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Tue, 9 Dec 2014 17:40:13 +0000

Hi Adrian,

This makes it clear whether or not that assignment needs to be updated when this
draft is approved for publication as RFC:

[[[

   Value  | Name                      | Reference

]]]

The current text  "This document has no IANA actions."  provides no
instructions and incorrectly tell people there is no actions requested.

Thanks
~pl

On Tue Dec 09 13:20:57 2014, [email-masked] wrote:
> > > above would not be made permanent. Is this the author's intent? If
> not,
> could
> > > the draft be revised to indicate that the assignment made based on
> the
> request
> the

---

From: Thomas Morin <[email-masked]>
Date: Wed, 10 Dec 2014 12:38:59 +0100

Hi Pearl,

> Has that address been set-up?

It seems that [email-masked]  (with an 's' to chairs) does 
exist, but that [email-masked] does not.
(In fact, I don't know if any <wg>-chair@ alias, without an 's', exist 
at all)

Best,

-Thomas

>> not, could
>> the request

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Wed, 10 Dec 2014 21:43:28 +0000

Hi Thomas,

Adrian already fixed it already.  Yeah, the bounce was caused by a typo in the tracker 
on 2014-12-09.  Here is what the tracker lists for "Send notices to":

[[[
IESG State: Waiting for Writeup::Revised I-D Needed
IANA Review State: IANA - Not OK
IANA Action State: None
Responsible AD: Adrian Farrel
Send notices to: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]

]]]

Thanks,
~pl

On Wed Dec 10 11:39:26 2014, [email-masked] wrote:
> > The email address you entered couldn't be found. Please check the
> recipient's email address and try to resend the message. If the
> problem continues, please contact your helpdesk.
> >
> > The following organization rejected your message:
> pechora3.icann.org, zinfandel.tools.ietf.org.
> >
> >>> the comments and/or questions below.  Please report any
> inaccuracies
> >> and
> >>> Previously, an early assignment has been made to support this
> draft.
> >> The
> >>>> MPLS-over-UDP encapsulation as specified in draft-ietf-mpls-in-
> udp
> >> .
> >>> no IANA actions."  and, as a result, the assignment made through
> the
> >> request
> >>> Note:  The actions requested in this document will not be
> completed
> >> until the
> >>> is available for some types of registrations. For more
> information,
> >> please see
> >>> RFC 7120.
> >
> >