Subject: [bess] Benoit Claise's Discuss on draft-ietf-l3vpn-acceptown-community-09: (with DISCUSS)

From: "Benoit Claise" <[email-masked]>
Date: Wed, 04 Feb 2015 14:07:58 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-l3vpn-acceptown-community-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-l3vpn-acceptown-community/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Ron's point, part of the OPS-DIR review, look valid to me. Can we please
discuss it.

This document is well written and well thought out. It is almost ready
for publication with one small issue.

In Section 2.3, the authors say, " ACCEPT_OWN handling SHOULD be
controlled by configuration, and SHOULD   default to being disabled. IMO,
they should say, "ACCEPT_OWN handling MUST be controlled by
configuration, and MUST default to being disabled."

AFAIKS, you would never want to build a router where ACCEPT_OWN behavior
is always on and cannot be disabled by configuration. Likewise, you would
never want to build a router where ACCEPT_OWN behavior is the default.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 13:24:27 -0000

Bit disappointed that this is a Discuss.

But let's discuss it.

> never want to build a router where ACCEPT_OWN behavior is the default.

I reject specifications that control what one might want to build. We produce specs to define interoperable behavior and to ensure the Internet works. We don't legislate for people producing product in niches or that is entirely unsalable.

However, let's separate the two SHOULDs.

Suppose one wanted to build an implementation where the feature is not controlled by configuration and is always disabled?
In that case you would be banned from doing so if "ACCEPT_OWN handling MUST be controlled by configuration", so I would say that "SHOULD" is correct in the first case.

I suspect the second "SHOULD" is a consequence of a compound sentence.
If we had "ACCEPT_OWN handling SHOULD be controlled by configuration, and if controlled by configuration it MUST default to being disabled" then that might be closer to correct according to what Ron is suggesting.

Thanks,
Adrian

PS. Would have helped if the original review had reached the AD, shepherd, and WG. Maybe also the IETF list.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 13:24:27 -0000

But let's discuss it.

Thanks,
Adrian

---

From: Benoit Claise <[email-masked]>
Date: Thu, 05 Feb 2015 15:49:33 +0100

Hi Adrian,
> Bit disappointed that this is a Discuss.
I wrote: "Ron's point, part of the OPS-DIR review, looks valid to me. 
Can we please discuss it."
More polite than this, that becomes to be difficult :-)
> If we had "ACCEPT_OWN handling SHOULD be controlled by configuration, and if controlled by configuration it MUST default to being disabled" then that might be closer to correct according to what Ro…
That makes sense to me (and to Ron, I just checked)
> PS. Would have helped if the original review had reached the AD, shepherd, and WG. Maybe also the IETF list.
Sure.

Regards, Benoit
> .

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 5 Feb 2015 14:54:30 +0000

Adrian,

> >
> > PS. Would have helped if the original review had reached the AD,
> shepherd, and WG. Maybe also the IETF list.

[RPB] 
This is my bad. When I did the OPS-DIR review, I copied [email-masked], but not [email-masked].

However, I did call one of the authors before posting it and he wasn't averse to the change.

                                                                             Ron

---

From: "David Smith (djsmith)" <[email-masked]>
Date: Thu, 5 Feb 2015 18:00:26 +0000

Adrian>If we had "ACCEPT_OWN handling SHOULD be controlled by configuration, and if controlled by configuration it MUST default to being disabled"...

I agree this may be most optimal. 

/dave

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Thursday, February 05, 2015 8:24 AM
To: Benoit Claise (bclaise); 'The IESG'
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Benoit Claise's Discuss on draft-ietf-l3vpn-acceptown-community-09: (with DISCUSS)

But let's discuss it.

> Ron's point, part of the OPS-DIR review, look valid to me. Can we 
> please discuss it.
> 
> AFAIKS, you would never want to build a router where ACCEPT_OWN 
> behavior is always on and cannot be disabled by configuration. 
> Likewise, you would never want to build a router where ACCEPT_OWN behavior is the default.

Thanks,
Adrian

---

From: "David Smith (djsmith)" <[email-masked]>
Date: Thu, 5 Feb 2015 18:00:26 +0000

/dave

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Thursday, February 05, 2015 8:24 AM
To: Benoit Claise (bclaise); 'The IESG'
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Benoit Claise's Discuss on draft-ietf-l3vpn-acceptown-community-09: (with DISCUSS)

But let's discuss it.

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 18:11:13 -0000

Thanks,

I'll turn the handle.

A

> From: iesg [mailto:[email-masked]] On Behalf Of David Smith (djsmith)
> Sent: 05 February 2015 18:00
> To: [email-masked]; Benoit Claise (bclaise); 'The IESG'
> Cc: [email-masked]; [email-masked]; bess-
> [email-masked]; [email-masked];
> [email-masked]
> Adrian>If we had "ACCEPT_OWN handling SHOULD be controlled by
> configuration, and if controlled by configuration it MUST default to being
> disabled"...
> 
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> I reject specifications that control what one might want to build. We produce
> specs to define interoperable behavior and to ensure the Internet works. We
> don't legislate for people producing product in niches or that is entirely unsalable.
> 
> Suppose one wanted to build an implementation where the feature is not
> controlled by configuration and is always disabled?
> In that case you would be banned from doing so if "ACCEPT_OWN handling MUST
> be controlled by configuration", so I would say that "SHOULD" is correct in the
> first case.
> 
> If we had "ACCEPT_OWN handling SHOULD be controlled by configuration, and if
> controlled by configuration it MUST default to being disabled" then that might be
> closer to correct according to what Ron is suggesting.
> 
> Thanks,
> Adrian
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Feb 2015 18:11:13 -0000

Thanks,

I'll turn the handle.

A