Subject: [bess] [BESS] Comment to draft-ietf-bess-evpn-usage-00.txt

From: Zhuangshunwan <[email-masked]>
Date: Fri, 27 Mar 2015 09:52:29 +0000

Dear Authors,

I have a comment, see inline with [Shunwan].

5.2.1. Service startup procedures

   As soon as the EVIs are created in PE1, PE2 and PE3, the following
   control plane actions are carried out:

   o Flooding tree setup per EVI (4k routes): Each PE will send one
     Inclusive Multicast Ethernet Tag route per EVI (up to 4k routes per
     PE) so that the flooding tree per EVI can be setup. Note that
     ingress replication, P2MP LSPs or MP2MP LSPs can optionally be
     signaled in the PMSI Tunnel attribute and the corresponding tree be
     created.

   o Ethernet A-D routes per ESI (a set of routes for ESI12): A set of
     A-D routes with a list of 4k RTs (one per EVI) for ESI12 will be
     issued from PE1 and PE2 (it has to be a set of routes so that the
     total number of RTs can be conveyed). This set will also include

[Shunwan]:
Sorry, maybe I miss something about this feature, I just don't know how to convey a bgp route with 4k RTs.
The BGP specification mandates a maximum BGP message size of 4096 octets, so a bgp route can only carry approximately 500 RTs once.
If we send one Ethernet A-D route per ESI with 4k RTs using a set of routes (Each route carrying a sub-set of 4K RTs) , because such set of routes have the same NLRI, in line with the behavior of BGP [RFC4271], the last route will override the previous routes, so the receiver PE can only maintain the last one other than a set of routes for one Ethernet A-D route with 4k RTs.

If I miss something, please let me know, thanks.

Rabadan-Palislamovic et al.Expires May 17, 2015                [Page 11]

Internet-Draft                 EVPN Usage              November 13, 2014

     ESI Label extended communities with the active-standby flag set to
     zero (all-active multi-homing type) and an ESI Label different from
     zero (used for split-horizon functions). These routes will be
     imported by the three PEs, since the RTs match the EVI RTs locally
     configured. The A-D routes per ESI will be used for fast
     convergence and split-horizon functions, as discussed in [EVPN].

Regards,

Shunwan

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Fri, 27 Mar 2015 12:14:55 +0000

Hi Shunwan,

A ‘set’ of A-D routes is used due to the reason you mention. It is indicated in the draft too: 'it has to be a set of routes so that the total number of RTs can be conveyed’.
The use of different RDs per route is implicit, as per RFC7432:

"Advertising a set of Ethernet A-D per ES routes
   for the ES allows each route to contain a subset of the complete set
   of RTs.  Each Ethernet A-D per ES route is differentiated from the
   other routes in the set by a different Route Distinguisher (RD).'

We did not think it was necessary to add that to the evpn-usage draft since it is part of the RFC7432, but let us know if you think it helps to add a sentence.

Thank you.
Jorge

From: Zhuangshunwan <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 27, 2015 at 2:52 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] [BESS] Comment to draft-ietf-bess-evpn-usage-00.txt

Dear Authors,

[Shunwan]:
Sorry, maybe I miss something about this feature, I just don’t know how to convey a bgp route with 4k RTs.
The BGP specification mandates a maximum BGP message size of 4096 octets, so a bgp route can only carry approximately 500 RTs once.
If we send one Ethernet A-D route per ESI with 4k RTs using a set of routes (Each route carrying a sub-set of 4K RTs) , because such set of routes have the same NLRI, in line with the behavior of BGP [RFC4271], the last route will override the previous routes, so the receiver PE can only maintain the last one other than a set of routes for one Ethernet A-D route with 4k RTs.

Regards,

Shunwan