Subject: Re: [bess] Request for WG adoption of draft-xu-bess-encaps-udp//RE: Why transform draft-xu-softwire-encaps-udp to draft-xu-bess-encaps-udp

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 4 Mar 2015 13:03:35 -0000

> > So you want an I-D that describes how to use the code point to achieve a
> > variety of things. That is potentially useful, but I haven't read that text
in 
> >your I-D.
> 
> I can update the text accordingly soon. Of course, it would be great if you
could
> propose any text.

Thank you for the offer, but I don't personally have any desire to see this
written, so I will not be suggesting text.

> > But please understand that the code point is already allocated (and I
shouldn't
> > be surprised to hear it is coded and deployed). So it is way too late to say
that
> > the wrong document asked for the code point.
> 
> How about proceeding draft-xu-bess-encaps-udp quickly and then making it to
> take over the allocated code point? After all, the draft is very short and
more
> importantly the IETF community has reached a consensus on the necessity of
> allocating a code point for UDP, it seems not a problem to proceed it quickly,
> IMHO.

I don't understand at all.
The code point has been allocated. We're done. We don't need any more work. It's
done.

Adrian

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 5 Mar 2015 01:38:46 +0000

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, March 04, 2015 9:04 PM
> To: Xuxiaohu; [email-masked]
> Subject: RE: [bess] Request for WG adoption of draft-xu-bess-encaps-udp//RE:
> Why transform draft-xu-softwire-encaps-udp to draft-xu-bess-encaps-udp
> 
> > > So you want an I-D that describes how to use the code point to
> > > achieve a variety of things. That is potentially useful, but I
> > > haven't read that text
> in
> > >your I-D.
> >
> Thank you for the offer, but I don't personally have any desire to see this written,
> so I will not be suggesting text.
> 
> > How about proceeding draft-xu-bess-encaps-udp quickly and then making
> > it to take over the allocated code point? After all, the draft is very
> > short and
> more
> > importantly the IETF community has reached a consensus on the
> > necessity of allocating a code point for UDP, it seems not a problem
> > to proceed it quickly, IMHO.
> 
> The code point has been allocated. We're done. We don't need any more work.
> It's done.

If you admit the fact that the wrong doc asked for the code point, I'm a bit confused why you still insist on that wrong action? Just because there is a strict IETF rule that the code point reference is not allowed to be corrected in any case or any other reasons? Sorry for such a direct question. I just want to learn the IETF code point related rules in passing.

Xiaohu

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 5 Mar 2015 18:08:04 -0000

This is my last email on this subject.

> > > short and more importantly the IETF community has reached a
> > > consensus on the necessity of allocating a code point for UDP, it seems
> > > not a problem to proceed it quickly, IMHO.
> >
> If you admit the fact that the wrong doc asked for the code point, I'm a bit
> confused why you still insist on that wrong action? Just because there is a
strict
> IETF rule that the code point reference is not allowed to be corrected in any
case
> or any other reasons? Sorry for such a direct question. I just want to learn
the
> IETF code point related rules in passing.

If.

But I don't admit any such thing.

The registry is First Come First Served.
The code point was requested according to that policy.
A document was provided as a reference (and that document provides further
reference to [I-D.ietf-mpls-in-udp])

The first objective is to allocate the code point - done
The second objective is to give a reference to a document that describes the use
of the code point - done

You are proposing a new I-D that provides more description and use cases. Sure.
Knock yourself out. I'm sure people will be happy to discuss the content of your
document.

Adrian