Subject: [bess] RtgDir review: draft-ietf-bess-mvpn-bidir-03.txt

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 11 Mar 2015 18:33:54 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-bess-mvpn-bidir-03.txt
Reviewer: Ben Niven-Jenkins
Review Date: 11th March 2015
IETF LC End Date: Not known 
Intended Status: Standards Track

Summary:
This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:
The draft is well written, in places I needed to re-read sentences to ensure I had understood them but I think this is more to do with the nature of the content and that multicast VPNs require complex descriptions rather than a reflection on the quality of the document.

Major issues:
No major issues found.

Minor issues:
No minor issues found.

Nits:
Section 1.1: C-multicast flow:
Change
  If a customer uses the "Any Source Multicast" (ASM) model, the
  some or all of the customer's C-flows may be traveling along the

to

  If a customer uses the "Any Source Multicast" (ASM) model, then
  some or all of the customer's C-flows may be traveling along the

i.e. s/the/then in the first line.

Section 1.2.4:
s/If a bidirectional P-tunnels/If bidirectional P-tunnels/

s/The method used by a given VRF used is determined/The method used by a given VRF is determined/

Section 3.2.2:
s/The PEs are REQUIRED to originate these routes are/The PEs REQUIRED to originate these routes are/

s/This document assumes that the root node address of an MP2MP LSP an IP address/This document assumes that the root node address of an MP2MP LSP is an IP address/

Section 3.2.4 states:

 In order to be compliant with this specification, an implementation
 that provides bidirectional P-tunnels MUST support one or both of the
 two P-tunnel technologies mentioned in section Section 1.2.1.

Saying implementations "MUST support one or both" sounds a bit strange to me and something like "MUST support at least one" sounds better (but both ultimately mean the same thing)?

Also the document states:

 A PE that does not provide C-BIDIR support using the "partitioned set
 of PEs" method may be deemed compliant to this specification if it
 supports the Unpartitioned Method, using either MP2MP LSPs or BIDIR-
 PIM multicast distribute trees as P-tunnels.

"may be deemed" implies there are cases where it "may not be deemed" compliant but I'm not sure what those are.

Do you really mean to say "is" instead of "may be"?

Regards
Ben

---

From: Eric C Rosen <[email-masked]>
Date: Sun, 15 Mar 2015 11:11:11 -0400

Ben,

Thanks for your review and comments.

I have incorporated your corrections into the XML, and they will be 
included in the -04 revision.

Eric

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 16 Mar 2015 14:38:33 +0000

Thanks Eric. Ben

> On 15 Mar 2015, at 15:11, Eric C Rosen <[email-masked]> wrote:
> 
> Ben,
> 
> I have incorporated your corrections into the XML, and they will be included in the -04 revision.
> 
> Eric
> 
>