Subject: Re: [bess] Sync between l2vpn service models

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Thu, 3 Dec 2015 16:21:35 +0000

Rotem,

These models are fundamentally different.

draft-shah-bess-l2vpn-yang<https://tools.ietf.org/html/draft-shah-bess-l2vpn-yang-00> meant to be a generic L2 device model whereas draft-xie-l3sm-l2vpn-service-model-00<https://tools.ietf.org/html/draft-xie-l3sm-l2vpn-service-model-00> models the service.
The service model call various device models to enable the defined service.

Regards,

Patrice

   [http://www.cisco.com/web/europe/images/email/signature/est2014/logo_06.png?ct=1406640631632]

Patrice Brissette
TECHNICAL LEADER.ENGINEERING

[email-masked]<mailto:[email-masked]>
Phone: +1 613 254 3336

Cisco Systems Canada Co. / Les Systemes Cisco Canada CIE
Canada
Cisco.com<http://www.cisco.com/global/CA/>

[http://www.cisco.com/assets/swa/img/thinkbeforeyouprint.gif] Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Please click here<http://www.cisco.com/web/about/doing_business/legal/cri/index.html> for Company Registration Information.

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Rotem Cohen <[email-masked]<mailto:[email-masked]>>
Date: Thursday, December 3, 2015 at 10:02 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>, Hai Balas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] Sync between l2vpn service models

Dear authors of L2VPN service model drafts,

Can you clarify please the relation between draft-shah-bess-l2vpn-yang<https://tools.ietf.org/html/draft-shah-bess-l2vpn-yang-00> and draft-xie-l3sm-l2vpn-service-model-00<https://tools.ietf.org/html/draft-xie-l3sm-l2vpn-service-model-00>?

There are fundamental differences between L2VPN and L3VPN services and it does not seem right to derive one model from the other. draft-xie-l3sm-l2vpn-service-model-00<https://tools.ietf.org/html/draft-xie-l3sm-l2vpn-service-model-00> made the effort to explain these differences but if the starting point had not been the L3VPN service model then it would not be necessary to do so.
VPLS and VPWS are widely deployed in MPLS-TP networks which do not assume any IP routing/forwarding capabilities and therefore using L3VPN constructs to define L2VPN services is not natural for these applications.

Relating to the conclusion section, the structure of L2VPN service is quite clear and modelling it without relying on L3VPN should not be regarded as reinventing a new wheel.

Thanks & regards,

Rotem Cohen

PTS System Architecture Group Manager

T:

+972.3.926.8247

M:

+972.54.926.8247

E:

[email-masked]<mailto:[email-masked]>

www.ecitele.com<http://www.ecitele.com/>

---

From: Rotem Cohen <[email-masked]>
Date: Thu, 10 Dec 2015 10:05:22 +0000

Hi Patrice,

draft-shah-bess-l2vpn-yang<https://tools.ietf.org/html/draft-shah-bess-l2vpn-yang-00>  "describes a YANG data model for Layer 2 VPN services over MPLS networks" according to its abstract. What did you mean by L2 device model?

There are some overlaps between the models, for example the Service parameters on the attachment. The ac-template approach taken in draft-shah-bess-l2vpn-yang<https://tools.ietf.org/html/draft-shah-bess-l2vpn-yang-00> seems more robust and prevents partial definition in the root service model.

Regarding the OAM container that defines BFD for the l2-connection.  An Ethernet service that is implemented as VPWS or VPLS will mostly use Y.1731 OAM tools and not BFD that runs in the IP or MPLS layers. Maybe the service model can hold a basic OAM container or point to an oam-template instead specifically calling for BFD.

custom-qos-profile container includes a rate-limit leaf. Ethernet services that conform to MEF CE2.0 service definition use a more complicated profile that defined CIR, CBS, EIR, EMB color awareness, coupling and more.  Is rate-limit leaf meant as a one-parameter abstraction for more detailed MEF QoS profile?

Regardless of the origin of the model, it seems highly preferable to have a single model covering all aspects of a L2VPN service.

Regards,
Rotem

From: Patrice Brissette (pbrisset) [mailto:[email-masked]]
Sent: Thursday, December 03, 2015 6:22 PM
To: Rotem Cohen; [email-masked]; [email-masked]
Cc: [email-masked]; Alexander Vainshtein; Hai Balas; [email-masked]
Subject: Re: [bess] Sync between l2vpn service models

Rotem,

Regards,

Patrice

Patrice Brissette

[http://www.cisco.com/assets/swa/img/thinkbeforeyouprint.gif]Think before you print.

Thanks & regards,

Rotem Cohen

T:

+972.3.926.8247

M:

+972.54.926.8247

E: