Subject: Re: [bess] Introducing a one-implementation requirement before WG last calls

From: Martin Vigoureux <[email-masked]>
Date: Mon, 14 Dec 2015 10:28:31 +0100

WG,

we have reviewed the different comments posted on the list in response 
to our initial proposal.
After thinking further about that, we'd like to propose the following as 
a way forward:

At the same time we issue a Working Group Last Call we would ask for 
knowledge of existing implementations, and the more details provided at 
that time, the better.
In the situation where an implementation would exist we would proceed 
with submission to IESG.
In the opposite situation (no implementation exists), we would 
systematically ask the WG for reasoned opinions regarding whether we 
should nevertheless proceed with submission to IESG.
We will gauge consensus on that aspect. In case consensus is in favour 
of proceeding with submission to IESG we will do so. In the opposite 
case, we will put the document in a "Waiting for implementation" state 
until information on an existing implementation is brought to our 
knowledge or of the WG.

Please share your views on that.

Thank you

M&T

Le 24/11/2015 10:03, Thomas Morin a écrit :
> Hello everyone,
>
> Following the positive feedback received during BESS meeting in Yokohama
> about introducing a one-implementation requirement in BESS, we propose
> to do the following for future WG last calls:
>
> As a prerequisite before doing a working group last call on a document,
> the chairs will ask the working group for known implementations of the
> specifications; a relatively detailed level of information will be
> required (e.g. "release x.y of solution z shipping date d", "all
> features implemented", "partial implementation only", etc.) and everyone
> will be invited to reply (not only co-authors of the specifications);
> the chairs will then do the working group last call if satisfying
> information was provided on at least one implementation.
>
> We are open for comments on this proposal until December 7th.
>
> Martin & Thomas
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 Dec 2015 10:14:51 -0500

Martin,

That sounds reasonable to me.

Cheers,
Andy

On Mon, Dec 14, 2015 at 4:28 AM, Martin Vigoureux <
[email-masked]> wrote:

> WG,
>
> we have reviewed the different comments posted on the list in response to
> our initial proposal.
> After thinking further about that, we'd like to propose the following as a
> way forward:
>
> In the situation where an implementation would exist we would proceed with
> submission to IESG.
> systematically ask the WG for reasoned opinions regarding whether we should
> nevertheless proceed with submission to IESG.
> We will gauge consensus on that aspect. In case consensus is in favour of
> proceeding with submission to IESG we will do so. In the opposite case, we
> will put the document in a "Waiting for implementation" state until
> information on an existing implementation is brought to our knowledge or of
> the WG.
>

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Mon, 14 Dec 2015 17:47:51 +0000

Martin, for me this seems a reasonable way forward

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 14 Dec 2015 18:05:34 +0000

Martin,

Sounds like solid and reasonable approach!

Regards,
Jeff

> On Dec 14, 2015, at 1:28 PM, Martin Vigoureux <[email-masked]> wrote:
> 
> WG,
> 
> we have reviewed the different comments posted on the list in response to our initial proposal.
> After thinking further about that, we'd like to propose the following as a way forward:
> 
> At the same time we issue a Working Group Last Call we would ask for knowledge of existing implementations, and the more details provided at that time, the better.
> In the situation where an implementation would exist we would proceed with submission to IESG.
> In the opposite situation (no implementation exists), we would systematically ask the WG for reasoned opinions regarding whether we should nevertheless proceed with submission to IESG.
> We will gauge consensus on that aspect. In case consensus is in favour of proceeding with submission to IESG we will do so. In the opposite case, we will put the document in a "Waiting for implementation" state until information on an existing implementation is brought to our knowledge or of the WG.
>

---

From: Antoni Przygienda <[email-masked]>
Date: Mon, 14 Dec 2015 18:21:35 +0000

If that's what can be agreed on, I'm for it ... That puts at least something in terms of reality check between things being paper and going into STD tracks ...  

thanks 

--- tony
_____________________________________________
"Simple, clear purpose and principles give rise to complex and intelligent behavior. Complex rules and regulations give rise to simple and stupid behavior." 
--- Dee Hock 

> -----Original Message-----
> From: BESS [mailto:[email-masked]] On Behalf Of Martin Vigoureux
> Sent: Monday, December 14, 2015 1:29 AM
> To: [email-masked]
> Subject: Re: [bess] Introducing a one-implementation requirement before
> WG last calls
> 
> WG,
> 
> In the opposite situation (no implementation exists), we would systematically
> ask the WG for reasoned opinions regarding whether we should nevertheless
> proceed with submission to IESG.
> > Following the positive feedback received during BESS meeting in
> > Yokohama about introducing a one-implementation requirement in BESS,
> > we propose to do the following for future WG last calls:
> >
> > As a prerequisite before doing a working group last call on a
> > document, the chairs will ask the working group for known
> > implementations of the specifications; a relatively detailed level of
> > information will be required (e.g. "release x.y of solution z shipping
> > date d", "all features implemented", "partial implementation only",
> > etc.) and everyone will be invited to reply (not only co-authors of
> > the specifications); the chairs will then do the working group last
> > call if satisfying information was provided on at least one implementation.
> >

---

From: Eric Rosen <[email-masked]>
Date: Mon, 14 Dec 2015 14:32:29 -0500

My opinion is unchanged; there is no need to impose any implementation 
requirement, nor is there any need to add more process hurdles that 
further slow down the progress of a document towards publication.  
Certainly there is no need to gather details about implementations, 
vendor releases, etc.  The process is already slow enough and has enough 
useless overhead.

If folks object to the progression of a document, they are already free 
to make those objections during last call.

On 12/14/2015 4:28 AM, Martin Vigoureux wrote:
> knowledge of existing implementations, and the more details provided 
> at that time, the better.

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Tue, 15 Dec 2015 00:08:46 +0000

This is a more reasonable approach. I am OK with this. 

Andrew

Sent from my iPhone

> On Dec 14, 2015, at 5:28 PM, Martin Vigoureux <[email-masked]> wrote:
> 
> WG,
>

---

From: Loa Andersson <[email-masked]>
Date: Tue, 15 Dec 2015 12:20:54 +0800

Folks,

I'm mostly on the same page as Eric, if for no other reason that we have
an implementation hurdle in the shepherds write-up. No need to raise it
higher it already serve the purpose.

/Loa

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 16 Dec 2015 17:56:31 -0500

M&T: 

You handling of this discussion has been excellent. 

I think you are making a sensible choice to look for an implementations
details, and then provide the details to the WG.   Your choice of one
implementation sending things to the WG provides the WG with more
information.  You allowing a draft to go forward based on input from the WG.

One other thought,  we might bring the subject of IDR and BESS handling of
the implementation requirements to the NANOG, RIPE, LACNIC, APNIC, and
*NOGs.  If they can give both IDR and BESS a list of their concerns, it
would be helpful to know what the operators as a whole want us to do.  What
needs 2 implementations versus 1 implementation.  In the past, NANOG folks
have encouraged me (as IDR chair) for 2 implementations for basic IDR
mechanisms.   It would be good to get more feedback for 2016's operators.  

Cheerily, 

Sue Hares

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Martin Vigoureux
Sent: Monday, December 14, 2015 4:29 AM
To: [email-masked]
Subject: Re: [bess] Introducing a one-implementation requirement before WG
last calls

WG,

knowledge of existing implementations, and the more details provided at that
time, the better.

Thank you

M&T