Subject: [bess] Alia Atlas' Discuss on draft-ietf-bess-virtual-subnet-06: (with DISCUSS)

From: "Alia Atlas" <[email-masked]>
Date: Wed, 02 Dec 2015 19:06:35 -0800

Alia Atlas has entered the following ballot position for
draft-ietf-bess-virtual-subnet-06: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-virtual-subnet/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for a clear and well-written document.  I have one point
that is peripheral to most of the draft.

In Section 4.3, it says:

 " In addition, for any other
   applications that generate intra-subnet traffic with TTL set to 1,
   these applications may not work properly in the Virtual Subnet
   context, unless special TTL processing for such context has been
   implemented (e.g., if the source and destination addresses of a
   packet whose TTL is set to 1 belong to the same extended subnet,
   neither ingress nor egress PE routers should decrement the TTL of
   such packet.  Furthermore, the TTL of such packet should not be
   copied into the TTL of the transport tunnel and vice versa)."

The idea of not decrementing TTL is quite concerning.  I can conjecture
cases where there is a routing loop between the relevant PEs - during
reconvergence when a host moves from one datacenter to another is
a trivial case.  

One approach may be to ask why a packet would have a TTL of 1 and
determine if this case must be resolved.  Another might detecting a loop
back to an out-of-datacenter PE and dropping the packet.  I'm sure you
can
develop other good ideas and solutions.

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 3 Dec 2015 04:08:39 +0000

Hi Alia,

> -----Original Message-----
> From: Alia Atlas [mailto:[email-masked]]
> Sent: Thursday, December 03, 2015 11:07 AM
> To: The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Alia Atlas' Discuss on draft-ietf-bess-virtual-subnet-06: (with DISCUSS)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Thank you for a clear and well-written document.  I have one point that is
> peripheral to most of the draft.
> 
> In Section 4.3, it says:
> 
> The idea of not decrementing TTL is quite concerning.  I can conjecture cases
> where there is a routing loop between the relevant PEs - during reconvergence
> when a host moves from one datacenter to another is a trivial case.
> 
> One approach may be to ask why a packet would have a TTL of 1 and determine
> if this case must be resolved.  Another might detecting a loop back to an
> out-of-datacenter PE and dropping the packet.  I'm sure you can develop other
> good ideas and solutions.

How about doing the following text change:

" In addition, for any other
    applications that generate intra-subnet traffic with TTL set to 1,
    these applications may not work properly in the Virtual Subnet
    context, unless special TTL processing and loop-prevention mechanisms for such context have been
    implemented. Details about such special TTL processing and loop-prevention mechanisms are outside the scope of this document."

Best regards,
Xiaohu

---

From: Alia Atlas <[email-masked]>
Date: Wed, 2 Dec 2015 23:13:51 -0500

That works for me.

Thanks,
Alia
On Dec 2, 2015 11:08 PM, "Xuxiaohu" <[email-masked]> wrote:

> email
> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> cases
> determine
>     implemented. Details about such special TTL processing and
> loop-prevention mechanisms are outside the scope of this document."
>
> Best regards,
> Xiaohu
>
> >
> >
>
>

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 14 Dec 2015 13:32:20 +0000

Alia:

Hi!

Xiaohu posted an update which I think should address your concerns.  Please take a look.

Thanks!

Alvaro.

On 12/2/15, 11:13 PM, "Alia Atlas" <[email-masked]<mailto:[email-masked]>> wrote:

That works for me.

Thanks,
Alia

On Dec 2, 2015 11:08 PM, "Xuxiaohu" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alia,

> From: Alia Atlas [mailto:[email-masked]<mailto:[email-masked]>]
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;
> [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Best regards,
Xiaohu