Subject: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?

From: "Henderickx, Wim (Nokia - BE)" <[email-masked]>
Date: Tue, 3 May 2016 08:41:52 +0000

On a 4PE node the connectivity is like this:

v4 peering <— BGP (v4 NLRI with v4 NH) —> 4PE  —— MPLS v6 ————— 4PE  <— BGP (v4 NLRI with v4 NH) —> v4 peering
                                                                                  <— BGP (v4 NLRI with v6 NH) —>

From: "EXT [email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 3 May 2016 at 08:31
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "thomas.morin" <[email-masked]<mailto:[email-masked]>>, bess <[email-masked]<mailto:[email-masked]>>
Subject: Re: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?

Don't you need a IPv4 next hop to populate the IPv4 routing table in the 4PE router?

________________________________
[email-masked]<mailto:[email-masked]>

From: Henderickx, Wim (Nokia - BE)<mailto:[email-masked]>
Date: 2016-04-29 00:17
To: [email-masked]<mailto:[email-masked]>; thomas.morin<mailto:[email-masked]>; bess<mailto:[email-masked]>
Subject: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?
To support a v6 MPLS network we just need a v6 Next-hop for V4 prefixes as described in RFC5549

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 26 April 2016 at 01:58
To: "thomas.morin" <[email-masked]<mailto:[email-masked]>>, bess <[email-masked]<mailto:[email-masked]>>
Subject: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?

Hi, Everyone,

As talked in IETF 95 meeting in Buenos Aires, and suggested by our Chairs, I want to know your opinion, especially the experts from the vendors, about 4PE routers.
Do 4PE routers need both IPv4 and IPv6 next hop information to install their IPv4 and IPv6 routing tables when they receive IPv4 routes from other 4PE routers? Or they only need IPv6 next hop information?

Since RFC5549 can only convey IPv4 or IPv6 next hop for IPv4 routes, but not both, I submit draft draft-li-bess-4pe to solve this problem. 4PE I think is a scenario for my draft. Any other scenarioes that need both IPv4 and IPv6 next hops?

For your reference, RFC5549 is here, https://www.rfc-editor.org/rfc/rfc5549.txt, draft-li-bess-4pe is here, https://www.ietf.org/id/draft-li-bess-4pe-01.txt<https://www.ietf.org/id/draft-li-bess-4pe-01.txt,>

Thank you very much

________________________________
[email-masked]<mailto:[email-masked]>

From: Thomas Morin<mailto:[email-masked]>
Date: 2016-04-13 20:47
To: [email-masked]<mailto:[email-masked]>; bess<mailto:[email-masked]>
Subject: Re: [bess] minutes of our IETF 95 meeting
Hi,

I've updated the minutes.
Thanks for the precision.

Beyond this minute adjustment, I understand that the key thing you need to clarify is what is missing or problematic in RFC5549.

Thank you,

-Thomas

2016-04-13, [email-masked]<mailto:[email-masked]>:
for draft-li-bess-4pe-01:
Please add my response to comments from Keyur and Wim: 4PE routers need IPv4 next hop information to install their IPv4 routing table.

Thanks and Best Regards,
________________________________
[email-masked]<mailto:[email-masked]>

From: Thomas Morin<mailto:[email-masked]>
Date: 2016-04-08 05:44
To: BESS<mailto:[email-masked]>
Subject: [bess] minutes of our IETF 95 meeting
Hi everyone,

We have just posted draft minutes for today's meeting.

You can read them at
https://www.ietf.org/proceedings/95/minutes/minutes-95-bess

Please send any comments you may have on these minutes.

Many many thanks to Gunter for his minute taking!

-Thomas/Martin

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 4 May 2016 16:49:06 +0800

Thank you very much for your perfect picture.

The problem is that the 4PE router only has one routing table for IPv4 routes including the routes learned from other 4PE routers and those learned from v4 peering routers. However, these two kinds of IPv4 routes have different NLRI format. Does the 4PE router use v6 NH or v4 NH in its IPv4 routing table? I want to confirm whether or not  the 4PE router can install its IPv4 routing table with two kinds of NLRI format illustrated in your picture.

[email-masked]
 
From: Henderickx, Wim (Nokia - BE)
Date: 2016-05-03 16:41
To: EXT [email-masked]; thomas.morin; bess
Subject: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?
On a 4PE node the connectivity is like this:

From: "EXT [email-masked]" <[email-masked]>
Date: Tuesday 3 May 2016 at 08:31
To: Wim Henderickx <[email-masked]>, "thomas.morin" <[email-masked]>, bess <[email-masked]>
Subject: Re: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?

[email-masked]
 
From: Henderickx, Wim (Nokia - BE)
Date: 2016-04-29 00:17
To: [email-masked]; thomas.morin; bess
Subject: Re: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?
To support a v6 MPLS network we just need a v6 Next-hop for V4 prefixes as described in RFC5549

From: BESS <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Tuesday 26 April 2016 at 01:58
To: "thomas.morin" <[email-masked]>, bess <[email-masked]>
Subject: [bess] Do 4PE routers need both IPv4 and IPv6 next hop information?

Hi, Everyone,

For your reference, RFC5549 is here, https://www.rfc-editor.org/rfc/rfc5549.txt, draft-li-bess-4pe is here, https://www.ietf.org/id/draft-li-bess-4pe-01.txt

Thank you very much

[email-masked]
 
From: Thomas Morin
Date: 2016-04-13 20:47
To: [email-masked]; bess
Subject: Re: [bess] minutes of our IETF 95 meeting
Hi,

Thank you,

-Thomas

2016-04-13, [email-masked]:
for draft-li-bess-4pe-01:
Please add my response to comments from Keyur and Wim: 4PE routers need IPv4 next hop information to install their IPv4 routing table.

Thanks and Best Regards,

[email-masked]
 
From: Thomas Morin
Date: 2016-04-08 05:44
To: BESS

You can read them at 

 
-Thomas/Martin
 
[email-masked]