Subject: [bess] Ben Campbell's No Objection on draft-ietf-bess-pta-flags-03: (with COMMENT)

From: "Ben Campbell" <[email-masked]>
Date: Tue, 03 May 2016 15:48:30 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-bess-pta-flags-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-pta-flags/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I do not suggest a change to the draft, but I am curious why the
"Additional PMSI Tunnel Attribute Flags" registry needs a
standards-action policy. It's pretty obvious why for the main flag
registry, due to the small value-space. Are people concerned that the
Additional flag will also run out of space? Or that people will define
"bad" or non-interoperable extensions?

---

From: Eric C Rosen <[email-masked]>
Date: Wed, 4 May 2016 16:48:56 -0400

On 5/3/2016 6:48 PM, Ben Campbell wrote:
> I am curious why the
> Additional flag will also run out of space?

Yes, I think that is an issue.  48 flags may sound like a lot, but the 
existing 8 flags got used up fairly quickly and suddenly; one draft 
grabbed four flag bits.  So FCFS doesn't really seem like an appropriate 
policy here.   The other possible policies are all subject to politics, 
but at least Standards Action comes with early allocation.

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Thu, 5 May 2016 08:59:36 +0000

Eric,

For my own understanding and apologies if this is a dumb question, but I read this in RFC5226:

"Standards Action - Values are assigned only for Standards Track RFCs approved by the IESG.”

What do you mean by "at least Standards Action comes with early allocation”?
This still requires an RFC or... do you mean there will be a way to register bits earlier than the RFC milestone?

Thank you.
Jorge 

On 5/4/16, 10:48 PM, "BESS on behalf of EXT Eric C Rosen" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Thu, 5 May 2016 11:15:39 +0000

Just in case it helps someone else: Martin clarified to me that early allocation before RFC is possible for Standards Action, according to RFC7120.

Thank you Martin.
Jorge

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 05 May 2016 09:01:58 -0500

On 4 May 2016, at 15:48, Eric C Rosen wrote:

> grabbed four flag bits.  So FCFS doesn't really seem like an 
> appropriate policy here.   The other possible policies are all subject 
> to politics, but at least Standards Action comes with early 
> allocation.

That's a reasonable answer.

Thanks!

Ben.