Subject: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

From: Thomas Morin <[email-masked]>
Date: Wed, 4 May 2016 16:17:59 +0200

Hello working group,

This email starts a two-week poll on adopting
draft-shah-bess-l2vpn-yang [1] as a working group document.

Please state on the list if you support adoption or not (in both cases, 
please also state the reasons).

This poll runs until *May 25th*.

This call runs in parallel with the adoption call on 
draft-brissette-bess-evpn-yang hence the extended period.

We are *coincidentally* also polling for knowledge of any other
IPR that applies to this draft, to ensure that IPR has been disclosed
in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669
and 5378 for more details).

==> *If* you are listed as a document author or contributor please
respond to this email and indicate whether or not you are aware of any
relevant IPR.

The draft will not be adopted until a response has been received from
each author and contributor.

If you are not listed as an author or contributor, then please 
explicitly respond only if you are aware of any IPR that has not yet 
been disclosed in conformance with IETF rules.

Thank you,

Martin & Thomas
bess chairs

[1] https://datatracker.ietf.org/doc/draft-shah-bess-l2vpn-yang

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 4 May 2016 10:36:12 -0400

Thomas,

I support adopting this as a WG draft, it’s excellent work.

Cheers,
Andy

On Wed, May 4, 2016 at 10:17 AM, Thomas Morin <[email-masked]>
wrote:

> If you are not listed as an author or contributor, then please explicitly
> respond only if you are aware of any IPR that has not yet been disclosed in
> conformance with IETF rules.
>
> Thank you,
>
> Martin & Thomas
> bess chairs
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: Ravi Torvi <[email-masked]>
Date: Wed, 04 May 2016 18:10:09 +0000

Support

Regards
Ravi

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Wed, 4 May 2016 18:10:26 +0000

Support.

Great team effort. This work should be adopted by the WG.

Thanks.
Jorge

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 04 May 2016 11:17:43 -0700

Yes/support

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Wed, 4 May 2016 19:57:33 +0000

Thomas,

As a co-author, I support this draft.
A lot of work has been done to get where we are with this one.
It is in a fairly good state and definitely ready for WG adoption.

Regards,

Patrice

   Patrice Brissette
TECHNICAL LEADER.ENGINEERING

[email-masked]
Phone: +1 613 254 3336

Cisco Systems Canada Co. / Les Systemes Cisco Canada CIE
Canada
Cisco.com <http://www.cisco.com/global/CA/>

 Think before you print.This
 email may contain confidential and privileged material for the sole use
 of the intended recipient. Any review, use, distribution or disclosure
by others is strictly prohibited. If you are not the intended recipient
(or authorized to receive for the recipient), please contact the sender
by reply email and delete all copies of this message.
Please click here 
<http://www.cisco.com/web/about/doing_business/legal/cri/index.html> for
Company Registration Information.

---

From: Iftekhar Hussain <[email-masked]>
Date: Wed, 4 May 2016 20:38:22 +0000

As a co-author, support this draft.
I am not aware of any relevant IPR.

Regards,
Iftekhar

-----Original Message-----
From: Thomas Morin [mailto:[email-masked]] 
Sent: Wednesday, May 04, 2016 7:18 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

This email starts a two-week poll on adopting draft-shah-bess-l2vpn-yang [1] as a working group document.

Please state on the list if you support adoption or not (in both cases, please also state the reasons).

This call runs in parallel with the adoption call on draft-brissette-bess-evpn-yang hence the extended period.

Thank you,

Martin & Thomas
bess chairs

---

From: "Jalil, Luay" <[email-masked]>
Date: Thu, 5 May 2016 06:14:48 -0400

Support as co-author

Not aware of any relevant IPR

Luay

From: Thomas Morin <[email-masked]<mailto:[email-masked]>>
Organization: Orange
Date: Wednesday, May 4, 2016 at 9:17 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [E] [bess] Poll for adoption: draft-shah-bess-l2vpn-yang
Resent-From: Thomas Morin <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>
Resent-Date: Wednesday, May 4, 2016 at 9:55 AM

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: Luay Jalil <[email-masked]>
Date: Thu, 5 May 2016 07:23:26 -0300

Resending due to mail delivery messages

Support as co-author

Thanks,
Luay

---

From: Zhuangshunwan <[email-masked]>
Date: Thu, 5 May 2016 14:12:10 +0000

Hi,

As a co-author, I support this draft.
I am not aware of any IPR that applies to this document.

Best Regards,
Shunwan

-----邮件原件-----
发件人: BESS [mailto:[email-masked]] 代表 Thomas Morin
发送时间: 2016年5月4日 22:18
收件人: [email-masked]
抄送: [email-masked]
主题: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: "Wen, Bin" <[email-masked]>
Date: Thu, 5 May 2016 14:30:38 +0000

Hi,

Best Regards,

Bin Wen

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 5 May 2016 10:48:46 -0400

Support as co-author.
I am not aware of any IPR that applies to this draft.

Himanshu using iPad (so excuse the auto-corrects...)
________________________________________
From: BESS [[email-masked]] On Behalf Of Luay Jalil [[email-masked]]
Sent: Thursday, May 05, 2016 6:23 AM
To: Thomas Morin
Cc: BESS; [email-masked]
Subject: Re: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Support as co-author

Thanks,
Luay

On May 4, 2016 9:18 AM, "Thomas Morin" <[email-masked]<mailto:[email-masked]>> wrote:
Hello working group,

If you are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Thank you,

Martin & Thomas
bess chairs

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: "Tapraj Singh (tapsingh)" <[email-masked]>
Date: Thu, 5 May 2016 16:43:36 +0000

Thanks
Tapraj

On 5/5/16, 7:48 AM, "BESS on behalf of Shah, Himanshu"
<[email-masked] on behalf of [email-masked]> wrote:

>On May 4, 2016 9:18 AM, "Thomas Morin"
><[email-masked]<mailto:[email-masked]>> wrote:
>Hello working group,
>
>respond only if you are aware of any IPR that has not yet been disclosed
>in conformance with IETF rules.
>
>Thank you,
>
>Martin & Thomas
>bess chairs
>

---

From: Sajjad Ahmed <[email-masked]>
Date: Thu, 5 May 2016 18:46:52 +0000

Support as co-author.
I am not aware of any IPR related to this draft.

Regards ,
Sajjad.

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, May 05, 2016 7:49 AM
To: Luay Jalil; Thomas Morin
Cc: BESS; [email-masked]
Subject: RE: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Support as co-author.

Himanshu using iPad (so excuse the auto-corrects...) ________________________________________

Support as co-author

Thanks,
Luay

We are *coincidentally* also polling for knowledge of any other IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

==> *If* you are listed as a document author or contributor please respond to this email and indicate whether or not you are aware of any relevant IPR.

The draft will not be adopted until a response has been received from each author and contributor.

Thank you,

Martin & Thomas
bess chairs

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Fri, 6 May 2016 03:49:48 +0000

Hi,

Best Regards,
Haibo

-----邮件原件-----
发件人: BESS [mailto:[email-masked]] 代表 Thomas Morin
发送时间: 2016年5月4日 22:18
收件人: [email-masked]
抄送: [email-masked]
主题: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: Giles Heron <[email-masked]>
Date: Fri, 6 May 2016 21:13:13 +0100

Hi Thomas,

I support this document being adopted.

However I would like to see the comments that Carl Moberg and I brought to the authors in Prague get addressed (they still seem to be outstanding).   Sorry - I should have followed up on those before now.

There’s also some degree of overlap with draft-brissette-bess-evpn-yang, and with draft-dhjain-bess-bgp-l3vpn-yang-01, and I’d like to see common components (e.g. BGP RTs/RDs) being abstracted into common models.

Giles

> On 4 May 2016, at 15:17, Thomas Morin <[email-masked]> wrote:
> 
> Hello working group,
>

---

From: Lizhenbin <[email-masked]>
Date: Mon, 9 May 2016 12:32:16 +0000

As a co-author, I support this document being adopted.
Not aware of any IPR that applies to this draft.

Thanks.
Robin

-----邮件原件-----
发件人: BESS [mailto:[email-masked]] 代表 Thomas Morin
发送时间: 2016年5月4日 22:18
收件人: [email-masked]
抄送: [email-masked]
主题: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: "Ing-Wher (Helen) Chen" <[email-masked]>
Date: Tue, 10 May 2016 14:42:09 +0000

As a co-author, I support adoption of this draft.  I'm not aware of any relevant IPR.

Thanks,
Helen

> Sent: Wednesday, May 4, 2016 10:18 AM
> To: [email-masked]

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 10 May 2016 14:58:56 +0000

Support.

Regards,

- Xufeng

> From: BESS [mailto:[email-masked]] On Behalf Of Thomas Morin

---

From: Jonathan Hardwick <[email-masked]>
Date: Tue, 10 May 2016 15:33:35 +0000

Support as co-author.

Best regards
Jon

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Thomas Morin
Sent: 04 May 2016 15:18
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: Kishore Tiruveedhula <[email-masked]>
Date: Tue, 10 May 2016 15:36:22 +0000

As a co-author, I support adoption of this draft.  I am not aware of any
relevant IPR.

Thanks,
Kishore

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 10 May 2016 15:40:14 +0000

Support as co-author.

Regards,
Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 10 May 2016 15:46:59 +0000

Support adoption as WG doc.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 11 May 2016 16:33:51 -0400

Hi Giles -

Thanks for your support.
We will work through your comments as highest priority through the next iteration of the draft.

Thanks,
Himanshu

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, May 06, 2016 4:13 PM
To: Thomas Morin; Carl Moberg (camoberg)
Cc: [email-masked]; [email-masked]
Subject: Re: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hi Thomas,

Giles

> We are *coincidentally* also polling for knowledge of any other IPR 
> that applies to this draft, to ensure that IPR has been disclosed in 
> compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for 
> more details).
>

---

From: Santosh Esale <[email-masked]>
Date: Wed, 11 May 2016 22:48:43 +0000

I support adoption of this draft as a co-author. I am not aware of any IPR
related to this draft.

Thanks

Santosh

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Mon, 23 May 2016 14:25:43 +0000

I am not aware of any IPR related to the draft.

Regards

Matthew

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 23 May 2016 13:31:46 -0400

Including kamran raza..

Thanks,
Himanshu

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Thomas Morin
Sent: Wednesday, May 04, 2016 10:18 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hello working group,

Thank you,

Martin & Thomas
bess chairs

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Tue, 24 May 2016 00:06:46 +0000

I support this draft as a co-author and I am not aware of any relevant IPR.

Regards,

Patrice

   Patrice Brissette

[email-masked]
Phone: +1 613 254 3336

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 24 May 2016 13:51:40 +0100

Hi Thomas,

I'm not opposed to this work at all. But I think that the extensive use of the
word "service" in the document may cause a load of confusion.

As far as I can see, this YANG model is about operating and monitoring the
network components and protocols that are used to realize (deliver) the service.
This is all information that the network operator (service provider) cares about
deeply, and that the equipment vendor must understand. But a lot of it is beyond
the concern (or understanding) of the service consumer who has requested the
service.

If I might compare with the work of L3SM, we need to distinguish between the
"service model" on the interface between the customer and the operator, and the
"service delivery model" on the northbound interface of an orchestrator". It may
be helpful to consider two separate conceptual components: a "service
orchestrator" that consumes a service model, and a "network orchestrator" that
consumes the model in this document and uses it to work out what to tell
protocols, network controller, etc. 

Perhaps the document could be enhanced by a little extra text explaining how the
model will be used. This need not be pages and pages, just a simple statement
that, for example, it is expected that this model will be used by the management
tools run by network operators in order to manage and monitor the network
resources that they use to deliver L2VPN services.

Might I ask also that one sentence is removed from the Abstract *before*
adoption?
   This is a
   living document and contains aspects of object models that have been
   discussed extensively in the working group with consensus.
It is not the place of the authors to claim consensus for the content of the
document: that call belongs to the WG chairs in response to targeted questions
to the WG. WG adoption is not a measure by which to determine consensus for the
content of the document, either.

Additionally, the Introduction has:
   The definition work is undertaken initially by a smaller
   working group with members representing various vendors and service
   providers.
I'm sure you don't mean to imply any subversion of the IETF process, and I am
equally sure that this is just a matter of English usage.
I think you need...
   The definition work was initially undertaken initially by a small
   group of co-authors with members representing various vendors and service
   providers.
Again, this change needs to be made before adoption.

Thanks,
Adrian

---

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Tue, 24 May 2016 13:59:40 +0000

Hi WG/chairs,

As a co-author, I support the adoption of this draft. I am also not aware
of any IPR associated with this draft.

Regards.
‹
Kamran Raza

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 25 May 2016 09:16:28 -0400

Hi Adrian -

Appreciate your detail review and the comments.
Please see below inline responses to your comments..

Thanks,
Himanshu

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Tuesday, May 24, 2016 8:52 AM
To: 'Thomas Morin'; [email-masked]
Cc: [email-masked]
Subject: Re: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hi Thomas,

I'm not opposed to this work at all. But I think that the extensive use of the word "service" in the document may cause a load of confusion.

As far as I can see, this YANG model is about operating and monitoring the network components and protocols that are used to realize (deliver) the service.
This is all information that the network operator (service provider) cares about deeply, and that the equipment vendor must understand. But a lot of it is beyond the concern (or understanding) of the service consumer who has requested the service.

If I might compare with the work of L3SM, we need to distinguish between the "service model" on the interface between the customer and the operator, and the "service delivery model" on the northbound interface of an orchestrator". It may be helpful to consider two separate conceptual components: a "service orchestrator" that consumes a service model, and a "network orchestrator" that consumes the model in this document and uses it to work out what to tell protocols, network controller, etc. 

Perhaps the document could be enhanced by a little extra text explaining how the model will be used. This need not be pages and pages, just a simple statement that, for example, it is expected that this model will be used by the management tools run by network operators in order to manage and monitor the network resources that they use to deliver L2VPN services.

[Himanshu>] Agreed. Will clarify the purpose of the draft as you suggest above.

Might I ask also that one sentence is removed from the Abstract *before* adoption?
   This is a
   living document and contains aspects of object models that have been
   discussed extensively in the working group with consensus.
It is not the place of the authors to claim consensus for the content of the
document: that call belongs to the WG chairs in response to targeted questions to the WG. WG adoption is not a measure by which to determine consensus for the content of the document, either.

I'm sure you don't mean to imply any subversion of the IETF process, and I am equally sure that this is just a matter of English usage.

[Himanshu>] Agreed on this as well. Did not mean to shortcut the due process at IETF
[Himanshu>] 

[Himanshu>] 
[Himanshu>] Will update the draft to address your comments in the -00- version of the WG draft.
Does that work for you?

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 25 May 2016 15:22:16 +0100

Thanks Himanshu,

That all sounds reasonable.

Adrian

> Sent: 25 May 2016 14:16
> To: [email-masked]; 'Thomas Morin'; [email-masked]
word
> "service" in the document may cause a load of confusion.
> 
> "service model" on the interface between the customer and the operator, and
> the "service delivery model" on the northbound interface of an orchestrator".
It
> may be helpful to consider two separate conceptual components: a "service
> Perhaps the document could be enhanced by a little extra text explaining how
> the model will be used. This need not be pages and pages, just a simple
> statement that, for example, it is expected that this model will be used by
the
> management tools run by network operators in order to manage and monitor the
> network resources that they use to deliver L2VPN services.
> 
> to the WG. WG adoption is not a measure by which to determine consensus for
> the content of the document, either.
> 
> [Himanshu>] Agreed on this as well. Did not mean to shortcut the due process
at
> IETF

---

From: "Tapraj Singh (tapsingh)" <[email-masked]>
Date: Wed, 25 May 2016 15:26:44 +0000

Support as co-author

Thanks,
Tapraj

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 25 May 2016 11:43:47 -0400

Support for draft-shah-bess-l2vpn-yang.  It is a good start to this model. 

+1 to Giles comment that the bgp-parameters structure needs to be harmonized draft-dhjain-bess-bgp-l3vpn-yang. 

Both draft-shah-bess-l2vpn-yang and draft-dhjain-bess-bgp-l3vpn-yang should reference the base bgp model (draft-idr-bgp-model) as the bgp parameters should link to a bgp peer.   

How is this linkage occurring in the models? Are you simply augmenting the base BGP specification?  Is it true that your bgp-parameters do not require any policy? 

Sue Hares 

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Shah, Himanshu
Sent: Wednesday, May 11, 2016 4:34 PM
To: Giles Heron; Thomas Morin; Carl Moberg (camoberg)
Cc: [email-masked]; [email-masked]
Subject: Re: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hi Giles -

Thanks for your support.

Thanks,
Himanshu

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, May 06, 2016 4:13 PM
To: Thomas Morin; Carl Moberg (camoberg)
Cc: [email-masked]; [email-masked]
Subject: Re: [bess] Poll for adoption: draft-shah-bess-l2vpn-yang

Hi Thomas,

Giles

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 30 May 2016 20:25:27 -0700

Yes/support