Subject: [bess] Fwd: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis

From: Loa Andersson <[email-masked]>
Date: Wed, 31 Aug 2016 12:28:43 +0800

Working Groups,

Please note that the working group adoption poll for draft-rosen-mpls-rfc3107bis has been started in the mpls wg. Please send your comments to the mpls wg mailing list ([email-masked]). 

/Loa
mpls wg co-chair

Sent from my iPhone

Begin forwarded message:

> From: Loa Andersson <[email-masked]>
> Date: 30 augusti 2016 08:10:13 GMT+8
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis
> 
> Working Group,
> 
> This is to start a two week poll on adopting draft-rosen-mpls-rfc3107bis
> as an MPLS working group document.
> 
> Please send your comments (support/not support) to the mpls working
> group mailing list ([email-masked]). Please give a technical
> motivation for your support/not support, especially if you think that
> the document should not be adopted as a working group document.
> 
> There are no IPR disclosures against this document.
> 
> All the authors has stated on the on the mpls wg mailing list that they
> are not aware of any IPRs that relate to this document.
> 
> The working group adoption poll ends September 14, 2016.
> 
> /Loa
> 
> MPLS wg co-chair.
> -- 
> 
> 
> Loa Andersson                        email: [email-masked]
> Senior MPLS Expert                          [email-masked]
> Huawei Technologies (consultant)     phone: +46 739 81 21 64
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 31 Aug 2016 11:24:54 +0200

Hi Eric,

While adoption call is sort of encouragement for further input before I
respond to Loa's mail I would like to get one additional answer from
3107bis authors and WGs members.

Those who spend years in mpls deployment know quite well that the biggest
issue with today's 3107 deployment is lack of the clear definition of its
interaction with SAFI-1. While one would hope that 3107bis with new
capability will clean this mess section 5 of your document rather sweeps it
all under the carpet stating that it is just local policy. IMO it is not a
matter of local policy nor it is implementation detail.

Local policy can be to choose which RIB (or sequence of RIBs) should be
used for resolution of specific SAFIs and not how to mix SAFI-1 with
SAFI-4. It's not a local matter at all to have deployment resulting in
inconsistent IBGP best paths across given domain.

To me cleanest is to separate those two SAFIs completely from each other by
the spec both in BGP (done) as well as local RIB and FIB/LFIB.

Likewise I do not quite agree that SAFI-4 should be "convertible" to
SAFI-1. And we all realize that opposite direction is rather hard.

Another perhaps minor clarification would be to get an explicit
confirmation that SAFI-4 can be recursive over SAFI-4 or for that matter
SAFI-1 (MPLS in GRE or SR in IP).

Thx,
R.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Aug 2016 14:15:01 +0000

Hi Robert,

Currently, everything in draft-rosen-mpls-rfc3107bis is pretty much backward compatible with our more than a decade old RFC 3107 implementations and deployments. What you are proposing is not and has implications in both the control and forwarding planes. If you really believe that this is “the biggest issue", I’d suggest you articulate it in a separate draft with concrete use cases for having separate IP and MPLS topologies for the same set of prefixes. Then the WGs can evaluate the requirement and proposed solution independent of RFC 3107 BIS.

Thanks,
Acee

From: mpls <[email-masked]<mailto:[email-masked]>> on behalf of Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 31, 2016 at 5:24 AM
To: Eric C Rosen <[email-masked]<mailto:[email-masked]>>
Cc: IDR List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mpls] [Idr] Fwd: Working Group adoption poll on draft-rosen-mpls-rfc3107bis

Hi Eric,

While adoption call is sort of encouragement for further input before I respond to Loa's mail I would like to get one additional answer from 3107bis authors and WGs members.

Those who spend years in mpls deployment know quite well that the biggest issue with today's 3107 deployment is lack of the clear definition of its interaction with SAFI-1. While one would hope that 3107bis with new capability will clean this mess section 5 of your document rather sweeps it all under the carpet stating that it is just local policy. IMO it is not a matter of local policy nor it is implementation detail.

Local policy can be to choose which RIB (or sequence of RIBs) should be used for resolution of specific SAFIs and not how to mix SAFI-1 with SAFI-4. It's not a local matter at all to have deployment resulting in inconsistent IBGP best paths across given domain.

To me cleanest is to separate those two SAFIs completely from each other by the spec both in BGP (done) as well as local RIB and FIB/LFIB.

Likewise I do not quite agree that SAFI-4 should be "convertible" to SAFI-1. And we all realize that opposite direction is rather hard.

Another perhaps minor clarification would be to get an explicit confirmation that SAFI-4 can be recursive over SAFI-4 or for that matter SAFI-1 (MPLS in GRE or SR in IP).

Thx,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 31 Aug 2016 16:40:23 +0200

Hi Acee,

There is no issue for compatibility as new proposal has its new BGP
capability hence there is no issue with deploying it gradually.

Yes it requires new RIB work for those implementations which today use
single RIB for both SAFI 1 and SAFI 4. FIB and LFIB are already separate.
Each SAFI in BGP also normally has it's own separate tables. So if anything
it requires a bit of cleanup work.

Main motivation here would be to help new vendors to make the unified
choice in how they will implement 3107bis so long term we get some
consistent way SAFI 4 is delivered. And if now at the "bis" rfc is not a
good time then what you are really advocating is to stay for years to come
with such undefined randomness across implementations.

Other then consistency I also see folks trying to use labeled BGP as
controller to network device protocol to install labels. For that use case
alone complete separation from SAFI 1 is very helpful.

Thx,
R.

On Wed, Aug 31, 2016 at 4:15 PM, Acee Lindem (acee) <[email-masked]> wrote:

> Hi Robert,
>
> Currently, everything in draft-rosen-mpls-rfc3107bis is pretty much
> backward compatible with our more than a decade old RFC 3107
> implementations and deployments. What you are proposing is not and has
> implications in both the control and forwarding planes. If you really
> believe that this is “the biggest issue", I’d suggest you articulate it in
> a separate draft with concrete use cases for having separate IP and MPLS
> topologies for the same set of prefixes. Then the WGs can evaluate the
> requirement and proposed solution independent of RFC 3107 BIS.
>
> Thanks,
> Acee
>
> From: mpls <[email-masked]> on behalf of Robert Raszuk <
> [email-masked]>
> To: Eric C Rosen <[email-masked]>
> Cc: IDR List <[email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> To me cleanest is to separate those two SAFIs completely from each other
> by the spec both in BGP (done) as well as local RIB and FIB/LFIB.
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Aug 2016 23:40:56 +0000

Hi Robert,

From: <[email-masked]<mailto:[email-masked]>> on behalf of Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 31, 2016 at 10:40 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: Eric C Rosen <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mpls] [Idr] Fwd: Working Group adoption poll on draft-rosen-mpls-rfc3107bis

Hi Acee,

There is no issue for compatibility as new proposal has its new BGP capability hence there is no issue with deploying it gradually.

The current capability is specific to support of multiple labels - not your parochial view on the interaction between SAFIs. Are you suggesting a second capability? All the more reason for a separate draft.

Yes it requires new RIB work for those implementations which today use single RIB for both SAFI 1 and SAFI 4. FIB and LFIB are already separate. Each SAFI in BGP also normally has it's own separate tables. So if anything it requires a bit of cleanup work.

So you are saying SAFI 4 would only apply to ILM and not NHLFE when the same prefix is advertised in both SAFI 1 and SAFI 4? Maybe I am missing something but I don’t see that this is useful deployment. In any event, the non-backward compatible behavior you are proposing would be better served in a separate draft than to burden RFC 3107 BIS.

Main motivation here would be to help new vendors to make the unified choice in how they will implement 3107bis so long term we get some consistent way SAFI 4 is delivered. And if now at the "bis" rfc is not a good time then what you are really advocating is to stay for years to come with such undefined randomness across implementations.

I agree with the current draft that it should be local policy. I don’t think you can assume that everyone agrees that this should be specified and that your view on how it should work is consensus. Hence, put it in a separate draft.

Other then consistency I also see folks trying to use labeled BGP as controller to network device protocol to install labels. For that use case alone complete separation from SAFI 1 is very helpful.

You have both ILM and NHLFE to consider here. I look forward to reviewing your draft on this topic. If there is consensus, merger with the draft under WG adoption can be considered.

Thanks,
Acee

Thx,
R.

On Wed, Aug 31, 2016 at 4:15 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,

Thanks,
Acee

Hi Eric,

Thx,
R.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Aug 2016 23:52:32 +0000

In case it is not obvious, I support MPLS WG adoption of the subject draft in its current form ;^). I already supported it on the MPLS list.
Thanks,
Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Loa Andersson <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 31, 2016 at 12:28 AM
To: IDR List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Fwd: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis

Working Groups,

Please note that the working group adoption poll for draft-rosen-mpls-rfc3107bis has been started in the mpls wg. Please send your comments to the mpls wg mailing list ([email-masked]<mailto:[email-masked]>).

/Loa
mpls wg co-chair

Sent from my iPhone

Begin forwarded message:

From: Loa Andersson <[email-masked]<mailto:[email-masked]>>
Date: 30 augusti 2016 08:10:13 GMT+8
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] Working Group adoption poll on draft-rosen-mpls-rfc3107bis

Working Group,

Please send your comments (support/not support) to the mpls working
group mailing list ([email-masked]<mailto:[email-masked]>). Please give a technical
motivation for your support/not support, especially if you think that
the document should not be adopted as a working group document.

/Loa

MPLS wg co-chair.
--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert                          [email-masked]<mailto:[email-masked]>
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls