Subject: [bess] Comments on draft-sajassi-bess-evpn-mvpn-seamless-interop-01

From: Xiejingrong <[email-masked]>
Date: Wed, 20 Jun 2018 02:37:43 +0000

Hi folks,
I have some comments on draft-sajassi-bess-evpn-mvpn-seamless-interop-01:

(1)     For section 9.2.2 where it stated "The MPLS label in the PMSI Tunnel Attribute MUST be the Virtual Network Identifier (VNI) associated with the customer MVPN.",

I think the VNI need not being included in 'MPLS Label' field of PTA, because every IP-VRF has a static configuration of the VNI value.

(2)     Some terminologies are lacking, for example CO and SPDC. I think they are different things, and authors can make clear about them.

(3)     Some references are lacking, for example [EVPN-IRB] in section 5, and [EVPN-IRB-MCAST] in section 9.

(4)     There are two nodes named 'PE3' repeatedly in Figure 1 and Figure 2.

(5)     For section 7.1 where it use 'Intra-subnet/Intra-ES', I think the 'Intra-subnet' is confusing and conflicting with general concepts as used in section 5.

Thanks
Jingrong

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 28 Jun 2018 16:51:36 +0000

Hi Jingrong,

Thanks for the comments. Please see my responses inline.

From: BESS <[email-masked]> on behalf of Xiejingrong <[email-masked]>
Date: Tuesday, June 19, 2018 at 7:38 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [bess] Comments on draft-sajassi-bess-evpn-mvpn-seamless-interop-01

Hi folks,

(1)    For section 9.2.2 where it stated “The MPLS label in the PMSI Tunnel Attribute MUST be the Virtual Network Identifier (VNI) associated with the customer MVPN.”,

I think the VNI need not being included in ‘MPLS Label’ field of PTA, because every IP-VRF has a static configuration of the VNI value.

We need to have the VNI set properly in the PTA so that the upstream PE can signal to downstream PEs what is the association of the multicast tunnel and VPN instance.

(2)    Some terminologies are lacking, for example CO and SPDC. I think they are different things, and authors can make clear about them.
Included them in the terminology section. If there are more, let me know.

(3)    Some references are lacking, for example [EVPN-IRB] in section 5, and [EVPN-IRB-MCAST] in section 9.
Added them to section 14.

(4)    There are two nodes named ‘PE3’ repeatedly in Figure 1 and Figure 2.
Corrected them.

(5)    For section 7.1 where it use ‘Intra-subnet/Intra-ES’, I think the ‘Intra-subnet’ is confusing and conflicting with general concepts as used in section 5.
I changed it from “Intra-subnet/Intra-ES” to only “Intra-ES”.

Thanks
Jingrong