Subject: [bess] A question on using EVPN label and Alias label in load balancing

From: Jaikumar Somasundaram <[email-masked]>
Date: Mon, 18 Feb 2019 10:07:47 +0000

Hi All,
                     --------------
                     |            |
              PORT1 |  DEVICE1   |PORT3
       --------------|     PE1    |-------------
       |      1/5    |  2.2.2.2   | 1/4         |
       |             |            |             |
       |             --------------             |
       |PORT1              |PORT2               |PORT2
--------------            |             +------------+            --------------
 |            |            |             |            |            |            |
 | DEVICE4    |            |             |            |PORT1       | DEVICE4    |
 | (CE1)      |            |             |   DEVICE3  |------------| (CE2)      |
 | Multi-home |            |             |     PE3     |       PORT3| Single home|
 |            |            |             |   4.4.4.4  |            |            |
--------------            |             +------------+            --------------
       |PORT2              |1/1                |PORT3
       |                   |PORT2              | 1/6
       |             --------------            |
       |             |            |            |
       |       PORT1 |  DEVICE2   |            |
       --------------|    PE2     |-------------
                1/4  |  3.3.3.3   |PORT3
                     |            |1/4
                     --------------

Let's say CE1 is connected to PE1 and PE2 (all-active case)
and PE1 and PE2 learn same MAC1 entry (say different destination)
PE3 will learn MAC1 from both PE1 and PE2 with their respective
EVPN label (Assume BGP ECMP is enabled). As part of load balancing,
should PE3 always use EVPN label to send the frame destined to MAC1
or can Alias label also be used? what is the need of using EVPN label?

Thanks & Regards
Jaikumar S

---

From: Jide Akintola <[email-masked]>
Date: Mon, 18 Feb 2019 11:30:20 +0000 (UTC)

Hi Jaikumar,
As per the rfc, aliasing is define as the ability of a PE to signal that it has reachability to an EVPN instance on a given ES even when it has learned no MAC addresses from that EVI/ES. It is advertised with Ethernet A-D per EVI type 1 routes.

Aliasing improves load-balancing by allowing remote VNEs to continue to load-balance traffic evenly though they have only received a single MAC/IP from a single ingress VNE. Meaning a remote PE that receives a MAC/IP Advertisement route (type 2 route) with a non-reserved ESI would consider the advertised MAC address to be reachable via all PEs that have advertised reachability to that MAC address EVI/ES via the Ethernet A-D per EVI route.

In your example, it would mean that if MAC1 is only learned by PE3 from PE1, but because PE3 has received Ethernet A-D per EVI type 1 route with aliasing label from PE2, it would consider that MAC1 is also reacheable via PE2 and would load balance traffic destined for MAC1 to both PE1 and PE2.

For cases where the MAC1 is learnt from PE1 and PE2 by PE3, then aliasing should not come into play.

There are some optimization done by some vendor using proxy advertisement via PE2 to mitigate traffic loss for cases where say PE3 only learns MAC1 from say PE1 and say you lost PE1.

Many thanks. 
 
Cheers, 
 
Jide 

    On Monday, 18 February 2019, 10:08:02 GMT, Jaikumar Somasundaram <[email-masked]> wrote:  
 
  <!--#yiv3210007971 _filtered #yiv3210007971 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv3210007971 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv3210007971 {font-family:Verdana;panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #yiv3210007971 {font-family:Consolas;panose-1:2 11 6 9 2 2 4 3 2 4;}#yiv3210007971  #yiv3210007971 p.yiv3210007971MsoNormal, #yiv3210007971 li.yiv3210007971MsoNormal, #yiv3210007971 div.yiv3210007971MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", sans-serif;}#yiv3210007971 a:link, #yiv3210007971 span.yiv3210007971MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv3210007971 a:visited, #yiv3210007971 span.yiv3210007971MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv3210007971 span.yiv3210007971EmailStyle17 {font-family:Consolas;color:windowtext;}#yiv3210007971 .yiv3210007971MsoChpDefault {font-family:"Calibri", sans-serif;} _filtered #yiv3210007971 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv3210007971 div.yiv3210007971WordSection1 {}-->
Hi All,
 
                     --------------
 
                     |            |
 
              PORT1 |  DEVICE1   |PORT3

       |      1/5    |  2.2.2.2   | 1/4         |
 
       |             |            |             |
 
       |             --------------             |
 
       |PORT1              |PORT2               |PORT2

 |            |            |             |            |            |            |    

 
 
 |            |            |             |   4.4.4.4  |            |            |

       |PORT2              |1/1                |PORT3
 
       |                   |PORT2              | 1/6
 
       |             --------------            |
 
       |             |            |            |
 
       |       PORT1 |  DEVICE2   |            |

                1/4  |  3.3.3.3   |PORT3
 
                     |            |1/4
 
                     --------------

Let’s say CE1 is connected to PE1 and PE2 (all-active case)

 

 
Thanks & Regards
 
Jaikumar S

 _______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: Jaikumar Somasundaram <[email-masked]>
Date: Mon, 18 Feb 2019 11:48:12 +0000

Thanks a lot Jide, for the reply.
Please find my response below [Jai]

Thanks & Regards
Jaikumar S

From: Jide Akintola <[email-masked]>
Sent: Monday, February 18, 2019 5:00 PM
To: [email-masked]; Jaikumar Somasundaram <[email-masked]>
Subject: Re: [bess] A question on using EVPN label and Alias label in load balancing

Hi Jaikumar,

For cases where the MAC1 is learnt from PE1 and PE2 by PE3, then aliasing should not come into play.
[Jai] Any reason why we should not use Alias label to reach any of PE1 or PE2. I see the only difference between EPN label and Alias label is that Mac look up will happen but Alias label does not expect the MAC entry to be present and so no MAC lookup is required
and simply forward it on the ESI port/link. Please correct me if something is not right.

Many thanks.

Cheers,

Jide

On Monday, 18 February 2019, 10:08:02 GMT, Jaikumar Somasundaram <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

                     --------------

                     |            |

              PORT1 |  DEVICE1   |PORT3

       |      1/5    |  2.2.2.2   | 1/4         |

       |             |            |             |

       |             --------------             |

       |PORT1              |PORT2               |PORT2

 |            |            |             |            |            |            |

 |            |            |             |   4.4.4.4  |            |            |

       |PORT2              |1/1                |PORT3

       |                   |PORT2              | 1/6

       |             --------------            |

       |             |            |            |

       |       PORT1 |  DEVICE2   |            |

                1/4  |  3.3.3.3   |PORT3

                     |            |1/4

                     --------------

Thanks & Regards

Jaikumar S

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Jide Akintola <[email-masked]>
Date: Mon, 18 Feb 2019 12:23:10 +0000 (UTC)

Hi Jaikumar,
You need to make a distinction between Alias label and several other EVPN routes labels defined in the RFC7432. Kindly check that RFC for the route encoding and their different usage/function.
As detailed in my previous email, alias label is a "hint" to the remote PE to load balance traffic, they are not used to do the actual traffic load balance.

Many thanks. 
 
Cheers, 
 
Jide 

    On Monday, 18 February 2019, 11:48:21 GMT, Jaikumar Somasundaram <[email-masked]> wrote:  
 
 #yiv1165875085 #yiv1165875085 -- _filtered #yiv1165875085 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv1165875085 {panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv1165875085 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv1165875085 {font-family:Verdana;panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #yiv1165875085 {font-family:Consolas;panose-1:2 11 6 9 2 2 4 3 2 4;} _filtered #yiv1165875085 {font-family:Old;panose-1:2 5 6 4 5 5 5 2 2 4;}#yiv1165875085 #yiv1165875085 p.yiv1165875085MsoNormal, #yiv1165875085 li.yiv1165875085MsoNormal, #yiv1165875085 div.yiv1165875085MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 a:link, #yiv1165875085 span.yiv1165875085MsoHyperlink {color:blue;text-decoration:underline;}#yiv1165875085 a:visited, #yiv1165875085 span.yiv1165875085MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv1165875085 p.yiv1165875085msonormal0, #yiv1165875085 li.yiv1165875085msonormal0, #yiv1165875085 div.yiv1165875085msonormal0 {margin-right:0in;margin-left:0in;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 p.yiv1165875085msonormal, #yiv1165875085 li.yiv1165875085msonormal, #yiv1165875085 div.yiv1165875085msonormal {margin-right:0in;margin-left:0in;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 p.yiv1165875085msochpdefault, #yiv1165875085 li.yiv1165875085msochpdefault, #yiv1165875085 div.yiv1165875085msochpdefault {margin-right:0in;margin-left:0in;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 span.yiv1165875085msohyperlink {}#yiv1165875085 span.yiv1165875085msohyperlinkfollowed {}#yiv1165875085 span.yiv1165875085emailstyle17 {}#yiv1165875085 p.yiv1165875085msonormal1, #yiv1165875085 li.yiv1165875085msonormal1, #yiv1165875085 div.yiv1165875085msonormal1 {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 p.yiv1165875085msonormal2, #yiv1165875085 li.yiv1165875085msonormal2, #yiv1165875085 div.yiv1165875085msonormal2 {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 span.yiv1165875085msohyperlink1 {color:#0563C1;text-decoration:underline;}#yiv1165875085 span.yiv1165875085msohyperlinkfollowed1 {color:#954F72;text-decoration:underline;}#yiv1165875085 span.yiv1165875085emailstyle171 {font-family:Consolas;color:windowtext;}#yiv1165875085 p.yiv1165875085msochpdefault1, #yiv1165875085 li.yiv1165875085msochpdefault1, #yiv1165875085 div.yiv1165875085msochpdefault1 {margin-right:0in;margin-left:0in;font-size:11.0pt;font-family:sans-serif;}#yiv1165875085 span.yiv1165875085EmailStyle30 {font-family:Consolas;color:#0070C0;}#yiv1165875085 .yiv1165875085MsoChpDefault {font-size:10.0pt;} _filtered #yiv1165875085 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv1165875085 div.yiv1165875085WordSection1 {}#yiv1165875085 
Thanks a lot Jide, for the reply.

 
Thanks & Regards
 
Jaikumar S

 
HiJaikumar,

 

 
Many thanks.

Cheers, 

Jide

 

Hi All,
 
                     --------------
 
                     |            |
 
              PORT1 |  DEVICE1   |PORT3

       |      1/5    |  2.2.2.2   | 1/4         |
 
       |             |            |             |
 
       |             --------------             |
 
       |PORT1              |PORT2               |PORT2

 |            |            |             |            |            |            |    

 
 
 |            |            |             |   4.4.4.4  |            |            |

       |PORT2              |1/1                |PORT3
 
       |                   |PORT2              | 1/6
 
       |             --------------            |
 
       |             |            |            |
 
       |       PORT1 |  DEVICE2   |            |

                1/4  |  3.3.3.3   |PORT3
 
                     |            |1/4
 
                     --------------

 

 

 
Thanks & Regards
 
Jaikumar S

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 18 Feb 2019 13:54:24 +0000

It “sounds” to me that Jaikumar’s question might be related to comparing MPLS-based vs MAC-based forwarding models.
RFC8388 may help, sections 6-8.

My 2 cents.

Thx
Jorge

From: BESS <[email-masked]> on behalf of Jide Akintola <jidept=[email-masked]>
Date: Monday, February 18, 2019 at 1:23 PM
To: "[email-masked]" <[email-masked]>, Jaikumar Somasundaram <[email-masked]>
Cc: Jide Akintola <[email-masked]>
Subject: Re: [bess] A question on using EVPN label and Alias label in load balancing

Hi Jaikumar,

Many thanks.

Cheers,

Jide

Thanks & Regards

Jaikumar S

Hi Jaikumar,

As per the rfc, aliasing is define as the ability of a PE to signal that it has reachability to an EVPN instance on a given ES even when it has learned no MAC addresses from that EVI/ES. It is advertised with Ethernet A-D per EVI type 1 routes..

Many thanks.

Cheers,

Jide

Hi All,

                     --------------

                     |            |

              PORT1 |  DEVICE1   |PORT3

       |      1/5    |  2.2.2.2   | 1/4         |

       |             |            |             |

       |             --------------             |

       |PORT1              |PORT2               |PORT2

 |            |            |             |            |            |            |

 |            |            |             |   4.4.4.4  |            |            |

       |PORT2              |1/1                |PORT3

       |                   |PORT2              | 1/6

       |             --------------            |

       |             |            |            |

       |       PORT1 |  DEVICE2   |            |

                1/4  |  3.3.3.3   |PORT3

                     |            |1/4

                     --------------

Thanks & Regards

Jaikumar S

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 18 Feb 2019 15:09:27 +0000

Ok, let me elaborate.

A remote PE sending known unicast traffic to any PE attached to the all-active Ethernet Segment (non-DF or DF, it’s irrelevant here!), has to use a label that identifies the Broadcast Domain at the egress PE for a MAC lookup (if MAC-based forwarding) or a label that identifies the egress ES (MPLS-based forwarding model).

Either way, it may happen that the ingress aliasing hash for a flow to MAC1, decides to send the unicast packet to a PE, PE2 that never advertised MAC1, but it is attached to the same ES; hence the only label available is the A-D per EVI route label.

If there is a MAC/IP route _and_ an A-D per-EVI route for the same ES and next-hop, the label should be the same anyway in case of MAC-based forwarding, and even in case of MPLS-based forwarding with label per ES. I can only see different labels if the egress PE forwarding model was label per MAC, which I don’t think there is any implementation like that out there. Bottom line, I would use the label from the A-D per-EVI route since, there might not be MAC/IP route for all the next-hops in the ES.

From: Muthu Arul Mozhi Perumal <[email-masked]>

Date: Monday, February 18, 2019 at 3:29 PM

To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>

Believe Jaikumar's question is, whether it is allowed per RFC 7432 to send known unicast traffic to a non-DF PE (for load balancing in all active multihoming scenario) using alias label when the non-DF PE has advertised a MAC/IP route with an EVPN label for the destination MAC. In other words, would sending known unicast traffic using alias label when there is a MAC/IP route for the destination MAC be a violation of RFC 7432 in the above scenario and is expected to cause any interop. issue?

Regards,

Muthu

On Mon, Feb 18, 2019 at 7:24 PM Rabadan, Jorge (Nokia - US/Mountain View) <mailto:[email-masked]> wrote:

My 2 cents.

Thx

Jorge

From: BESS <mailto:[email-masked]> on behalf of Jide Akintola <jidept=mailto:[email-masked]>

To: "mailto:[email-masked]" <mailto:[email-masked]>, Jaikumar Somasundaram <mailto:[email-masked]>

Cc: Jide Akintola <mailto:[email-masked]>

Hi Jaikumar,

Many thanks.

Cheers,

Jide

On Monday, 18 February 2019, 11:48:21 GMT, Jaikumar Somasundaram <mailto:[email-masked]> wrote:

Thanks & Regards

Jaikumar S

From: Jide Akintola <mailto:[email-masked]>

To: mailto:[email-masked]; Jaikumar Somasundaram <mailto:[email-masked]>

Hi Jaikumar,

Many thanks.

Cheers,

Jide

On Monday, 18 February 2019, 10:08:02 GMT, Jaikumar Somasundaram <mailto:[email-masked]> wrote:

Hi All,

                     --------------

                     |            |

              PORT1 |  DEVICE1   |PORT3

       |      1/5    |  2.2.2.2   | 1/4         |

       |             |            |             |

       |             --------------             |

       |PORT1              |PORT2               |PORT2

 |            |            |             |            |            |            |

 |            |            |             |   4.4.4.4  |            |            |

       |PORT2              |1/1                |PORT3

       |                   |PORT2              | 1/6

       |             --------------            |

       |             |            |            |

       |       PORT1 |  DEVICE2   |            |

                1/4  |  3.3.3.3   |PORT3

                     |            |1/4

                     --------------

Thanks & Regards

Jaikumar S

BESS mailing list

mailto:[email-masked]

BESS mailing list

mailto:[email-masked]