Subject: [bess] Request for version update of draft-ietf-bess-evpn-yang

From: Lavanya Sundarraj <[email-masked]>
Date: Thu, 21 Feb 2019 13:23:08 +0000

Hi,

Please find updated  EVPN yang model with evpn-pw attributes in the attachment.
This draft is to introduce EVPN-VPWS attributes :

o   Control-word

o   MTU

o   EVPN Instance Context

The new changes added in the existing EVPN yang model are highlighted.

Could you please review this draft and send your valuable comments.

Regards,
Lavanya Sundarraj.

---

From: Yu Tianpeng <[email-masked]>
Date: Thu, 21 Feb 2019 19:32:41 +0000

Hi,
Haven't got time to read through but had a quick look on what is newly
added, there are couple of issues:
1. 7432 clearly defines usage of control word usage, cw is not sth
dedicated to vpws I have to point out.
2. Type of control word should be boolean instead of empty.

Another one is I don't understand the meaning of newly added concext.
Appreciate to clarify.
Thanks
Tim

On Thu, 21 Feb 2019, 13:28 Lavanya Sundarraj, <
[email-masked]> wrote:

> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: Lavanya Sundarraj <[email-masked]>
Date: Thu, 21 Feb 2019 14:49:29 +0000

Hi,

I am new to IETF and the document was posted as mistake.

The following parameters are attributes of evpn-pw which are missing in the EVPN-YANG model.

    augment /pw:pseudowires/pw:pseudowire/pw:pw-type:
       +-:(evpn-pw)
          +-rw evpn-pw
             +-rw remote-id?   uint32
             +-rw local-id?    uint32
          +-rw evpn-instance-context!
          |  +-rw inst-cont    string
          +-rw mtu?                     uint32
          +-rw control-word?            empty

And the corresponding yang changes are
     /* augments */

     augment "/pw:pseudowires/pw:pseudowire/pw:pw-type" {
       description "Augment for an L2VPN instance to add EVPN VPWS " +
                   "pseudowire";
       case evpn-pw {
         container evpn-pw {
           description "EVPN pseudowire";
           leaf remote-id {
             type uint32;
             description "Remote pseudowire ID";
           }
           leaf local-id {
             type uint32;
             description "Local pseudowire ID";
           }
         }
       }
      /*
    evpn instance context (inst-cont)
    */
    container evpn-instance-context {
      presence "";
      description
        "Configure evpn evi context";
      leaf inst-cont {
        type string;
        mandatory true;
        description
          "EVPN context name";
      }
    }
    /*
    mtu (vpws-mtu)
    */
    leaf mtu {
      type uint32 {
        range "0..4294967295";
      }
      description
        "Configure MTU";
    }
    control-word
    */
    leaf control-word {
      type empty;
      description
        "Configure control-word";
    }
  }

Could you please review these changes and send your valuable comments.

Regards,
Lavanya Sundarraj.

From: Lavanya Sundarraj
Sent: Thursday, February 21, 2019 6:53 PM
To: [email-masked]' <[email-masked]>
Cc: P Muthu Arul Mozhi <[email-masked]>; C Gangadhara Reddy <[email-masked]>; Chundu Kotesh Babu <[email-masked]>; SatishKumar N Rodd <[email-masked]>; Debojyoti Guha <[email-masked]>
Subject: Request for version update of draft-ietf-bess-evpn-yang

Hi,

o   Control-word

o   MTU

o   EVPN Instance Context

Regards,
Lavanya Sundarraj.