Subject: [bess] A question on CE behavior on traffic forwarding to EVPN multihomed PEs in single-active mode

From: Jaikumar Somasundaram <[email-masked]>
Date: Wed, 13 Feb 2019 06:11:12 +0000

Hello All,

In EVPN MH with Single-Active scenario, could you help us to clarify the below query?

                     --------------
                     |            |
               PORT1 |  DEVICE1   |PORT3
       --------------|     PE1    |-------------
       |      1/5    |  2.2.2.2   | 1/4         |
       |             |            |             |
       |             --------------             |
       |PORT1              |PORT2               |PORT2
--------------            |             +------------+            --------------
 |            |            |             |            |            |            |
 | DEVICE4    |            |             |            |PORT1       | DEVICE4    |
 | (CE1)      |            |             |   DEVICE3  |------------| (CE2)      |
 | Multi-home |            |             |     PE     |       PORT3| Single home|
 |            |            |             |   4.4.4.4  |            |            |
--------------            |             +------------+            --------------
       |PORT2              |1/1                |PORT3
       |                   |PORT2              | 1/6
       |             --------------            |
       |             |            |            |
       |       PORT1 |  DEVICE2   |            |
       --------------|    PE2     |-------------
                1/4  |  3.3.3.3   |PORT3
                     |            |1/4
                     --------------

Let's say CE1 is connected to PE1 and PE2 (single-active case)
and PE1 is the DF for VLAN 10 and has the active link,
but CE1 sends unknown unicast traffic on the link to PE2 (standby link),
wouldn't the traffic be dropped because its non-DF ?

or

How does CE ensure traffic is always forwarded on the active link
(as standby link will drop the traffic) ?

Thanks & Regards
Jaikumar S

---

From: "Mrinmoy Ghosh (mrghosh)" <[email-masked]>
Date: Wed, 13 Feb 2019 07:51:23 +0000

Hi Jaikumar,

EVPN Single active heavily depends upon MAC Flush mechanism like MVRP or TCN Flush.

In your topology, initially CE1 would flood unknown ucast to both PE1 and PE2; PE1 being DF will send and receive traffic for that (ES, EVI), hence once the traffic  will be learned eventually from PE1.
However on switchover, Mac flush is sent to CE so that the forwarding table is flushed and the traffic is flooded to both PE until learned from the new DF.

Thanks,
Mrinmoy

From: BESS <[email-masked]> On Behalf Of Jaikumar Somasundaram
Sent: Tuesday, February 12, 2019 10:11 PM
To: [email-masked]
Cc: Pradeep Ramakrishnan <[email-masked]>; Chalapathi Andhe <[email-masked]>
Subject: [bess] A question on CE behavior on traffic forwarding to EVPN multihomed PEs in single-active mode

Hello All,

                     --------------
                     |            |
               PORT1 |  DEVICE1   |PORT3

or

Thanks & Regards
Jaikumar S

---

From: Yu Tianpeng <[email-masked]>
Date: Wed, 13 Feb 2019 08:52:22 +0000

I guess it worth clarify CE using LAG or L2 switching to connect to PE in
the question.
Thanks
Tim

On Wed, 13 Feb 2019, 07:51 Mrinmoy Ghosh (mrghosh) <[email-masked] wrote:

> In your topology, initially CE1 would flood unknown ucast to both PE1 and
> PE2; PE1 being DF will send and receive traffic for that (ES, EVI), hence
> once the traffic  will be learned eventually from PE1.
>
> However on switchover, Mac flush is sent to CE so that the forwarding
> table is flushed and the traffic is flooded to both PE until learned from
> the new DF.
>
>
>
> Thanks,
>
> Mrinmoy
>
>
>
> *From:* BESS <[email-masked]> *On Behalf Of * Jaikumar Somasundaram
> *Sent:* Tuesday, February 12, 2019 10:11 PM
> *To:* [email-masked]
> *Cc:* Pradeep Ramakrishnan <[email-masked]>;
> Chalapathi Andhe <[email-masked]>
> *Subject:* [bess] A question on CE behavior on traffic forwarding to EVPN
> multihomed PEs in single-active mode
>
>
>
> Hello All,
>
>
>
>  |            |            |             |            |
>  |            |            |             |   4.4.4.4  |
> Let’s say CE1 is connected to PE1 and PE2 (single-active case)
>
> wouldn’t the traffic be dropped because its non-DF ?
>
>
>
> or
>
>
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: Jaikumar Somasundaram <[email-masked]>
Date: Wed, 13 Feb 2019 11:47:28 +0000

Thanks Mrinmoy for the quick answer.

Thanks & Regards
Jaikumar S

From: Mrinmoy Ghosh (mrghosh) <[email-masked]>
Sent: Wednesday, February 13, 2019 1:21 PM
To: Jaikumar Somasundaram <[email-masked]>; [email-masked]
Cc: Pradeep Ramakrishnan <[email-masked]>; Chalapathi Andhe <[email-masked]>
Subject: RE: A question on CE behavior on traffic forwarding to EVPN multihomed PEs in single-active mode

Hi Jaikumar,

Thanks,
Mrinmoy

From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of Jaikumar Somasundaram
Sent: Tuesday, February 12, 2019 10:11 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Pradeep Ramakrishnan <[email-masked]<mailto:[email-masked]>>; Chalapathi Andhe <[email-masked]<mailto:[email-masked]>>
Subject: [bess] A question on CE behavior on traffic forwarding to EVPN multihomed PEs in single-active mode

Hello All,

                     --------------
                     |            |
               PORT1 |  DEVICE1   |PORT3

or

Thanks & Regards
Jaikumar S