Subject: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Fri, 22 Mar 2019 16:53:20 +0530

While RFC 8214 doesn't recommend any DF election algorithm capable of
electing the BDF in EVPN VPWS single-active multihoming for deciding the
backup PE, any feedback on what is(are) the widely implemented/supported DF
election  algorithm(s) by vendors?

Regards,
Muthu

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 22 Mar 2019 14:17:17 +0000

The implementations I know use the same DF Alg for DF election _and_ backup DF Election. And I don’t see why you would use something different?
In other words, if you use e.g., Pref based DF Alg, use it for DF and BDF elections. Only that the BDF election excludes the DF from the candidate list.

Thx
Jorge

From: BESS <[email-masked]> on behalf of Muthu Arul Mozhi Perumal <[email-masked]>
Date: Friday, March 22, 2019 at 4:23 AM
To: "[email-masked]" <[email-masked]>
Subject: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

While RFC 8214 doesn't recommend any DF election algorithm capable of electing the BDF in EVPN VPWS single-active multihoming for deciding the backup PE, any feedback on what is(are) the widely implemented/supported DF election  algorithm(s) by vendors?

Regards,
Muthu

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Fri, 22 Mar 2019 23:10:51 +0530

Hi Jorge,

I didn't mean using different algorithms for electing the DF and BFD. I am
just asking which algorithm is most widely implemented/used for electing
the DF *and* BDF for EVPN VPWS single-active multihoming.

Regards,
Muthu

On Fri, Mar 22, 2019 at 7:47 PM Rabadan, Jorge (Nokia - US/Mountain View) <
[email-masked]> wrote:

> The implementations I know use the same DF Alg for DF election _*and*_
> backup DF Election. And I don’t see why you would use something different?
>
> In other words, if you use e.g., Pref based DF Alg, use it for DF and BDF
> elections. Only that the BDF election excludes the DF from the candidate
> list.
>
>
>
> Thx
>
> Jorge
>
>
>
> *From: *BESS <[email-masked]> on behalf of Muthu Arul Mozhi
> Perumal <[email-masked]>
> *Date: *Friday, March 22, 2019 at 4:23 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[bess] BDF Election in EVPN VPWS Single-Active Multihoming
>
>
>

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 22 Mar 2019 18:15:38 +0000

Hi,

Well, everyone has to support the default DF Alg, based on RFC7432. So that one for sure. And in addition there are others that have been implemented. For instance, Pref DF election has been implemented by multiple vendors.
Thanks,
Jorge

________________________________
From: Muthu Arul Mozhi Perumal <[email-masked]>
Sent: Friday, March 22, 2019 10:41
To: Rabadan, Jorge (Nokia - US/Mountain View)
Cc: [email-masked]
Subject: Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Hi Jorge,

I didn't mean using different algorithms for electing the DF and BFD. I am just asking which algorithm is most widely implemented/used for electing the DF *and* BDF for EVPN VPWS single-active multihoming.

Regards,
Muthu

On Fri, Mar 22, 2019 at 7:47 PM Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>> wrote:
The implementations I know use the same DF Alg for DF election _and_ backup DF Election. And I don’t see why you would use something different?
In other words, if you use e.g., Pref based DF Alg, use it for DF and BDF elections. Only that the BDF election excludes the DF from the candidate list.

Thx
Jorge

From:BESS <[email-masked]<mailto:[email-masked]>> on behalf of Muthu Arul Mozhi Perumal <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 22, 2019 at 4:23 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Regards,
Muthu

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Sat, 23 Mar 2019 00:10:16 +0530

Thanks, Jorge. Need another clarification. RFC 7432 does not describe how
to calculate the BDF for the default DF algo. Though it is straightforward
to calculate the BDF by eliminating the DF from the candidate list, would
an implementation calculating the BDF that way for the default DF algo
interoperate without any problem?

Regards,
Muthu

On Fri, Mar 22, 2019 at 11:45 PM Rabadan, Jorge (Nokia - US/Mountain View) <
[email-masked]> wrote:

> Hi,
>
> Well, everyone has to support the default DF Alg, based on RFC7432. So
> that one for sure. And in addition there are others that have been
> implemented. For instance, Pref DF election has been implemented by
> multiple vendors.
> Thanks,
> Jorge
>
> ------------------------------
> *From:* Muthu Arul Mozhi Perumal <[email-masked]>
> *Sent:* Friday, March 22, 2019 10:41
> *To:* Rabadan, Jorge (Nokia - US/Mountain View)
> *Cc:* [email-masked]
> *Subject:* Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming
>
> Hi Jorge,
>
>> *From:*BESS <[email-masked]> on behalf of Muthu Arul Mozhi

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Fri, 22 Mar 2019 21:16:02 +0000

Hi Muthu,

Yes, the BDF is as per what you have mentioned.
https://tools.ietf.org/html/draft-ietf-bess-evpn-df-election-framework-09 formally defines it.

Thanks,
--Satya

From: BESS <[email-masked]> on behalf of Muthu Arul Mozhi Perumal <[email-masked]>
Date: Friday, March 22, 2019 at 11:41 AM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Thanks, Jorge. Need another clarification. RFC 7432 does not describe how to calculate the BDF for the default DF algo. Though it is straightforward to calculate the BDF by eliminating the DF from the candidate list, would an implementation calculating the BDF that way for the default DF algo interoperate without any problem?

Regards,
Muthu

On Fri, Mar 22, 2019 at 11:45 PM Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

________________________________
From: Muthu Arul Mozhi Perumal <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 22, 2019 10:41
To: Rabadan, Jorge (Nokia - US/Mountain View)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Hi Jorge,

Regards,
Muthu

Thx
Jorge

Regards,
Muthu

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Mon, 25 Mar 2019 12:52:10 +0530

Hi Satya,

draft-ietf-bess-evpn-df-election-framework also does not describe how the
BDF is to be calculated for the default DF election algo. Am I missing
something?

I think my question still holds:
Though it is straightforward to calculate the BDF by eliminating the DF
from the candidate list, would an implementation calculating the BDF that
way for the default DF election algo interoperate without any problem?

Would it be better to update draft-ietf-bess-evpn-df-election-framework on
how the BDF is to be calculated in general for any DF election algo
(including the default DF election algo)?

Regards,
Muthu

On Sat, Mar 23, 2019 at 2:46 AM Satya Mohanty (satyamoh) <[email-masked]>
wrote:

> *Date: *Friday, March 22, 2019 at 11:41 AM
> *To: *"Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]
> >
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming
>
>
>
> to calculate the BDF for the default DF algo. Though it is
> straightforward to calculate the BDF by eliminating the DF from the
> candidate list, would an implementation calculating the BDF that way for
> the default DF algo interoperate without any problem?
>
>
>
> Regards,
>
> Muthu
>
>
>
> On Fri, Mar 22, 2019 at 11:45 PM Rabadan, Jorge (Nokia - US/Mountain View)
> <[email-masked]> wrote:
>
> Hi,
>
>
>
> *From:*BESS <[email-masked]> on behalf of Muthu Arul Mozhi Perumal
> <[email-masked]>

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Wed, 27 Mar 2019 18:47:18 +0000

Hi Muthu,

As you mentioned it is straightforward to calculate the BDF in the default DF Algorithm by taking the current DF out of reckoning.
It is my personal view that since this is self-evident it need not be explicitly stated.
But I will let others decide.

Thanks,
--Satya

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Monday, March 25, 2019 at 8:22 AM
To: "Satya Mohanty (satyamoh)" <[email-masked]>
Cc: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Hi Satya,

draft-ietf-bess-evpn-df-election-framework also does not describe how the BDF is to be calculated for the default DF election algo. Am I missing something?

I think my question still holds:
Though it is straightforward to calculate the BDF by eliminating the DF from the candidate list, would an implementation calculating the BDF that way for the default DF election algo interoperate without any problem?

Would it be better to update draft-ietf-bess-evpn-df-election-framework on how the BDF is to be calculated in general for any DF election algo (including the default DF election algo)?
[Satya] IMHO opinion, much as it appears obvious, we cannot say for certain that in every future DF algorithm (that may come into existence), the BDF computation will always be as simple as taking the current DF (PE) out of reckoning and doing the recomputation.

Regards,
Muthu

Best,
--Satya

On Sat, Mar 23, 2019 at 2:46 AM Satya Mohanty (satyamoh) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Muthu,

Thanks,
--Satya

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Muthu Arul Mozhi Perumal <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 22, 2019 at 11:41 AM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BDF Election in EVPN VPWS Single-Active Multihoming

Regards,
Muthu

Hi Jorge,

Regards,
Muthu

Thx
Jorge

Regards,
Muthu

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Thu, 28 Mar 2019 17:13:30 +0530

Hi Satya,

Thanks for your response..

I see no harm in stating explicitly how the BDF is to be calculated for the
default DF election algorithm.

I however agree that it can't be generalized for all future DF election
algorithms, so it is better described on a per algorithm basis..

Regards,
Muthu

On Thu, Mar 28, 2019 at 12:17 AM Satya Mohanty (satyamoh) <
[email-masked]> wrote:

> Hi Muthu,
>
>
>
> As you mentioned it is straightforward to calculate the BDF in the default
> DF Algorithm by taking the current DF out of reckoning.
>
> *From: *Muthu Arul Mozhi Perumal <[email-masked]>
> *Date: *Monday, March 25, 2019 at 8:22 AM
> *To: *"Satya Mohanty (satyamoh)" <[email-masked]>
> *Cc: *"Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> [Satya] IMHO opinion, much as it appears obvious, we cannot say for
> certain that in every future DF algorithm (that may come into existence),
> the BDF computation will always be as simple as taking the current DF (PE)
> out of reckoning and doing the recomputation.
>
>
>
> Regards,
>
> Muthu
>
>
>
> Best,
>
> --Satya
>
>
>
> On Sat, Mar 23, 2019 at 2:46 AM Satya Mohanty (satyamoh) <
> [email-masked]> wrote:
>
> Hi Muthu,
>
>
>