Subject: [bess] Review on draft-ietf-bess-evpn-yang-06

From: Yu Tianpeng <[email-masked]>
Date: Sat, 2 Mar 2019 11:30:54 -0800

Dear authors and WG,
I had a review on draft-ietf-bess-evpn-yang-06.
This draft covers most of the evpn/vpws scenarios, but there are some
points I would like to discuss.

For small points that do not impact the architecture of the yang data
model, I have made changes in a new yang file directly (attached), which
will be easier to understand.
Also, some comments related to the structure of the data model in the final.
Appreciate authors and WG can have a review on comments and proposed
changes below.
Thanks in advance.
Regards,
Tim
=================================================================================
Changes:
ietf-ethernet-segment.yang
1. esid-type defined. current uint32 cannot cover 10 octs ESI. We can
either use a string with a regex or uint64 with a range. in the attachment
is the regex.
2. change key to esi instead of "name", the name looks like a string or a
description to me, cannot be used as the key.
3. add new leaf "interface" to indicate which ESI applied to which
interface.
4. BGP parameters are deleted, I don't think RD RT are concepts related
with ES. I have put a new leaf es-list in the EVPN yang data model
providing links between ES and EVPN yang
5. change of VLAN type to unit16 with range limit

ietf-evpn.yang
1. evpn label mode function added
2. re-write RD RT part as rt-types:vpn-route-targets is a list type
already, an extra level of list definition in EVPN is not needed anymore.
3. ES list leaf added. This leaf provides a list indicating ESs bound to
the EVPN instance.
4. control word and MTU added
5. statistics part re-structure.
6. change the counter type from uint32 to counter64 to avoid overflow.
7. interface type leaf added, the previous vpws-vlan-aware deleted. reason:
all interface type should be covered across EVPN and VPWS

General comments:
1. In EVPN yang, I would suggest to re-structure current content as below
instead of one evpn container :
- EVPN general: RD, RT, name, etc.
- EVPN ELAN/VPWS/E-TREE specifics: BUM, leaf indication, proxy.. and use
the generals to get yang data model for each scenario.

2. EVPN parameters are not registered under /ni:network-instances and /pw:
pseudowires. Now only very few info registered

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 3 Mar 2019 10:46:11 +0000

Dear all,
I concur with Tim’s comment regarding representation of ESI in  draft-ietf-bess-evpn-yang-06.

I have raised similar concerns in an email<https://mailarchive.ietf.org/arch/msg/bess/HfPveilbdp5iufQYh5pu9KSf4Ug> to the authors of the draft and to the WG  last August (when the draft was still at its -05 version).
Unfortunately, I did not receive any response, nor were my concerns addresses in the -06 version of the draft.

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: BESS <[email-masked]> On Behalf Of Yu Tianpeng
Sent: Saturday, March 2, 2019 9:31 PM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Review on draft-ietf-bess-evpn-yang-06

Dear authors and WG,
I had a review on draft-ietf-bess-evpn-yang-06.
This draft covers most of the evpn/vpws scenarios, but there are some points I would like to discuss.

For small points that do not impact the architecture of the yang data model, I have made changes in a new yang file directly (attached), which will be easier to understand.
Also, some comments related to the structure of the data model in the final.
Appreciate authors and WG can have a review on comments and proposed changes below.
Thanks in advance.
Regards,
Tim
=================================================================================
Changes:
ietf-ethernet-segment.yang
1. esid-type defined. current uint32 cannot cover 10 octs ESI. We can either use a string with a regex or uint64 with a range. in the attachment is the regex.
2. change key to esi instead of "name", the name looks like a string or a description to me, cannot be used as the key.
3. add new leaf "interface" to indicate which ESI applied to which interface.
4. BGP parameters are deleted, I don't think RD RT are concepts related with ES. I have put a new leaf es-list in the EVPN yang data model providing links between ES and EVPN yang
5. change of VLAN type to unit16 with range limit

ietf-evpn.yang
1. evpn label mode function added
2. re-write RD RT part as rt-types:vpn-route-targets is a list type already, an extra level of list definition in EVPN is not needed anymore.
3. ES list leaf added. This leaf provides a list indicating ESs bound to the EVPN instance.
4. control word and MTU added
5. statistics part re-structure.
6. change the counter type from uint32 to counter64 to avoid overflow.
7. interface type leaf added, the previous vpws-vlan-aware deleted. reason: all interface type should be covered across EVPN and VPWS

General comments:
1. In EVPN yang, I would suggest to re-structure current content as below instead of one evpn container :
- EVPN general: RD, RT, name, etc.
- EVPN ELAN/VPWS/E-TREE specifics: BUM, leaf indication, proxy.. and use the generals to get yang data model for each scenario.

2. EVPN parameters are not registered under /ni:network-instances and /pw: pseudowires. Now only very few info registered

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Luc Andre Burdet (lburdet)" <[email-masked]>
Date: Sun, 3 Mar 2019 13:02:10 +0000

Hi Sasha, Tim,

Apologies for not sending a response to your prior email; Your comments were noted and intend to update the draft this week.

Thanks,
Luc André

[http://www.cisco.com/c/dam/m/en_us/signaturetool/images/banners/standard/09_standard_graphic.png]

Luc André Burdet
[email-masked]<mailto:[email-masked]>
Tel: +1 613 254 4814

Cisco Systems Canada Co. / Les Systemes Cisco Canada CIE
Cisco.com<http://www.cisco.com/web/CA/>

From: BESS <[email-masked]> on behalf of Alexander Vainshtein <[email-masked]>
Date: Sunday, March 3, 2019 at 05:46
To: Yu Tianpeng <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] Review on draft-ietf-bess-evpn-yang-06

Dear all,

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Dear authors and WG,

ietf-evpn.yang

General comments:

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 3 Mar 2019 15:39:20 +0000

Luc hi,
Lots of thanks for a prompt response.

Will be waiting for the new version of the draft.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: Luc Andre Burdet (lburdet) <[email-masked]>
Sent: Sunday, March 3, 2019 3:02 PM
To: Alexander Vainshtein <[email-masked]>; Yu Tianpeng <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [bess] Review on draft-ietf-bess-evpn-yang-06

Hi Sasha, Tim,

Thanks,
Luc André

Luc André Burdet

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 3, 2019 at 05:46
To: Yu Tianpeng <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] Review on draft-ietf-bess-evpn-yang-06

Dear all,

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of Yu Tianpeng
Sent: Saturday, March 2, 2019 9:31 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [bess] Review on draft-ietf-bess-evpn-yang-06

Dear authors and WG,

ietf-evpn.yang

General comments:

---

From: Yu Tianpeng <[email-masked]>
Date: Mon, 4 Mar 2019 06:20:15 +0000

Hi Luc and Sasha,
Thanks both for the reply.
Will wait for the new version.
Regards,
Tim

On Sun, 3 Mar 2019, 15:39 Alexander Vainshtein, <
[email-masked]> wrote:

> *From:* Luc Andre Burdet (lburdet) <[email-masked]>
> *Sent:* Sunday, March 3, 2019 3:02 PM
> *To:* Alexander Vainshtein <[email-masked]>; Yu
> Tianpeng <[email-masked]>;
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [bess] Review on draft-ietf-bess-evpn-yang-06
>
>
>
> Hi Sasha, Tim,
>
>
>
> Apologies for not sending a response to your prior email; Your comments
> were noted and intend to update the draft this week.
>
>
>
> Thanks,
>
> Luc André
>
>
>
>
>
> [image:
> http://www.cisco.com/c/dam/m/en_us/signaturetool/images/banners/standard/09_standard_graphic.png]
>
> *Luc André Burdet*
>
> [email-masked]
>
> Tel: *+1 613 254 4814*
>
> Cisco.com <http://www.cisco.com/web/CA/>
>
>
>
>
>
> *From: *BESS <[email-masked]> on behalf of Alexander Vainshtein <
> [email-masked]>
> *Date: *Sunday, March 3, 2019 at 05:46
> *To: *Yu Tianpeng <[email-masked]>, "
> [email-masked]" <
> [email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [bess] Review on draft-ietf-bess-evpn-yang-06
>
>
>
> Dear all,
>
> I have raised similar concerns in an email
> <https://mailarchive.ietf.org/arch/msg/bess/HfPveilbdp5iufQYh5pu9KSf4Ug>
> to the authors of the draft and to the WG  last August (when the draft was
> still at its -05 version).
>
> Unfortunately, I did not receive any response, nor were my concerns
> addresses in the -06 version of the draft.
>
>
>
> My 2c,
>
> Sasha
>
>
>
> Office: +972-39266302
>
> Cell:      +972-549266302
>
> *From:* BESS <[email-masked]> *On Behalf Of *Yu Tianpeng
> *Sent:* Saturday, March 2, 2019 9:31 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* [bess] Review on draft-ietf-bess-evpn-yang-06
>
>
>
> Dear authors and WG,
>
> 7. interface type leaf added, the previous vpws-vlan-aware deleted.
> reason: all interface type should be covered across EVPN and VPWS
>
>
>
> General comments:
>