Subject: [bess] Barry Leiba's No Objection on draft-ietf-bess-bgp-vpls-control-flags-07: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Sun, 07 Apr 2019 23:01:37 -0700

Barry Leiba has entered the following ballot position for
draft-ietf-bess-bgp-vpls-control-flags-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-bgp-vpls-control-flags/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

— Section 3.1 —

   but the PW MUST
   NOT be prevented from coming up due to this mismatch. So, the PW MUST
   still come up but not use control word in either direction.

The second MUST seems wrong to me: the normative behaviour is already stated by
the MUST NOT, but there could be other factors that legitimately prevent the PW
from coming up, no?  Likely, this should say, “So, the PW will still come up,
...”

— Section 3.2 —

   If the PEs at both ends of the PW do not agree on the
   setting of the S-bit, the PW SHOULD NOT come up.

Why SHOULD NOT?  Why might it be allowed to come up anyway, and what would the
consequences of that be (which would need to be understood in order to not obey
the SHOULD NOT)?

---

From: Ravi Singh <[email-masked]>
Date: Sat, 20 Apr 2019 02:12:18 +0000

Hi Barry
Thanks for your input.
Been addressed in -08.
Regards
Ravi

> -----Original Message-----
> From: Barry Leiba via Datatracker [mailto:[email-masked]]
> Sent: Sunday, April 7, 2019 11:02 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Mach Chen
> <[email-masked]>; [email-masked]
> Subject: Barry Leiba's No Objection on draft-ietf-bess-bgp-vpls-control-flags-
> 07: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_iesg_statement_discuss-
> 2Dcriteria.html&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=6ArkE4n20mNZQF6JxrMYwJyAGBWWjzhSIC2O3-
> fXPV4&m=iYf8gbrFPSefanXbHRPp5582-Y-
> dLzDlAcHBoscJ0Do&s=anFZ7mbROjHZMCc_pKrheWD0xYtMm-
> z8Ihv0ZBTU_dE&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dbess-2Dbgp-2Dvpls-2Dcontrol-
> 2Dflags_&d=DwIDaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=6ArkE4n20mNZQF6JxrMYwJyAGBWWjzhSIC2O3-
> fXPV4&m=iYf8gbrFPSefanXbHRPp5582-Y-
> dLzDlAcHBoscJ0Do&s=AvdGXE0aC9SvKnOrFh24zSPKqEvmZR27lIQTulUn05g&
> e=
> 
> 
> 
> The second MUST seems wrong to me: the normative behaviour is already
> stated by the MUST NOT, but there could be other factors that legitimately
> prevent the PW from coming up, no?  Likely, this should say, “So, the PW will
> still come up, ...”
> 
> — Section 3.2 —
> 
> Why SHOULD NOT?  Why might it be allowed to come up anyway, and what
> would the consequences of that be (which would need to be understood in
> order to not obey the SHOULD NOT)?
>