Subject: [bess] Question on ARP probe in draft-ietf-bess-evpn-inter-subnet-forwarding

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Tue, 30 Apr 2019 08:09:13 +0530

Hi Everyone,

draft-ietf-bess-evpn-inter-subnet-forwarding describes the mobility
procedure to be followed when a TS moves from a source NVE to a target NVE
and starts sending data traffic without first initiating an ARP request. It
says the following in section 4.2:

<snip>
   - The source NVE upon receiving this MAC/IP advertisement, realizes
   that the MAC has moved to the new NVE. It updates its MAC-VRF table
   accordingly by updating the adjacency information for that MAC
   address to point to the target NVE and withdraws its EVPN MAC/IP
   route that has only the MAC address (if it has advertised such route
   previously). Furthermore, *it searches its ARP table for this MAC and*
   *sends an ARP probe for this <MAC,IP> pair*. The ARP request message is
   sent both locally to all attached TSes in that subnet as well as it
   is sent to other NVEs participating in that subnet including the
   target NVE.
</snip>

The question I have is, the MAC/IP Advertisement route the source NVE
receives from the target NVE in the above case has only the MAC address of
the TS and the RT corresponding to the MAC-VRF. How can the source NVE
deduce the IP-VRF to search the corresponding ARP table and send an ARP
probe?

Regards,
Muthu

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 30 Apr 2019 08:13:58 +0000

Muthu,

The source NVE identifies the MAC-VRF/BD out of the RT/eth-tag. The assumption is that the BD is only attached to one IP-VRF, hence you know what ARP table to look up.

My two cents.

Jorge

From: BESS <[email-masked]> on behalf of Muthu Arul Mozhi Perumal <[email-masked]>
Date: Tuesday, April 30, 2019 at 4:39 AM
To: "[email-masked]" <[email-masked]>
Subject: [bess] Question on ARP probe in draft-ietf-bess-evpn-inter-subnet-forwarding

Hi Everyone,

draft-ietf-bess-evpn-inter-subnet-forwarding describes the mobility procedure to be followed when a TS moves from a source NVE to a target NVE and starts sending data traffic without first initiating an ARP request. It says the following in section 4.2:

<snip>
   - The source NVE upon receiving this MAC/IP advertisement, realizes
   that the MAC has moved to the new NVE. It updates its MAC-VRF table
   accordingly by updating the adjacency information for that MAC
   address to point to the target NVE and withdraws its EVPN MAC/IP
   route that has only the MAC address (if it has advertised such route
   previously). Furthermore, it searches its ARP table for this MAC and
   sends an ARP probe for this <MAC,IP> pair. The ARP request message is
   sent both locally to all attached TSes in that subnet as well as it
   is sent to other NVEs participating in that subnet including the
   target NVE.
</snip>

The question I have is, the MAC/IP Advertisement route the source NVE receives from the target NVE in the above case has only the MAC address of the TS and the RT corresponding to the MAC-VRF. How can the source NVE deduce the IP-VRF to search the corresponding ARP table and send an ARP probe?

Regards,
Muthu