Subject: [bess] Poll to progress draft-ietf-bess-nsh-bgp-controlplane without implementation

From: <[email-masked]>
Date: Thu, 4 Apr 2019 11:58:20 +0000

Hi WG,

draft-ietf-bess-nsh-bgp-controlplane has passed WGLC and its finishing the shepherd's review phasis (I-D update required). It is in a good shape to progress further. However we are not aware of any implementation. As per our Implementation Requirement Policy, we need to poll the WG to know if WG agrees to progress the document without implementation.

This email starts a 2 weeks poll closing on 04/18/2019.

Please raise your support or any concern regarding the progress of this document without implementation.
If you are aware of any implementation, please also state it.

https://datatracker.ietf.org/doc/draft-ietf-bess-nsh-bgp-control-plane/

Brgds,

Stephane & Matthew

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 5 Apr 2019 12:52:50 -0400

I think is a useful complement to the work in RFC 8300.  It appears 
ready for publication.  Given the evolution in SFC usage, I think 
getting this out there now serves the community better than waiting for 
the implementations.  Please do progress this.

Thank you,
Joel

On 4/4/19 1:58 PM, [email-masked] wrote:
> Hi WG,
> 
> draft-ietf-bess-nsh-bgp-controlplane has passed WGLC and its finishing 
> the shepherd’s review phasis (I-D update required).. It is in a good 
> shape to progress further. However we are not aware of any 
> implementation. As per our Implementation Requirement Policy, we need to 
> poll the WG to know if WG agrees to progress the document without 
> implementation.
> 
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 5 Apr 2019 13:02:52 -0400

I agree with Joel. I think a reason that we don't yet have implementations
is that this draft has three normative references that are also still
drafts (although
two of them recently joined the RFC Editor's queue and the third has passed
WG LC), so as they get implemented and we get more SFC implementations in
general, I would expect to see activity with this draft as well. It would
be a disservice to wait.

Cheers,
Andy

On Fri, Apr 5, 2019 at 12:53 PM Joel M. Halpern <[email-masked]> wrote:

> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 5 Apr 2019 10:51:56 -0700

Dear WG Chairs, et al.,
I support going forward with the publication
of draft-ietf-bess-nsh-bgp-control-plane despite the absence of a readily
available implementation. As Andy had noted, three other documents, that
this document refers to, had reached the state of the assured technical
stability thus minimizing the risk for the implementor. I strongly believe
that the publication of this document is in the best interest of everyone
working on aspects of SFC as it provides SFC with the comprehensive dynamic
distributed control plane solution.

Regards,
Greg.

On Thu, Apr 4, 2019 at 4:58 AM <[email-masked]> wrote:

> Hi WG,
>
>
>
> draft-ietf-bess-nsh-bgp-controlplane has passed WGLC and its finishing the
> shepherd’s review phasis (I-D update required).. It is in a good shape to
> progress further. However we are not aware of any implementation. As per
> our Implementation Requirement Policy, we need to poll the WG to know if WG
> agrees to progress the document without implementation.
>
>
>