Subject: [bess] Questions to draft-dawra-bess-srv6-services-02

From: Linda Dunbar <[email-masked]>
Date: Thu, 3 Oct 2019 14:45:32 +0000

Robert,

Thank you very much for the explanation.
With the L3VPN case,  there are nodes between Egress and Ingress PEs that do look into the VPN label carried by the packets for VRF & IP lookup, correct?
I was just confused of the statement about “all nodes between Egress & Ingress PE are SR unaware plain IP forwarding nodes”.

Thanks,

Linda

From: Robert Raszuk <[email-masked]>
Sent: Thursday, October 03, 2019 3:50 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [bess] WG adoption and IPR poll for draft-dawra-bess-srv6-services-02

Linda,

SRv6 services is just a general term used here. Imagine one of such service is L3VPN. VPN label (or pointer to it) is needed to be carried somewhere in the packet as address space may be overlapping between VPN customers and simple IP lookup will not be sufficient to determine VRF or exit interface.

One option which has been done and deployed is to encode it natively in the packet and on ingress simply apply prodecures of IPv4 or IPv6 encapsulation - RFC4797 and RFC7510

The other new option is to take the VPN label or VPN demux value and encode it in SRH or in DO.

Now which option to choose is left for the operator to decide likely depending on a lot of other factors involved.

Thx,
R.

On Thu, Oct 3, 2019 at 5:52 AM Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
I support WG adoption of the draft, with the following questions. Hope authors can help to explain:

Section 1 Introduction states that the underlay between the Ingress and Egress only needs to support plain IPv6
Forwarding. Those plain IPv6 routers don't need to understand the SR policies encoded in the payload, correct?
Why need Ingress PE to encapsulate the policy sent by egress PE if all the nodes between them are plain IPv6 routers?

Which PE is to enforce the SR policy?
If the policies are for the egress to enforce, why can't the egress PE simply enforce the policy instead of asking ingress node to encapsulate the policy in the packet header? Which has the drawback of extra header bits in packets.

Linda Dunbar

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, September 27, 2019 at 4:00 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: WG adoption and IPR poll for draft-dawra-bess-srv6-services-02
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Swadesh Agrawal <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Friday, September 27, 2019 at 4:00 AM

Hello,

This email begins a two-weeks WG adoption poll for draft-dawra-bess-srv6-services-02 [1] .

Please review the draft and post any comments to the BESS working group list.

We are also polling for knowledge of any undisclosed IPR that applies to this Document, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an author or a contributor of this document, please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR, copying the BESS mailing list. The document won't progress without answers from all the authors and contributors.
Currently, there are no IPR disclosures against this document.

If you are not listed as an author or a contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

This poll for adoption closes on Friday 11th October 2019.

Regards,
Matthew and Stephane

[1] https://datatracker.ietf.org/doc/draft-dawra-bess-srv6-services/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dawra-bess-srv6-services%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Ccda46858450b47cddd2908d747deab0f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637056893990134792&sdata=KplKMUlBMxL1hSt2ZMbYHpChddEsDhTRrUOLH7e7gaQ%3D&reserved=0>

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 3 Oct 2019 17:01:53 +0200

Hi Linda,

Nope. Nodes except egress have any reason to look at VPN label. That label
has only local significance on egress.

Thx,
R.

On Thu, Oct 3, 2019 at 4:45 PM Linda Dunbar <[email-masked]>
wrote:

> With the L3VPN case,  there are nodes between Egress and Ingress PEs that
> do look into the VPN label carried by the packets for VRF & IP lookup,
> correct?
>
> I was just confused of the statement about “all nodes between Egress &
> Ingress PE are SR unaware plain IP forwarding nodes”.
>
>
>
> Thanks,
>
>
>
> Linda
>
>
>
> *From:* Robert Raszuk <[email-masked]>
> *Sent:* Thursday, October 03, 2019 3:50 AM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [bess] WG adoption and IPR poll for
> draft-dawra-bess-srv6-services-02
>
>
>
> Linda,
>
>
>
> SRv6 services is just a general term used here. Imagine one of such
> service is L3VPN. VPN label (or pointer to it) is needed to be carried
> somewhere in the packet as address space may be overlapping between VPN
> customers and simple IP lookup will not be sufficient to determine VRF or
> exit interface.
>
>
>
> One option which has been done and deployed is to encode it natively in
> the packet and on ingress simply apply prodecures of IPv4 or IPv6
> encapsulation - RFC4797 and RFC7510
>
>
>
> Now which option to choose is left for the operator to decide likely
> depending on a lot of other factors involved.
>
>
>
> Thx,
>
> R.
>
>
>
> On Thu, Oct 3, 2019 at 5:52 AM Linda Dunbar <[email-masked]>
> wrote:
>
> Forwarding. Those plain IPv6 routers don't need to understand the SR
> policies encoded in the payload, correct?
>
> Why need Ingress PE to encapsulate the policy sent by egress PE if all the
> nodes between them are plain IPv6 routers?
>
>
>
> If the policies are for the egress to enforce, why can't the egress PE
> simply enforce the policy instead of asking ingress node to encapsulate the
> policy in the packet header? Which has the drawback of extra header bits in
> packets.
>
>
>
> Linda Dunbar
>
>
>
>
>
> *From: *"Bocci, Matthew (Nokia - GB)" <[email-masked]>
> *Date: *Friday, September 27, 2019 at 4:00 AM
> *To: *"[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *WG adoption and IPR poll for draft-dawra-bess-srv6-services-02
> *Resent-From: *<[email-masked]>
> *Resent-To: *<[email-masked]>, <[email-masked]>, <
> [email-masked]>, Swadesh Agrawal <[email-masked]>, <
> [email-masked]>, <[email-masked]>, <[email-masked]>, <
> [email-masked]>, <[email-masked]>, <
> [email-masked]>, <[email-masked]>, <
> [email-masked]>
> *Resent-Date: *Friday, September 27, 2019 at 4:00 AM
>
>
>
> Hello,
>
>
>
> We are also polling for knowledge of any undisclosed IPR that applies to
> this Document, to ensure that IPR has been disclosed in compliance with
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
>
>
> If you are listed as an author or a contributor of this document, please
> respond to this email and indicate whether or not you are aware of any
> relevant undisclosed IPR, copying the BESS mailing list. The document won't
> progress without answers from all the authors and contributors.
>
> If you are not listed as an author or a contributor, then please
> explicitly respond only if you are aware of any IPR that has not yet been
> disclosed in conformance with IETF rules.
>
>
>
> [1] https://datatracker.ietf.org/doc/draft-dawra-bess-srv6-services/
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dawra-bess-srv6-services%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Ccda46858450b47cddd2908d747deab0f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637056893990134792&sdata=KplKMUlBMxL1hSt2ZMbYHpChddEsDhTRrUOLH7e7gaQ%3D&reserved=0>
>
>
>
>
>
>

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 3 Oct 2019 19:03:31 -0400

Hi Robert 

In-line question

Sent from my iPhone

> On Oct 3, 2019, at 11:01 AM, Robert Raszuk <[email-masked]> wrote:
> 
> Hi Linda, 
> 
> Nope. Nodes except egress have any reason to look at VPN label. That label has only local significance on egress. 
> 
> Thx,
> R.

Robert 

From an operator perspective ease of implementation and migration is critical to deployment.

So just as with SR-MPLS where you can prefer SR over mpls and it’s a swap of the “topmost label” in the label stack and all VPN services label at the bottom of the stack remain unchanged.  Drawing an analogy to SRv6 scenario that would it be exactly the same it sounds like that L3 VPN vpn label remains intact for vpnv4 vpnv6 scenario and IP native native IPv4 / IPv6 encapsulation IP/MPLS remains the same no change and it’s just the “topmost” label gets swapped out from either legacy mpls LDP/TE to either SR-MPLS or now SRv6 topmost label. The services bottom label are only imposed by ingress PE as with legacy mpls and per SRv6 End SID programming is either PSP or USP popped similar to legacy mpls PHP UHP and VPN label is then processed by the egress PE identical to how it’s done with SR-MPLS or legacy mpls.

So from an operator perspective such as Verizon that does make it attractive and an easy swap out migration or new green field implementation to migrate to SRv6 as all the customer Edge PE-CE protocols and encapsulation VPN related services L3 VPN. MVPN EVPN PBB VPWS e-tree e-lan e-line does not change for any services bottom labels.

Is that true and if so that is a major design concern for migration of customers to a SRv6 core.

With SR-TE now we would have native TE capabilities with SRv6 over SR-MPLS so that we can individually color each per vpn  flow to an SR-TE tunnel over SRv6 core.  I am stating that correctly that is the major benefit of SRv6 over SR-MPLS.

Gyan
Verizon Communications 
Cell phone 301 502-1347
> 
>> On Thu, Oct 3, 2019 at 4:45 PM Linda Dunbar <[email-masked]> wrote:
>> Robert,
>> 
>>  
>> 
>> On Thu, Oct 3, 2019 at 5:52 AM Linda Dunbar <[email-masked]> wrote:
>> 
>> From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
>> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
>> Resent-From: <[email-masked]>
>> Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, Swadesh Agrawal <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 4 Oct 2019 01:29:30 +0200

Hello Gyan,

I have read your comment few times. but can't parse it.

Is this a question ? A concern ? Just comment ?

You say:

"Is that true and if so that is a major design concern for migration of
customers to a SRv6 core."

But what is that ? I am very happy to answer any questions you may have in
honest way, but just need to understand what the question really is.

Thx,
R.

On Fri, Oct 4, 2019 at 1:03 AM Gyan Mishra <[email-masked]> wrote:

> So just as with SR-MPLS where you can prefer SR over mpls and it’s a swap
> of the “topmost label” in the label stack and all VPN services label at the
> bottom of the stack remain unchanged.  Drawing an analogy to SRv6 scenario
> that would it be exactly the same it sounds like that L3 VPN vpn label
> remains intact for vpnv4 vpnv6 scenario and IP native native IPv4 / IPv6
> encapsulation IP/MPLS remains the same no change and it’s just the
> “topmost” label gets swapped out from either legacy mpls LDP/TE to either
> SR-MPLS or now SRv6 topmost label. The services bottom label are only
> imposed by ingress PE as with legacy mpls and per SRv6 End SID programming
> is either PSP or USP popped similar to legacy mpls PHP UHP and VPN label is
> then processed by the egress PE identical to how it’s done with SR-MPLS or
> legacy mpls.
>
> So from an operator perspective such as Verizon that does make it
> attractive and an easy swap out migration or new green field implementation
> to migrate to SRv6 as all the customer Edge PE-CE protocols and
> encapsulation VPN related services L3 VPN. MVPN EVPN PBB VPWS e-tree e-lan
> e-line does not change for any services bottom labels.
>
> With SR-TE now we would have native TE capabilities with SRv6 over SR-MPLS
> so that we can individually color each per vpn  flow to an SR-TE tunnel
> over SRv6 core.  I am stating that correctly that is the major benefit of
> SRv6 over SR-MPLS.
>
> Gyan
> Verizon Communications
> Cell phone 301 502-1347
>
>
>> Why need Ingress PE to encapsulate the policy sent by egress PE if all
>> the nodes between them are plain IPv6 routers?
>>
>>
>>
>> [email-masked]>, <[email-masked] <[email-masked]>>,
>> <[email-masked]>, <[email-masked]>, <[email-masked]>, <

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 4 Oct 2019 01:27:34 -0400

Hi Robert

in-line responses

Thank you

Gyan

> I have read your comment few times. but can't parse it.

    OK  let me try to clarify

> Is this a question ? A concern ? Just comment ?
    Question & Comment I guess let me try and rephrase

>     So "that" is the BGP services provided by an SRv6 service provider
that if AFI/SAFI  does not change for L3 VPN services and any underlying L3
protocols do not change then it does make SRv6 more viable without major
code rewriting and I believe that is what the purpose of this draft that it
is stating that the overlay services edges at the PE edge weather its L3
VPN vpnv4/vpnv6 6PE/6VPE, MVPN, EVPN whatever that service maybe all of
that will still work but now its just the flow is encapsulated in IPv6 SRv6
EH SRH header inserted by the source node and SID's copied hop by hop to
the destination for the hop by hop Ti-LFA traffic engineered path over the
service provider core.

In the draft I am talking about sections 3.1-vpnv4,3.2 vpnv6 ,3.3 ipv4,3.4
ipv6 4. evpn - that their AFI/SAFI remain the unchanged and will continue
to work as they do today providing seamless migration with what I said
swapping out the "topmost label" which is in MPLS terms but in the SRv6
world  instead of having an MPLS LDP shim now you have IPv6 encapsulation
of the L3 vpn services label using either RFC 4797 or RFC 7510 or new EH
encoding method.

So this is really the crux of it and critical for SRv6 to gain traction and
get of the ground  is having consensus on this draft as BESS WG is
providing the framework for existing technologies AFI/SAFI bgp "services"
to be used over SRv6.  So not having to reinvent the wheel and create a
request for IANA for any new AFI/SAFI for SRv6 as the existing address
families can all be "reused" with SRv6.  The main thing is figuring out
what encapsulation method to use for the L3 VPN label.

Regarding the L3 VPN service label and how that would get encapsulated in
SRv6 you mentioned existing methods using GRE/MPLS RFC 4797 or UDP/MPLS RFC
7510 or a new encoding of VPN label into SRH.  In the draft are you keeping
both options open for the operator to make a decision based on many factors
whichever works best for their environment?  With the later option encoing
VPN label into SRH would you save on overhead bytes from the encapsulation
I am guessing.  What is the benefit of one over the other.  Also when
encapsulating the L3 VPN service label traditionally in an MPLS
environement you only have the VPN label 4 byte shim added to the bottom of
the label stack but now with RFC 4797 with GRE you add extra 24 GRE/IP
bytes and with UDP/MPLS 8 bytes.

>> Nope. Nodes except egress have any reason to look at VPN label. That
>> label has only local significance on egress.
>>
>> Thx,
>> R.
>>
>>
>> Robert
>>
>> With SR-TE now we would have native TE capabilities with SRv6 over
>> SR-MPLS so that we can individually color each per vpn  flow to an SR-TE
>> tunnel over SRv6 core.  I am stating that correctly that is the major
>> benefit of SRv6 over SR-MPLS.
>>
>> Gyan
>> Verizon Communications
>> Cell phone 301 502-1347
>>
>>
>>> With the L3VPN case,  there are nodes between Egress and Ingress PEs
>>> that do look into the VPN label carried by the packets for VRF & IP lookup,
>>> correct?
>>>
>>> [email-masked]>, "[email-masked]" <[email-masked]
>>> >

-- 

Gyan S. Mishra

IT Network Engineering & Technology

Verizon Communications Inc. (VZ)

13101 Columbia Pike FDC1 3rd Floor

Silver Spring, MD 20904

United States

Phone: 301 502-1347

Email: [email-masked]

www.linkedin.com/in/GYAN-MISHRA-RS-SP-MPLS-IPV6-EXPERT

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 4 Oct 2019 18:09:30 -0400

In line to Robert and any of the other co-authors on my comment

Sent from my iPhone

> On Oct 4, 2019, at 1:27 AM, Gyan Mishra <[email-masked]> wrote:
> 
> Hi Robert
> 
> in-line responses
> 
> Thank you
> 
> Gyan
> 
>> "Is that true and if so that is a major design concern for migration of customers to a SRv6 core." 
>> 
>> But what is that ? I am very happy to answer any questions you may have in honest way, but just need to understand what the question really is. 
>> 
>     So "that" is the BGP services provided by an SRv6 service provider  that if AFI/SAFI  does not change for L3 VPN services and any underlying L3 protocols do not change then it does make SRv6 more viable without major code rewriting and I believe that is what the purpose of this draft that it is stating that the overlay services edges at the PE edge weather its L3 VPN vpnv4/vpnv6 6PE/6VPE, MVPN, EVPN whatever that service maybe all of that will still work but now its just the flow is encapsulated in IPv6 SRv6 EH SRH header inserted by the source node and SID's copied hop by hop to the destination for the hop by hop Ti-LFA traffic engineered path over the service provider core.
> 
> In the draft I am talking about sections 3.1-vpnv4,3.2 vpnv6 ,3.3 ipv4,3.4 ipv6 4. evpn - that their AFI/SAFI remain the unchanged and will continue to work as they do today providing seamless migration with what I said swapping out the "topmost label" which is in MPLS terms but in the SRv6 world  instead of having an MPLS LDP shim now you have IPv6 encapsulation of the L3 vpn services label using either RFC 4797 or RFC 7510 or new EH encoding method. 
> 
> So this is really the crux of it and critical for SRv6 to gain traction and get of the ground  is having consensus on this draft as BESS WG is providing the framework for existing technologies AFI/SAFI bgp "services" to be used over SRv6.  So not having to reinvent the wheel and create a request for IANA for any new AFI/SAFI for SRv6 as the existing address families can all be "reused" with SRv6.  The main thing is figuring out what encapsulation method to use for the L3 VPN label.
> 
> Regarding the L3 VPN service label and how that would get encapsulated in SRv6 you mentioned existing methods using GRE/MPLS RFC 4797 or UDP/MPLS RFC 7510 or a new encoding of VPN label into SRH.  In the draft are you keeping both options open for the operator to make a decision based on many factors whichever works best for their environment?  With the later option encoing VPN label into SRH would you save on overhead bytes from the encapsulation I am guessing.  What is the benefit of one over the other.  Also when encapsulating the L3 VPN service label traditionally in an MPLS environement you only have the VPN label 4 byte shim added to the bottom of the label stack but now with RFC 4797 with GRE you add extra 24 GRE/IP bytes and with UDP/MPLS 8 bytes.

Robert and other Co-Authors 

I was trying to be crystal clear and hopefully in my explaining I did not muddy the water and make it more confusing.

Try to reword again so basically I am stating I would guess is the obvious but as a question as the reason for this draft as well as how bgp services over SRv6 are supported and implemented and that is that the overlay signaling control plane for L3 vpn vpnv4 vpnv6 and IPv4 IPv6 as well as EVPN and MVPN  there is no change to the overlay and can use existing AFI / SAFI and as the only change is now with encapsulation method used for the VPN label.

If what I have stated is the goals of the draft as far as bgp overlay service then I fully support the draft coming to the table  as a major stakeholder from an operators perspective.  

Thanks 

Gyan