Subject: [bess] I-D Action: draft-ietf-bess-srv6-services-00.txt

From: [email-masked]
Date: Wed, 16 Oct 2019 03:44:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the BGP Enabled ServiceS WG of the IETF.

        Title           : SRv6 BGP based Overlay services
        Authors         : Gaurav Dawra
                          Clarence Filsfils
                          Patrice Brissette
                          Swadesh Agrawal
                          Jonn Leddy
                          Daniel Voyer
                          Daniel Bernier
                          Dirk Steinberg
                          Robert Raszuk
                          Bruno Decraene
                          Satoru Matsushima
                          Shunwan Zhuang
                          Jorge Rabadan
	Filename        : draft-ietf-bess-srv6-services-00.txt
	Pages           : 28
	Date            : 2019-10-15

Abstract:
   This draft defines procedures and messages for SRv6-based BGP
   services including L3VPN, EVPN and Internet services.  It builds on
   RFC4364 "BGP/MPLS IP Virtual Private Networks (VPNs)" and RFC7432
   "BGP MPLS-Based Ethernet VPN".

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bess-srv6-services/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-bess-srv6-services-00
https://datatracker.ietf.org/doc/html/draft-ietf-bess-srv6-services-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: li zhenqiang <[email-masked]>
Date: Thu, 24 Oct 2019 09:54:33 +0000

Dear authors and all,

I've read the draft with the following comments that need your clarificaton or consideration.
1. For Network Address of Next Hop in MP_REACH_NLRI, the doc says this field is IPv6 address of the egress PE, or 8 octets of RD set to 0 followed by IPv6 address of the egress PE. I want to know the IPv6 address of the egress PE can only be the IPv6 address which the egress PE uses to establish the BGP session, or it can also be the END SID of the egress PE. Would you please add a couple of sentences in the doc according to your answer to clarify this explicitly?

2. For the BGP session used to delivery the SRv6 services defined in this doc, is it only a IPv6 TCP connection, or a IPv4 TCP connection in the dual stack core network is also ok? If IPv4 BGP session is also ok, in my understanding the services carried in the BGP do not depend on the BGP session, i.e. the BGP session can be IPv4 or IPv6, so could you please find an apropriate place to state this in the doc? In this scenario, how to fill Network Address of Next Hop in MP_REACH_NLRI also needs to be specified.

3. Should we add a paragraph to specify the behavior of the ingress PE when it receives BGP update message? I think at least the following information should be included. Does the engress PE need to check the reachability of the locator since it will be used to encapsulate the traffic and it is distributed in IGP? Does BGP need to synchronize with IGP? We have to handle the situation that locator is not distributed in IGP by mistake or something.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: internet-drafts<mailto:[email-masked]>
Date: 2019-10-16 18:44
To: [email-masked]<mailto:[email-masked]>
CC: bess<mailto:[email-masked]>
Subject: [bess] I-D Action: draft-ietf-bess-srv6-services-00.txt

Abstract:

_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess