Subject: [bess] [Technical Errata Reported] RFC8584 (5900)

From: RFC Errata System <[email-masked]>
Date: Tue, 12 Nov 2019 04:02:39 -0800 (PST)

The following errata report has been submitted for RFC8584,
"Framework for Ethernet VPN Designated Forwarder Election Extensibility".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5900

--------------------------------------
Type: Technical
Reported by: Frank Lu <[email-masked]>

Section: 1.1

Original Text
-------------
BD: Broadcast Domain.  An EVI may be comprised of one BD
      (VLAN-based or VLAN Bundle services) or multiple BDs (VLAN-aware
      Bundle services).

Corrected Text
--------------
BD: Broadcast Domain.  An EVI may be comprised of one BD
      (VLAN-based) or multiple BDs (VLAN Bundle services 
or VLAN-aware Bundle services).

Notes
-----
By definition, tgere

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8584 (draft-ietf-bess-evpn-df-election-framework-09)
--------------------------------------
Title               : Framework for Ethernet VPN Designated Forwarder Election Extensibility
Publication Date    : April 2019
Author(s)           : J. Rabadan, Ed., S. Mohanty, Ed., A. Sajassi, J. Drake, K. Nagaraj, S. Sathappan
Category            : PROPOSED STANDARD
Source              : BGP Enabled Services
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: John E Drake <[email-masked]>
Date: Tue, 12 Nov 2019 15:37:06 +0000

This should be rejected as well.

Sent from my iPhone

> On Nov 12, 2019, at 5:32 PM, RFC Errata System <[email-masked]> wrote:
> 
> https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid5900__;!8WoA6RjC81c!TpKkmNpLw0IxSEE-fJ1n-SvT2U3XV1WV-yf10zT1tAutFg-Xf1AC-VLo5hXdcR4$ 
>

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Tue, 12 Nov 2019 19:10:35 +0000

Yes, This errata should be rejected because VLAN-bundle service requires ONLY a single BD - that is analogous to SVL mode in 802.1Q. It is VLAN-aware bundle service that requires multiple BDs!

Cheers,
Ali

On 11/12/19, 7:37 AM, "John E Drake" <[email-masked]> wrote:

    Sent from my iPhone

---

From: 呂國正 <[email-masked]>
Date: Tue, 12 Nov 2019 23:40:02 +0000

Hi!

Best regards,

Frank

[email-masked] 於 2019年11月13日 上午7:32 寫道：

Hi!

I believe you may misunderstand the definition of Broadcast domain (BD) and bridge table( as known as bridge domain).

6.2<https://tools.ietf.org/html/rfc7432#section-6.2>. VLAN Bundle Service Interface

   With this service interface, an EVPN instance corresponds to multiple
   broadcast domains (e.g., multiple VLANs); however, only a single
   bridge table is maintained per MAC-VRF, which means multiple VLANs
   share the same bridge table.

Best regards,

Frank

Ali Sajassi (sajassi) <[email-masked]> 於 2019年11月13日 上午3:10 寫道：

Cheers,
Ali

   Sent from my iPhone

Section: 1.1

Original Text
-------------

Corrected Text
--------------

Notes
-----
By definition, tgere

Instructions:
-------------

------Please consider the environment before printing this e-mail.

---

From: 呂國正 <[email-masked]>
Date: Tue, 12 Nov 2019 23:32:54 +0000

Hi!

Best regards,

Frank

Cheers,
Ali

   Sent from my iPhone

Section: 1.1

Original Text
-------------

Corrected Text
--------------

Notes
-----
By definition, tgere

Instructions:
-------------

---

From: 呂國正 <[email-masked]>
Date: Tue, 12 Nov 2019 23:56:11 +0000

Hi!
This is another illustration.

Best regards,

Frank

[email-masked] 於 2019年11月13日 上午7:40 寫道：

Hi!

Best regards,

Frank

Hi!

Best regards,

Frank

Cheers,
Ali

   Sent from my iPhone

Section: 1.1

Original Text
-------------

Corrected Text
--------------

Notes
-----
By definition, tgere

Instructions:
-------------

---

From: Eric Gray <[email-masked]>
Date: Wed, 13 Nov 2019 00:55:57 +0000

John is correct.

-----Original Message-----
From: BESS <[email-masked]> On Behalf Of John E Drake
Sent: Tuesday, November 12, 2019 10:37 AM
To: RFC Errata System <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [bess] [Technical Errata Reported] RFC8584 (5900)

Sent from my iPhone

> https://protect2.fireeye.com/v1/url?k=35121900-69983bd6-3512599b-0cc47
> ad93dcc-b8503188c2a38820&q=1&e=55b2e833-27c5-4a5b-ba26-f8fe85b01aef&u=
> https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fwww.rfc-editor.org
> %2Ferrata%2Feid5900__%3B%218WoA6RjC81c%21TpKkmNpLw0IxSEE-fJ1n-SvT2U3XV
> 1WV-yf10zT1tAutFg-Xf1AC-VLo5hXdcR4%24
> 
>      (VLAN-based) or multiple BDs (VLAN Bundle services or VLAN-aware 
> Bundle services).
> 
> Notes
> -----
> By definition, tgere
> 
> Instructions:
> -------------
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
> 
_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess