Subject: Re: [bess] [Technical Errata Reported] RFC8584 (5899)

From: John E Drake <[email-masked]>
Date: Tue, 12 Nov 2019 15:56:15 +0000

That’s not correct.  The service in question assumes that there are multiple VLANs but that a given MAC address is unique across all of them.  Hence, one broadcast domain.

Sent from my iPhone

On Nov 12, 2019, at 9:16 PM, Luc André Burdet <[email-masked]> wrote:

7432 makes the clear distinction between broadcast domain and bridge table (in definitions section no less...)
Concur, this erratum 5899 should be rejected.

Erratum 5900<https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid5900__;!8WoA6RjC81c!UGrmlwynsVF22uakunYYqBVrii_3PWz4Q43L2WbuaSCoKttHoPEA3FhjNypHO7k$> makes somewhat more sense, VLAN Bundle in 7432 6.2 is for multiple broadcast domains, so switching "VLAN Bundle services" to "multiple BDs" makes sense. Nit.

.:|:.:|:. Luc André Burdet          | Cisco Systems Canada Inc.
          email: [email-masked]<mailto:[email-masked]> | phone: +1 613 254 4814

On Tue, Nov 12, 2019 at 10:30 AM John E Drake <jdrake=[email-masked]<mailto:[email-masked]>> wrote:
I agree

Sent from my iPhone

> On Nov 12, 2019, at 3:10 PM, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>
> I don't understand why this erratum was filed.
> "Broadcast Domain" is the correct term used in RFC7432 and all the EVPN documents.
> It should be rejected.
>
> Thanks.
> Jorge
>
> -----Original Message-----
> From: RFC Errata System <[email-masked]<mailto:[email-masked]>>
> Date: Tuesday, November 12, 2019 at 4:17 PM
> To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Nagaraj, Kiran (Nokia - US/Mountain View)" <[email-masked]<mailto:[email-masked]>>, "Sathappan, Senthil (Nokia - US/Mountain View)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]<mailto:[email-masked]>>, "Bocci, Matthew (Nokia - GB)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> Subject: [Technical Errata Reported] RFC8584 (5899)
>
>    The following errata report has been submitted for RFC8584,
>    "Framework for Ethernet VPN Designated Forwarder Election Extensibility".
>
>    --------------------------------------
>    You may review the report below and at:
>    https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid5899__;!8WoA6RjC81c!SaIWS8sh_Qv0z3EeiwJR318oBQoGXbgX9muwUkuY33c6bBXZItc9S87ssaGNDd4$
>
>    --------------------------------------
>    Type: Technical
>    Reported by: Sean.Chen <[email-masked]<mailto:[email-masked]>>
>
>    Section: 1.1
>
>    Original Text
>    -------------
>    BD: Broadcast Domain.  An EVI may be comprised of one BD
>          (VLAN-based or VLAN Bundle services) or multiple BDs (VLAN-aware
>          Bundle services).
>
>    Corrected Text
>    --------------
>    BD: Bridge Domain.  An EVI may be comprised of one BD
>          (VLAN-based or VLAN Bundle services) or multiple BDs (VLAN-aware
>          Bundle services).
>
>    Notes
>    -----
>    broadcast domain is not comprised in any services (VLAN-based or VLAN Bundle service).
>
>    Instructions:
>    -------------
>    This erratum is currently posted as "Reported". If necessary, please
>    use "Reply All" to discuss whether it should be verified or
>    rejected. When a decision is reached, the verifying party
>    can log in to change the status and edit the report, if necessary.
>
>    --------------------------------------
>    RFC8584 (draft-ietf-bess-evpn-df-election-framework-09)
>    --------------------------------------
>    Title               : Framework for Ethernet VPN Designated Forwarder Election Extensibility
>    Publication Date    : April 2019
>    Author(s)           : J. Rabadan, Ed., S. Mohanty, Ed., A. Sajassi, J. Drake, K. Nagaraj, S. Sathappan
>    Category            : PROPOSED STANDARD
>    Source              : BGP Enabled Services
>    Area                : Routing
>    Stream              : IETF
>    Verifying Party     : IESG
>
>
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bess__;!8WoA6RjC81c!UGrmlwynsVF22uakunYYqBVrii_3PWz4Q43L2WbuaSCoKttHoPEA3FhjirmvnDo$>

---

From: Eric Gray <[email-masked]>
Date: Wed, 13 Nov 2019 00:54:34 +0000

To be strictly compatible with the bridging model, all of the VLANs included in the same Shared VLAN Learning (SVL) context (which may be all VLANs or not) form a set in which all MAC addresses have to be unique for the set.  I am not certain it is a requirement, but I am fairly certain that implementations mostly treat that set as a single broadcast domain (there would otherwise be possible pathological corner cases).

From: BESS <[email-masked]> On Behalf Of John E Drake
Sent: Tuesday, November 12, 2019 10:56 AM
To: Luc André Burdet <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>; Sathappan, Senthil (Nokia - US/Mountain View) <[email-masked]>; [email-masked]; Bocci, Matthew (Nokia - GB) <[email-masked]>; Nagaraj, Kiran (Nokia - US/Mountain View) <[email-masked]>; [email-masked]; [email-masked]; Vigoureux, Martin (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; RFC Errata System <[email-masked]>
Subject: Re: [bess] [Technical Errata Reported] RFC8584 (5899)

On Nov 12, 2019, at 9:16 PM, Luc André Burdet <[email-masked]<mailto:[email-masked]>> wrote:

Erratum 5900<https://protect2.fireeye.com/v1/url?k=55bdc68d-0937e467-55bd8616-0cc47ad93e32-b25cf5b2e65c92e2&q=1&e=31f39d3b-03cd-419c-b0b8-c67160786f30&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid5900__%3B%218WoA6RjC81c%21UGrmlwynsVF22uakunYYqBVrii_3PWz4Q43L2WbuaSCoKttHoPEA3FhjNypHO7k%24> makes somewhat more sense, VLAN Bundle in 7432 6.2 is for multiple broadcast domains, so switching "VLAN Bundle services" to "multiple BDs" makes sense. Nit.

Sent from my iPhone

>    https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid5899__;!8WoA6RjC81c!SaIWS8sh_Qv0z3EeiwJR318oBQoGXbgX9muwUkuY33c6bBXZItc9S87ssaGNDd4$<https://protect2.fireeye.com/v1/url?k=f3187003-af9252e9-f3183098-0cc47ad93e32-d36ae2ce9efdb0c9&q=1&e=31f39d3b-03cd-419c-b0b8-c67160786f30&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid5899__%3B%218WoA6RjC81c%21SaIWS8sh_Qv0z3EeiwJR318oBQoGXbgX9muwUkuY33c6bBXZItc9S87ssaGNDd4%24>
>
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://protect2.fireeye.com/v1/url?k=a53565b8-f9bf4752-a5352523-0cc47ad93e32-2bf6e07acee6ab05&q=1&e=31f39d3b-03cd-419c-b0b8-c67160786f30&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbess__%3B%218WoA6RjC81c%21UGrmlwynsVF22uakunYYqBVrii_3PWz4Q43L2WbuaSCoKttHoPEA3FhjirmvnDo%24>