Subject: [bess] Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

From: Linda Dunbar <[email-masked]>
Date: Thu, 19 Mar 2020 16:54:07 +0000

Based on Basil's comment on needing an identifier to differentiate SDWAN instances, I added a section to  draft-dunbar-bess-bgp-sdwan-usage . Want to hear people's feedback.

3.1    Requirements
3.1.1 Supporting Multiple SDWAN Segmentations
The term "network segmentation" is used extensively in SDWAN deployment. In general (and in this document), the "Network Segmentation" is referring to the process of dividing the network into logical sub-networks using isolation techniques on a forwarding device such as a switch, router, or firewall. For a homogeneous network, such as MPLS VPN or Layer 2 network, VRF or VLAN are used to separate network segments.
As SDWAN is an overlay network arching over multiple types of networks, it is important to have distinct identifiers to differentiate SDWAN network instances (or segmentations). When different SDWAN network segments do not have their own assigned AS numbers, a very easy way is to use Private AS numbers, in the range of 64512 to 65535, to differentiate different SDWAN segmentations. When using BGP to control the SDWAN networks, the Private AS numbers are carried by the BGP UPDATE messages to their corresponding RRs.

Greatly appreciate any feedback on this description.

Is there any scenario that Private AS cannot be used?

Thank you very much.

Linda Dunbar

From: Najem, Basil <[email-masked]>
Sent: Friday, February 7, 2020 3:02 PM
To: Linda Dunbar <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: solicit feedback on draft-dunbar-bess-bgp-sdwan-usage description of using BGP UPDATE messages to achieve SD-WAN Application Based Segmentation

Hi Linda;

The SD-WAN Segment is part of the SD-WAN fabric; in other words, there could be more than one Segment over a single underlay depending on the design and the business requirements.

Each Segment represents a single and an isolated L3 domain; therefore, I suggested that we may need to include the Segment ID in the BGP update messages in order to identify and build the routing the table for each Segment (based on the Segment ID).

Hope this helps.

Regards;

Basil

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: February-03-20 10:40 AM
To: Najem, Basil <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [EXT]RE: solicit feedback on draft-dunbar-bess-bgp-sdwan-usage description of using BGP UPDATE messages to achieve SD-WAN Application Based Segmentation

Basil,

Thank you very much for the comments.
Your suggested wording change will be incorporated in the next revision.

As for your suggestion of Segment and Segment ID of a SDWAN node (to be included in the BGP UPDATE), does the "Segment" mean the different Underlay?
In the figure below, C-PE1 has 3 WAN ports: 2 to MPLS network and 1 to Public Internet.
Do you mean C-PE1 has 3 WAN "segments"?
If not, can you elaborate more?

Thanks, Linda

From: Najem, Basil <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, February 02, 2020 5:48 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: solicit feedback on draft-dunbar-bess-bgp-sdwan-usage description of using BGP UPDATE messages to achieve SD-WAN Application Based Segmentation

Hello Linda;

I haven't gone through the entire document; however, I have the following quick comments

  1.  Regarding the following paragraph:

  1.  Augment of transport, which refers to utilizing overlay paths over different underlay networks. Very often there are multiple parallel overlay paths between any two SDWAN edges, some of which are private networks over which traffic can traverse without encryption, others require encryption, e.g. over untrusted public networks.

The traffic that traverses the privet networks can be either encrypted or unecrypted (in other words, the assumption that the traffic is NOT encrypted is not always correct). I would change the parpagaph to the following (for clarity):

  1.  Augment of transport, which refers to utilizing overlay paths over different underlay networks. Very often there are multiple parallel overlay paths between any two SDWAN edges, some of which are private networks over which traffic can traverse with or without encryption, others require encryption, e.g. over untrusted public networks.

  1.  Another thing that we need to discuss is the Segment ID; each Segment (at the SD-WAN Edge) MUST have an ID. The SD-WAN Policy will map the Application Flow to the Segment. Since the Segment is a "routing domain", the BGP update will be exchanged with the memebers of a particular Segment.

As such: Should we include the Segment ID as an attribute in the BGP update messages? Perhaps we need to further discuss this in details.

Any feedback is welcomed and it's highly appreciated.

Regards;

Basil

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: January-31-20 5:17 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [EXT]solicit feedback on draft-dunbar-bess-bgp-sdwan-usage description of using BGP UPDATE messages to achieve SD-WAN Application Based Segmentation

BESS participants:

"SDWAN" networks is characterized by:

  1.  Augment of transport, which refers to utilizing overlay paths over different underlay networks. Very often there are multiple parallel overlay paths between any two SDWAN edges, some of which are private networks over which traffic can traverse without encryption, others require encryption, e.g. over untrusted public networks.
  2.  Enable direct Internet access from remote sites, instead hauling all traffic to Corporate HQ for centralized policy control.
  3.  Some traffic are routed based on application IDs instead of based on destination IP addresses.

https://datatracker.ietf.org/doc/draft-dunbar-bess-bgp-sdwan-usage/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-bess-bgp-sdwan-usage%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Ca9128cd6280b43a3456408d7ac10f64a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637167061164641902&sdata=vcl8z6cEeSYXXhp%2FzuZjQ7bIfSTnzPSjYiWnENbs27g%3D&reserved=0> describes examples of using BGP UPDATE messages to achieve the SDWAN Application Based Segmentation,  assuming that the applications are assigned with unique IP addresses.
In the Figure below, the following BGP Updates can be advertised to ensure that Payment Application only communicates with the Payment Gateway:

BGP UPDATE #1 from C-PE2 to RR for the RED P2P topology (only propagated to Payment GW node:

-        MP-NLRI Path Attribute:

        *   30.1.1.x/24

-        Tunnel Encap Path Attribute

        *   IPsec Attributes for PaymentGW ->C-PE2

BGP UPDATE #2 from C-PE2 to RR for the routes to be reached by Purple:

-        MP-NLRI Path Attribute:

        *   10.1.x.x
        *   12.4.x.x

-        TunnelEncap Path Attribute:

        *   Any node to C-PE2

Your feedback is greatly appreciated.

Thank you very much.

Linda Dunbar
________________________________
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints
________________________________
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 19 Mar 2020 17:22:36 +0000

BGP Experts,

Do you know if  there is any problem of using  Private AS as  "Identifier" to differentiate SD-WAN Segmentation? Here is the discussion in BESS WG. Want to get IDR WG feedbacks for this question.

Thank you.
Linda

From: Linda Dunbar
Sent: Thursday, March 19, 2020 11:54 AM
To: Najem, Basil <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

3.1    Requirements
3.1.1Supporting Multiple SDWAN Segmentations
The term "network segmentation" is used extensively in SDWAN deployment. In general (and in this document), the "Network Segmentation" is referring to the process of dividing the network into logical sub-networks using isolation techniques on a forwarding device such as a switch, router, or firewall. For a homogeneous network, such as MPLS VPN or Layer 2 network, VRF or VLAN are used to separate network segments.
As SDWAN is an overlay network arching over multiple types of networks, it is important to have distinct identifiers to differentiate SDWAN network instances (or segmentations). When different SDWAN network segments do not have their own assigned AS numbers, a very easy way is to use Private AS numbers, in the range of 64512 to 65535, to differentiate different SDWAN segmentations. When using BGP to control the SDWAN networks, the Private AS numbers are carried by the BGP UPDATE messages to their corresponding RRs.

Thank you very much.

Linda Dunbar

Hi Linda;

Hope this helps.

Regards;

Basil

Basil,

Thanks, Linda

Hello Linda;

Regards;

Basil

BESS participants:

        *   30.1.1.x/24

        *   10.1.x.x
        *   12.4.x.x

        *   Any node to C-PE2

Thank you very much.

Linda Dunbar

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 19 Mar 2020 23:44:43 +0000

Hi Linda,

    It seems that a label may be used as an "Identifier" to differentiate SD-WAN Segmentation.

Best Regards,
Huaimo
________________________________
From: Idr <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Sent: Thursday, March 19, 2020 1:22 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [Idr] FW: Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

BGP Experts,

Thank you.

Linda

From: Linda Dunbar

Based on Basil’s comment on needing an identifier to differentiate SDWAN instances, I added a section to  draft-dunbar-bess-bgp-sdwan-usage . Want to hear people’s feedback.

3.1    Requirements

The term “network segmentation” is used extensively in SDWAN deployment. In general (and in this document), the “Network Segmentation” is referring to the process of dividing the network into logical sub-networks using isolation techniques on a forwarding device such as a switch, router, or firewall. For a homogeneous network, such as MPLS VPN or Layer 2 network, VRF or VLAN are used to separate network segments.

Thank you very much.

Linda Dunbar

Hi Linda;

Hope this helps.

Regards;

Basil

Basil,

As for your suggestion of Segment and Segment ID of a SDWAN node (to be included in the BGP UPDATE), does the “Segment” mean the different Underlay?

Do you mean C-PE1 has 3 WAN “segments”?

Thanks, Linda

Hello Linda;

I haven’t gone through the entire document; however, I have the following quick comments

  1.  Another thing that we need to discuss is the Segment ID; each Segment (at the SD-WAN Edge) MUST have an ID. The SD-WAN Policy will map the Application Flow to the Segment. Since the Segment is a “routing domain”, the BGP update will be exchanged with the memebers of a particular Segment.

Any feedback is welcomed and it’s highly appreciated.

Regards;

Basil

BESS participants:

“SDWAN” networks is characterized by:

https://datatracker.ietf.org/doc/draft-dunbar-bess-bgp-sdwan-usage/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-bess-bgp-sdwan-usage%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C6a93b40e311047eaceeb08d7cc2a39e0%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202354082601405&sdata=EBCBw7BsPNKbPQ3OGzJxRW%2BlLuGAOHUZgseJt01ZqfU%3D&reserved=0> describes examples of using BGP UPDATE messages to achieve the SDWAN Application Based Segmentation,  assuming that the applications are assigned with unique IP addresses.

        *   30.1.1.x/24

        *   10.1.x.x
        *   12.4.x.x

        *   Any node to C-PE2

Thank you very much.

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 20 Mar 2020 04:54:50 +0000

Huaimo,

Thank you very much for the suggestion.
Do you mean using the similar approach as VPN Label carried by NLRI Path Attribute [RFC8277] for SDWAN Segmentation Identifier?
If yes, the UPDATE message should not use the MPLS VPN SAFI (=128) to avoid confusion, right?

Linda

From: Huaimo Chen <[email-masked]>
Sent: Thursday, March 19, 2020 6:45 PM
To: Linda Dunbar <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Idr] FW: Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

Hi Linda,

Best Regards,
Huaimo
________________________________
From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 19, 2020 1:22 PM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] FW: Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

BGP Experts,

Thank you.

Linda

From: Linda Dunbar

3.1    Requirements

Thank you very much.

Linda Dunbar

Hi Linda;

Hope this helps.

Regards;

Basil

Basil,

Thanks, Linda

Hello Linda;

Regards;

Basil

BESS participants:

https://datatracker.ietf.org/doc/draft-dunbar-bess-bgp-sdwan-usage/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-bess-bgp-sdwan-usage%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Caf554cc9ce6b44b8267608d7cc5f7fcb%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202582862902790&sdata=FBCyAo0FjPczNS3BJsMOveEck0RbWEST7%2FSDolaeJVw%3D&reserved=0> describes examples of using BGP UPDATE messages to achieve the SDWAN Application Based Segmentation,  assuming that the applications are assigned with unique IP addresses.

        *   30.1.1.x/24

        *   10.1.x.x
        *   12.4.x.x

        *   Any node to C-PE2

Thank you very much.

Linda Dunbar

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 23 Mar 2020 14:14:16 +0000

Hi Linda,

    It seems that using another SAFI is a possible solution.

Best Regards,
Huaimo
________________________________
From: Linda Dunbar <[email-masked]>
Sent: Friday, March 20, 2020 12:54 AM
To: Huaimo Chen <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: RE: [Idr] FW: Is there any problem of using Private AS as "Identifier" to differentiate SD-WAN Segmentation for draft-dunbar-bess-bgp-sdwan-usage?

Huaimo,

Linda

Hi Linda,

Best Regards,

Huaimo

BGP Experts,

Thank you.

Linda

From: Linda Dunbar

3.1    Requirements

Thank you very much.

Linda Dunbar

Hi Linda;

Hope this helps.

Regards;

Basil

Basil,

Thanks, Linda

Hello Linda;

Regards;

Basil

BESS participants:

https://datatracker.ietf.org/doc/draft-dunbar-bess-bgp-sdwan-usage/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-bess-bgp-sdwan-usage%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C8a02ffe78a7144f9d47308d7cc8ad29d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202768953162260&sdata=gqmAC4lw3AYyM0tr%2BLMV%2BujiSTqOIwF51iO76ucZNFA%3D&reserved=0> describes examples of using BGP UPDATE messages to achieve the SDWAN Application Based Segmentation,  assuming that the applications are assigned with unique IP addresses.

        *   30.1.1.x/24

        *   10.1.x.x
        *   12.4.x.x

        *   Any node to C-PE2

Thank you very much.

Linda Dunbar