Subject: Re: [bess] IGMP / MLD Proxy Draft update (NLRI change)

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 23 Apr 2020 08:18:42 +0000

Thank you Mankamana.

From Nokia’s perspective I confirm your reference below. We implemented it without a Seq number based on what we thought was that agreement among authors pre-IETF106.

Just wanted to mention that there were never any procedures specified for the sequence number in the draft. So even if two implementors had attempted to implement that sequence number, there is no guarantee they could have interoperated with each other. So the Sequence number reference must go from the draft anyway. To me, the real discussion is if removing those 4 bytes from the NLRI length will cause issues.

My take is that, given the implementations that we have in the field, the proposal for the RR to accept both lengths seems like the better practical option. And since that field cannot be a sequence number anymore, it should be removed from the draft as soon as possible to avoid confusion for future implementors.

But I would also like people to share their concerns here.

Thanks.
Jorge

From: BESS <[email-masked]> on behalf of "Mankamana Mishra (mankamis)" <mankamis=[email-masked]>
Date: Thursday, April 23, 2020 at 8:32 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [bess] IGMP / MLD Proxy Draft update (NLRI change)

All,
Post WGLC  before IETF Singapore it came to our notice that there were implementation discrepancies of this draft (https://tools.ietf.org/html/draft-ietf-bess-evpn-igmp-mld-proxy-04#section-9.3). Though draft had NLRI definition as

             +--------------------------------------------------+
             |  RD (8 octets)                                   |
             +--------------------------------------------------+
             | Ethernet Segment Identifier (10 octets)          |
             +--------------------------------------------------+
             |  Ethernet Tag ID  (4 octets)                     |
             +--------------------------------------------------+
             |  Multicast Source Length (1 octet)               |
             +--------------------------------------------------+
             |  Multicast Source Address (variable)             |
             +--------------------------------------------------+
             |  Multicast Group Length (1 octet)                |
             +--------------------------------------------------+
             |  Multicast Group Address (Variable)              |
             +--------------------------------------------------+
             |  Originator Router Length (1 octet)              |
             +--------------------------------------------------+
             |  Originator Router Address (variable)            |
             +--------------------------------------------------+
             |  Leave Group Synchronization  # (4 octets)       |
             +--------------------------------------------------+
             |  Maximum Response Time (1 octet)                 |
             +--------------------------------------------------+
             |  Flags (1 octet)                                 |
             +--------------------------------------------------+
Where there was Leave Group Synchronization number as part of NLRI. But two implementation were

1.      With this field as part of NLRI

2.      Without this field as part of NLRI

Implementation survey As of 2019:
 Since it came to notice that at least there are two implementation which would not interop, we did try to take survey of other implementation.  We tried it with IETF & Nanog forum. We reached out to some of vendors directly as well. And implementation were
Cisco – Without Seq number
Juniper – With Seq number
Arista -  with and without sequence number
Apart from these vendors, we did not get response from any one else who had implemented these routes.

Before IETF 106 (Singapore) there were couple of discussion among authors & other vendors. And it was evident that there are two implementation which would not interop as is.  And Sequence number for IGMP does not have any value or need. And majority of vendors were ok to remove this field from NLRI as there is no practical use case.  So one of the proposal was to remove the field. And to make sure we interop with old version proposal was to

1.      Remove Seq number from NLRI

2.      RR MUST accept both len of NLRI

IETF 106 Update :

These changes were presented in IETF 106 Singapore as well.

Implementation Changes post IETF106, As of Today:

Nokia -  Implemented without Seq number, and RR supports both length
Cisco  - Modified implementation to make sure as RR we support both len
Arista -  Already had this implementation to support both len.

Update in Draft :

             +--------------------------------------------------+
             |  RD (8 octets)                                   |
             +--------------------------------------------------+
             | Ethernet Segment Identifier (10 octets)          |
             +--------------------------------------------------+
             |  Ethernet Tag ID  (4 octets)                     |
             +--------------------------------------------------+
             |  Multicast Source Length (1 octet)               |
             +--------------------------------------------------+
             |  Multicast Source Address (variable)             |
             +--------------------------------------------------+
             |  Multicast Group Length (1 octet)                |
             +--------------------------------------------------+
             |  Multicast Group Address (Variable)              |
             +--------------------------------------------------+
             |  Originator Router Length (1 octet)              |
             +--------------------------------------------------+
             |  Originator Router Address (variable)            |
             +--------------------------------------------------+
             |  Leave Group Synchronization  # (4 octets)       |
             +--------------------------------------------------+
             |  Maximum Response Time (1 octet)                 |
             +--------------------------------------------------+
             |  Flags (1 octet)                                 |
             +--------------------------------------------------+

1.      Removed Seq number from EVPN route type 8

2.      Added text stating older version of draft had 4 byte extra and RR MUST  accept and reflect both length.

WGLC :
It had been discussed with chairs, and agreed upon one more short WGLC once changes are posted

Before publishing the draft, we wanted to make sure if there are any other vendor have any concern.

Mankamana

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Thu, 23 Apr 2020 19:26:26 +0000

Thanks Mankamana for bringing this in. I agree with Jorge here, that draft doesn’t describe any procedures specifying leave group sequence number. We should remove this field from the draft to avoid any confusion. Our implementation wise it would be okay as we haven’t implemented yet.

Just on a cautious note, as Jeorge mentioned we should make sure RR should accept both length so that it doesn’t cause any interop issues in the field. But as such the sequence number field goes, it should be removed.

Thanks,
Kausik

From: BESS <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Thursday, April 23, 2020 1:19 AM
To: Mankamana Mishra (mankamis) <mankamis=[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [bess] IGMP / MLD Proxy Draft update (NLRI change)

Thank you Mankamana. From Nokia’s perspective I confirm your reference below. We implemented it without a Seq number based on what we thought was that agreement among authors pre-IETF106. Just wanted
External ([email-masked]<mailto:[email-masked]>)
Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tLzhlNjFmOGQyNDFhZmY2MGY3ZjNhNzY0YWY3N2MwZjE5LzE1ODc2Mjk5NDMuNTc=#key=4ecc4afc2f4a8105fefeda763beee8e7>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

Thank you Mankamana.

Thanks.
Jorge

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of "Mankamana Mishra (mankamis)" <mankamis=[email-masked]<mailto:mankamis=[email-masked]>>
Date: Thursday, April 23, 2020 at 8:32 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] IGMP / MLD Proxy Draft update (NLRI change)

All,
Post WGLC  before IETF Singapore it came to our notice that there were implementation discrepancies of this draft (https://tools.ietf.org/html/draft-ietf-bess-evpn-igmp-mld-proxy-04#section-9.3<https://secure-web.cisco.com/1QO1N1lQGBJwDUaacDBEdUBiI46lrxFSLZzCIcEu5luY0mF5k5sK-4xqjS6l-4u1LRgp0tYu801gJMladAje711jAxnvTTH0JIVXQYM-7sw_d_SWkXfKxf1--Ky3ZSwMPaRT37yp-QU8bvx5OQivLou8XxTWfsUsAUZmX0QI4KLxjImng6RHuvptXqqEGBkZJYsNhSL0-kW9BA0m4j23Q0BOM-H75GRoDAE0GWj0FcHtvo-lM4gn4kgW2SOEcVziEwtKmg22wa0YQ67lQ1wQ72C4WTOov4hNq5Fr-5ONXWxQlhFp78wUYVTTz-9cUxaGsQ7qhbzfAkF8r2P8atRUUD3j-G-hMudqFH6HNWNQ5wD4/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-bess-evpn-igmp-mld-proxy-04%23section-9.3>). Though draft had NLRI definition as

IETF 106 Update :

Update in Draft :

WGLC :

Mankamana

---

From: Keyur Patel <[email-masked]>
Date: Thu, 23 Apr 2020 20:16:18 +0000

I agree with Jorge and Mankamana. We don’t need leave group sequence number.  I would keep it out for now.

Regards,
Keyur

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Thursday, April 23, 2020 at 1:18 AM
To: "Mankamana Mishra (mankamis)" <mankamis=[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] IGMP / MLD Proxy Draft update (NLRI change)
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, April 23, 2020 at 1:18 AM

Thank you Mankamana.

Thanks.
Jorge

All,

IETF 106 Update :

Update in Draft :

WGLC :

Mankamana

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 23 Apr 2020 15:35:31 -0700

I'm OK with the changes mentioned below (remove the field and require RR to
accept both lengths).

I think RR accepting both lengths should be a SHOULD rather than a MUST (it
would be more accommodative of implementations), but I could probably live
with the MUST.

Anoop

On Thu, Apr 23, 2020 at 1:16 PM Keyur Patel <[email-masked]> wrote:

> *From: *"Rabadan, Jorge (Nokia - US/Mountain View)" <
> [email-masked]>
> *Date: *Thursday, April 23, 2020 at 1:18 AM
> *To: *"Mankamana Mishra (mankamis)" <mankamis=[email-masked]>,
> "[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <
> [email-masked]>
> *Subject: *Re: [bess] IGMP / MLD Proxy Draft update (NLRI change)
> *Resent-From: *<[email-masked]>
> *Resent-To: *<[email-masked]>, <[email-masked]>, <[email-masked]>,
> <[email-masked]>, <[email-masked]>
> *Resent-Date: *Thursday, April 23, 2020 at 1:18 AM
>
>
>
> Thank you Mankamana.
>
>
>
> From Nokia’s perspective I confirm your reference below. We implemented it
> *without* a Seq number based on what we thought was that agreement among
> authors pre-IETF106.
>
>
>
> Just wanted to mention that there were *never* any procedures specified
> for the sequence number in the draft. So even if two implementors had
> attempted to implement that sequence number, there is no guarantee they
> could have interoperated with each other. So the Sequence number reference
> must go from the draft anyway. To me, the real discussion is if removing
> those 4 bytes from the NLRI length will cause issues.
>
>
>
> My take is that, given the implementations that we have in the field, the
> proposal for the RR to accept both lengths seems like the better practical
> option. And since that field cannot be a sequence number anymore, it should
> be removed from the draft as soon as possible to avoid confusion for future
> implementors.
>
>
>
> *From: *BESS <[email-masked]> on behalf of "Mankamana Mishra
> (mankamis)" <mankamis=[email-masked]>
> *Date: *Thursday, April 23, 2020 at 8:32 AM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <
> [email-masked]>
> *Subject: *[bess] IGMP / MLD Proxy Draft update (NLRI change)
>
>
>
> All,
>
> Post WGLC  before IETF Singapore it came to our notice that there were *implementation
> discrepancies* of this draft (
> https://tools.ietf.org/html/draft-ietf-bess-evpn-igmp-mld-proxy-04#section-9.3).
> Though draft had NLRI definition as
>
>
>
> *Implementation survey As of 2019*:
>
>  Since it came to notice that at least there are two implementation which
> would not interop, we did try to take survey of other implementation.  We
> tried it with IETF & Nanog forum. We reached out to some of vendors
> directly as well. And implementation were
>
> *Cisco* – Without Seq number
>
> *Juniper* – With Seq number
>
> *Arista* -  with and without sequence number
>
> Before IETF 106 (Singapore) there were couple of discussion among authors
> & other vendors. And it was evident that there are two implementation which
> would not interop as is.  And Sequence number for IGMP does not have any
> value or need. And majority of vendors were ok to remove this field from
> NLRI as there is no practical use case.  So one of the proposal was to
> remove the field. And to make sure we interop with old version proposal was
> to
>
> *IETF 106 Update* :
> *Implementation Changes post IETF106, As of Today*:
>
>
>
> *Nokia* -  Implemented without Seq number, and RR supports both length
>
> *Cisco*  - Modified implementation to make sure as RR we support both len
>
> *Arista* -  Already had this implementation to support both len.
>
>
>
>
>
> *Update in Draft* :
>
>
>
>
>
> *WGLC : *
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Fri, 24 Apr 2020 22:59:46 +0000

++ Chris, to provide input from Arista point of view.

Mankamana

From: BESS <[email-masked]> on behalf of Keyur Patel <[email-masked]>
Date: Thursday, April 23, 2020 at 1:16 PM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>, "Mankamana Mishra (mankamis)" <mankamis=[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] IGMP / MLD Proxy Draft update (NLRI change)

Regards,
Keyur

Thank you Mankamana.

Thanks.
Jorge

All,

IETF 106 Update :

Update in Draft :

WGLC :

Mankamana