Subject: [bess] WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option

From: <[email-masked]>
Date: Fri, 4 Jun 2021 11:19:27 +0200

Hi WG,

Just as a reminder, draft-ietf-bess-evpn-fast-df-recovery currently proposes
two options: 1) use time synchronization, 2) Use handshake.

We have issues moving forward the draft because of some controversy on the
handshake option while the time sync option seems to have implementations.

It seems that the authors/co-authors agreed to progress the document by
removing the handshake option, leaving the "time sync" as the core of the
document.

As the document is a WG document, we (chairs) need to confirm that there is
no objection from the WG progressing the document in such a way.

Please provide your feedback.

We are opening a poll starting today and ending on **** 18th June **** to
gather feedbacks.

Thanks,

Stephane

https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-fast-df-recovery/

---

From: John E Drake <[email-masked]>
Date: Fri, 4 Jun 2021 21:16:34 +0000

Hi,

Please use time synchronization only - it's a much simpler and more robust solution.

Yours Irrespectively,

John

Juniper Business Use Only
From: BESS <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, June 4, 2021 5:19 AM
To: 'BESS' <[email-masked]>
Cc: [email-masked]
Subject: [bess] WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option

[External Email. Be cautious of content]

Hi WG,

Just as a reminder, draft-ietf-bess-evpn-fast-df-recovery currently proposes two options: 1) use time synchronization, 2) Use handshake.

We have issues moving forward the draft because of some controversy on the handshake option while the time sync option seems to have implementations.

It seems that the authors/co-authors agreed to progress the document by removing the handshake option, leaving the "time sync" as the core of the document.

As the document is a WG document, we (chairs) need to confirm that there is no objection from the WG progressing the document in such a way.

We are opening a poll starting today and ending on **** 18th June **** to gather feedbacks.

Thanks,

Stephane

https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-fast-df-recovery/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-fast-df-recovery/__;!!NEt6yMaO-gk!RwO-jIrx4xtw5BeGEy408fDdEbGd5LCFJzTQLJ5VCR2vLRfUycon8iLT9vlpbuw$>

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 4 Jun 2021 17:45:05 -0700

+1

Regards,
Jeff

> On Jun 4, 2021, at 14:16, John E Drake <jdrake=[email-masked]> wrote:
> 
> 
> Hi,
>  
> Please use time synchronization only – it’s a much simpler and more robust solution.
>  
> Yours Irrespectively,
>  
> John
>  
>  
> It seems that the authors/co-authors agreed to progress the document by removing the handshake option, leaving the “time sync” as the core of the document.
>  
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: Luc André Burdet <[email-masked]>
Date: Mon, 7 Jun 2021 13:21:34 +0000

I strongly support this simplification.

Regards,
Luc André Burdet |  Cisco  |  [email-masked]  |  Tel: +1 613 254 4814

From: BESS <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Friday, June 4, 2021 at 05:19
To: 'BESS' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [bess] WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option

Hi WG,

Thanks,

Stephane

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Mon, 7 Jun 2021 17:23:11 +0000

Support, it would be good to progress with simplified version of document. And we can later consider if its worth considering other solution .

From: "[email-masked]" <[email-masked]>
Date: Friday, June 4, 2021 at 2:19 AM
To: 'BESS' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Friday, June 4, 2021 at 2:19 AM

Hi WG,

Thanks,

Stephane

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 9 Jun 2021 00:25:10 -0400

I support the simple and robust time synchronization one-way signaling
solution over the 2-way overly complex handshake solution.

The time sync solution seems very flexible and limits exposure to loops and
duplicates during the switchover.

>From a implementation perspective I don’t think most vendors would want to
implement both and if they pick one or the other to implement that could be
a problem, so I think a decision should be made from an interoperability
standpoint on one of the solutions and remove the other.

I agree to remove the handshake option from the draft if we have WG
consensus.

Kind Regards

Gyan

On Mon, Jun 7, 2021 at 1:24 PM Mankamana Mishra (mankamis) <mankamis=
[email-masked]> wrote:

> Support, it would be good to progress with simplified version of document.
> And we can later consider if its worth considering other solution .
>
>
>
> *From: *"[email-masked]" <[email-masked]>
>
>
> *Date: *Friday, June 4, 2021 at 2:19 AM
> *To: *'BESS' <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery
> by dropping "Handshake" option
> *Resent-From: *<[email-masked]>
> *Resent-To: *<[email-masked]>, <[email-masked]>, <
> [email-masked]>
> *Resent-Date: *Friday, June 4, 2021 at 2:19 AM
>
>
>
> Hi WG,
>
>
>
> Just as a reminder, draft-ietf-bess-evpn-fast-df-recovery currently
> proposes two options: 1) use time synchronization, 2) Use handshake.
>
>
>
> removing the handshake option, leaving the “time sync” as the core of the
> document.
>
>
>
> As the document is a WG document, we (chairs) need to confirm that there
> is no objection from the WG progressing the document in such a way.
>
>
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Wed, 9 Jun 2021 14:58:49 +0000

Hi,

I completely support the idea of removing the complex handshake solution from the draft.
The NTP approach is lean and clean
Regards,
Patrice Brissette, Principal Engineer
Cisco Systems

http://e-vpn.io
http://go2.cisco.com/evpn

Date: Friday, June 4, 2021 at 05:20

Hi WG,

Thanks,

Stephane

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 9 Jun 2021 09:44:29 -0700

My only concern with the time sync approach is that it imposes the
requirement for some kind of time sync protocol (either ntp or ptp).  From
what I understand, running these in the data center is not that common.

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Wed, 9 Jun 2021 17:15:40 +0000

Anoop,

This approach is optional.
The intent here is to remove “a” handshake mechanism which is too complex and not always working.
Other people may come with different solution in the future if needed be.

Regards,

http://e-vpn.io

From: BESS <[email-masked]> on behalf of Anoop Ghanwani <[email-masked]>
Date: Wednesday, June 9, 2021 at 12:45
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, BESS <[email-masked]>
Subject: Re: [bess] WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option

My only concern with the time sync approach is that it imposes the requirement for some kind of time sync protocol (either ntp or ptp).  From what I understand, running these in the data center is not that common.

On Fri, Jun 4, 2021 at 2:19 AM <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

Thanks,

Stephane

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 9 Jun 2021 10:52:32 -0700

OK, I see your point.

On Wed, Jun 9, 2021 at 10:15 AM Patrice Brissette (pbrisset) <
[email-masked]> wrote:

> *http://e-vpn.io <http://e-vpn.io>*
>
> *http://go2.cisco.com/evpn <http://go2.cisco.com/evpn>*
>
>
>
>
>
>
>
>
>
> *From: *BESS <[email-masked]> on behalf of Anoop Ghanwani <
> [email-masked]>
> *Date: *Wednesday, June 9, 2021 at 12:45
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, BESS <[email-masked]>
> *Subject: *Re: [bess] WG POLL: Moving forward
> draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option
>
>
>

---

From: <[email-masked]>
Date: Mon, 21 Jun 2021 17:04:07 +0200

Hi WG,

We have received any objection and have seen some support for dropping the handshake options for the current draft.

Thus, the WG is fine with the proposed change.

Authors,

Please proceed with the removal and progress the draft to closure.

Thanks,

Stephane

From: BESS <[email-masked] <mailto:[email-masked]> > on behalf of Anoop Ghanwani <[email-masked] <mailto:[email-masked]> >
Date: Wednesday, June 9, 2021 at 12:45
To: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, BESS <[email-masked] <mailto:[email-masked]> >
Subject: Re: [bess] WG POLL: Moving forward draft-ietf-bess-evpn-fast-df-recovery by dropping "Handshake" option

My only concern with the time sync approach is that it imposes the requirement for some kind of time sync protocol (either ntp or ptp).  >From what I understand, running these in the data center is not that common.

On Fri, Jun 4, 2021 at 2:19 AM <[email-masked] <mailto:[email-masked]> > wrote:

Hi WG,

Thanks,

Stephane

 

_______________________________________________
BESS mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/bess