Subject: Re: [bess] [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

From: Srihari Sangli <[email-masked]>
Date: Tue, 20 Jul 2021 14:55:00 +0000

Mustapha,

I think Shraddha is pointing about the paragraph “When providing best-effort connectivity…” where it specifically talks about fallback to best-effort and if so, perform the resolvability check on the service-SID. Going by what you are saying that its general behavior of SRv6 policy, there is no need to over specify that it SHOULD check for resolvability and need for SRH.

srihari…

On 20/07/21, 7:24 PM spring on behalf of Aissaoui, Mustapha (Nokia - CA/Ottawa) from [email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]> said >

[External Email. Be cautious of content]

Hi Shraddha,
An implementation can allow any fallback strategy, including multiple levels of fallback, but the backup path you are describing is simply the general behavior of a SRv6 policy. The End SID is part of the SRv6 policy segment list and is the top SID. So, the service SID will indeed be pushed into a SRH and the End SID is looked up by the ingress PE to forward the packet. It does not matter if the End SID is from base topology of from a flex-algo topology.

Regards,
Mustapha.

From: spring <[email-masked]> On Behalf Of Shraddha Hegde
Sent: Tuesday, July 20, 2021 5:56 AM
To: Robert Raszuk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Good to know the intention is to support fallback for Srv6.

The way current text is written, it implies service SID is always in the destination address.

And hence service SID should be resolvable. This is not the case when a service SID

Corresponding to flex-algo wants to fallback on best effort services. The destination address cannot carry

Service SID for fallback cases and hence it need not be resolved.

I suggest that the authors add below text in bold to the draft.

“When providing best-effort connectivity or flex-algo connectivity to the egress PE,

the ingress PE encapsulates the payload in an outer IPv6 header where the destination

address is the SRv6 Service SID associated with the related BGP route update.

 Therefore, the ingress PE SHOULD perform resolvability check for the SRv6 Service SID

 before considering the received prefix for the BGP best path computation.

“

“In some cases a service prefix intending to use flex-algo paths may want fallback on

best effort paths when a flex-algo path isn’t available. The fallback behavior

SHOULD be governed by local policies.

The destination address SHOULD contain the best-effort locator based END SID

of the egress PE and the SRH SHOULD contain the service SID. Service SID

resolvability SHOULD NOT be checked on the ingress for this case.”

Rgds

Shraddha

Juniper Business Use Only
From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 20, 2021 12:04 PM
To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

[External Email. Be cautious of content]

Shraddha,

> that authors don’t intend to support any form of tunnelling for SRv6
> because it is not optimal. Is that the right read?

Quite the opposite. It is the local operator's choice (not the draft authors) to decide to fall back to best effort or to drop.

Thx,
R.

On Tue, Jul 20, 2021 at 8:15 AM Shraddha Hegde <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

What do you mean by SR? is it SR-MPLS or SRv6.
My question is about draft-ietf-bess-srv6-services and applies only to SRv6.

Let me repeat the question.
Do the authors intend to support the case of fallback from SRv6 flex-algo to SRv6 best effort transport for SRv6
Services or not?

From your vague answer it appears that authors don’t intend to support any form of tunnelling for SRv6
because it is not optimal. Is that the right read?

Rgds
Shraddha

Juniper Business Use Only
From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 20, 2021 11:17 AM
To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Cc: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

[External Email. Be cautious of content]

Shraddha,

In an SR network fallback to best effort will also result in encapsulated forwarding using SR. It may not be as optimal service wise as using flex-algo, but this is form of tunneling. Hence I don't think your comment applies.

Note that operator may also choose to use IP tunneling for best effort forwarding if SR best effort forwarding is not supported or enabled.

Best,
R.

On Tue, Jul 20, 2021 at 7:20 AM Shraddha Hegde <[email-masked]<mailto:[email-masked]>> wrote:
Hi Authors,

There is a possibility of a usecase that wants to use flex-algo paths if available and if flex-algo paths
Are not available use best effort paths.

“When providing best-effort connectivity to the egress PE, the ingress
   PE encapsulates the payload in an outer IPv6 header where the
   destination address is the SRv6 Service SID associated with the
   related BGP route update.  Therefore, the ingress PE SHOULD perform
   resolvability check for the SRv6 Service SID before considering the
   received prefix for the BGP best path computation.
“

The current text says for best effort tunnels Srv6 service SID resolution SHOULD be checked and
I am told that (from previous mailing list exchanges) authors intend to update the text to make it applicable for flex-algo connectivity  as well.

It is not possible to support fallback on best effort tunnels if flex-algo SRv6 service SIDs have to be resolved.
It is possible to support fallback to best effort in SRv6 if packets can be tunneled to egress PE  (destination address being PE’s best effort END SID and service SID in the SRH)and
then do a service SID lookup on egress, in which case there is no need to resolve the SRv6 service SIDs on the ingress.

It is not clear whether the authors intend to support these kind of tunnelling to egress cases for
Best effort and flex-algo transport. If it not going to be supported, pls add text indicating clearly
Tunnelling is not required to be supported and hence Fallback to best effort  is also not supported.

If that is not the intention, Its reasonable to update the text to indicate SRv6 service SIDs need not be resolved
If the ingress is tunneling the packet.

Rgds
Shraddha

Juniper Business Use Only
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Aissaoui, Mustapha (Nokia - CA/Ottawa)
Sent: Monday, July 19, 2021 7:34 PM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

[External Email. Be cautious of content]

Rajesh,
Also you can change the service SID for a subset of prefixes using a policy, to apply a flex-algo for example, but you do not want to change the next-hop for each new service SID.

Mustapha.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Monday, July 19, 2021 9:47 AM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

The draft is written so that the next-hop address MAY be covered by the locator, but there are cases in which the next-hop address is not part of the locator prefix, and there are implementations already allowing that, so I don’t agree the document should mandate what you are suggesting.

Thanks.
Jorge

From: Rajesh M <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 19, 2021 at 3:24 PM
To: Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>, Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Shraddha Hegde <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)
Hi Authors,

Please respond.

Thanks
Rajesh

Juniper Business Use Only
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rajesh M
Sent: Thursday, July 15, 2021 4:36 PM
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

[External Email. Be cautious of content]

Hi All,

As per this draft, this is how resolution must work.

1)For Non Intent service Route:
if BGP next hop is not reachable return.
Resolve SRv6 Service SID for forwarding.

2)For Intent service Route (IGP Flex-Algo first then BGP CAR then SR Policy):
BGP next hop is not reachable return.
Resolve SRv6 Service SID for forwarding(To find IGP flex algo).if successfully resolves then return.
Resolve BGP next hop for forwarding (in case above is not success).

Using Service SID (overlay),for resolution is definitely not recommended.

Instead in case of srv6, we always resolve on BGP nexthop. This will be in line with BGP legacy.
In case of best effort/flex algo we must mandate user to set corresponding locator as BGP nexthop for srv6 routes.
I think this is a reasonable mandate.

Thanks
Rajesh

Juniper Business Use Only

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 20 Jul 2021 17:14:29 +0000

Hi Srihari,
I am not able to find the text about fallback in the version 07 of the draft. I may have misunderstood but I thought Shraddha was proposing new text to cover fallback in the draft.

The draft refers to “SRv6 service with best-effort connectivity” and to “SRv6 service in conjunction with an underlay SLA”. I would propose to change these to “SRv6 service using shortest path in base or a flex-algo topology” and “SRv6 service using SRv6 policy” respectively.

As for fallback, it is really an implementation option and vendors may implement different things based on their customer requirements. I am not sure it should be discussed in this draft.

Regards,
Mustapha.

From: Srihari Sangli <[email-masked]>
Sent: Tuesday, July 20, 2021 10:55 AM
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>; Shraddha Hegde <shraddha=[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Mustapha,

srihari…

Hi Shraddha,

Regards,
Mustapha.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Shraddha Hegde
Sent: Tuesday, July 20, 2021 5:56 AM
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

“

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 20 Jul 2021 17:28:41 +0000

Comments In-Line..

Thanks,
              Jim Uttaro

From: spring <[email-masked]> On Behalf Of Aissaoui, Mustapha (Nokia - CA/Ottawa)
Sent: Tuesday, July 20, 2021 1:14 PM
To: Srihari Sangli <[email-masked]>; Shraddha Hegde <shraddha=[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Srihari,

As for fallback, it is really an implementation option and vendors may implement different things based on their customer requirements. I am not sure it should be discussed in this draft.
[Jim U>] Fallback should be addressed as it needs to be consistent.

Regards,
Mustapha.

From: Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 20, 2021 10:55 AM
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <shraddha=[email-masked]<mailto:shraddha=[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Mustapha,

srihari…

Hi Shraddha,

Regards,
Mustapha.

“

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Shraddha Hegde <[email-masked]>
Date: Wed, 21 Jul 2021 09:16:25 +0000

I agree with Jim that fallback needs to be discussed in the draft .

The current draft mandates the resolvability of the service SID. The fact that when flex-algo is allowed to
Fallback to best effort,  service SID resolvability is not required  because service SID corresponds to flex-algo locator in this case.This is an important aspect that needs to be addressed in the draft.

Rgds
Shraddha

Juniper Business Use Only
From: UTTARO, JAMES <[email-masked]>
Sent: Tuesday, July 20, 2021 10:59 PM
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>; Srihari Sangli <[email-masked]>; Shraddha Hegde <[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Comments In-Line..

Thanks,
              Jim Uttaro

To: Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <shraddha=[email-masked]<mailto:shraddha=[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>

Hi Srihari,

The draft refers to "SRv6 service with best-effort connectivity" and to "SRv6 service in conjunction with an underlay SLA". I would propose to change these to "SRv6 service using shortest path in base or a flex-algo topology" and "SRv6 service using SRv6 policy" respectively.

Regards,
Mustapha.

Mustapha,

I think Shraddha is pointing about the paragraph "When providing best-effort connectivity..." where it specifically talks about fallback to best-effort and if so, perform the resolvability check on the service-SID. Going by what you are saying that its general behavior of SRv6 policy, there is no need to over specify that it SHOULD check for resolvability and need for SRH.

srihari...

Hi Shraddha,

Regards,
Mustapha.

"When providing best-effort connectivity or flex-algo connectivity to the egress PE,

"

"In some cases a service prefix intending to use flex-algo paths may want fallback on

best effort paths when a flex-algo path isn't available. The fallback behavior

resolvability SHOULD NOT be checked on the ingress for this case."

Rgds

Shraddha

Shraddha,

> that authors don't intend to support any form of tunnelling for SRv6

Thx,
R.

>From your vague answer it appears that authors don't intend to support any form of tunnelling for SRv6

Rgds
Shraddha

Shraddha,

Best,
R.

"When providing best-effort connectivity to the egress PE, the ingress
"

It is not possible to support fallback on best effort tunnels if flex-algo SRv6 service SIDs have to be resolved.
It is possible to support fallback to best effort in SRv6 if packets can be tunneled to egress PE  (destination address being PE's best effort END SID and service SID in the SRH)and
then do a service SID lookup on egress, in which case there is no need to resolve the SRv6 service SIDs on the ingress.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

The draft is written so that the next-hop address MAY be covered by the locator, but there are cases in which the next-hop address is not part of the locator prefix, and there are implementations already allowing that, so I don't agree the document should mandate what you are suggesting.

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 21 Jul 2021 21:54:34 +0000

Hi Shraddha,
do you agree this is about switching between shortest path (in base topology or flex-algo topology) and SRv6 policy?

You can describe a fallback strategy but the need to resolve or not the service SID is orthogonal and is only dictated by the use of shortest path forwarding or SRv6 policy.

Mustapha.
Sent from my iPhone

On Jul 21, 2021, at 5:16 AM, Shraddha Hegde <[email-masked]> wrote:

Rgds
Shraddha

Comments In-Line..

Thanks,
              Jim Uttaro

Hi Srihari,

Regards,
Mustapha.

Mustapha,

srihari…

Hi Shraddha,

Regards,
Mustapha.

“

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh