Subject: [bess] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

From: Rajesh M <[email-masked]>
Date: Thu, 15 Jul 2021 11:06:27 +0000

Hi All,

As per this draft, this is how resolution must work.

1)For Non Intent service Route:
if BGP next hop is not reachable return.
Resolve SRv6 Service SID for forwarding.
2)For Intent service Route (IGP Flex-Algo first then BGP CAR then SR Policy):
BGP next hop is not reachable return.
Resolve SRv6 Service SID for forwarding(To find IGP flex algo).if successfully resolves then return.
Resolve BGP next hop for forwarding (in case above is not success).

Using Service SID (overlay),for resolution is definitely not recommended.

Instead in case of srv6, we always resolve on BGP nexthop. This will be in line with BGP legacy.
In case of best effort/flex algo we must mandate user to set corresponding locator as BGP nexthop for srv6 routes.
I think this is a reasonable mandate.

Thanks
Rajesh

Juniper Business Use Only

---

From: Rajesh M <[email-masked]>
Date: Mon, 19 Jul 2021 13:22:14 +0000

Hi Authors,

Please respond.

Thanks
Rajesh

Juniper Business Use Only
From: spring <[email-masked]> On Behalf Of Rajesh M
Sent: Thursday, July 15, 2021 4:36 PM
To: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Shraddha Hegde <[email-masked]>; [email-masked]
Subject: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

[External Email. Be cautious of content]

Hi All,

Thanks
Rajesh

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 19 Jul 2021 13:47:00 +0000

Hi Rajesh,

The draft is written so that the next-hop address MAY be covered by the locator, but there are cases in which the next-hop address is not part of the locator prefix, and there are implementations already allowing that, so I don’t agree the document should mandate what you are suggesting.

Thanks.
Jorge

From: Rajesh M <[email-masked]>
Date: Monday, July 19, 2021 at 3:24 PM
To: Rajesh M <mrajesh=[email-masked]>, Ketan Talaulikar (ketant) <[email-masked]>, [email-masked] <[email-masked]>, Clarence Filsfils (cfilsfil) <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Shraddha Hegde <[email-masked]>, [email-masked] <[email-masked]>, Srihari Sangli <[email-masked]>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)
Hi Authors,

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 19 Jul 2021 15:52:31 +0200

I agree with Jorge..

In fact I find the tone of the comment to be very inappropriate:

*> In case of best effort/flex algo we must mandate user to set
corresponding locator as BGP nexthop for srv6 routes.*

*No we MUST not mandate anything to the user. *

*We MUST provide flexibility to address all deployment cases user may
have. *

*Best,*
*R.*

On Mon, Jul 19, 2021 at 3:47 PM Rabadan, Jorge (Nokia - US/Mountain View) <
[email-masked]> wrote:

> Hi Rajesh,
>
>
>
> The draft is written so that the next-hop address MAY be covered by the
> locator, but there are cases in which the next-hop address is not part of
> the locator prefix, and there are implementations already allowing that, so
> I don’t agree the document should mandate what you are suggesting.
>
>
>
> Thanks.
>
> Jorge
>
>
>
> *From: *Rajesh M <[email-masked]>
> *Date: *Monday, July 19, 2021 at 3:24 PM
> *To: *Rajesh M <mrajesh=[email-masked]>, Ketan Talaulikar
> (ketant) <[email-masked]>, [email-masked] <[email-masked]>,
> Clarence Filsfils (cfilsfil) <[email-masked]>, [email-masked] <
> [email-masked]>, [email-masked] <[email-masked]>,
> Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
> *Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>,
> Shraddha Hegde <[email-masked]>, [email-masked] <[email-masked]>,
> Srihari Sangli <[email-masked]>
> *Subject: *RE: SRv6 BGP based Overlay Services
> (draft-ietf-bess-srv6-services-07)
>
> Hi Authors,
>
>
>
> Please respond.
>
>
>
> Thanks
>
> Rajesh
>
>
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Rajesh M
> *Sent:* Thursday, July 15, 2021 4:36 PM
> *To:* Ketan Talaulikar (ketant) <[email-masked]>; [email-masked];
> Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]; Shraddha Hegde <[email-masked]>;
> [email-masked]
> *Subject:* [spring] SRv6 BGP based Overlay Services
> (draft-ietf-bess-srv6-services-07)
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi All,
>
>
>
> *Using Service SID (overlay),for resolution is definitely not recommended.*
>
>
>
> *Instead in case of srv6, we always resolve on BGP nexthop. This will be
> in line with BGP legacy.*
>
> *In case of best effort/flex algo we must mandate user to set
> corresponding locator as BGP nexthop for srv6 routes.*
>
> *I think this is a reasonable mandate.*
>
>
>
> Thanks
>
> Rajesh
>
>
>

---

From: Rajesh M <[email-masked]>
Date: Mon, 19 Jul 2021 13:57:50 +0000

Hi All,

For best effort service, flex algo - Resolve SRv6 Service SID for forwarding.
For SR-TE, CAR/CT - Resolve BGP next hop for forwarding.

There is no unification here, it's better to unify.
Any other solution is OK.

Thanks
Rajesh

Juniper Business Use Only
From: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
Sent: Monday, July 19, 2021 7:17 PM
To: Rajesh M <[email-masked]>; Rajesh M <mrajesh=[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Shraddha Hegde <[email-masked]>; [email-masked]; Srihari Sangli <[email-masked]>
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

The draft is written so that the next-hop address MAY be covered by the locator, but there are cases in which the next-hop address is not part of the locator prefix, and there are implementations already allowing that, so I don't agree the document should mandate what you are suggesting.

Thanks.
Jorge

From: Rajesh M <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 19, 2021 at 3:24 PM
To: Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>, Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Shraddha Hegde <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)
Hi Authors,

Please respond.

Thanks
Rajesh

Juniper Business Use Only
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rajesh M
Sent: Thursday, July 15, 2021 4:36 PM
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi All,

Thanks
Rajesh

---

From: Gaurav Dawra <[email-masked]>
Date: Mon, 19 Jul 2021 07:00:59 -0700

+1 on Jorge and Robert. I don’t think we should mandate.

Gaurav

> On Jul 19, 2021, at 6:52 AM, Robert Raszuk <[email-masked]> wrote:
> 
> 
> I agree with Jorge.. 
> 
> No we MUST not mandate anything to the user. 
> 
> We MUST provide flexibility to address all deployment cases user may have. 
> 
> Best,
> R.
> 
> 
> 
>> On Mon, Jul 19, 2021 at 3:47 PM Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]> wrote:
>> Hi Rajesh,
>> 
>>  
>>

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 19 Jul 2021 14:04:02 +0000

Rajesh,
Also you can change the service SID for a subset of prefixes using a policy, to apply a flex-algo for example, but you do not want to change the next-hop for each new service SID.

Mustapha.

From: spring <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Monday, July 19, 2021 9:47 AM
To: Rajesh M <[email-masked]>; Rajesh M <mrajesh=[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Srihari Sangli <[email-masked]>; Shraddha Hegde <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 20 Jul 2021 08:33:38 +0200

Shraddha,

> that authors don’t intend to support any form of tunnelling for SRv6

> because it is not optimal. Is that the right read?

Quite the opposite. It is the local operator's choice (not the draft
authors) to decide to fall back to best effort or to drop.

Thx,
R.

On Tue, Jul 20, 2021 at 8:15 AM Shraddha Hegde <[email-masked]> wrote:

> Robert,
>
>
>
> What do you mean by SR? is it SR-MPLS or SRv6.
>
> My question is about draft-ietf-bess-srv6-services and applies only to
> SRv6.
>
>
>
> Let me repeat the question.
>
> Do the authors intend to support the case of fallback from SRv6 flex-algo
> to SRv6 best effort transport for SRv6
>
> Services or not?
>
>
>
> From your vague answer it appears that authors don’t intend to support any
> form of tunnelling for SRv6
>
> because it is not optimal. Is that the right read?
>
>
>
> Rgds
>
> Shraddha
>
>
>
>
>
> *From:* Robert Raszuk <[email-masked]>
> *Sent:* Tuesday, July 20, 2021 11:17 AM
> *To:* Shraddha Hegde <[email-masked]>
> *Cc:* Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>;
> Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>;
> Rajesh M <[email-masked]>; Rajesh M <mrajesh=
> [email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>;
> [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; Srihari Sangli <
> [email-masked]>; [email-masked]
> *Subject:* Re: SRv6 BGP based Overlay Services
> Shraddha,
> In an SR network fallback to best effort will also result in encapsulated
> forwarding using SR. It may not be as optimal service wise as using
> flex-algo, but this is form of tunneling. Hence I don't think your comment
> applies.
>
>
>
> Note that operator may also choose to use IP tunneling for best effort
> forwarding if SR best effort forwarding is not supported or enabled.
>
>
>
> Best,
>
> R.
>
>
>
>
>
>
>
>
>
> On Tue, Jul 20, 2021 at 7:20 AM Shraddha Hegde <[email-masked]>
> wrote:
>
> Hi Authors,
>
>
>
> There is a possibility of a usecase that wants to use flex-algo paths if
> available and if flex-algo paths
>
> Are not available use best effort paths.
>
>
>
> “When providing best-effort connectivity to the egress PE, the ingress
>
>    PE encapsulates the payload in an outer IPv6 header where the
>
>    destination address is the SRv6 Service SID associated with the
>
>    related BGP route update.  Therefore, the ingress PE SHOULD perform
>
>    resolvability check for the SRv6 Service SID before considering the
>
>    received prefix for the BGP best path computation.
>
> “
>
>
>
> The current text says for best effort tunnels Srv6 service SID resolution
> SHOULD be checked and
>
> I am told that (from previous mailing list exchanges) authors intend to
> update the text to make it applicable for flex-algo connectivity  as well.
>
>
>
> It is not possible to support fallback on best effort tunnels if flex-algo
> SRv6 service SIDs have to be resolved.
>
> It is possible to support fallback to best effort in SRv6 if packets can
> be tunneled to egress PE  (destination address being PE’s best effort END
> SID and service SID in the SRH)and
>
> then do a service SID lookup on egress, in which case there is no need to
> resolve the SRv6 service SIDs on the ingress.
>
>
>
> It is not clear whether the authors intend to support these kind of
> tunnelling to egress cases for
>
> Best effort and flex-algo transport. If it not going to be supported, pls
> add text indicating clearly
>
> Tunnelling is not required to be supported and hence Fallback to best
> effort  is also not supported.
>
>
>
> If that is not the intention, Its reasonable to update the text to
> indicate SRv6 service SIDs need not be resolved
>
> If the ingress is tunneling the packet.
>
>
>
> Rgds
>
> Shraddha
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Aissaoui,
> Mustapha (Nokia - CA/Ottawa)
> *Sent:* Monday, July 19, 2021 7:34 PM
> *To:* Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>;
> Rajesh M <[email-masked]>; Rajesh M <mrajesh=
> [email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>;
> [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>;
> [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]; Srihari Sangli <[email-masked]>;
> [email-masked]; Shraddha Hegde <[email-masked]>
> *Subject:* Re: [spring] SRv6 BGP based Overlay Services
> Also you can change the service SID for a subset of prefixes using a
> policy, to apply a flex-algo for example, but you do not want to change the
> next-hop for each new service SID.
>
>
>
> Mustapha.
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Rabadan, Jorge
> (Nokia - US/Mountain View)
> *Sent:* Monday, July 19, 2021 9:47 AM
> *To:* Rajesh M <[email-masked]>; Rajesh M <
> mrajesh=[email-masked]>; Ketan Talaulikar (ketant) <
> [email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <
> [email-masked]>; [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]; Srihari Sangli <[email-masked]>;
> Shraddha Hegde <[email-masked]>; [email-masked]
> *Subject:* Re: [spring] SRv6 BGP based Overlay Services

---

From: Shraddha Hegde <[email-masked]>
Date: Tue, 20 Jul 2021 09:56:13 +0000

Good to know the intention is to support fallback for Srv6.

The way current text is written, it implies service SID is always in the destination address.

And hence service SID should be resolvable. This is not the case when a service SID

Corresponding to flex-algo wants to fallback on best effort services. The destination address cannot carry

Service SID for fallback cases and hence it need not be resolved.

I suggest that the authors add below text in bold to the draft.

"When providing best-effort connectivity or flex-algo connectivity to the egress PE,

the ingress PE encapsulates the payload in an outer IPv6 header where the destination

address is the SRv6 Service SID associated with the related BGP route update.

 Therefore, the ingress PE SHOULD perform resolvability check for the SRv6 Service SID

 before considering the received prefix for the BGP best path computation.

"

"In some cases a service prefix intending to use flex-algo paths may want fallback on

best effort paths when a flex-algo path isn't available. The fallback behavior

SHOULD be governed by local policies.

The destination address SHOULD contain the best-effort locator based END SID

of the egress PE and the SRH SHOULD contain the service SID. Service SID

resolvability SHOULD NOT be checked on the ingress for this case."

Rgds

Shraddha

Juniper Business Use Only
From: Robert Raszuk <[email-masked]>
Sent: Tuesday, July 20, 2021 12:04 PM
To: Shraddha Hegde <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Shraddha,

> that authors don't intend to support any form of tunnelling for SRv6

Quite the opposite. It is the local operator's choice (not the draft authors) to decide to fall back to best effort or to drop.

Thx,
R.

On Tue, Jul 20, 2021 at 8:15 AM Shraddha Hegde <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

What do you mean by SR? is it SR-MPLS or SRv6.
My question is about draft-ietf-bess-srv6-services and applies only to SRv6.

Let me repeat the question.
Do the authors intend to support the case of fallback from SRv6 flex-algo to SRv6 best effort transport for SRv6
Services or not?

>From your vague answer it appears that authors don't intend to support any form of tunnelling for SRv6

Rgds
Shraddha

Juniper Business Use Only
From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 20, 2021 11:17 AM
To: Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Cc: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Shraddha,

In an SR network fallback to best effort will also result in encapsulated forwarding using SR. It may not be as optimal service wise as using flex-algo, but this is form of tunneling. Hence I don't think your comment applies.

Note that operator may also choose to use IP tunneling for best effort forwarding if SR best effort forwarding is not supported or enabled.

Best,
R.

On Tue, Jul 20, 2021 at 7:20 AM Shraddha Hegde <[email-masked]<mailto:[email-masked]>> wrote:
Hi Authors,

There is a possibility of a usecase that wants to use flex-algo paths if available and if flex-algo paths
Are not available use best effort paths.

"When providing best-effort connectivity to the egress PE, the ingress
"

The current text says for best effort tunnels Srv6 service SID resolution SHOULD be checked and
I am told that (from previous mailing list exchanges) authors intend to update the text to make it applicable for flex-algo connectivity  as well.

It is not possible to support fallback on best effort tunnels if flex-algo SRv6 service SIDs have to be resolved.
It is possible to support fallback to best effort in SRv6 if packets can be tunneled to egress PE  (destination address being PE's best effort END SID and service SID in the SRH)and
then do a service SID lookup on egress, in which case there is no need to resolve the SRv6 service SIDs on the ingress.

It is not clear whether the authors intend to support these kind of tunnelling to egress cases for
Best effort and flex-algo transport. If it not going to be supported, pls add text indicating clearly
Tunnelling is not required to be supported and hence Fallback to best effort  is also not supported.

If that is not the intention, Its reasonable to update the text to indicate SRv6 service SIDs need not be resolved
If the ingress is tunneling the packet.

Rgds
Shraddha

Juniper Business Use Only
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Aissaoui, Mustapha (Nokia - CA/Ottawa)
Sent: Monday, July 19, 2021 7:34 PM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Rajesh,

Mustapha.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Monday, July 19, 2021 9:47 AM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 20 Jul 2021 10:20:14 +0000

Comments In-Line..

Thanks,
              Jim Uttaro

From: spring <[email-masked]> On Behalf Of Shraddha Hegde
Sent: Tuesday, July 20, 2021 5:56 AM
To: Robert Raszuk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

"

[Jim U>] It would be helpful to provide an example of local policies and how would/should said local policies be applied across a heterogeneous network.

Rgds

Shraddha

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 20 Jul 2021 12:27:30 +0200

Jim,

The "policy" I had in mind was a simple cfg switch "fallback global" for
any SRv6 service originally set to say run over different IGP topology. Or
perhaps if more then two options are available, list the chain of
forwarding tables/topologies to be used as transport for a given SRv6
service.

Implementation may get even smarter and allow operator to set performance
based triggers to select such forwarding topologies from a flat pool.

If Shraddha has the same in mind not sure there is much to elaborate on
here :)

Best,
R.

On Tue, Jul 20, 2021 at 12:20 PM UTTARO, JAMES <[email-masked]> wrote:

> *Comments In-Line..*
>
>
>
> *Thanks,*
>
> *              Jim Uttaro*
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Shraddha Hegde
> *Sent:* Tuesday, July 20, 2021 5:56 AM
> *To:* Robert Raszuk <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> “When providing best-effort connectivity *or flex-algo connectivity* to the egress PE,
>
> “*In some cases a service prefix intending to use flex-algo paths may want fallback on*
>
> *best effort paths when a flex-algo path isn’t available. The fallback behavior *
>
> *SHOULD be governed by local policies.   *
>
> *[Jim U>] It would be helpful to provide an example of local policies and how would/should said local policies be applied across a heterogeneous network.*
>
> *The destination address SHOULD contain the best-effort locator based END SID *
>
> *of the egress PE and the SRH SHOULD contain the service SID. Service SID *
>
> *resolvability SHOULD NOT be checked on the ingress for this case*.”
>
>
>
>
>
> Rgds
>
> Shraddha
>
>
>
>
>
> *Sent:* Tuesday, July 20, 2021 12:04 PM
> *Cc:* [email-masked]; [email-masked]

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 20 Jul 2021 13:53:37 +0000

Hi Shraddha,
An implementation can allow any fallback strategy, including multiple levels of fallback, but the backup path you are describing is simply the general behavior of a SRv6 policy. The End SID is part of the SRv6 policy segment list and is the top SID. So, the service SID will indeed be pushed into a SRH and the End SID is looked up by the ingress PE to forward the packet. It does not matter if the End SID is from base topology of from a flex-algo topology.

Regards,
Mustapha.

"

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 22 Jul 2021 07:48:43 +0000

Resending with individual email addressed trimmed

From: Ketan Talaulikar (ketant)
Sent: 22 July 2021 13:13
To: Rajesh M <[email-masked]>; Rajesh M <mrajesh=[email-masked]>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Shraddha Hegde <[email-masked]>; [email-masked]; Srihari Sangli <[email-masked]>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

My apologies for the delay in my response. However, some of my co-authors and other WG members have already clarified this point. Let me try to summarize.

The draft covers two SRv6 based mechanisms for the transport of services between SRv6 PEs. (1) using SR Policy based steering (i.e. for service routes with Color Extended Communities) using the H.encap construct along with a list of SRv6 segments  and the other (2) using H.encap with just the SRv6 Service SID in the IPv6 DA.

As mentioned in the draft, it is required to verify the reachability of the SRv6 Service SID before the mechanism (2) can be used. This is an explicit clarification for verification of reachability. In an MPLS-VPN scenario, if the egress PE NH's IP route is reachable at the ingress PE but without an MPLS label, such a path cannot be used. This is semantically similar.

The mechanism (1) is different since the routing to the egress PE is via SR Policy and hence the requirement for verification of reachability of the SRv6 Service SID is not there.

There is no mandate for the setting of the NH since that is left to deployment design.

I hope this helps in addition to the various clarifications already provided by others.

Thanks,
Ketan

From: Rajesh M <[email-masked]<mailto:[email-masked]>>
Sent: 22 July 2021 12:09
To: Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Could Authors respond to this ?

Juniper Business Use Only
From: Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>
Sent: Monday, July 19, 2021 7:28 PM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi All,

Thanks
Rajesh

Juniper Business Use Only
From: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 19, 2021 7:17 PM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>
Subject: Re: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 22 Jul 2021 08:14:07 +0000

Hi Shraddha,

As clarified a short while ago on the same thread, the draft talks about two SRv6-based transport mechanisms. I believe your comments are not related to the SR Policy based steering mechanisms. We already have mechanisms defined for fallback in that case.

Since the draft is covering SRv6-based mechanisms, we have obviously no text in there for other forms of tunnelling between the PEs.

As has been clarified by others, there can be many different forms of reachability or tunnels setup. In the end though, it would be an implementation specific mechanism or a way to resolve the SRv6 Service SID over such a tunnel. E.g. a backup static route pointing over an IP-in-IP tunnel? Or set color extended community locally and steer over an SR Policy that uses best-effort. Or other such implementation-specific options via other forms of route-policy.

Please check inline below.

Sent: 20 July 2021 15:26

"

[KT] We have an edit change in the buffer on this text that we will post it once the submission window opens over the weekend. How BGP resolves is implementation specific and a local policy. E.g. it could be via a backup static route as indicated above or via some other mechanisms mentioned above. Also note that the usage is a SHOULD to allow implementation-specific mechanisms.

[KT] Why should the fallback be only over best-effort locator? Why can't it be over another Flex-Algo, or some IP-IP tunnel or even perhaps an MPLS path. Why just this mechanism and that too is suggested to be mandated as a SHOULD? All these techniques and mechanisms would be implementation and more importantly deployment specific. Therefore, I do not agree with this text proposal.

Thanks,

Ketan

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 22 Jul 2021 17:04:49 +0000

Ketan,

I started off with one fallback scenario as to the kind of detail I am expecting in the draft.

Ofcourse all of the other fallback scenarios you mentioned need to be captured in detail too.

Implementations may choose what fallback mechanisms they support and which ones they do not

Support based on the software/hardware capabilities.

This fallback mechanism needs to inter-op between different vendors. If ingress is one vendor

And decides to send traffic with certain encapsulation that is not supported on the egress, packet will drop.

For example : you are talking about fallback on MPLS path. How is the packet going to be encapsulated in this scenario? Where would be the SRv6 service SID placed? If another vendor isn't aware of this and doesn't implement handling these encapsulations, it's not going to work.

I strongly insist fallback scenarios and details need to be covered in this document.

If its not possible to cover this level of detail, then I am ok to update the draft saying fallback is out of scope

For this document.

Rgds
Shraddha

Juniper Business Use Only
From: Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: Thursday, July 22, 2021 1:44 PM
To: Shraddha Hegde <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Shraddha,

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Shraddha Hegde
Sent: 20 July 2021 15:26
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

"

Thanks,

Ketan

Rgds

Shraddha

Shraddha,

Thx,
R.

Rgds
Shraddha

Shraddha,

Best,
R.

Rgds
Shraddha

Rajesh,

Mustapha.

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 23 Jul 2021 15:08:26 +0000

< trimming list to mostly mailers >

Hi Mustapha,

I agree.

Also after seeing Shraddha's latest email, the coverage and details for the fallback mechanisms that she seems to be looking for is quite vast and better tackled in a separate document since this one has completed its WGLC. Some of those concepts are applicable for MPLS as well and not SRv6 specific.

We (authors) will work on some text proposal and get back to the WG next week.

Thanks,
Ketan

From: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>
Sent: 23 July 2021 19:20
To: Ketan Talaulikar (ketant) <[email-masked]>; Rajesh M <[email-masked]>; Rajesh M <[email-masked]>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>; [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; Srihari Sangli <[email-masked]>; Shraddha Hegde <[email-masked]>; [email-masked]
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Ketan,
I believe it will be worth expanding the text in draft-ietf-bess-srv6-services to describe the two types of transport more consistently and along the lines of what you wrote below. Also, I would propose that we move away from terminology like best-effort service and instead just mention shortest path forwarding in base topology or in flex-algo topology.

Mustapha.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Ketan Talaulikar (ketant)
Sent: Thursday, July 22, 2021 3:43 AM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <mrajesh=[email-masked]<mailto:mrajesh=[email-masked]>>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Rajesh,

Thanks,
Ketan

Hi All,

Thanks
Rajesh

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 23 Jul 2021 16:40:03 +0000

That is great. Thank you.

Mustapha.

From: Ketan Talaulikar (ketant) <[email-masked]>
Sent: Friday, July 23, 2021 11:08 AM
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>
Cc: [email-masked]; Shraddha Hegde <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Mustapha,

I agree.

Thanks,
Ketan

From: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Sent: 23 July 2021 19:20
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rajesh M <[email-masked]<mailto:[email-masked]>>; Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Clarence Filsfils (cfilsfil) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Srihari Sangli <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi Ketan,

Mustapha.

Hi Rajesh,

Thanks,
Ketan

Hi All,

Thanks
Rajesh

Hi Rajesh,

Thanks.
Jorge

Please respond.

Thanks
Rajesh

Hi All,

Thanks
Rajesh

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 24 Jul 2021 02:56:37 -0400

Hi Shraddha

I agree the fallback mechanisms are important to operators but as there are
many complex scenarios related to fallback and some of which include SRv6
to SR-MPLS interworking, I agree that this is important and as such can be
captured in a separate document that defines all the permutations in detail.

As this SRv6 BGP overlay services specification is critical for operators
as it’s in WGLC I think it should proceed to publication.

Kind Regards

Gyan

On Fri, Jul 23, 2021 at 12:40 PM Aissaoui, Mustapha (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> *From:* Ketan Talaulikar (ketant) <[email-masked]>
> *Sent:* Friday, July 23, 2021 11:08 AM
> *To:* Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>
> *Cc:* [email-masked]; Shraddha Hegde <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* RE: SRv6 BGP based Overlay Services
> Also after seeing Shraddha’s latest email, the coverage and details for
> the fallback mechanisms that she seems to be looking for is quite vast and
> better tackled in a separate document since this one has completed its
> WGLC. Some of those concepts are applicable for MPLS as well and not SRv6
> specific.
>
>
>
> *From:* Aissaoui, Mustapha (Nokia - CA/Ottawa) <
> [email-masked]>
> *Sent:* 23 July 2021 19:20
> *To:* Ketan Talaulikar (ketant) <[email-masked]>; Rajesh M <
> [email-masked]>; Rajesh M <[email-masked]>; Rabadan, Jorge
> (Nokia - US/Mountain View) <[email-masked]>;
> *Subject:* RE: SRv6 BGP based Overlay Services
> I believe it will be worth expanding the text in
> draft-ietf-bess-srv6-services to describe the two types of transport more
> consistently and along the lines of what you wrote below. Also, I would
> propose that we move away from terminology like best-effort service and
> instead just mention shortest path forwarding in base topology or in
> flex-algo topology.
>
>
>
> Mustapha.
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Ketan Talaulikar
> (ketant)
> *Sent:* Thursday, July 22, 2021 3:43 AM
> mrajesh=[email-masked]>; Rabadan, Jorge (Nokia -
> US/Mountain View) <[email-masked]>; [email-masked];
> [email-masked]
> My apologies for the delay in my response. However, some of my co-authors
> and other WG members have already clarified this point. Let me try to
> summarize.
>
>
>
> The draft covers two SRv6 based mechanisms for the transport of services
> between SRv6 PEs. (1) using SR Policy based steering (i.e. for service
> routes with Color Extended Communities) using the H.encap construct along
> with a list of SRv6 segments  and the other (2) using H.encap with just the
> SRv6 Service SID in the IPv6 DA.
>
>
>
> As mentioned in the draft, it is required to verify the reachability of
> the SRv6 Service SID before the mechanism (2) can be used. This is an
> explicit clarification for verification of reachability. In an MPLS-VPN
> scenario, if the egress PE NH’s IP route is reachable at the ingress PE but
> without an MPLS label, such a path cannot be used. This is semantically
> similar.
>
>
>
> The mechanism (1) is different since the routing to the egress PE is via
> SR Policy and hence the requirement for verification of reachability of the
> SRv6 Service SID is not there.
>
>
>
> *From:* Rajesh M <[email-masked]>
> *Sent:* 22 July 2021 12:09
> *To:* Rajesh M <mrajesh=[email-masked]>; Rabadan, Jorge
> (Nokia - US/Mountain View) <[email-masked]>; Ketan Talaulikar
> (ketant) <[email-masked]>; [email-masked]; Clarence Filsfils
> (cfilsfil) <[email-masked]>; [email-masked];
> [email-masked]
> [email-masked]; Srihari Sangli <[email-masked]>
> *Subject:* RE: SRv6 BGP based Overlay Services
> *From:* Rajesh M <mrajesh=[email-masked]>
> *Sent:* Monday, July 19, 2021 7:28 PM
> Rajesh M <[email-masked]>; Ketan Talaulikar (ketant) <
> [email-masked]; Srihari Sangli <[email-masked]>
> *Subject:* RE: SRv6 BGP based Overlay Services
> For best effort service, flex algo – Resolve SRv6 Service SID for
> forwarding.
>
> There is no unification here, it’s better to unify.
>
> *From:* Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
>
> *Sent:* Monday, July 19, 2021 7:17 PM
> [email-masked]; Srihari Sangli <[email-masked]>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*