Subject: [bfcpbis] reminder to review draft-ietf-bfcpbis-bfcp-websocket-01

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 29 Aug 2014 16:09:05 +0000

BFCP¹ers,

We need more reviews of the websocket draft before progressing it further.
https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-bfcp-websocket/

Several people stated interest in the draft and the need for it at the
BFCPBIS session at IETF 89. The authors have addressed all comments to
date. Please review the draft and share your comments. If there are any
issues, let¹s surface those issues now. If you think the draft is in great
shape and is ready for WGLC, please state that as well.
 
Cheers,
Charles

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 30 Aug 2014 08:57:26 +0000

Hi,

Below are my comments. I appologise for not providing them earlier, as promissed. They are mostly editorial, but would still require some work if accepted.

---------------

Section 1 (Introduction):
------------------------------

Q1_1: I don't understand the need for the last paragraph, talking about the draft not preventing the usage of other transport mechanisms. Why does the draft need to say that?. IF that needs to be said, it should be said in the base BFCP spec.

Section 3:
------------

Q3_1: Why is this section needed? The draft is not a teach-yourself-websocket document, is it? :)

           In my opinion the draft should reference the WebSocket RFC for general information about WebSocket, and the draft then describes the BFCP specifics - ie what is described in section 4.

           Otherwise, if some details of WebSocket change in the future, you may have to update this RFC also - even if the change does not affect the BFCP usage of WebSocket.

Section 4:
------------

Q4_1: I'd suggest to change "through" to "over", "using", or something similar.

Section 5:
------------

Q5_1: I'd suggest to change the section name to "Transport reliability"

Section 6:
------------

Q6_1: I'd suggest to change the section name to "SDP Considerations", with separate subsections for the new transport value, the new SDP attribute etc.

Q6_2: Is the new SDP ws-uri attribute BFCP specific? If not, should it be in a separate draft?

Q6_3: I think it would be good to have a reference to a document which talks more about the URI matching requirement.

           Something like: "As defined in section YYYY of RFC XXXX, when using Secure Websockets the CNAME of the SSL certificate must match the WebSocket connection URI host..."

Q6_4: As you define a new SDP attribute, you should have a "SDP Offer/Answer Proceudures" section.

Thanks!

Regards,

Christer