Subject: [bfcpbis] BFCPbis: UDP- and TCP candidates and proto value

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Sep 2016 05:51:37 +0000

Hi,

An issue came up during the review of draft-sctp-sdp, which I believe also applies to BFCPbis.

Q1:

The document defines TCP/TLS/BFCP and UDP/TLS/BFCP. If ICE is used, and there can be both TCP- and UDP-based candidates, which value shall be used? Also, if there is a
candidate switch from TCP to UDP (or vice verse), is an updated offer required? Is it even possible to switch between candidates, since in the case of BCFP one uses DTLS and the other TLS (for RTP and SCTP DTLS is always used – also for TCP).
The same applies to UDP/BFCP and TCP/BFCP.

In the following pull request you can see how we suggest to address it in draft-sctp-sdp (look at the changes in the ICE Considerations sections):

https://github.com/cdh4u/draft-sctp-sdp/pull/2

Q2:

In case of TCP/TLS/BFCP and UDP/TLS/BFCP, if you have both UDP- and TCP-based candidates, it also means you are going to have both a TLS connection and an DTLS association. If the TLS roles (client/server) change etc, it will affect both the TLS connection and the DTLS association. I think this needs to be described in the draft, as it is not covered e.g. by referencing draft-dtls-sdp.

Regards,

Christer

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 28 Sep 2016 17:30:01 +0000

Christer,

Thanks for point out this issue and sharing the proposal for addressing it within draft-sctp-sdp. I’d like to hear from folks who have implementation experience using ICE for determining BFCP ports as to what they are doing. If you are not using ICE, it would good to understand why that is the case as well.

Cheers,
Charles

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 26, 2016 at 10:51 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] BFCPbis: UDP- and TCP candidates and proto value

Hi,

Q1:

Q2:

Regards,

Christer