Subject: Re: [bfcpbis] FW: Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 1 Dec 2016 19:45:21 +0000

For BFCP, requiring support for transport switch on-the-fly before nomination seems like overkill.

Cheers,
Charles

From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Saturday, November 19, 2016 at 1:30 AM
To: "[email-masked]" <[email-masked]>
Subject: [bfcpbis] FW: Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Forwarding to bfcpbis, as this is very much related to BFCP. If you have comments, please bring those to the ICE WG list, so we get everything in one place :)

Regards,

Christer

From: Ice [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 19 November 2016 11:27
To: [email-masked]
Subject: [Ice] Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Hi,

One potential issue that came to my mind while reading the SDP m- line thread.

Previously, before removal of aggressive nomination, while and endpoint might support both UDP and TCP for a protocol, it didn’t have to be able to simultaneously use the protocol with both UDP and TCP, and switching between. Because, until nomination was done, no protocol data was sent. And, once nomination had been done, endpoints used the protocol with the selected transport.

Now, with the allowed-to-send-media-before-nomination rules, protocols basically have to support switch of transport (from UDP to TCP, and vice versa), until the nomination takes place.

Now, even people always say that a good designed protocol should be transport-independent, isn’t *mandating* transport switching on-the-fly (before nomination takes place) by all protocols supporting ICE and multiple transports a bad thing to do?

Perhaps the ICE considerations of each protocol (RTP, BFCP etc) should indicate whether transport switching is supported, and whether there are protocol specific procedures associated with that. I guess a protocol could also specify that data shouldn’t be sent in the first place before nomination has been done, if there are good reasons for that.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 1 Dec 2016 19:57:38 +0000

Hi,

Assuming BFCP-for-TCP works with ICE to begin with (Roman had some doubts), then I think you need to write down those restrictions.

Either no switch, or no offering of both TCP and UDP to begin with.

And, IF you allow offering both TCP and UDP, I think you should define a MIT transport (UDP, I assume). Note that the MIT would only apply to cases when ICE is used. Legacy TCP implementations (that don’t support ICE) would not become non-compliant.

Regards,

Christer

From: Charles Eckel (eckelcu) [mailto:[email-masked]]
Sent: 01 December 2016 21:45
To: Christer Holmberg <[email-masked]>; [email-masked]
Subject: Re: [bfcpbis] FW: Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Cheers,
Charles

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Saturday, November 19, 2016 at 1:30 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] FW: Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Regards,

Christer

From: Ice [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 19 November 2016 11:27
To: [email-masked]<mailto:[email-masked]>
Subject: [Ice] Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Hi,

Regards,

Christer

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 2 Dec 2016 23:47:26 +0000

Works for me.

Cheers,
Charles

From: Christer Holmberg <[email-masked]>
Date: Thursday, December 1, 2016 at 11:57 AM
To: Charles Eckel <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [bfcpbis] FW: Do we want to mandate all protocols supporting ICE and multiple transports to support transport switch on-the-fly before nomination?

Hi,

Regards,

Christer

Cheers,
Charles

Regards,

Christer

Hi,

Regards,

Christer