Subject: Re: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 5 Oct 2017 21:09:13 +0000

Hi Tom,

Any updates to share on this draft?

Thanks,
Charles

From: Charles Eckel <[email-masked]>
Date: Monday, September 25, 2017 at 1:30 PM
To: Tom Kristensen <[email-masked]>, Roman Shpount <[email-masked]>
Cc: Tom Kristensen <[email-masked]>, Alan Ford <[email-masked]>, "[email-masked]" <[email-masked]>, Gonzalo Camarillo <[email-masked]>, Christer Holmberg <[email-masked]>
Subject: Re: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

Please see inline.

From: Tom Kristensen <[email-masked]>
Date: Monday, September 25, 2017 at 11:28 AM
To: Roman Shpount <[email-masked]>
Cc: Charles Eckel <[email-masked]>, Tom Kristensen <[email-masked]>, Alan Ford <[email-masked]>, "[email-masked]" <[email-masked]>, Gonzalo Camarillo <[email-masked]>, Christer Holmberg <[email-masked]>
Subject: Re: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

Answers inline.

On 19 July 2017 at 01:37, Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

I have reviewed the document and have the following comments:

Section 8 BFCP Connection Management:

It specifies that BFCP can use TCP or UDP as underlying transport. It does not specify what happens when ICE, TCP/DTLS/BFCP, TCP/TLS/BFCP, or UDP/TLS/BFCP are used. I suggest to explicitly specify that ICE, TCP/DTLS/BFCP, and UDP/TLS/BFCP follow the same procedures for connection management as UDP/BFCP. TCP/TLS/BFCP follows the same procedures as TCP/BFCP

TK: :) Yes, stating just that for a clear definition of behaviour to use and expect.

Section 9 Authentication:

Not sure why we are talking about SIP here. I think we should restate

When SDP is used to perform an offer/answer exchange, the initial mutual authentication takes place at the SIP level. Additionally, SIP uses S/MIME [6] to provide an integrity-protected channel with optional confidentiality for the offer/answer exchange.

as

When SDP is used to perform an offer/answer exchange, the initial mutual authentication SHOULD take place at the signaling level. Additionally, signaling can use S/MIME [6] to provide an integrity-protected channel with optional confidentiality for the offer/answer exchange.

 TK: :) Yes, we may very well generalize from stating SIP to use the term signaling (of some sort).

This section specifies that "This implies that unless a 'fingerprint' attribute is included in the session description, the certificate provided at the TLS-/DTLS-level MUST either be directly signed by one of the other party's trust anchors or be validated using a certification path that terminates at one of the other party's trust anchors [5]". I thought "fingerprint" attribute are required and certificate signature by trust anchor is irrelevant.

Not sure what "When using UDP, the procedure above was preferred since it adheres to [16] as used for DTLS-SRTP" means, especially since [16} is not specific to SRTP-DTLS, but specifies generic rules for all DTLS based protocols. The whole logic is circular since it proposes to follow procedures from [16] since they are compliant with procedures from [16].

TK: I'm currently trying to remember the background for this text, it was altered and added in one of the many rounds earlier on. I agree that this is not clear and a bit confusing.
[cue] After consulting the archives, it seems this was introduced in version -04 of the draft as a result of an issue raised by Gonzalo.
https://mailarchive.ietf.org/arch/msg/bfcpbis/emDvYolUyI4VjEiVuBqNoWMgz40/?qid=0e356a8b7a948f87669c6d992f6214db

Cheers,
Charles
Section 10. ICE Considerations

Please synchronize text with text in https://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-26#section-12.2 . This section was updated during WGLC for draft-ietf-mmusic-sctp-sdp, so it would make sense to synchronize those changes here. Let me know if you need help with this.

TK: I'll draft a sketch of this.

Regards,

_____________
Roman Shpount

On Mon, Jul 17, 2017 at 4:10 AM, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:
(As WG co-chair)

This is a reminder that WGLC ends tomorrow. I realize the time to review overlaps with IETF prep and meeting times. If you require more time to review the draft, please let me know. Otherwise, please share your review comments by the end of tomorrow.

Thanks,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Charles Eckel <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 5, 2017 at 5:59 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

    (As WG co-chair)

    This is to announce an additional working group last call for draft-ietf-bfcpbis-rfc4583bis, "Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams".
    http://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/

    This is intended as a Standards Track RFC, obsoleting RFC 4583.
    Please respond to the list by July 18th (i.e. 2 weeks) with any comments.

    We had a working group last call previous, but a significant amount of time and some substantial changes and additions have occurred to justify another review of the draft in its entirely. It is helpful to attempt to categorize your comment (e.g. technical issue vs. editorial), and also to provide any replacement text you feel is necessary.
    If you review the document and have no comments, please tell the chairs that you have reviewed it. This is always useful information in assessing the degree of WG review and consensus behind the document.
    Note, we have not scheduled a working group session for IETF 99 in Prague. This WGLC will close during IETF 99. If helpful, we can arrange a side meeting to discuss any significant issues, or with any luck, gather at a bar to celebrate the draft being ready to advance to the next step toward RFC.

    Cheers,
    Charles

    _______________________________________________
    bfcpbis mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bfcpbis

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

--
# http://folk.uio.no/tomkri/ | +47 9516 1107 (m)
## http://facebook.com/tomkri/ | xmpp:[email-masked]<mailto:[email-masked]>
### "Å leve er å ta stilling. Jeg hater likegyldige mennesker.", A. Gramsci

---

From: "Tom Kristensen (tomkrist)" <[email-masked]>
Date: Thu, 12 Oct 2017 06:42:25 +0000

​Friday, i.e. tomorrow it will be hacked into the XML and presented, in addition to some discussion points/clarification needs till then.

-- Tom

________________________________
Fra: Charles Eckel (eckelcu)
Sendt: 5. oktober 2017 23:09
Til: Tom Kristensen; Roman Shpount
Kopi: Tom Kristensen (tomkrist); Alan Ford; [email-masked]; Gonzalo Camarillo; Christer Holmberg
Emne: Re: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

Hi Tom,

Thanks,
Charles

Please see inline.

Answers inline.

as

Cheers,
Charles

Regards,

_____________
Roman Shpount

Thanks,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Charles Eckel <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 5, 2017 at 5:59 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

    (As WG co-chair)

    Cheers,
    Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 17 Oct 2017 15:31:11 +0000

Hi Tom,

I was bored this weekend without any interesting drafts to read. Can you post or otherwise share it this week?
It would be ideal to have the draft out and work though any issues before people get wrapped up with IETF 100 deadlines and prep.

Cheers,
Charles

From: Tom Kristensen <[email-masked]>
Date: Wednesday, October 11, 2017 at 11:42 PM
To: Charles Eckel <[email-masked]>, Tom Kristensen <[email-masked]>, Roman Shpount <[email-masked]>
Cc: Alan Ford <[email-masked]>, "[email-masked]" <[email-masked]>, Gonzalo Camarillo <[email-masked]>, Christer Holmberg <[email-masked]>
Subject: SV: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

-- Tom

Hi Tom,

Thanks,
Charles

Please see inline.

Answers inline.

as

Cheers,
Charles

Regards,

_____________
Roman Shpount

Thanks,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Charles Eckel <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 5, 2017 at 5:59 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

    (As WG co-chair)

    Cheers,
    Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 26 Oct 2017 06:36:28 +0000

Hi Tom,

The deadline for draft submission before IETF 100 is Monday, Oct 30. Please ask any clarifying question on the list and post the corresponding update to the draft prior to this deadline. If there is anything you need from me or anyone else in the working group, let us know asap.

Cheers,
Charles

From: bfcpbis <[email-masked]> on behalf of Charles Eckel <[email-masked]>
Date: Tuesday, October 17, 2017 at 5:31 PM
To: Tom Kristensen <[email-masked]>, Tom Kristensen <[email-masked]>, Roman Shpount <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Christer Holmberg <[email-masked]>, Gonzalo Camarillo <[email-masked]>, Alan Ford <[email-masked]>
Subject: Re: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

Hi Tom,

Cheers,
Charles

-- Tom

Hi Tom,

Thanks,
Charles

Please see inline.

Answers inline.

as

Cheers,
Charles

Regards,

_____________
Roman Shpount

Thanks,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Charles Eckel <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 5, 2017 at 5:59 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] WGLC for draft-ietf-bfcpbis-rfc4583bis

    (As WG co-chair)

    Cheers,
    Charles