Subject: Re: [bfcpbis] 4583bis: Fixes and clarification regarding SDP attributes in offers and answers

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sun, 25 Mar 2018 22:55:05 +0000

As an individual, these look good as well.

Cheers,
Charles

From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Saturday, March 24, 2018 at 2:42 PM
To: "[email-masked]" <[email-masked]>
Subject: [bfcpbis] 4583bis: Fixes and clarification regarding SDP attributes in offers and answers

Hi,

I noted that an importance part had been lost when I re-structured the draft.

In the offer/answer section, most attributes are included in offer and answers only if the offerer/answerer is acting as floor control server.

I have created a pull request that fixes that.

Now, when doing the fix, I noted another thing that needs clarification:

The procedures say that an offerer includes a set of attributes if it is acting as floor control server. However, if the offerer includes a ‘floorctrl’ attribute with a ‘c-s’ attribute value in the offer, it does not know whether it will be acting as floor control server – that will be determined once the answer arrives.

So, I have added a note clarifying that an offerer includes the attributes also in case of ‘c-s’, but that the attribute values will only be used if the offerer becomes floor control server (or both floor control server and floor control client).

        “NOTE: If the offerer includes an SDP 'floorctrl' attribute with an 'c-s' attribute value, attribute values above will only be used if it is determined
          that the offerer will act as floor control server. If it is determined that the offerer will act as both floor
        control server and floor control client, the attribute values will be used for the BFCP-controlled media streams where the offerer acts as floor
        control server.”

https://github.com/cdh4u/draft-bfcp-4583bis/pull/6

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 26 Mar 2018 07:08:43 +0000

Pull request merged, a couple of editorial nits fixed, and a new version (-21) submitted.

Regards,

Christer

From: Charles Eckel <[email-masked]<mailto:[email-masked]>>
Date: Monday 26 March 2018 at 01:55
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] 4583bis: Fixes and clarification regarding SDP attributes in offers and answers

Cheers,
Charles

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Saturday, March 24, 2018 at 2:42 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] 4583bis: Fixes and clarification regarding SDP attributes in offers and answers

Hi,

Regards,

Christer