Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 27 Mar 2018 03:43:27 +0000

(as an individual)

Hi Christer,

The offer/answer language used for confid, userid, and floorid, was used for bfcpver as well. I do not see any harm in a floor control client including a bfcpver attribute in an SDP offer or answer, but the draft is currently silent on this.
If I had it to do over, I would probably opt for being explicit that the bfcpver attribute is required in all offers and answers, but I do not think we can make that change now. The example is okay as is. It would also be fine to remove the bfcpver attribute from the answer in which he answerer is a client.
Alternatively, I suppose we could as that the bfcpver is optional (i.e. MAY include) when acting as a floor control client. Thoughts?

Charles

From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Monday, March 26, 2018 at 12:14 AM
To: "[email-masked]" <[email-masked]>
Subject: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi,

I would like to clarify the usage of the SDP ‘bfcpver' attribute.

According to the procedures, the attribute is only inserted by the floor control server. I double checked this in older versions of 4583bis. However, in the examples of older versions the attribute is included in an SDP answer, even if the answerer indicates that it will be floor control client.

So, what is the correct way?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 27 Mar 2018 05:07:58 +0000

Hi,

There is a way to determine a default value of the attribute is not present, so that is not a problem.

The question is whether the floor control server should care about a value sent (either explicit or implicit default) by the floor control client or not, or whether the only one sending a valid value is the floor control server.

I am fine either way, but if both the client and server send it we will need additional procedures. So, it would probably be easiest to keep the text saying that only the server sends it.

Regards,

Christer

Sent from my iPhone

On 27 Mar 2018, at 6.43, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:

(as an individual)

Hi Christer,

Charles

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 26, 2018 at 12:14 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi,

Regards,

Christer