Subject: Re: [bfcpbis] Draft new version: draft-ietf-bfcpbis-rfc4583bis-19

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 22 Mar 2018 17:06:51 +0000

As chair,

I’d like to thank Christer for jumping in, pulling all the changes together, and posting this updated version of the draft.
Now it is time for the rest of us to do our part. Please review the draft promptly and respond to the list stating:

1) that you reviewed the draft
2) if it covers all your comments since the previous version of the draft
3) if there is anything else that need to be addresses prior to proto write-up

I realize that verifying comments made months ago have been addressed appropriately can be painful, but by doing this now we can capitalize on the momentum Christer gave us and finally get this draft done.

Thanks,
Charles

From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Thursday, March 22, 2018 at 4:14 PM
To: "[email-masked]" <[email-masked]>
Subject: [bfcpbis] Draft new version: draft-ietf-bfcpbis-rfc4583bis-19

Hi,

I have submitted a new version (-19) of rfc4593bis.

The changes are based on my previous comments, and the pull requests that were submitted in recent days.

Regards,

Christer (new co-editor)

---

From: Alan Ford <[email-masked]>
Date: Fri, 23 Mar 2018 10:25:17 +0000

Hi Christer, all,

Great stuff! The new splits and the rewording really make the document much easier to follow.

A few concerns/comments:

1) Section 5 now features the word “stream” standalone in three places:

   The
   attribute is used to determine the floor control role for a given
   stream ( represented by an SDP media description).
…
   An endpoint includes the attribute to indicate the role(s) it would
   be willing to perform for the stream associated with the attribute:
…
   Endpoints compliant with [16 <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-19#ref-16>] might not include the 'floorctrl'
   attribute in offers and answerer.  For a given stream, if the
   'floorctrl' attribute is not present the offerer will act as floor
   control client and the answerer will act as floor control server.

For clarity’s sake, can you make these three say “BFCP stream”, to ensure it’s not causing confusion with associated media streams.

Section 8 also suffers from two new instances of this; all other instances of “stream” that I can find are refined appropriately.

2) Going back to my concern over:

   floor-id-attribute = "a=floorid:" token [" mstrm:" token *(SP token)]

I notice that in S13.1, we say:

   o  MUST associate an SDP 'label' attribute (Section 7 <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-19#section-7>), with the 'm'
      line; and

Given a label is a MUST, then it infers that the mstrm attribute must be a MUST, so should not be optional in the ABNF above, i.e.

   floor-id-attribute = "a=floorid:" token " mstrm:" token *(SP token)

2a) The text is weird for that MUST anyway; in both 13.1 and 13.2 we say:

   o  MUST associate an SDP 'label' attribute (Section 7 <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-19#section-7>), with the 'm'
      line; and

But the SDP label attribute is for the media stream not the BFCP stream.

   o  MUST associate an SDP 'label' attribute (Section 7 <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-19#section-7>), with the 'm'
      line of the associated media stream(s); and

And for clarity, every other one should probably be changed from: ‘m’ line -> ‘m’ line of the BFCP stream

3) In Section 5, can we refine to 2119 language, i.e.

   An offerer can indicate multiple attribute value for a given session.
   An answerer can only indicate one attribute value.

Change to:

   An offerer MAY indicate multiple attribute value for a given session.
   An answerer MUST indicate only one attribute value.

Regards,
Alan

> On 22 Mar 2018, at 17:06, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> As chair,
>  
> Hi, <>
> _______________________________________________
> bfcpbis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bfcpbis