Subject: [bfcpbis] 4582bis terminology

From: Christer Holmberg <[email-masked]>
Date: Thu, 20 Sep 2018 10:48:21 +0000

Hi,

I took a look at the 4582bis terminology, and I am a little confused.

We have the following definitions:

   Client: A floor participant or a floor chair that communicates with a

   floor control server using BFCP.

   Floor Control Server: A logical entity that maintains the state of

   the floor(s), including which floors exists, who the floor chairs

   are, who holds a floor, etc.  Requests to manipulate a floor are

   directed at the floor control server.  The floor control server of a

   conference may perform other logical roles (e.g., floor participant)

   in another conference.

So far, so good, I think. 4582bis does not define “client” and “server” as roles, though.

Then there is:

   Floor Chair: A logical entity that manages one floor (grants, denies,
   or revokes a floor).  An entity that assumes the logical role of a
   floor chair for a given transaction may assume a different role
   (e.g., floor participant) for a different transaction.  The roles of
   floor chair and floor participant are defined on a transaction-by-
   transaction basis.  BFCP transactions are defined in Section 8.

Still ok, I think. The chair is per transaction, so both a client and server can act as floor chair.

But, then there is:

   Floor Participant: A logical entity that requests floors, and

   possibly information about them, from a floor control server.  An

   entity that assumes the logical role of a floor participant for a

   given transaction may assume a different role (e.g., a floor chair)

   for a different transaction.

First, it says that a floor participant request floors from a floor control server. My understanding of that is that the floor participant is always the client, which means it stays the same throughout the session (due to the c-s removal in 4583bis).

Second, the text says that the role is per transaction, which would mean the client/server thing is also per transaction.

Is there a bug? Should the text say:

   Floor Participant: A logical entity that requests floors, and

   possibly information about them, from a floor chair.

Regards,

Christer

---

From: Alan Ford <[email-masked]>
Date: Thu, 20 Sep 2018 17:30:17 +0100

Hi Christer,

Hmm. I think we might be ok here.

A Floor Participant will communicate with the FCS just as the Floor Chair will. The Floor Participant will request information from the FCS - that bit seems fine to me.

This text is all very weird though, and designed for BFCP as it was originally specified, and not the very simple implementations we meet in the world today. All that’s actually implemented in the real world has a FCS and Floor Chair being the same, and holding s-only role, and then a Floor Participant is a client (c-only role). And that’s it. 

There isn’t any FCS + Chair communication on the wire. I can see that if there was, then this text may make more sense. But then it’s talking about “logical entities” so I guess it holds.

The problem, I think, is with the text about different roles being determined per-transaction. That doesn’t really map to the way BFCP is used in the real world, but fundamentally the protocol (4582bis) doesn’t prevent the three logical entities all passing messages and changing roles. We only nail this down to fixed roles in 4583bis through the SDP exchange.

So I guess what I’m saying is I think this text is probably ok as-is.

Regards,
Alan

> On 20 Sep 2018, at 11:48, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>  
> _______________________________________________
> bfcpbis mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/bfcpbis <https://www.ietf.org/mailman/listinfo/bfcpbis>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Sep 2018 06:23:13 +0000

Hi Alan,

Thanks for your input. My understanding of what is deployed is similar as yours.

>The problem, I think, is with the text about different roles being determined per-transaction. That doesn’t really map to the way BFCP is
>used in the real world, but fundamentally the protocol (4582bis) doesn’t prevent the three logical entities all passing messages and changing
>roles. We only nail this down to fixed roles in 4583bis through the SDP exchange.

Also note that, in 4582bis, “client” and “server” are not defined as roles (“participant” and “chair” are the defined roles).

However, 4583bis defines “client” and “server” as roles. Should we remove “role” from 4583bis and only talk about “client” and “server”?

Regards,

Christer

On 20 Sep 2018, at 11:48, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

   in another conference.

Then there is:

But, then there is:

Regards,

Christer
_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: Alan Ford <[email-masked]>
Date: Fri, 21 Sep 2018 11:30:10 +0100

Hi Christer,

I see your point but “role” is used sparingly in 4583bis, and is specific to 4583bis. I think the text is clear enough and there isn’t any particular risk of confusion - I’d leave it as it is.

Cheers,
Alan

> On 21 Sep 2018, at 07:23, Christer Holmberg <[email-masked]> wrote:
> 
> Hi Alan,
>  
>> On 20 Sep 2018, at 11:48, Christer Holmberg <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> Hi,
>>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Sep 2018 17:01:48 +0000

Hi,

>I see your point but “role” is used sparingly in 4583bis, and is specific to 4583bis.

Yes, but “client” and “server” are the same things in both specs, so I thought we could align the terminology.

Anyway, if people are ok with the current text, I won’t object :)

Regards,

Christer

On 21 Sep 2018, at 07:23, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi Alan,

Regards,

Christer

Hi,

   in another conference.

Then there is:

But, then there is:

Regards,

Christer