Subject: [bfcpbis] Suresh Krishnan's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 24 Oct 2018 13:23:51 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-bfcpbis-rfc4583bis-26: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Similar to Mirja, I was also wondering why UDP/TLS/BFCP is not called
UDP/DTLS/BFCP instead since it does use DTLS?

---

From: Roman Shpount <[email-masked]>
Date: Wed, 24 Oct 2018 16:27:22 -0400

Hi Suresh,

> UDP/DTLS/BFCP instead since it does use DTLS?
The same reason RTP over DTLS over UDP is called UDP/TLS/RTP/SAVP instead
of UDP/DTLS/RTP/SAVP -- legacy interop with existing implementations which
are already using this proto name.

Regards,
_____________
Roman Shpount

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 24 Oct 2018 20:33:11 +0000

On Oct 24, 2018, at 4:27 PM, Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:

Hi Suresh,

On Wed, Oct 24, 2018 at 4:23 PM Suresh Krishnan <[email-masked]<mailto:[email-masked]>> wrote:
Similar to Mirja, I was also wondering why UDP/TLS/BFCP is not called
UDP/DTLS/BFCP instead since it does use DTLS?

The same reason RTP over DTLS over UDP is called UDP/TLS/RTP/SAVP instead of UDP/DTLS/RTP/SAVP -- legacy interop with existing implementations which are already using this proto name.

Thanks for the quick response Roman. That makes sense. Maybe a note to the same effect in the draft would be helpful as well.

Regards
Suresh

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 25 Oct 2018 08:22:51 +0000

From: Suresh Krishnan <[email-masked]>
Date: Wednesday, October 24, 2018 at 9:33 PM
To: Roman Shpount <[email-masked]>
Cc: Mary Barnes <[email-masked]>, "[email-masked]" <[email-masked]>, IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] Suresh Krishnan's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)
Resent-From: <[email-masked]>
Resent-To: Charles Eckel <[email-masked]>, Keith Drage <[email-masked]>
Resent-Date: Wednesday, October 24, 2018 at 9:33 PM

Hi Suresh,

[cue] Yes, Roman is exactly right, and great recommendation Suresh.

Cheers,
Charles

Regards
Suresh