Subject: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

From: Robert Raszuk <[email-masked]>
Date: Wed, 29 Jan 2020 20:18:14 +0100

Hello,

Let me see if the list works :)

Resending for the record two proposals in the BGP autodiscovery space.

I understand that first we perhaps need to agree on requirements. Some of
them are listed in the below documents. Perhaps few of them are missing.

IMO we should also agree first on decoupling BGP in WAN and IX automated
session setup from Data Centers. While on the surface they may look the
same "Oh I just want my BGP to come up" if you look under the hood and say
compare iBGP vs eBGP via L2 switch vs eBGP via p2p link they are really
different animals in the same garden.

Thx,
R.

---------- Forwarded message ---------
From: Robert Raszuk <[email-masked]>
Date: Wed, Dec 11, 2019 at 8:24 PM
Subject: BGP Auto Discovery and BGP Auto Session Setup
To: idr@ietf. org <[email-masked]>
Cc: [email-masked] [email-masked] <[email-masked]>

Dear WG,

We have seen formation of BGP Autodiscovery WG followed by total silence.
Well maybe group is
live just not everyone got onto its private list :)

Regardless of this I refreshed and resubmitted two proposals in this very
space.

1. BGP Auto Discovery

https://tools.ietf.org/html/draft-raszuk-idr-bgp-auto-discovery-06

and

2. BGP Automated Session Setup

https://tools.ietf.org/html/draft-raszuk-idr-bgp-auto-session-setup-01

*Ad 1:*

First document is focused on WAN and IX scenario where establishing
full mesh of IBGP or

selected eBGP peering can automate the operational management tasks or
if run in informational

mode could validate NMS session setup correctness.

Original proposal was presented many years ago in Vienna and at that
point suggested extension to

IGPs to flood discovery information for IBGP auto mesh. Later based on
the input and discussions with

Pedro the proposal got simplified to use classic Route Reflector as
bootstrap node (info broker).

Last input from Jon and Warren added the ability to also automate
setup of eBGP sessions in selected

scenarios.

Since then the document was shelved for some time waiting for IDR WG
turn to deal with discovery topic.

So here we are.

*Ad 2: *

The second document first published in July 2018 provides a very
trivial to implement mechanism (without

even changing BGP state machine) to automatically establish common LAN
or p2p interfaces BGP sessions.

Typical use case would be Clos DC fabrics, customer PE-CE LANs, TORs
to Compute Nodes etc ...

Comments, questions, feedback on both proposals all very welcome.

Kind regards,

Robert.

---

From: Randy Bush <[email-masked]>
Date: Wed, 29 Jan 2020 19:58:39 -0800

actually, i have tried to start a biblio.  so far, i have these drafts:

    raft-raszuk-idr-ibgp-auto-mesh-00
    draft-wkumari-idr-socialite-02

    both above might have merged into
    draft-raszuk-idr-bgp-auto-discovery-06

    draft-raszuk-idr-bgp-auto-session-setup-01

    draft-xu-idr-neighbor-autodiscovery-12.txt

    draft-ymbk-lsvr-l3dl-ulpc-02.txt

i would be interested in other drafts, or maybe even if there have been
research or measurement papers in the area

randy

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 30 Jan 2020 09:33:08 +0100

>
>     draft-raszuk-idr-ibgp-auto-mesh-00

To be very precise the latest draft draft-raszuk-idr-bgp-auto-discovery-06
is a merge of draft-raszuk-idr-bgp-auto-discovery-00 &
draft-wkumari-idr-socialite-02  + later additions by Jon for the IX cases.

And just so we have all history in one place in early 2003 I started with
proposal to discover iBGP peers via ISIS & OSPF flooding extensions as a
package with original draft-raszuk-idr-ibgp-auto-mesh-00:

https://tools.ietf.org/html/draft-raszuk-isis-peer-discovery-00
https://tools.ietf.org/html/draft-raszuk-ospf-bgp-peer-discovery-00

Of course this is not that I intend to respin those ... from now on in the
WAN/IX space what matters is the latest:

Thx,
R.

> --
> Bgp-autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bgp-autoconf
>

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 30 Jan 2020 12:09:06 +0100

Hi Robert,

To my feeling we have already agreed to treat them separately?

Regards,
Jeff

> On Jan 29, 2020, at 20:18, Robert Raszuk <[email-masked]> wrote:
> 
> 
> Hello,
> 
> I understand that first we perhaps need to agree on requirements. Some of them are listed in the below documents. Perhaps few of them are missing. 
> 
> IMO we should also agree first on decoupling BGP in WAN and IX automated session setup from Data Centers. While on the surface they may look the same "Oh I just want my BGP to come up" if you look under the hood and say compare iBGP vs eBGP via L2 switch vs eBGP via p2p link they are really different animals in the same garden.
> 
> Thx,
> R.
> 
> 
> We have seen formation of BGP Autodiscovery WG followed by total silence. Well maybe group is 
> Regardless of this I refreshed and resubmitted two proposals in this very space. 
> 
> 1. BGP Auto Discovery
> Ad 1:
> First document is focused on WAN and IX scenario where establishing full mesh of IBGP or 
> selected eBGP peering can automate the operational management tasks or if run in informational 
> Original proposal was presented many years ago in Vienna and at that point suggested extension to 
> IGPs to flood discovery information for IBGP auto mesh. Later based on the input and discussions with 
> Pedro the proposal got simplified to use classic Route Reflector as bootstrap node (info broker). 
> 
> Last input from Jon and Warren added the ability to also automate setup of eBGP sessions in selected 
> scenarios. 
> 
> Since then the document was shelved for some time waiting for IDR WG turn to deal with discovery topic. 
> 
> So here we are. 
> 
> Ad 2: 
> 
> The second document first published in July 2018 provides a very trivial to implement mechanism (without 
> even changing BGP state machine) to automatically establish common LAN or p2p interfaces BGP sessions. 
> 
> Typical use case would be Clos DC fabrics, customer PE-CE LANs, TORs to Compute Nodes etc ... 
>

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 30 Jan 2020 13:07:48 +0100

>  To my feeling we have already agreed to treat them separately?

Is that a question or a statement ?

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 30 Jan 2020 13:12:25 +0100

A statement with a question mark ;-)
To rephrase - I think we have already agreed. 

Regards,
Jeff

> On Jan 30, 2020, at 13:08, Robert Raszuk <[email-masked]> wrote:
> 
> 
>

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 30 Jan 2020 13:13:40 +0100

Cool - then we accomplished first design team milestone :)

---

From: Randy Bush <[email-masked]>
Date: Thu, 30 Jan 2020 08:52:57 -0800

i am tracking the biblio in

https://git.rg.net/randy/randy/src/master/bgp-autodiscovery.md

randy

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sat, 1 Feb 2020 06:17:29 +0000

Hi Robert and Jeff,

Yes I also think we’ve agreed to treat them separately. Then the next question is which scenario(s) would be the first target for this design team? My personal feeling is there may be more interests to work on the DC case first. What do you think?

Best regards,
Jie

From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, January 30, 2020 8:14 PM
To: Jeff Tantsura <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

On Thu, Jan 30, 2020 at 1:12 PM Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
A statement with a question mark ;-)
To rephrase - I think we have already agreed.

Regards,
Jeff

> On Jan 30, 2020, at 13:08, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
>
> 
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sat, 1 Feb 2020 06:25:37 +0000

Hi Randy, 

Thanks for tracking this. 

There is one draft which was missed in this list: draft-acee-idr-lldp-peer-discovery-06

Best regards,
Jie

> -----Original Message-----
> From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of
> Randy Bush
> Sent: Friday, January 31, 2020 12:53 AM
> To: Robert Raszuk <[email-masked]>