Subject: [Bgp-autoconf] Kicking things off

From: John Scudder <[email-masked]>
Date: Wed, 29 Jan 2020 19:29:11 +0000

Hi All,

The mailing list was the last administrative hurdle [*] so at this point I think we’re up and running. I’m hoping that at this point you will carry things forward on your own, please check in with Sue and me as desired but other than that I’m going to try to keep my nose out of your business. 

Thanks again,

—John

[*] Having typed that I realize I also need to check in to getting you a WebEx space. But I don’t think that needs to hold things up.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 30 Jan 2020 07:34:24 +0000

Hi all, 

Now we can get started on the list. (Thanks John!)

As mentioned in John's mail to IDR list, the design team is initially chartered to consider requirements and review the solution space (including existing proposals). And a good point raised by Robert is to firstly identify the scope of our problem space, whether our goal is to provide BGP auto-configuration for WAN, IXP, DC or for all of these cases. The scope can have some impact to the requirement. 

Thus my proposal for the discussion is:

1. Determine the problem space the design team aims to solve.

2. List the requirements for that problem space.

3. Review existing proposals, for each solution, summarize which requirements can be met, and what are the gaps (if any).

Thanks to Robert and Randy for providing the list of relevant drafts. I put them together in the following list, and also add one more draft.

draft-acee-idr-lldp-peer-discovery-06

draft-xu-idr-neighbor-autodiscovery-12

draft-ymbk-lsvr-l3dl-ulpc-02

draft-raszuk-idr-bgp-auto-session-setup-01

draft-raszuk-idr-bgp-auto-discovery-06
  draft-raszuk-idr-ibgp-auto-mesh-00 (merged)
  draft-wkumari-idr-socialite-02 (merged)

Once we have the Webex space, we could start to have regular conference calls to review the progress of our work, while it is highly recommended to have most discussion happen on the list. 

Thoughts?

Best regards,
Jie

> -----Original Message-----
> From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of
> John Scudder
> Sent: Thursday, January 30, 2020 3:29 AM
> To: [email-masked]
> Cc: Hares Susan <[email-masked]>
> Subject: [Bgp-autoconf] Kicking things off
> 
> Hi All,
> 
> The mailing list was the last administrative hurdle [*] so at this point I think
> we’re up and running. I’m hoping that at this point you will carry things
> forward on your own, please check in with Sue and me as desired but other
> than that I’m going to try to keep my nose out of your business.
> 
> Thanks again,
> 
> —John
> 
> [*] Having typed that I realize I also need to check in to getting you a WebEx
> space. But I don’t think that needs to hold things up.
> --
> Bgp-autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bgp-autoconf