Subject: [Bgp-autoconf] Issues not mentioned in yesterday's revision

From: "Susan Hares" <[email-masked]>
Date: Tue, 26 Jan 2021 08:52:16 -0500

Jeff and Warren: 

Thank you for the first draft.  

Here's a list of requirements that I do not see mentioned: 

1.  security requirements -  

Is it a requirement to secure data sent in a L3 multicast BGP
auto-configuration packet?

Is there a requirement that people could send a secure portion of the packet
if they desired? 

It all gets down to trust vs. complexity

2.  validation of Data sent 

Will the bgp-autoconf  check syntax of data sent? 

Will it validate the content of the data set? 

3.  Will it carry link level information? 

If so, what security issues will that cause. 

If you trust everyone, what about errors in the fabric. 

4.  Will it have a link to BFD? 

5.  What requirements are there on top of the IP Multicast - 

 Is the IP multicast a "spray and pray" multicast without   or is it "blast
and echo check"?

Mechanisms that I personally hoped would work: 

a) layer 3 multicast with "blast and echo" with ability to go through 2+
switches on way to remote end

b) optional securing of the data sent on BGP auto-configuration  

c) Fast failure - via BFD or some "x" mechanism 

d) optional bootstrap from IGPs or LLDP

Mechanism that I personally hoped a BGP-5 might revise its FSM. 

Sue

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 26 Jan 2021 08:54:29 -0500

> On Jan 26, 2021, at 8:52 AM, Susan Hares <[email-masked]> wrote:
> 
> Jeff and Warren: 
>  

This isn't even a full first draft.  It's the work in progress as currently completed for discussion today.

We can certainly cover many of the items you list below today if that's your agenda.

-- Jeff

>  
> Here’s a list of requirements that I do not see mentioned: 
>  
> 1.  security requirements –  
>  
> Is it a requirement to secure data sent in a L3 multicast BGP auto-configuration packet?
> Is there a requirement that people could send a secure portion of the packet if they desired? 
>  
>  Is the IP multicast a “spray and pray” multicast without   or is it “blast and echo check”?
>  
> a) layer 3 multicast with “blast and echo” with ability to go through 2+ switches on way to remote end
> c) Fast failure – via BFD or some “x” mechanism 
> -- 
> Bgp-autoconf mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/bgp-autoconf <https://www.ietf.org/mailman/listinfo/bgp-autoconf>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 26 Jan 2021 09:02:06 -0500

Jeff and Warren: 

My chair goal for the meetings is to facilitate the discussion as chair.  

IMHO, the best way to that is :

1) simply support both of your leading the discussions as editors, 

2) provide “chair” policy if requested by the editors, 

3) provide participant feedback requested after reading github drafts 

4) encourage publication of “something” by IETF 110 

    and insure a slot at IETF 110 for design team. 

All of the last message was simply participant feedback on what’s missing. 

Cheers, Sue 

From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Tuesday, January 26, 2021 8:54 AM
To: Sue Hares
Cc: [email-masked]; Linda Dunbar; Majumdar, Kausik
Subject: Re: [Bgp-autoconf] Issues not mentioned in yesterday's revision

Jeff and Warren: 

-- Jeff

Sue    

-- 
Bgp-autoconf mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/bgp-autoconf> https://www.ietf.org/mailman/listinfo/bgp-autoconf

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Tue, 26 Jan 2021 15:05:41 +0000

Is the meeting started? I can’t get in - https://ietf.webex.com/meet/idr

Thanks,
Kausik

From: Jeffrey Haas <[email-masked]>
Sent: Tuesday, January 26, 2021 5:54 AM
To: Sue Hares <[email-masked]>
Cc: [email-masked]; Linda Dunbar <[email-masked]>; Majumdar, Kausik <[email-masked]>
Subject: Re: [Bgp-autoconf] Issues not mentioned in yesterday's revision

On Jan 26, 2021, at 8:52 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote: Jeff and Warren: Thank you for the first draft. This isn't even a full first draft. It's the work in progress as currently compl
External ([email-masked]<mailto:[email-masked]>)
Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tL2VhMGFiYjFhZDU4OWM0NWUyNzFmNzI4NmIwMWZhMGFiLzE2MTE2NjkyNzkuODE=#key=e7aea29ee9056d7902eb43357db92212>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

On Jan 26, 2021, at 8:52 AM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Jeff and Warren:

-- Jeff

Sue

--
Bgp-autoconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bgp-autoconf<https://secure-web.cisco.com/1ZfPf_XalNHICBOCfRS_ndff5_P2V-MdhIi3BZ7M23ETXS6DcmDRClMDvtD2JQPfyV7s5X4-Xig-NlUN94QLE2nxgS-c4KaQMm8LxM95wbntKnxQ4LnKsnuu0FgopXx3kZTp2CAEXViNLnSeDqLl79hnkIRHzUIklrgr4EQGwfN_AmWmWuvwDLFtrrNL_UGsMCT-h1i2zUQSAzuCTVn0NlX6DYoksfxLltE2NNlkzN939qaxzwMsdGtPuZj-91atFKkch8U55zUl2fk2HfZN8dNXGTyDGTnDISxRY8qcdG-rDDLgMmqZMMudRJKnvFang/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbgp-autoconf>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 26 Jan 2021 15:09:44 +0000

I can't get in either.

Linda

From: Majumdar, Kausik <[email-masked]>
Sent: Tuesday, January 26, 2021 9:06 AM
To: Jeffrey Haas <[email-masked]>; Sue Hares <[email-masked]>
Cc: [email-masked]; Linda Dunbar <[email-masked]>
Subject: RE: [Bgp-autoconf] Issues not mentioned in yesterday's revision

Is the meeting started? I can't get in - https://ietf.webex.com/meet/idr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fmeet%2Fidr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C63ae8476526c421de45208d8c20bde19%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637472703522182405%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=orE0Vvqmx5xdR9CXcrebEz7Poicy0zillFiWheomWjo%3D&reserved=0>

Thanks,
Kausik

From: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, January 26, 2021 5:54 AM
To: Sue Hares <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Majumdar, Kausik <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bgp-autoconf] Issues not mentioned in yesterday's revision

Jeff and Warren:

-- Jeff

5.  What requirements are there on top of the IP Multicast -
 Is the IP multicast a "spray and pray" multicast without   or is it "blast and echo check"?

a) layer 3 multicast with "blast and echo" with ability to go through 2+ switches on way to remote end

Sue

--
Bgp-autoconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bgp-autoconf<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsecure-web.cisco.com%2F1ZfPf_XalNHICBOCfRS_ndff5_P2V-MdhIi3BZ7M23ETXS6DcmDRClMDvtD2JQPfyV7s5X4-Xig-NlUN94QLE2nxgS-c4KaQMm8LxM95wbntKnxQ4LnKsnuu0FgopXx3kZTp2CAEXViNLnSeDqLl79hnkIRHzUIklrgr4EQGwfN_AmWmWuvwDLFtrrNL_UGsMCT-h1i2zUQSAzuCTVn0NlX6DYoksfxLltE2NNlkzN939qaxzwMsdGtPuZj-91atFKkch8U55zUl2fk2HfZN8dNXGTyDGTnDISxRY8qcdG-rDDLgMmqZMMudRJKnvFang%2Fhttps%253A%252F%252Fwww.ietf.org%252Fmailman%252Flistinfo%252Fbgp-autoconf&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C63ae8476526c421de45208d8c20bde19%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637472703522182405%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=vXOe229gf%2Fdc0bLOQ8iHtVNK%2Fb7yzvtFh3AqFvwQbnk%3D&reserved=0>