Subject: [Bier] Comments on draft-chh-bier-bier-yang-00

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 23 Jul 2015 11:43:23 +0000

Hi authors,

  *   I tried to pyang the model in the draft and ran into quite a few errors. I stopped after the 4 below (these are basic YANG errors, wasn’t even using strict/ietf option)
  *   Once you fix these errors please compile with —ietf option (sricter rules regarding ordering of statements, requiring description etc etc)
  *   Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> etc
  *   Finally, please use the validator @ http://www.yangvalidator.com/

Regards,
Reshad.

ERRORS

No “” for the contact
ietf-bier.yang:34: error: unterminated statement definition for keyword "contact", looking at L

Extra “ in "reference "draft-chen-bier-bier-yang-00”;
59: error: unterminated statement definition for keyword "reference", looking at d

Missing ; in key "sub-domain-id"
125: error: unterminated statement definition for keyword "key", looking at l

Missing ; in type if:interface-ref
154: error: unterminated statement definition for keyword "type", looking at }

---

From: [email-masked]
Date: Thu, 23 Jul 2015 20:46:17 +0800

Hi, Rahman,

Thanks for your comments, we will correct it based on your suggestion.

Regards
Fangwei.

"Reshad Rahman (rrahman)" <[email-masked]> 
发件人:  "BIER" <[email-masked]>
2015-07-23 19:43

收件人
"[email-masked]" 
<[email-masked]>, 
抄送
"[email-masked]" <[email-masked]>
主题
[Bier] Comments on draft-chh-bier-bier-yang-00

Hi authors,
I tried to pyang the model in the draft and ran into quite a few errors. I 
stopped after the 4 below (these are basic YANG errors, wasn’t even using 
strict/ietf option)
Once you fix these errors please compile with ―ietf option (sricter rules 
regarding ordering of statements, requiring description etc etc)
Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> 
etc
Finally, please use the validator @ http://www.yangvalidator.com/

Regards,
Reshad.

ERRORS

No “” for the contact
ietf-bier.yang:34: error: unterminated statement definition for keyword 
"contact", looking at L

Extra “ in "reference "draft-chen-bier-bier-yang-00”;
59: error: unterminated statement definition for keyword "reference", 
looking at d

Missing ; in key "sub-domain-id"
125: error: unterminated statement definition for keyword "key", looking 
at l

Missing ; in type if:interface-ref
154: error: unterminated statement definition for keyword "type", looking 
at }

_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier