Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

From: Greg Shepherd <[email-masked]>
Date: Mon, 1 Aug 2016 08:24:47 -0700

This will be determined by the design team.

Thanks,
Greg

On Sun, Jul 31, 2016 at 7:12 PM, Xuxiaohu <[email-masked]> wrote:

> Hi Greg,
>
>
>
> I hope to understand what the alternative encapsulation options mean
> before responding to this poll. Should these alternative encapsulation
> options be built on the MPLS-BIER header, more specially, should these
> options still contain a indirection field (i.e., the BIER-MPLS label) by
> which some information used for BIER forwarding could be inferred? Or these
> alternative encapsulation options allow all the necessary information used
> for BIER forwarding to be contained in the BIER header directly?
>
>
>
> Best regards,
>
> Xiaohu
>
>
>
> *From:* BIER [mailto:[email-masked]] *On Behalf Of *Greg Shepherd
> *Sent:* Friday, July 29, 2016 12:33 AM
> *To:* [email-masked]
> *Subject:* Re: [Bier] Alternate Encap Design Team - Call for volunteers
>
>
>
> Thank you to the 9 responders so far to the call. I'm going to start a
> date/location poll for the current list of volunteers. If others are
> interested in joining, the call is still open. Please send email to the
> chairs requesting to be added.
>
>
>
> Thanks!,
>
> Greg
>
>
>
> On Wed, Jul 20, 2016 at 5:17 PM, Greg Shepherd <[email-masked]> wrote:
>
> *,
>
>
>
> Thank you to all who attended and contributed to the lively discussion at
> the WG meeting in Berlin this week. This is what WG meetings should be -
> and some would say, used to be.
>
>
>
> From a poll in the room, there was consensus to pull together a volunteer
> design team to look at the various encap options, and based on
> use-case/operational considerations/support the team will pick one
> additional encap to document and offer as a WG item. The expectation is the
> list of volunteers will attend an interim WG meeting were we will work
> together for 2-3 days to hash out the direction and details. This will be a
> physical meeting, but will accommodate remote participation as well.
>
>
>
> I would like to see this work published and available for further
> discussion to the group at large on the list before and in the room during
> the next WG meeting in November. Considering the requirements for interim
> meeting announcements, the soonest we can reasonably target an interim
> meeting is Sept.
>
>
>
> Anyone wanting to volunteer as a member of the BIER Encap Design Team,
> please send email to the WG chairs. We will compile the list, then target a
> suitable location and dates from there. We look forward to pulling this
> enthusiastic team together in one direction.
>
>
>
> Thanks,
>
> Greg
>
>
>
>
>
>
>

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 1 Aug 2016 09:59:14 -0700

+1

On Mon, Aug 1, 2016 at 8:24 AM, Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 2 Aug 2016 01:47:31 +0000

Hi Greg,

Thanks for your answer.

Since two BIER encapsulation options are already there: one is MPLS-based (or called it indirection-based if the MPLS term seems too sensitive) and another is non-MPLS-based  (https://tools.ietf.org/html/draft-xu-bier-encapsulation-05), shouldn’t we widely discuss whether the existing two options are enough in the WG scope prior to forming a design team to invent additional encapsulation options? Note that “enough” here doesn’t mean they are ‘perfect’, it just means we can use them as baselines and complete them continuously. Maybe I misunderstand your real intention of forming a design team to develop alternative encapsulation options.

Best regards,
Xiaohu

From: Greg Shepherd [mailto:[email-masked]]
Sent: Monday, August 01, 2016 11:25 PM
To: Xuxiaohu
Cc: [email-masked]
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Thanks,
Greg

On Sun, Jul 31, 2016 at 7:12 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

I hope to understand what the alternative encapsulation options mean before responding to this poll. Should these alternative encapsulation options be built on the MPLS-BIER header, more specially, should these options still contain a indirection field (i.e., the BIER-MPLS label) by which some information used for BIER forwarding could be inferred? Or these alternative encapsulation options allow all the necessary information used for BIER forwarding to be contained in the BIER header directly?

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Shepherd
Sent: Friday, July 29, 2016 12:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Thank you to the 9 responders so far to the call. I'm going to start a date/location poll for the current list of volunteers. If others are interested in joining, the call is still open. Please send email to the chairs requesting to be added.

Thanks!,
Greg

On Wed, Jul 20, 2016 at 5:17 PM, Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
*,

Thank you to all who attended and contributed to the lively discussion at the WG meeting in Berlin this week. This is what WG meetings should be - and some would say, used to be.

From a poll in the room, there was consensus to pull together a volunteer design team to look at the various encap options, and based on use-case/operational considerations/support the team will pick one additional encap to document and offer as a WG item. The expectation is the list of volunteers will attend an interim WG meeting were we will work together for 2-3 days to hash out the direction and details. This will be a physical meeting, but will accommodate remote participation as well.

I would like to see this work published and available for further discussion to the group at large on the list before and in the room during the next WG meeting in November. Considering the requirements for interim meeting announcements, the soonest we can reasonably target an interim meeting is Sept.

Anyone wanting to volunteer as a member of the BIER Encap Design Team, please send email to the WG chairs. We will compile the list, then target a suitable location and dates from there. We look forward to pulling this enthusiastic team together in one direction.

Thanks,
Greg

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 1 Aug 2016 22:55:29 -0700

Xuxiaohu,

Thanks for your input. I believe you were in the room in Berlin when this
was being discussed. If you like I can resend you the minutes. We had room
consensus to work together to identify any use case or service requirement
gaps in the current, chartered MPLS encapsulation. And if sufficient case
could be made, we would work together to design a specification to address
these identified use-case/service gaps.

Your input as a member of the design team is welcome and encouraged. Anyone
willing to come to the table without an agenda, to identify a need and
create a solution, together as part of the WG team, is welcome to help us
out.

Thanks,
Greg

On Mon, Aug 1, 2016 at 6:47 PM, Xuxiaohu <[email-masked]> wrote:

> Hi Greg,
>
>
>
> Thanks for your answer.
>
>
>
> Since two BIER encapsulation options are already there: one is MPLS-based
> (or called it indirection-based if the MPLS term seems too sensitive) and
> another is non-MPLS-based  (
> https://tools.ietf.org/html/draft-xu-bier-encapsulation-05), shouldn’t we
> widely discuss whether the existing two options are enough in the WG scope
> prior to forming a design team to invent additional encapsulation options?
> Note that “enough” here doesn’t mean they are ‘perfect’, it just means we
> can use them as baselines and complete them continuously. Maybe I
> misunderstand your real intention of forming a design team to develop
> alternative encapsulation options.
>
>
>
> Best regards,
>
> Xiaohu
>
>
>
> *From:* Greg Shepherd [mailto:[email-masked]]
> *Sent:* Monday, August 01, 2016 11:25 PM
> *To:* Xuxiaohu
> *Cc:* [email-masked]

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 3 Aug 2016 02:56:58 +0000

Hi Greg,

Thanks a lot for your explanation. It’s great to form a DT to do gap analysis work firstly. I’m willing to contribute.

Best regards,
Xiaohu

From: Greg Shepherd [mailto:[email-masked]]
Sent: Tuesday, August 02, 2016 1:55 PM
To: Xuxiaohu
Cc: [email-masked]
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Xuxiaohu,

Thanks for your input. I believe you were in the room in Berlin when this was being discussed. If you like I can resend you the minutes. We had room consensus to work together to identify any use case or service requirement gaps in the current, chartered MPLS encapsulation. And if sufficient case could be made, we would work together to design a specification to address these identified use-case/service gaps.

Your input as a member of the design team is welcome and encouraged. Anyone willing to come to the table without an agenda, to identify a need and create a solution, together as part of the WG team, is welcome to help us out.

Thanks,
Greg

On Mon, Aug 1, 2016 at 6:47 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Thanks for your answer.

Best regards,
Xiaohu

From: Greg Shepherd [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, August 01, 2016 11:25 PM
To: Xuxiaohu
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Thanks,
Greg

Best regards,
Xiaohu

Thanks!,
Greg

Thanks,
Greg

---

From: "IJsbrand Wijnands (iwijnand)" <[email-masked]>
Date: Wed, 3 Aug 2016 15:33:34 +0000

I would like to volunteer,

Thx,

Ice.

Sent from my iPhone

On 28 Jul 2016, at 18:41, Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:

*,

Let me add, that if you DID NOT send email to this request, you are not on the current list for the Alt Encap Design team. The call for hands in the room was just to gauge interest. The official call is here on the list and you need to respond on the list or you will not be included.

Thanks,
Greg

On Thu, Jul 28, 2016 at 9:32 AM, Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Thank you to the 9 responders so far to the call. I'm going to start a date/location poll for the current list of volunteers. If others are interested in joining, the call is still open. Please send email to the chairs requesting to be added.

Thanks!,
Greg

Thanks,
Greg

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 3 Aug 2016 08:34:03 -0700

Add, thanks.

On Wed, Aug 3, 2016 at 8:33 AM, IJsbrand Wijnands (iwijnand) <[email-masked]>
wrote:

> On 28 Jul 2016, at 18:41, Greg Shepherd <[email-masked]> wrote:
>
> *,
>
> Let me add, that if you DID NOT send email to this request, you are not on
> the current list for the Alt Encap Design team. The call for hands in the
> room was just to gauge interest. The official call is here on the list and
> you need to respond on the list or you will not be included.
>
> Thanks,
> Greg
>
> On Thu, Jul 28, 2016 at 9:32 AM, Greg Shepherd <[email-masked]> wrote:
>
>>> Thank you to all who attended and contributed to the lively discussion
>>> at the WG meeting in Berlin this week. This is what WG meetings should be -
>>> From a poll in the room, there was consensus to pull together a
>>> volunteer design team to look at the various encap options, and based on

---

From: "Dolganow, Andrew (Nokia - SG)" <[email-masked]>
Date: Wed, 3 Aug 2016 17:04:31 +0000

Plus one.

Andrew

Sent from my iPhone

On Aug 3, 2016, at 11:36 PM, Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:

Add, thanks.

On Wed, Aug 3, 2016 at 8:33 AM, IJsbrand Wijnands (iwijnand) <[email-masked]<mailto:[email-masked]>> wrote:
I would like to volunteer,

Thx,

Ice.

Sent from my iPhone

*,

Thanks,
Greg

Thanks!,
Greg

Thanks,
Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 3 Aug 2016 18:15:24 +0000

Please add me too.

                Regards,
                                Greg

From: BIER [mailto:[email-masked]] On Behalf Of Dolganow, Andrew (Nokia - SG)
Sent: Wednesday, August 03, 2016 10:05 AM
To: [email-masked]
Cc: [email-masked]; IJsbrand Wijnands (iwijnand) <[email-masked]>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Plus one.

Andrew

Sent from my iPhone

Thx,

Ice.

Sent from my iPhone

Thanks,
Greg

Thanks!,
Greg

Thanks,
Greg

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 03 Aug 2016 16:02:37 -0700

+1

Cheers,

Jeff

From: BIER <[email-masked]> on behalf of Gregory Mirsky <[email-masked]>
Date: Wednesday, August 3, 2016 at 11:15
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Please add me too.

                Regards,

                                Greg

Plus one. 

Andrew 

Sent from my iPhone

On Aug 3, 2016, at 11:36 PM, Greg Shepherd <[email-masked]> wrote:

Add, thanks.

On Wed, Aug 3, 2016 at 8:33 AM, IJsbrand Wijnands (iwijnand) <[email-masked]> wrote:

Thx,

Ice.

Sent from my iPhone

*, 

Thanks,

Greg

Thanks!,

Greg

*, 

Thanks,

Greg

 

_______________________________________________ BIER mailing list [email-masked] https://www.ietf.org/mailman/listinfo/bier

---

From: AbdurRashidSangi <[email-masked]>
Date: Fri, 5 Aug 2016 03:06:46 +0000

+1

Regards,
Rashid Sangi,
Huawei, Beijing, China.

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 2016年8月4日 7:03
To: Gregory Mirsky; [email-masked]
Cc: [email-masked]
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

+1

Cheers,
Jeff

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 3, 2016 at 11:15
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Please add me too.

                Regards,
                                Greg

From: BIER [mailto:[email-masked]] On Behalf Of Dolganow, Andrew (Nokia - SG)
Sent: Wednesday, August 03, 2016 10:05 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; IJsbrand Wijnands (iwijnand) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] Alternate Encap Design Team - Call for volunteers

Plus one.

Andrew

Sent from my iPhone

Thx,

Ice.

Sent from my iPhone

Thanks,
Greg

Thanks!,
Greg

Thanks,
Greg

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier
_______________________________________________ BIER mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/bier