Subject: [Bier] Comments on draft-ietf-bier-te-arch-00

From: <[email-masked]>
Date: Thu, 12 Apr 2018 15:20:24 +0800 (CST)

Hi authors,

There are some small nits in several example parts, IMO it's better to revise them though these nits may not lead to misunderstanding.

1)In section 3.4,

a, "pXX indicate ......  For example,

   p9 is the adjacency towards BFR9 on the LAN connecting to BFER2."

---There isn't BFR9 in the figure, it should be BFR5.

b, "BFIR2 forwards based on that BitString......

   Only p13 is in BitString which has an adjacency towards BFR3.  BFIR2

   resets p2 in BitString and sends a copy towards BFR2."

---It should be: "Only p2 is in BitString which has an adjacency towards BFR3. BFIR2 resets p2 in BitString and sends a copy towards BFR3."

2), In the second paragraph of section 3.5,

"When a packet is received, ......, but not BIER-T

   itself.  It is expected ......."

---It is "BIER-TE".

3) In the pseudocode of section 6,

"for (Index = 0; Index++ ; Index <= BitStringLength)

     if(BIFT[Index] != <empty>)

         MyBitsOfInterest != 2<<(Index-1)"

---My understanding is MyBitsOfInterest is the collection of the non-zero bps in a BIFT array. The corresponding bit in MyBitsOfInterest should be set to 1 when BIFT[Index]'s value is non-zero. If my understanding is right, it seems like the pseudocode should be:

"for (Index = 0; Index++ ; Index < BitStringLength)

    if(BIFT[Index] != <empty>)

        MyBitsOfInterest |= 1<<(Index);"

And this modification is also suitable for the ForwardBierTePacket pseudocode example in section 6.

4) In the first paragraph of section 7.5.1,

"Consider a network setup with a bitstring length of 256 for a network

   topology ......  The network has 6 areas,

   each with ca. 180 BFR, connecting via a core with some larger (core)

   BFR.  To address all BFER with BIER, 4 SI are required."

---It seems like 4 SIs for 256 BitStringLength are not enough to hold 180*6=1080 BFERs. To modify simply, 170 BFR is suitable.

5) In the pseudocode of section 6,

The "interface" mentioned in ForwardBierTePacket pseudocode seems the same as "adjacency". Should it be modified uniformly?

BTW: In section 4.7, I am not understanding well about the usage of seed. Are these seeds' value in BFR1/2/3's BIFT entry same? 

Could you please add more detail about how to use it?

Thanks,

Sandy

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 21 Apr 2018 23:36:07 +0200

Thanks a lot

Will fix in next rev.

-- 
---
[email-masked]