Subject: [Bier] Multicast ABR in BBF

From: "Purkayastha, Debashish" <[email-masked]>
Date: Mon, 20 Aug 2018 21:26:03 +0000

Dear Rachel and All,

W.r.t comment in IETF 102 on draft “BIER multicast overlay for http response”, there was a discussion on  Multicast ABR.  It was mentioned that BBF is working on similar area for streaming live video.

Can you please point me to the correct document, which can help me in understanding the framework better?

Thanks
Debashish.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Tue, 21 Aug 2018 02:19:07 +0000

Hi Debashish,

I was mentioning that in the application layer, similar idea is developing in other SDOs, i.e., DVB and BBF.

DVB has been working on this for a long time. They are developing technical architecture, modules, and  transport protocols between different devices. See https://www.dvb.org/resources/public/standards/a176_adaptive_media_streaming_over_ip_multicast_2018-02-16_draft_bluebook.pdf

BBF also started similar work in October 2016. It’s called WT-399. This work is now coordinated with DVB. The basic agreement was made that BBF will only focus on the device management models developing.

Anyway, these existing work are decoupled from the network multicast capabilities. Current IGMP PIM could work with them perfectly.

So basically, I think BIER would help in this area to provide a better multicast delivery. But we need to dig more and point it out in the draft.

BR,
Rachel

From: BIER [mailto:[email-masked]] On Behalf Of Purkayastha, Debashish
Sent: Tuesday, August 21, 2018 5:26 AM
To: [email-masked]
Subject: [Bier] Multicast ABR in BBF

Dear Rachel and All,

Thanks
Debashish.

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 21 Aug 2018 17:15:59 -0700

I think the draft should be clear as to whether any referenced technique
contitute reliable delivery or is relly just a better best effort delivery.
Given the groups working on the proposals i would expect the latter,.

On Mon, Aug 20, 2018 at 7:19 PM, Huangyihong (Rachel) <
[email-masked]> wrote:

> DVB has been working on this for a long time. They are developing
> technical architecture, modules, and  transport protocols between different
> devices. See https://www.dvb.org/resources/public/standards/a176_
> adaptive_media_streaming_over_ip_multicast_2018-02-16_draft_bluebook.pdf
>
>
>
> BBF also started similar work in October 2016. It’s called WT-399. This
> work is now coordinated with DVB. The basic agreement was made that BBF
> will only focus on the device management models developing.
>
>
>
> Anyway, these existing work are decoupled from the network multicast
> capabilities. Current IGMP PIM could work with them perfectly.
>
>
>
> So basically, I think BIER would help in this area to provide a better
> multicast delivery. But we need to dig more and point it out in the draft.
>
>
>
> BR,
>
> Rachel
>
>
>
> *From:* BIER [mailto:[email-masked]] *On Behalf Of *Purkayastha,
> Debashish
> *Sent:* Tuesday, August 21, 2018 5:26 AM
> *To:* [email-masked]
> *Subject:* [Bier] Multicast ABR in BBF
>
>
>
> Dear Rachel and All,
>
>
>
> W.r.t comment in IETF 102 on draft “BIER multicast overlay for http
> response”, there was a discussion on  Multicast ABR.  It was mentioned that
> BBF is working on similar area for streaming live video.
>
>
>
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>