Subject: [Bier] What is the motivation for RFC8401 to have a strict "MUST NOT be set" for R-Flag?

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 7 Aug 2018 10:39:51 +0000

Folks,

When having desire to do BIER between ISIS L1/L2 domains then there is something I do not understand.

In RFC8401 I see:
4.2<https://tools.ietf.org/html/rfc8401#section-4.2>.  Advertising BIER Information

   BIER information advertisements are associated with a new sub-TLV in

   the extended reachability TLVs.  BIER information is always

   associated with a host prefix, which MUST be a node address for the

   advertising node.  If this is not the case, the advertisement MUST be

   ignored.  Therefore, the following restrictions apply:

   o  Prefix length MUST be 32 for an IPv4 prefix or 128 for an IPv6

      prefix.

   o  When the Prefix Attributes Flags sub-TLV [RFC7794<https://tools.ietf.org/html/rfc7794>] is present, the

      N flag MUST be set and the R flag MUST NOT be set.

   o  BIER sub-TLVs MUST be included when a prefix reachability

      advertisement is leaked between levels.

In RFC7794 I find:

   R-Flag:  Re-advertisement Flag (Bit 1)

      Set when the prefix has been leaked from one level to another

      (upwards or downwards).

The issue that is unclear to me:

  *   If I leak a (node-)prefix between L1/L2 then I MUST set the R-flag (according RFC7794), but then this seem to contradict the strict MUST NOT from RFC8401.

What logic am I misunderstanding? Why is the motivation in RFC8401 regarding the strict "MUST NOT be set" requirement for the R-Flag?

Brgds,
G/

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 7 Aug 2018 15:56:47 +0000

Gunter -

In early versions of the draft we did not support inter-area, so we specified that R bit MUST be 0.
Then in V6 of the draft we allowed for inter-area support and the text relating to R-bit was removed.

However, somehow the text regarding R-bit ended up being put back in V9 of the draft. I don't think there was any reason for this - probably just a cut and paste error.

At this point I think you will need to file an Errata.

Sigh...

    Les

From: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>
Sent: Tuesday, August 07, 2018 3:40 AM
To: [email-masked]; Les Ginsberg (ginsberg) <[email-masked]>; Tony Przygienda <[email-masked]>; [email-masked]
Cc: Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]>
Subject: What is the motivation for RFC8401 to have a strict "MUST NOT be set" for R-Flag?

Folks,

In RFC8401 I see:

      prefix.

In RFC7794 I find:

      (upwards or downwards).

Brgds,
G/

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 7 Aug 2018 16:52:27 +0000

Hi Les, thanks for this confirmation.

G/

From: Les Ginsberg (ginsberg) <[email-masked]>
Sent: Tuesday, August 7, 2018 17:57
To: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]; Tony Przygienda <[email-masked]>; [email-masked]
Cc: Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]>
Subject: RE: What is the motivation for RFC8401 to have a strict "MUST NOT be set" for R-Flag?

Gunter -

Sigh...

    Les

From: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, August 07, 2018 3:40 AM
To: [email-masked]<mailto:[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: What is the motivation for RFC8401 to have a strict "MUST NOT be set" for R-Flag?

Folks,

In RFC8401 I see:

      prefix.

In RFC7794 I find:

      (upwards or downwards).

Brgds,
G/