Subject: [Bier] RFC 8401 clarification

From: "Bidgoli, Hooman (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 18 Sep 2018 15:53:55 +0000

Dear all

Just a general comment on ISIS and R and X flag, there is some ambiguity on these flags when as an example

1.            Leaking BIER Sub-TLVs between Multi-instance ISIS, it would make sense to not set the X flag when a local prefix is redistributed between instances.
2.            Same as SR In the case where a Level-1-2 router has local interface addresses configured in one level, it may also propagate these addresses into the other level.  In such case, the Level-1-2 router MUST NOT set the R bit.

What is the view of the WG on these topics

Regards

Hooman

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Sep 2018 12:36:57 +0000

Hooman -

https://tools.ietf.org/html/rfc7794 is the authoritative document on IS-IS prefix attribute flags. RFC 8401 is NOT making any changes to  RFC 7794  (indeed - why would it?).

If you are unclear on when X and R flags should be set please direct your question to the LSR WG.

Some responses inline.

From: Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]>
Sent: Tuesday, September 18, 2018 8:54 AM
To: Les Ginsberg (ginsberg) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>; BIER WG <[email-masked]>; [email-masked]
Subject: RFC 8401 clarification

Dear all

[Les:] As per https://tools.ietf.org/html/rfc7794#section-2.1

"X-Flag:  External Prefix Flag (Bit 0)
      Set if the prefix has been redistributed from another protocol.
      This includes the case where multiple virtual routers are
      supported and the source of the redistributed prefix is another
      IS-IS instance."

[Les:] When an L1L2 router advertises its local addresses it may do so in its own L1 and/or L2 LSPs. This is NOT "leaking" and the R-bit will NOT be set in such cases.
Leaking is when an L1L2 router leaks prefixes originated by other routers upwards or downwards.

   Les

Regards

Hooman

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 20 Sep 2018 09:11:22 -0700

On Thu, Sep 20, 2018 at 5:37 AM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Hooman –
>
>
>
> https://tools.ietf.org/html/rfc7794 is the authoritative document on
> IS-IS prefix attribute flags. RFC 8401 is NOT making any changes to  RFC
> 7794  (indeed – why would it?).
>
>
>

+1, additionally, LSR is chartered with this work, not BIER, so in a sense,
not my circus and stuff ;-)  ...

--- tony