Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 16 Nov 2018 23:12:32 +0000

Hi Stig,

I just submitted -04 revision and it should have addressed your comments (thank you for reviewing the diff beforehand).

Thanks.
Jeffrey

> -----Original Message-----
> From: BIER <[email-masked]> On Behalf Of Stig Venaas
> Sent: Tuesday, October 16, 2018 5:23 PM
> To: Greg Shepherd <[email-masked]>
> Cc: BIER WG <[email-masked]>
> Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa
> 
> Hi
> 
> I think the draft needs a little bit more work before publication.
> 
> It's not clear to me what the contents of the BAR and IPA fields are.
> 
> For BAR you say that it is BCBA and that for the currently defined
> algorithm 0, BC and BA are both NULL. But if new BIER algorithms are
> defined, how would you define BC? Is the idea that the values in the
> BIER algorithm registry signify both BC and BA? In that case the name
> is misleading.
> 
> For IPA it is also not clear how you specify RC for the different
> values of RA. The existing registry only specifies the RA.
> 
> In section 1 it says:
>    [To be added]
> Will anything be added here?
> 
> In section 2 it says:
> 
>    In [RFC8401] and [I-D.ietf-bier-ospf-bier-extensions], an 8-bit BAR
>    field and 8-bit IPA field are defined to signal the BIER specific
>    algorithm and generic IGP Algorithm respectively and only value 0 is
>    allowed for both fields currently.  This document specifies the
>    general rules for the two fields and their interaction when either or
>    both fields are not 0.
> 
> I think the term "currently" will be confusing once this becomes an RFC.
> "Currently" here talks about the situation prior to the publication of the
> RFC, it would no longer be true after publication.
> 
> Typo in the title.
> 
> Typo: multit-topolgy
> 
> Stig
> 
> On Tue, Oct 16, 2018 at 7:55 AM Greg Shepherd <[email-masked]> wrote:
> >
> > Today starts a WGLC two week timer for:
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dbier-2Dbar-2Dipa-
> 2D02&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=9Up4dsFxMx0w5cbbj5c7DKimcRHUXcjL7EQw6mygnp
> A&e=
> >
> > Please read and respond to this thread with/without support.
> >
> > Thanks,
> > Shep
> > (Chairs)
> > _______________________________________________
> > BIER mailing list
> > [email-masked]
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bier&d=DwICAg&c=HAkYuh63rsuhr6Scbf
> h0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=TcDDTfwL4a4v6qxlh7BvKbIsDtm-
> WeF4RR8xqjpAIag&e=
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bier&d=DwICAg&c=HAkYuh63rsuhr6Scbf
> h0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=TcDDTfwL4a4v6qxlh7BvKbIsDtm-
> WeF4RR8xqjpAIag&e=

---

From: Stig Venaas <[email-masked]>
Date: Fri, 16 Nov 2018 15:31:25 -0800

Right, looks good to me,

Stig

On Fri, Nov 16, 2018 at 3:14 PM Jeffrey (Zhaohui) Zhang
<[email-masked]> wrote:
>
> I meant the -03 revision.
>
> > From: Jeffrey (Zhaohui) Zhang
> > Sent: Friday, November 16, 2018 6:13 PM
> > To: 'Stig Venaas' <[email-masked]>; Greg Shepherd <[email-masked]>;
> > 'Tony Przygienda' <[email-masked]>
> > Subject: RE: [Bier] WGLC: draft-ietf-bier-bar-ipa
> >
> > Hi Stig,
> >
> > I just submitted -04 revision and it should have addressed your comments
> > (thank you for reviewing the diff beforehand).
> >
> > Thanks.
> > Jeffrey
> >

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 16 Nov 2018 23:12:59 +0000

---

From: Senthil Dhanaraj <[email-masked]>
Date: Mon, 19 Nov 2018 15:44:21 +0530

To the Authors,

(Excerpts from the draft - Section 2)

For a new IGP Algorithm to be used as a BIER IPA,
its RC/RA semantics MUST also be clear.

Senthil //

This statement is confusing.

Any new IGP algorithm (allocated by IANA in IGP registry) would have
already defined the semantics clearly in the corresponding lsr
document.

Do you mean "for the new IGP algorithms to be used as BIER IPA", we
again need to specify the semantics (from BIER/Multicast per-se) in a
separate document which proposes "a IGP algorithm to be used for BIER
IPA" ?

If yes, why ?

If no, may be we should remove above statement?, As its a
pre-requisite for any new IGP algorithm types and does't need explicit
mention in this document.

Thanks,

Senthil

On Sat, Nov 17, 2018 at 5:01 AM Stig Venaas <[email-masked]> wrote:

> https://www.ietf.org/mailman/listinfo/bier
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 19 Nov 2018 13:19:17 +0000

Hi Senthil,

I think that’s a reasonable requirement – if it is to be used for BIER (as you quoted from the draft). If it is not to be used for BIER, then of course there is no need to clarify its RC/RA semantics. The clarification would either be in its day-one specification, or a follow-up spec if it is applied to BIER only later.

Jeffrey

From: Senthil Dhanaraj <[email-masked]>
Sent: Monday, November 19, 2018 5:14 AM
To: [email-masked]
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa

To the Authors,

Senthil //

Any new IGP algorithm (allocated by IANA in IGP registry) would have already defined the semantics clearly in the corresponding lsr document.

Do you mean "for the new IGP algorithms to be used as BIER IPA", we again need to specify the semantics (from BIER/Multicast per-se) in a separate document which proposes "a IGP algorithm to be used for BIER IPA" ?

If yes, why ?

If no, may be we should remove above statement?, As its a pre-requisite for any new IGP algorithm types and does't need explicit mention in this document.

Thanks,

Senthil

On Sat, Nov 17, 2018 at 5:01 AM Stig Venaas <[email-masked]<mailto:[email-masked]>> wrote:
Right, looks good to me,

Stig

On Fri, Nov 16, 2018 at 3:14 PM Jeffrey (Zhaohui) Zhang
<[email-masked]<mailto:[email-masked]>> wrote:
> > To: 'Stig Venaas' <[email-masked]<mailto:[email-masked]>>; Greg Shepherd <[email-masked]<mailto:[email-masked]>>;
> > 'Tony Przygienda' <[email-masked]<mailto:[email-masked]>>
> > Cc: BIER WG <[email-masked]<mailto:[email-masked]>>
> > > From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Stig Venaas
> > > To: Greg Shepherd <[email-masked]<mailto:[email-masked]>>
> > > Cc: BIER WG <[email-masked]<mailto:[email-masked]>>
> > > On Tue, Oct 16, 2018 at 7:55 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
> > > >
> > > > [email-masked]<mailto:[email-masked]>
> > > [email-masked]<mailto:[email-masked]>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bier&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&m=4RfYTy3X3VzttZF14AHr_oAeDYurzCe6xOA3MaSWre0&s=hk9-yVxFjV5KkxhT6nRVMQ3OevGOFni4Yji2Rl51VsQ&e=>

---

From: Senthil Dhanaraj <[email-masked]>
Date: Mon, 19 Nov 2018 19:53:47 +0530

Hi Jeffrey,

Let me try to be more specific.

Lets take IGP Flex Algo as an example. (refer draft-ietf-lsr-flex-algo-01)
FlexAlgo can be defined locally and [the Algorithm-Id & the associated
constraints ] shall be advertised via IGP using FAD TLV.

Assuming we have defined a new FlexAlgo=128 with "constraints = exclude a
specific color", and we want to use this constraints for BIER multicast
path, then we just need to specify BAR=0, IPA=128. Why do we need to
specify the semantics of FlexAlgo=128 explicitly for BIER/Multicast ?

I assume that in most of the cases, the Constraints/FlexAlgo defined for
unicast traffic can be used as-is for Multicast path as well.
Cases, where we are required to define a constraint which is specific only
to multicast paths (ex: less span-out's), we would define the "new
constraint" as part of BCA in BAR (allocate the Id for BAR from BIER
Registry). Is't it ?

Thanks,
Senthil

On Mon, Nov 19, 2018 at 6:49 PM Jeffrey (Zhaohui) Zhang <[email-masked]>
wrote:

> Hi Senthil,
>
>
>
> I think that’s a reasonable requirement – if it is to be used for BIER (as
> you quoted from the draft). If it is not to be used for BIER, then of
> course there is no need to clarify its RC/RA semantics. The clarification
> would either be in its day-one specification, or a follow-up spec if it is
> applied to BIER only later.
>
>
>
> Jeffrey
>
>
>
> *From:* Senthil Dhanaraj <[email-masked]>
> *Sent:* Monday, November 19, 2018 5:14 AM
> *To:* [email-masked]
> *Cc:* Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked];
> [email-masked]
> *Subject:* Re: [Bier] WGLC: draft-ietf-bier-bar-ipa
>
>
>
> To the Authors,
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bier&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&m=4RfYTy3X3VzttZF14AHr_oAeDYurzCe6xOA3MaSWre0&s=hk9-yVxFjV5KkxhT6nRVMQ3OevGOFni4Yji2Rl51VsQ&e=>
>
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 19 Nov 2018 14:26:42 +0000

Hi Senthil,

The spec says:

Ø  For a new IGP Algorithm to be used as a BIER IPA,

Ø  its RC/RA semantics MUST also be clear.

In your example, the RC/RA semantics for the new algorithm is clear, so nothing needs to be done to apply it to BIER.
Only if the RC/RA semantics is not clear, then either it can’t be applied to BIER, or some clarification is needed.

Jeffrey

From: Senthil Dhanaraj <[email-masked]>
Sent: Monday, November 19, 2018 9:24 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]; Greg Shepherd <[email-masked]>; [email-masked]
Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa

Hi Jeffrey,

Lets take IGP Flex Algo as an example. (refer draft-ietf-lsr-flex-algo-01)
FlexAlgo can be defined locally and [the Algorithm-Id & the associated constraints ] shall be advertised via IGP using FAD TLV.

Assuming we have defined a new FlexAlgo=128 with "constraints = exclude a specific color", and we want to use this constraints for BIER multicast path, then we just need to specify BAR=0, IPA=128. Why do we need to specify the semantics of FlexAlgo=128 explicitly for BIER/Multicast ?

I assume that in most of the cases, the Constraints/FlexAlgo defined for unicast traffic can be used as-is for Multicast path as well.
Cases, where we are required to define a constraint which is specific only to multicast paths (ex: less span-out's), we would define the "new constraint" as part of BCA in BAR (allocate the Id for BAR from BIER Registry). Is't it ?

Thanks,
Senthil

On Mon, Nov 19, 2018 at 6:49 PM Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Senthil,

Jeffrey

From: Senthil Dhanaraj <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 19, 2018 5:14 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa

To the Authors,

Senthil //

If yes, why ?

Thanks,

Senthil

Stig