Subject: [Bier] Feedback on draft-hu-bier-bfd-02

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 8 Nov 2018 03:54:52 +0000

Hi,

I just took a quick look at the draft:

  1.  Section 1, 2nd paragraph mentions “…detect unicast failures..”, I believe this should be unidirectional?
  2.  Section 1, 3rd paragraph says that active-tail is for further study. So when a tail detects a failure, how will the head be notified? If the head does not have to be notified, what action is taken?

Regards,
Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 8 Nov 2018 04:20:58 +0000

And now adding the BFD alias.

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thursday, November 8, 2018 at 10:54 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Feedback on draft-hu-bier-bfd-02

Hi,

Regards,
Reshad.

---

From: <[email-masked]>
Date: Thu, 8 Nov 2018 12:27:19 +0800 (CST)

Hi, Rahman

Thanks for your comments.

Plese see inline marked with[hfw].

 

>1.Section 1, 2nd paragraph mentions “…detect unicast failures..”, I believe this  should be unidirectional?

[hfw] Agree, the BFD multipoint document only defines the unidirectional deteck from header to one or more tails.

>2.Section 1, 3rd paragraph says that active-tail is for further study. So when a tail detects a failure, how will the head be notified?  If the head does not have to be notified, what action is taken?

[hfw] Ok. Actually, we are considering the active-tails solution. It  will be added in the next version.

Regards

Fangwei.

发件人：ReshadRahman(rrahman) <[email-masked]>
收件人：[email-masked] <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2018年11月08日 11:56
主 题 ：Feedback on draft-hu-bier-bfd-02

Hi,

Section 1, 2nd paragraph mentions “…detect unicast failures..”, I believe this  should be unidirectional?

Section 1, 3rd paragraph says that active-tail is for further study. So when a tail detects a failure, how will the head be notified?  If the head does not have to be notified, what action is taken?

Regards,

Reshad.

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 8 Nov 2018 12:18:27 +0700

Hi Reshad,
thank you for taking the time to review and sharing your comments, much
appreciated. I'll add to answers by Fangwei, please find them in-line
tagged GIM>>.

Regards,
Greg

> deteck from header to one or more tails.
GIM>> Great catch, thank you. Will fix in the next version.

> >2.Section 1, 3rd paragraph says that active-tail is for further study.
> So when a tail detects a failure, how will the head be notified?  If the
> head does not have to be notified, what action is taken?
>
GIM>> Our plan is to use BFD for Multipoint Network with Active Tail
specfication as the base for this mode. Since tails in p2mp BFD are in the
Demand mode the head only can query all tail and/or the particular tail
using the Poll sequence (referred as multicast and unicast Poll). Depending
on the type of the failure, the head may recieve or not the BFD control
message with Final flag set. Absence of the response in combination with
the content of the Diag field must be used to draw the conclusion on
liveleness of the path from the head to the particular tail. From here the
head may use BIER Ping to localize the defect and switch to using the
alternative path through the BIER domain by using different transient BFRs.

>
> Regards
>
> Fangwei.
> *发件人：*ReshadRahman(rrahman) <[email-masked]>
> *收件人：[email-masked] <[email-masked]>;
> *抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
> *日 期 ：*2018年11月08日 11:56
> *主 题 ：**Feedback on draft-hu-bier-bfd-02*
>
> Hi,
>
>
>
>    1.
>    2.
>    Section 1, 3rd paragraph says that active-tail is for further study.
>    So when a tail detects a failure, how will the head be notified?  If the
>    head does not have to be notified, what action is taken?
>
>
>
> Regards,
>
> Reshad.
>
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 8 Nov 2018 12:20:43 +0700

Apologies for the duplicate.
Now with the corrected BFD WG alias.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 8 Nov 2018 05:22:45 +0000

Thanks Greg and Fangwei. As discussed in BIER meeting, please add a reference to draft-xiong-bier-resilience.

Regards,
Reshad.

From: Greg Mirsky <[email-masked]>
Date: Thursday, November 8, 2018 at 12:18 PM
To: "[email-masked]" <[email-masked]>
Cc: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>, BIER WG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Feedback on draft-hu-bier-bfd-02

Hi Reshad,
thank you for taking the time to review and sharing your comments, much appreciated. I'll add to answers by Fangwei, please find them in-line tagged GIM>>.

Regards,
Greg

On Thu, Nov 8, 2018 at 11:27 AM <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Rahman

[hfw] Ok. Actually, we are considering the active-tails solution. It  will be added in the next version.
GIM>> Our plan is to use BFD for Multipoint Network with Active Tail specfication as the base for this mode. Since tails in p2mp BFD are in the Demand mode the head only can query all tail and/or the particular tail using the Poll sequence (referred as multicast and unicast Poll). Depending on the type of the failure, the head may recieve or not the BFD control message with Final flag set. Absence of the response in combination with the content of the Diag field must be used to draw the conclusion on liveleness of the path from the head to the particular tail. From here the head may use BIER Ping to localize the defect and switch to using the alternative path through the BIER domain by using different transient BFRs.

Regards

Fangwei.
发件人：ReshadRahman(rrahman) <[email-masked]<mailto:[email-masked]>>
收件人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
日 期 ：2018年11月08日 11:56
主 题 ：Feedback on draft-hu-bier-bfd-02
Hi,

Regards,
Reshad.