Subject: [Bier] Prague Agenda

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 01:34:09 -0700

Unlike meetings past, our agenda for this week is quite light. I did
however find an email that slipped my agenda filter, so maybe others failed
to follow directions and respond to the request thread directly. So, here
is what we have so far. If something is missing please let me know ASAP so
we can make correction.

BIER WG Agenda

IETF 104, Prague
Monday, 25 March 2019 09:00-12:20
Karlin 3

Welcome, Notewell, Agenda bash 5min Chairs
draft-xie-bier-ipv6-mvpn-00 10min Jingrong Xie
draft-ietf-bier-mtud 10min
draft-ietf-bier-mld 5min Stig Venaas
ietf-bier-bgp-ls-bier-ext-04
draft-ietf-bier-bier-yang-04
draft-chen-pce-bier-04 20min Ran Chen
draft-ietf-bier-te-01 10min Toerless Eckert

Thanks,
Shep
(Chairs)

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 01:42:14 -0700

Already an update:

BIER WG Agenda

IETF 104, Prague

draft-dhanaraj-bier-lsr-ethernet-extensions 10min Senthil Dhanaraj

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 02:17:01 -0700

..and more updates. I've added two agenda items as I received slides for
them (to the wrong email address...) but no actual agenda request.
Following instructions is hard. :)

I'm going to publish this version. I'll check email later for any updates.
Still some slides missing too (you know who you are). We are on deck
tomorrow at 0900 so there's not much time left. I won't take slides in the
room.

BIER WG Agenda

IETF 104, Prague

Welcome, Notewell, Agenda bash 5min Chairs
draft-ietf-bier-mtud 10min
draft-ietf-bier-mld 5min Stig Venaas
draft-dhanaraj-bier-lsr-ethernet-extensions 10min Senthil Dhanaraj
ietf-bier-bgp-ls-bier-ext-04
draft-ietf-bier-bier-yang-04
draft-chen-pce-bier-04 20min Ran Chen
ietf104-slides-bier-ipv6-encapsulation
draft-mcbride-bier-ipv6-problem-statement 10min Mike McBride
draft-xie-bier-6man-encapsulation 10min Jingrong Xie
draft-xie-bier-ipv6-mvpn-00 10min Jingrong Xie
draft-ietf-bier-te-01 10min Toerless Eckert

-Shep
(Chairs)

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 02:33:29 -0700

Here's the latest agenda just published:

BIER WG Agenda

IETF 104, Prague

Welcome, Notewell, Agenda bash 5min Chairs
draft-ietf-bier-mtud 10min
draft-ietf-bier-mld 5min Stig Venaas
draft-dhanaraj-bier-lsr-ethernet-extensions 10min Senthil Dhanaraj
draft-purkayastha-bier-multicast-http-response 15min Purkayastha
ietf-bier-bgp-ls-bier-ext-04
draft-ietf-bier-bier-yang-04
draft-chen-pce-bier-04 20min Ran Chen
draft-mcbride-bier-ipv6-problem-statement
ietf104-slides-bier-ipv6-encapsulation 10min Mike McBride
draft-xie-bier-6man-encapsulation 10min Jingrong Xie
draft-xie-bier-ipv6-mvpn-00 10min Jingrong Xie
draft-ietf-bier-te-01 10min Toerless Eckert

Anything else?

-Shep
(Chairs)

---

From: Michael Menth <[email-masked]>
Date: Sun, 24 Mar 2019 11:00:37 +0100

Hi Greg,

my presentation on BIER-FRR is missing. Details are in the attached
email. Can you add that talk, please?

Kind Regards,

Michael

Am 24.03.2019 um 10:33 schrieb Greg Shepherd:
> Welcome, Notewell, Agenda bash5minChairs
> draft-ietf-bier-mtud10min
> draft-ietf-bier-mld5minStig Venaas
> draft-dhanaraj-bier-lsr-ethernet-extensions10minSenthil Dhanaraj
> draft-purkayastha-bier-multicast-http-response15minPurkayastha
> draft-chen-pce-bier-0420minRan Chen
> ietf104-slides-bier-ipv6-encapsulation10minMike McBride
> draft-xie-bier-6man-encapsulation10minJingrong Xie
> draft-xie-bier-ipv6-mvpn-0010minJingrong Xie
> draft-ietf-bier-te-0110minToerless Eckert
> 
> Anything else?
> 
> -Shep
> (Chairs)
> 
> On Sun, Mar 24, 2019 at 2:17 AM Greg Shepherd <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     ..and more updates. I've added two agenda items as I received slides
>     for them (to the wrong email address...) but no actual agenda
>     request. Following instructions is hard. :)
> 
>     I'm going to publish this version. I'll check email later for any
>     updates. Still some slides missing too (you know who you are). We
>     are on deck tomorrow at 0900 so there's not much time left. I won't
>     take slides in the room.
> 
>     BIER WG Agenda
> 
>     IETF 104, Prague
>     Welcome, Notewell, Agenda bash5minChairs
>     draft-ietf-bier-mtud10min
>     draft-ietf-bier-mld5minStig Venaas
>     draft-dhanaraj-bier-lsr-ethernet-extensions10minSenthil Dhanaraj
>     draft-chen-pce-bier-0420minRan Chen
>     draft-mcbride-bier-ipv6-problem-statement10minMike McBride
>     draft-xie-bier-6man-encapsulation10minJingrong Xie
>     draft-xie-bier-ipv6-mvpn-0010minJingrong Xie
>     draft-ietf-bier-te-0110minToerless Eckert
> 
>     -Shep
>     (Chairs)
> 
>     On Sun, Mar 24, 2019 at 1:42 AM Greg Shepherd <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Already an update:
> 
>         BIER WG Agenda
> 
>         IETF 104, Prague
>         Welcome, Notewell, Agenda bash5minChairs
>         draft-ietf-bier-mtud10min
>         draft-ietf-bier-mld5minStig Venaas
>         draft-dhanaraj-bier-lsr-ethernet-extensions10minSenthil Dhanaraj
>         draft-chen-pce-bier-0420minRan Chen
>         draft-xie-bier-ipv6-mvpn-0010minJingrong Xie
>         draft-ietf-bier-te-0110minToerless Eckert
> 
> 
> 
>         On Sun, Mar 24, 2019 at 1:34 AM Greg Shepherd <[email-masked]
>         <mailto:[email-masked]>> wrote:
> 
>             Unlike meetings past, our agenda for this week is quite
>             light. I did however find an email that slipped my agenda
>             filter, so maybe others failed to follow directions and
>             respond to the request thread directly. So, here is what we
>             have so far. If something is missing please let me know ASAP
>             so we can make correction.
> 
>             BIER WG Agenda
> 
>             IETF 104, Prague
>             Welcome, Notewell, Agenda bash5minChairs
>             draft-xie-bier-ipv6-mvpn-0010minJingrong Xie
>             draft-ietf-bier-mtud10min
>             draft-ietf-bier-mld5minStig Venaas
>             draft-chen-pce-bier-0420minRan Chen
>             draft-ietf-bier-te-0110minToerless Eckert
> 
>             Thanks,
>             Shep
>             (Chairs)
> 
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

Subject: Re: New Version Notification for draft-merling-bier-frr-00.txt
From: Michael Menth <[email-masked]>
To: [email-masked], Daniel Merling <[email-masked]>
Date: Tue, 5 Mar 2019 11:28:59 +0100

Dear WG,

please find attached a new draft for BIER-FRR. We would like to present
it in Prague and are happy to receive feedback.

Kind regards,

Michael

Am 05.03.2019 um 11:22 schrieb [email-masked]:
> 
> A new version of I-D, draft-merling-bier-frr-00.txt
> has been successfully submitted by Daniel Merling and posted to the
> IETF repository.
> 
> Name:		draft-merling-bier-frr
> Revision:	00
> Title:		BIER Fast Reroute
> Document date:	2019-03-05
> Group:		Individual Submission
> Pages:		15
> URL:            https://www.ietf.org/internet-drafts/draft-merling-bier-frr-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-merling-bier-frr/
> Htmlized:       https://tools.ietf.org/html/draft-merling-bier-frr-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-merling-bier-frr
> 
> 
> Abstract:
>    BIER is a scalable multicast overlay [RFC8279] that utilizes some
>    routing underlay, e.g., IP, to build up its Bit Index Forwarding
>    Tables (BIFTs).  This document proposes a Fast Reroute Extension for
>    BIER (BIER-FRR).  In case of a link or node failure, the routing
>    underlay may first utilize FRR techniques to restore connectivity and
>    then its forwarding tables converge.  After that, BIER can update its
>    BIFTs, which requires time.  BIER packets may not be delivered until
>    the last procedure has finished.  With BIER-FRR, a BIER Forwarding
>    Router (BFR) can deliver BIER packets again after a link or node
>    failures as soon as the connectivity within the routing underlay is
>    restored and the BFR is informed about a next-hop (NH) that is
>    unreachable on a lower layer.  BIER-FRR provides a mode for link
>    protection and node protection.  For link protection, it tunnels
>    traffic to the next-hop using the underlying routing.  For node
>    protection, it forwards BIER packets to their specific next-hop and
>    next-next-hops using tunnels in the underlying routing after applying
>    a suitable backup bitmask to the bitstring in the BIER header of each
>    packet.  This procedure prevents duplicates.  If topology allows,
>    BIER-FRR achieves full protection against any single component
>    failure.  For link protection, BIER-FRR requires only a minor change
>    to the forwarding logic.  For node protection, BIER-FRR also requires
>    backup entries in the BIFT.
> 
>    This document describes the concept and operating principles of BIER-
>    FRR.  It defines the necessary modifications to the BIER forwarding
>    Procedure and the BIFT, and explains how backup entries are computed.
> 
>                                                                                   
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 03:12:54 -0700

And more updates..

BIER WG Agenda

IETF 104, Prague

Welcome, Notewell, Agenda bash 5min Chairs
draft-ietf-bier-mtud 10min
draft-ietf-bier-mld 5min Stig Venaas
draft-dhanaraj-bier-lsr-ethernet-extensions 10min Senthil Dhanaraj
draft-purkayastha-bier-multicast-http-response 15min Purkayastha
draft-merling-bier-frr-00 10min Michael Menth
ietf-bier-bgp-ls-bier-ext-04
draft-chen-pce-bier-04
draft-ietf-bier-bier-yang-04 20min Ran Chen
draft-zhang-bier-te-yang-07 5min Sandy Zhang
draft-xiong-bier-resilience-02
draft-hu-bier-bfd-03 15min Quan
draft-mcbride-bier-ipv6-problem-statement
ietf104-slides-bier-ipv6-encapsulation 10min Mike McBride
draft-xie-bier-ipv6-mvpn-00 10min Jingrong Xie
draft-ietf-bier-te-01 10min Toerless Eckert

On Sun, Mar 24, 2019 at 2:33 AM Greg Shepherd <[email-masked]> wrote:

>> updates. Still some slides missing too (you know who you are). We are on
>> deck tomorrow at 0900 so there's not much time left. I won't take slides in
>> the room.
>>
>> BIER WG Agenda
>>
>> IETF 104, Prague

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 24 Mar 2019 03:27:40 -0700

All receive slides are published, some still missing. This is the latest
agenda:

BIER WG Agenda

IETF 104, Prague

0-Welcome, Notewell, Agenda bash 5min Chairs
1-draft-ietf-bier-mtud 10min
2-draft-ietf-bier-mld 5min Stig Venaas
3-draft-dhanaraj-bier-lsr-ethernet-extensions 10min Senthil Dhanaraj
4-draft-purkayastha-bier-multicast-http-response 15min Purkayastha
5-draft-merling-bier-frr-00 10min Michael Menth
6-ietf-bier-bgp-ls-bier-ext-04
7-draft-chen-pce-bier-04
8-draft-ietf-bier-bier-yang-04 20min Ran Chen
9-draft-zhang-bier-te-yang-07 5min Sandy Zhang
10-draft-xiong-bier-resilience-02
11-draft-hu-bier-bfd-03 15min Quan
12-draft-mcbride-bier-ipv6-problem-statement
13-ietf104-slides-bier-ipv6-encapsulation 10min Mike McBride
14-draft-xie-bier-ipv6-mvpn-00 10min Jingrong Xie
15-draft-ietf-bier-te-01 10min Toerless Eckert

---

From: Xiejingrong <[email-masked]>
Date: Mon, 25 Mar 2019 05:23:16 +0000

Hi Greg,

aren't there two BIER sessions with total 4 hours today ?  can we ask for a longer time for the following presentation since there are many things to discuss according to the feedback on ietf103.

15min
15min

thanks,
jingrong (on behalf of the authors)
From:Greg Shepherd <[email-masked]>
To:BIER WG <[email-masked]>
Date:2019-03-24 11:13:29
Subject:Re: [Bier] Prague Agenda

And more updates..

BIER WG Agenda

IETF 104, Prague

On Sun, Mar 24, 2019 at 2:33 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Here's the latest agenda just published:

BIER WG Agenda

IETF 104, Prague

Anything else?

-Shep
(Chairs)

On Sun, Mar 24, 2019 at 2:17 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
..and more updates. I've added two agenda items as I received slides for them (to the wrong email address...) but no actual agenda request. Following instructions is hard. :)

I'm going to publish this version. I'll check email later for any updates. Still some slides missing too (you know who you are). We are on deck tomorrow at 0900 so there's not much time left. I won't take slides in the room..

BIER WG Agenda

IETF 104, Prague

-Shep
(Chairs)

On Sun, Mar 24, 2019 at 1:42 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Already an update:

BIER WG Agenda

IETF 104, Prague

On Sun, Mar 24, 2019 at 1:34 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Unlike meetings past, our agenda for this week is quite light. I did however find an email that slipped my agenda filter, so maybe others failed to follow directions and respond to the request thread directly. So, here is what we have so far. If something is missing please let me know ASAP so we can make correction.

BIER WG Agenda

IETF 104, Prague

Thanks,
Shep
(Chairs)

---

From: Xiejingrong <[email-masked]>
Date: Mon, 25 Mar 2019 05:56:46 +0000

it's 3 hours.
so maybe 20 minutes for the below two drafts.

thanks!
From:Xiejingrong <[email-masked]>
To:[email-masked] <[email-masked]>;BIER WG <[email-masked]>
Date:2019-03-25 06:23:53
Subject:Re: [Bier] Prague Agenda

Hi Greg,

thanks,

And more updates..

BIER WG Agenda

IETF 104, Prague

BIER WG Agenda

IETF 104, Prague

Anything else?

-Shep
(Chairs)

BIER WG Agenda

IETF 104, Prague

-Shep
(Chairs)

BIER WG Agenda

IETF 104, Prague

On Sun, Mar 24, 2019 at 1:34 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Unlike meetings past, our agenda for this week is quite light. I did however find an email that slipped my agenda filter, so maybe others failed to follow directions and respond to the request thread directly.. So, here is what we have so far. If something is missing please let me know ASAP so we can make correction.

BIER WG Agenda

IETF 104, Prague

Thanks,
Shep
(Chairs)