Subject: [Bier] Direction: draft-xie-bier-ipv6-encapsulation

From: Greg Shepherd <[email-masked]>
Date: Mon, 16 Mar 2020 17:50:30 -0700

draft-xie-bier-ipv6-encapsulation authors,

To date, there has been insufficient support on the list to adopt the
draft. It is the BIER WG position at this time that a review by the 6man WG
should take place before any further discussion in the BIER WG.

6MAN WG review aside, the draft still raises significant technical concerns
within the BIER WG. Adding replication information into a programmatic header
does NOT add replication to programmatic forwarding path, nor programmatics
to your replication forward path. It is at this point where replication
begins that all prograrmmatics cease due to the multi-point nature of
replication.  We have a nearly three decades of experience trying to use
unicast semantics to describe multi-point forwarding, and sometimes
learning from the past requires leaving it.

Thanks you,
Chairs

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 17 Mar 2020 02:37:34 +0100

Thanks, Greg, inline

On Mon, Mar 16, 2020 at 05:50:30PM -0700, Greg Shepherd wrote:
> within the BIER WG.

I think this should be a recommendation to both BIER for IPv6 drafts.

> Adding replication information into a programmatic header

I really do not understand what that means. Can you rephrase that, please ?

Maybe also through comparison with Sandy's drafts way to do things ?
To me (subject to 6man review) Xie's draft could be a nice way to
be relying on the spirit of rfc8200 and the use of Addresses as SIDs
to support BIER with IPv6 and VPNs.

BIER with MPLS is AFAIK nostly required/desired as a replacement of
pre-BIER solutions for MPLS-VPN. How is this supposed to be done with
BIER via IPv6 ?

Cheers
    Toerless

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

-- 
---
[email-masked]

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Tue, 17 Mar 2020 09:36:23 +0000

Dear the chairs,

See inline below >>

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Tuesday, March 17, 2020 8:51 AM
To: BIER WG <[email-masked]>
Subject: [Bier] Direction: draft-xie-bier-ipv6-encapsulation

To date, there has been insufficient support on the list to adopt the draft. It is the BIER WG position at this time that a review by the 6man WG should take place before any further discussion in the BIER WG.

Can you confirm that we are not allowed to discuss about this draft in BIER WG -- Either solely BIER related issues, or cross-WG issues ?

6MAN WG review aside, the draft still raises significant technical concerns within the BIER WG. Adding replication information into a programmatic header does NOT add replication to programmatic forwarding path, nor programmatics to your replication forward path. It is at this point where replication begins that all prograrmmatics cease due to the multi-point nature of replication.  We have a nearly three decades of experience trying to use unicast semantics to describe multi-point forwarding, and sometimes learning from the past requires leaving it.

Thanks you,
Chairs

---

From: Michael McBride <[email-masked]>
Date: Tue, 17 Mar 2020 16:27:14 +0000

Hi Greg,

>To date, there has been insufficient support on the list to adopt the draft.

We won’t know unless we ask the WG.

>It is the BIER WG position at this time that a review by the 6man WG should take place before any further discussion in the BIER WG.

You mean the bier chairs position. Either way a punt to 6man for bierv6 work is fair. We will return and report.

>6MAN WG review aside, the draft still raises significant technical concerns within the BIER WG. Adding replication information into a programmatic header does NOT add replication to programmatic for…

Perhaps others can help me understand what this means. Regardless, what we will do for the time being, in bier wg, is continue working on gaining bier wg consensus of the requirements, in our draft-ietf-bier-ipv6-requirements, to help steer the wg toward agreeable solutions.

mike

Thanks you,
Chairs

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 17 Mar 2020 10:37:48 -0700

Mike,

On Tue, Mar 17, 2020 at 9:27 AM Michael McBride <
[email-masked]> wrote:

> Hi Greg,
>
>
>
> *>*To date, there has been insufficient support on the list to adopt the
> draft.
>
>
>
> >It is the BIER WG position at this time that a review by the 6man WG

Thanks Mike. Please keep the BIER WG updated on your progress in 6MAN.

> >6MAN WG review aside, the draft still raises significant technical
> concerns within the BIER WG. Adding replication information into a
> programmatic header does NOT add replication to programmatic forwarding
> path, nor programmatics to your replication forward path. It is at this
> point where replication begins that all prograrmmatics cease due to the
> multi-point nature of replication.  We have a nearly three decades of
> experience trying to use unicast semantics to describe multi-point
> forwarding, and sometimes learning from the past requires leaving it.
>
>
>
> Perhaps others can help me understand what this means. Regardless, what we
> will do for the time being, in bier wg, is continue working on gaining bier
> wg consensus of the requirements, in our draft-ietf-bier-ipv6-requirements,
> to help steer the wg toward agreeable solutions.
>

I look forward to further discussions around reqs. Once we have consensus
on reqs, the WG will be open to solutions drafts in this space.

Thanks again,
Chairs
(Shep)

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 17 Mar 2020 13:17:52 -0700

+1 basically

1st, it is advised for the draft to validate that their assumptions as to
packet processing and IPv6 conformance hold, refer to questions raised
among others in IETF 105 meeting minutes (if I record correctly).

2nd,yes, we should focus on the requirements document at this point in time
state of which leaves a lot to be desired IMO. I will dig out my old
comments in next days and let's work on this.

--- tony

On Tue, Mar 17, 2020 at 10:38 AM Greg Shepherd <[email-masked]> wrote:

>> Perhaps others can help me understand what this means. Regardless, what
>> we will do for the time being, in bier wg, is continue working on gaining
>> bier wg consensus of the requirements, in our
>> draft-ietf-bier-ipv6-requirements, to help steer the wg toward agreeable
>> solutions.
>>
>