Subject: [Bier] BIER-TE -07 uploaded (was: Re: Pls "vote" on name (draft-ietf-bier-te-arch))

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Mar 2020 23:12:57 +0100

Thanks for everybody chiming into the WG last call of this document,
i hope the chairs can declare it to have successfully finished WG
work now and pass it to the responsible AD for further IETF processing:

I did push the -07 update to the draft that changes the name to
BIER-TE "Tree Engineering" as shown to be the consensus of the WG.

I btw. also like "Tree Engineering" the most, but did not 
suggest it initially, in an attempt to satisfy Debra's concern,
but also agree very much with what Greg said about the point. 
Also, see my email reply to Debra early and the points it made.

-07 also includes explanation about that name change and the relationship
to "Traffic Engineering" as a note on top of the document marked for removal
by RFC-editor, so that further reviews by AD/IETF/IESG can be on top of
the these two points without the need to argue about the RFC viability of such
explanations (was not sure everybody reads changelog).

I had hoped to receive a followup from Lou re. his suggestion for
additional text about "Traffic Engineering". I also polled him in PM
last week, but no further reply. This is not a complained, i know
how everybody is busy, but i think if he wants to provide further simple text to 
provide additional documentation for that relationship, then he can
always do it still in IETF review.

Nevertheless, i feel it would be more appropriate to take relationships
about Tree Engineering and Traffic Engineering to the
proposed TEAS BIER-TE framework document, which i am happy to revive
and improve upon after this draft is an RFC. Especially also given
Alias guidance when we adopted the document in the WG, that traffic
engineering must be done in TEAS and that BIER should only do the
BIER related forwarding plane aspects. Which is exactly what the
document does.

IMHO, there are no further "Traffic Engineering" considerations
that would change any technical aspects of this document. As i
explained in another email, both BIER and BIER-TE could be part of
a traffic engineering as i understand the options. BIER of course
being more limited by the path steering solution it is combined with,
like Flex-Algos). Hence i feel further "Traffic Engineering" aspects
would be misplaced in this document anyhow.

Cheers
    Toerless

On Mon, Mar 02, 2020 at 03:56:51PM +0800, [email-masked] wrote:
> +1.
> 
> 
> Seems like the previous mail has been lost. So I sent the mail again.
> 
> 
> 
> 
> 
> 
> Thanks,
> 
> 
> Sandy
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> ????????????
> 
> 
> 
> ????????????GregShepherd <[email-masked]>
> ????????????Acee Lindem (acee) <[email-masked]>;
> ????????????Dirk Trossen <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;BRUNGARD,DEBORAH A <[email-masked]>;Toerless Eckert <[email-masked]>;Lou Berger <[email-masked]>;[email-masked] <[email-masked]>;
> ??? ??? ???2020???02???29??? 00:00
> ??? ??? ???Re: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)
> 
> 
> 
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
> 
> 
> My vote: BIER-TE Call it Tree Engineering. If we were so concerned with acronym overuse the IETF would grind to a halt... I've been involved in other WGs where I felt the name missed the mark describing the ideas in the draft, but felt reading the draft was how someone got their heads around the proposed solution, rather than miss-read the title and run away confused. ie - Vlex-Algo. No, it's Flex-Topo, but what's to be gained from arguing for a name at this point? 
> 
> 
> Yes, we should strive to be as 'correct' as possible. But the IETF is full of baggage that engineers have managed to wade through, make sense of, and implement successfully. Get the spec right, No #1 priority. If you don't like the name, read on. It will grow on you. :)
> 
> 
> Shep (w/o chair hat)
> 
> 
> 
> 
> On Fri, Feb 28, 2020 at 7:31 AM Acee Lindem (acee) <[email-masked]> wrote:
> 
> If you go with PBR, you could continue the BIER WG traditional of selecting brew-based acronyms. Hence, that would be my vote. It could be confused with Policy Based Routing but only if someone actually implements it.
> Thanks,
> Acee
> 
> ???On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:
> 
>     Sure, Just reply wth the ones you like whether existing or added and
>     give them the weiht you like, e.g.: from your email something like:
> 
>     5  BIER-PBR    (Path Based Routing)
>     5  BIER-PST    (Path based STeering)
>     3  BIER-PE     (Path Engineering)
> 
>     On Fri, Feb 28, 2020 at 07:54:07AM +0000, Dirk Trossen wrote:
>     > Toerless, all,
>     > 
>     > May I add to the mix (which might not help) with the proposal for 'path-based routing' (or BIER-PBR) or 'path-based steering' (or BIER-PST)? If you want to keep a two letter acronym, I'd add 'path steering' (rather than path engineering) to the mix. From the below, without considering any alternatives, I'd go for BIER-PE but it comes with the issues like many two letter acronyms, namely the higher 'collision rate' with others.
>     > 
>     > Best,
>     > 
>     > Dirk
>     > 
>     > 
>     > 
>     > -----Original Message-----
>     > From: BIER [mailto:[email-masked]] On Behalf Of Toerless Eckert
>     > Sent: 27 February 2020 21:41
>     > To: [email-masked]
>     > Cc: Lou Berger <[email-masked]>; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]
>     > Subject: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)
>     > 
>     > Dear WG
>     > 
>     > Please chime in with opinions about the following or any new name you like as the new name for BIER-TE. Timeout is deadline for submission of draft before IETF107, when i'll post an update. If you propose a new name try to avoid re-using abbreviations that may be misinterpreted.
>     > 
>     > 5 = best name ever, ... 1 = lame name, no number assigned means 0 votes are just added up and maximum sum option wins.
>     > Explanations if you haven't followed thread at the end.
>     > 
>     > BIER-PE  - Path Engineering
>     > BIER-ET  - Explicit Trees
>     > BIER-EET - Explicit Engineered Trees
>     > BIER-BET - Bit Engineered Trees
>     > BIER-BST - Bit Steered Trees
>     > BIER-TrE - Tree engineering
>     > BIER-ET  - Engineered Trees
>     > BIER-ST  - Steered Trees
>     > 
>     > BIER-ASB - Adjacency Steering Bits   (adjacencies are how bits in BIER-PE are defined)
>     > BIER-AB  - Adjacency Bits
>     > BIER-SB  - Steering Bits             (overloads with "Source Block" - never heard)
>     > 
>     > Thanks,
>     >     Toerless
>     > 
>     > Explanations: If you have read through the threads with Lou and Deborah, and my understanding is correct:
>     > 
>     > Lou desired there to be a new name so BIER-TE the forwarding/steering mechanism (this document) is named differently from BIER-TE the larger framework utilizing TEAS/PCE definition (separate future draft).
>     > 
>     > Lou did not like my "Path Engineering" proposal as the name in the last version of the doc and felt we should pick a name with Steering/routing-policy in it. I think usn only steering/routing would be misleading (confused with unicast approaches).
>     > 
>     > Deborah pointed to avoiding confusions in the name with pre-established named (e.g.: "PE" meaning Provider Edge).
>     > Said we should finalize on the name before we as the WG should pass the document to IESG. And she asked chairs to extend last-call by one more week (unrelated). Hence timeout end of next week.
>     > 
>     > _______________________________________________
>     > BIER mailing list
>     > [email-masked]
>     > https://www.ietf.org/mailman/listinfo/bier
>     > 
>     > _______________________________________________
>     > BIER mailing list
>     > [email-masked]
>     > https://www.ietf.org/mailman/listinfo/bier
> 
>     -- 
>     ---
>     [email-masked]...de
> 
>     _______________________________________________
>     BIER mailing list
>     [email-masked]
>     https://www.ietf.org/mailman/listinfo/bier

-- 
---
[email-masked]

---

From: Lou Berger <[email-masked]>
Date: Wed, 11 Mar 2020 19:42:31 -0400

On 3/11/2020 6:12 PM, Toerless Eckert wrote:
> additional text about "Traffic Engineering".

Sorry I didn't see any message seriously asking for input into the 
document, public or private or otherwise.  As I stated previously, I'm 
happy to provide such. I'll try to produce it over the weekend, but it 
may be into next week.  Things are a bit busy for the moment -- I 
haven't even been able to keep up on the IETF list entertainment!

Lou

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 12 Mar 2020 02:04:31 +0100

On Wed, Mar 11, 2020 at 07:42:31PM -0400, Lou Berger wrote:
> Sorry I didn't see any message seriously asking for input into the document,
> public or private or otherwise. 

https://mailarchive.ietf.org/arch/msg/bier/5SMrtPDgBo861DVf4ZcstXL1b78/
https://mailarchive.ietf.org/arch/msg/bier/lNsrv3d28gHiOPSnVe9TpLUM_z4/
PM March 5th "Subject: Lou: Re: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)"

> As I stated previously, I'm happy to
> provide such. I'll try to produce it over the weekend, but it may be into
> next week.  Things are a bit busy for the moment -- I haven't even been able
> to keep up on the IETF list entertainment!

As i said in my mails, i am completely unclear as to what you would
want to write, and its not clear to me either why it better would go
into this document than into the planned TEAS framework document.

Would be happy to also have a quick voice call if you prefer that.

Cheers
    Toerless

---

From: Lou Berger <[email-masked]>
Date: Thu, 12 Mar 2020 07:11:57 -0400

Stay tuned, I'll try to send the text over the weekend, but it may be next 
week....

----------