Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

From: <[email-masked]>
Date: Tue, 16 Mar 2021 14:40:48 +0800 (CST)

A 2-week WG adoption call begins for the following draft:

https://datatracker.ietf.org/doc/draft-chen-bier-frr/

Please indicate your support or objection by March 30th, 2021.

Authors, please respond to the list indicating whether you are aware of any IPR that applies to this draft.

Thanks,

Sandy (As WG secretary, on behalf of Greg/Tony)

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 16 Mar 2021 11:08:30 +0100

+1

I think it's a good addition within the architecture for the case IGP is
not used for signalling, e.g. when controller or static programming.

The draft must however explain in what scenarios it is used and quote the
according IGP drafts to guarantee loop-free behavior (well, BIER will
tie-break loops but we'll have 1x microloop & possibly not deliver payload
if BIER FRR is not properly computed/intsalled). With that the draft should
also pay attention to how the function is deployed/updated network-wide if
IGP is not present

thanks

-- tony

---

From: Michael Menth <[email-masked]>
Date: Tue, 16 Mar 2021 12:11:16 +0100

Hi Tony, all,

> not used for signalling, e.g. when controller or static programming.

Right. The solution may make sense if the routing underlay does not
offer FRR capabilities.

> 
> The draft must however explain in what scenarios it is used and quote
> the according IGP drafts to guarantee loop-free behavior (well, BIER
> will tie-break loops but we'll have 1x microloop & possibly not deliver
> payload if BIER FRR is not properly computed/intsalled). With that the
> draft should also pay attention to how the function is deployed/updated
> network-wide if IGP is not present

I agree. in the absence of an IGP, the "native BIER-FRR on bier layer"
must be set by a controller.

So, below the line, an applicability statement would be helpful. What
are those cases?
- IGP running but without FRR on the routing underlay?
- No IGP and no FRR on the routing underlay?

However, if the controller takes care of BIER-FRR, what could be reasons
for missing FRR on the routing underlay? If there is a FRR on the
routing underlay (also provided through a controller), tunnel-based
bier-frr solves the problem in a transparent way.

BTW, we studied protection variants for controller-based infrastructures
(for routing underlays, not for BIER). Challenge is to keep state low.
LFA-based solutions help a lot and outperform others. 100% protection is
possible with only little additions. Results are available:
https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth20-Sub-6.pdf (under
revision)

Regards,

Michael

> 
> thanks
> 
> -- tony
> 
> On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     <https://datatracker.ietf.org/doc/draft-chen-bier-frr/>
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 14:55:38 +0000

Hi Tony,

    Thank you very much for your support and valuable comments.
    My responses are inline below with prefix [HC].

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]> on behalf of Tony Przygienda <[email-masked]>
Sent: Tuesday, March 16, 2021 6:08 AM
To: zhang.zheng <[email-masked]>
Cc: BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

+1

I think it's a good addition within the architecture for the case IGP is not used for signalling, e.g. when controller or static programming.

The draft must however explain in what scenarios it is used and quote the according IGP drafts to guarantee loop-free behavior (well, BIER will tie-break loops but we'll have 1x microloop & possibly not deliver payload if BIER FRR is not properly computed/intsalled). With that the draft should also pay attention to how the function is deployed/updated network-wide if IGP is not present

[HC]: We will add explanations into the draft accordingly.
When IGP is not present in a network, the BIER controller for the network calculates, installs and/or updates BIER FRR BIFTs into BFRs in the network.
When IGP is present in a network, each BFR in the network calculates, installs and/or updates its BIER FRR BIFTs.
The BIER FRR in the draft is independent of the underlay IP FRR.

thanks

-- tony

On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]<mailto:[email-masked]>> wrote:

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C79ac63710b47427a558d08d8e8638df2%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514861570555970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw%3D&reserved=0>

Thanks,

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 16:02:09 +0000

Hi Michael,

    Thanks much for your valuable comments.
    My responses are inline below with prefix [HC].

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]> on behalf of Michael Menth <[email-masked]>
Sent: Tuesday, March 16, 2021 7:11 AM
To: [email-masked] <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony, all,

[HC]: When the routing underlay supports IP FRR, the BIER should also
provide BIER FRR since the BIER packets are forwarded using the BIFTs.
When failures happen in the network, the BIER packets are still forwarded
using the old BIFTs until the old BIFTs are updated according to the
updated network topology after the failures.

[HC]: I agree too.

[HC]: When IGP is running in the network, each BFR in the network calculates,
installs and/or updates its BIER FRR BIFTs. The BIER FRR in the draft is
independent of the underlay IP FRR.
When no IGP is running in the network, the BIER controller for the network
calculates, installs and/or updates the BIER FRR BIFTs into BFRs in the network,
regardless of whether the routing underlay FRR is provided.

[HC]: The BIER FRR in the draft is independent of the underlay IP FRR.
Regardless of whether the routing underlay FRR is provided, the
BIER FRR BIFTs are computed in the same way.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0 (under
revision)

[HC]: Thanks much for your information.

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0

_______________________________________________
BIER mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 16 Mar 2021 17:58:52 +0100

we need a framework here ;-)

when IGP calculates the underlying FRR it's always a better solution.
Nothing is faster than IGP and anything calculated as "better FRR" or
"backup FRR" will not have the topology to do a better job/faster than IGP
can. So AFAIS the only real use case here is BIER without IGP signalling
but correct me if I'm wrong

-- tony

On Tue, Mar 16, 2021 at 5:02 PM Huaimo Chen <[email-masked]>
wrote:

> ------------------------------
> *From:* BIER <[email-masked]> on behalf of Michael Menth <
> [email-masked]>
> *Sent:* Tuesday, March 16, 2021 7:11 AM
> *To:* [email-masked] <[email-masked]>
> *Subject:* Re: [Bier] WG adoption call for draft-chen-bier-frr-02
>
> Hi Tony, all,
>
> > <mailto:[email-masked] <[email-masked]>>> wrote:
> >
> >     <
> mailto:[email-masked] <[email-masked]>
>

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 16 Mar 2021 18:15:25 +0100

I correct myself a bit here ;-) _IF_ the assumption is that _every_ node is
somehow directly connected to the controller and reports topology this can
be faster than IGP. very expensive proposition and pretty fragile but no
account for taste often. Bears all discussing out in a framework & spell
use cases clearly AFAIS

-- tony

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 17:27:44 +0000

Hi Tony,

    Even though there is IGP running in the network and the underlay IP FRR is provided, the BIER FRR seems still needed. All the BIER packets are forwarded using the BIFTs. They are not forwarded using the normal FIBs with IP FRR support.  When a failure happens in the network, the BIER packets will still be forwarded using the old BIFTs without considering the failure until the old BIFT is recomputed and updated based on the new network topology after the failure. During this period (from the time of the failure to the time at which the BIFTs are updated), the BIER packets may be lost.

Best Regards,
Huaimo
________________________________
From: Tony Przygienda <[email-masked]>
Sent: Tuesday, March 16, 2021 12:58 PM
To: Huaimo Chen <[email-masked]>
Cc: Michael Menth <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

when IGP calculates the underlying FRR it's always a better solution. Nothing is faster than IGP and anything calculated as "better FRR" or "backup FRR" will not have the topology to do a better job/faster than IGP can. So AFAIS the only real use case here is BIER without IGP signalling but correct me if I'm wrong

-- tony

On Tue, Mar 16, 2021 at 5:02 PM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Michael,

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Michael Menth <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 16, 2021 7:11 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733090092%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CNKcultin43VrTAvr%2BFH7V1FrMALSvaSpfmEiHcKm%2Fg%3D&reserved=0> (under
revision)

Regards,

Michael

>
> thanks
>
> -- tony
>
> On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]<mailto:[email-masked]>
>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733090092%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA%3D&reserved=0>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733100045%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=koqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ%3D&reserved=0>>
>
> [email-masked]<mailto:[email-masked]>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733110014%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8%3D&reserved=0>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733110014%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=JxeRMSG7j%2FOyGLbPa%2BzGXw6kmFMVp5QqUTHjBEi69L8%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733119960%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=t3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733129927%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5GMZctOBdR6ynmvuwvZlL2O2%2FIFbQWVFmmk%2FJwKnHxE%3D&reserved=0>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 16 Mar 2021 18:09:47 +0000

I object to adopting this on experimental track.

The draft is purely about internal implementation details. It at most could be treated as informational.

Even as an information draft, it is not ready for adoption yet. I will send out a separate email for my comments.

Jeffrey

From: BIER <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, March 16, 2021 2:41 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

[External Email. Be cautious of content]

Thanks,

Juniper Business Use Only

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 16 Mar 2021 18:23:19 +0000

If you consider BIFT and unicast FIB, they are actually very similar (ignoring the SI/sub-domain and bier label aspects). The only differences are:

  1.  (bfr-id % bitstringLength) or prefix as key
  2.  F-BM associated with a BFR-nbr in BIFT

Each BIFT entry is built according how to reach a corresponding BFER, and the F-BM is obtained by setting the bits for all the BFERs that are reached by the BFR nbr.

So, however you do FRR for unicast (LFA or tunnel based link/node protection or whatever) and whether it is IGP or BGP or whatever, you can just build the BIER FRR forwarding state the same way, and update the F-BM for the backup nbr accordingly.

That's why I keep saying that there is not much to standardize on BIER FRR. It seems that this topic keeps coming up, so perhaps I should write an information draft to elaborate the above principle and how it works with various protection mechanisms.

Jeffrey

From: BIER <[email-masked]> On Behalf Of Huaimo Chen
Sent: Tuesday, March 16, 2021 1:28 PM
To: Tony Przygienda <[email-masked]>
Cc: [email-masked]; Michael Menth <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony,

Best Regards,
Huaimo
________________________________
From: Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 16, 2021 12:58 PM
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Cc: Michael Menth <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

-- tony

Best Regards,
Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CNKcultin43VrTAvr*2BFH7V1FrMALSvaSpfmEiHcKm*2Fg*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFKhaK3F2$> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFNWNaFXu$>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733100045*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=koqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFF8NiiJX$>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMxV4XUQ$>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=JxeRMSG7j*2FOyGLbPa*2BzGXw6kmFMVp5QqUTHjBEi69L8*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMoeJ9A-$>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733119960*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=t3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFEmh99Af$>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733129927*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=5GMZctOBdR6ynmvuwvZlL2O2*2FIFbQWVFmmk*2FJwKnHxE*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFLvTCBdE$>

---

From: Michael Menth <[email-masked]>
Date: Tue, 16 Mar 2021 20:02:40 +0100

Hi Huaimo,

> updated network topology after the failures.

Right. Some form of BIER-FRR is helpful. But just tunnelling the traffic
over the underlay in case of a failure (that may be the frr action) let
the traffic benefit from the underlay's frr mechanism. That's what
tunnel-based bier-frr is about.

Regards

Michael

---

From: Michael Menth <[email-masked]>
Date: Tue, 16 Mar 2021 20:02:48 +0100

Hi Jeffrey, all,

your proposal was also the conclusion two years ago when I brought up
the topic in the working group:

"The BIER FRR mechanism - be it tunnel-based or re-implementing LFAs on
the BIER layer - is a local mechanism and does not require cooperation
from other nodes. Probably both mechanisms can be even mixed within the
same network. Therefore, there is not need for standardization."

I think this is not documented in any IETF drafts or even meeting
minutes, it was just a conclusion from some side meetings. That was also
the reason why we did not progress the draft on tunnel-based bier-frr.

Nevertheless, it may be helpful to at least document both existing
bier-frr approaches as an informational draft so that manufacturers can
easily point to an implemented solution. This is helpful as both
solutions have pros and cons. A lot of contents is already in that paper
in which we summarized our understanding of the discussions two years ago:
https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth20c.pdf
Some of its content may be useful for an overview draft of bier-frr methods.

Regards

Michael

Am 16.03.2021 um 19:23 schrieb Jeffrey (Zhaohui) Zhang:
> If you consider BIFT and unicast FIB, they are actually very similar
> (ignoring the SI/sub-domain and bier label aspects). The only
> differences are:
> 
>  
> 
> Each BIFT entry is built according how to reach a corresponding BFER,
> and the F-BM is obtained by setting the bits for all the BFERs that are
> reached by the BFR nbr.
> 
>  
> 
> So, however you do FRR for unicast (LFA or tunnel based link/node
> protection or whatever) and whether it is IGP or BGP or whatever, you
> can just build the BIER FRR forwarding state the same way, and update
> the F-BM for the backup nbr accordingly.
> 
>  
> 
> That’s why I keep saying that there is not much to standardize on BIER
> FRR. It seems that this topic keeps coming up, so perhaps I should write
> an information draft to elaborate the above principle and how it works
> with various protection mechanisms.
> 
>  
> 
> Jeffrey
> 
>  
> 
> *From:* BIER <[email-masked]> *On Behalf Of * Huaimo Chen
> *Sent:* Tuesday, March 16, 2021 1:28 PM
> *To:* Tony Przygienda <[email-masked]>
> *Cc:* [email-masked]; Michael Menth <[email-masked]>
> *[External Email. Be cautious of content]*
> 
>  
> 
> Hi Tony,
> 
>  
> 
>     Even though there is IGP running in the network and the underlay IP
> FRR is provided, the BIER FRR seems still needed. All the BIER packets
> are forwarded using the BIFTs. They are not forwarded using the normal
> FIBs with IP FRR support.  When a failure happens in the network, the
> BIER packets will still be forwarded using the old BIFTs without
> considering the failure until the old BIFT is recomputed and updated
> based on the new network topology after the failure. During this period
> (from the time of the failure to the time at which the BIFTs are
> updated), the BIER packets may be lost.
> 
>  
> 
> Best Regards,
> 
> Huaimo
> 
> ------------------------------------------------------------------------
> 
> *From:*Tony Przygienda <[email-masked] <mailto:[email-masked]>>
> *Sent:* Tuesday, March 16, 2021 12:58 PM
> *To:* Huaimo Chen <[email-masked]
> <mailto:[email-masked]>>
> *Cc:* Michael Menth <[email-masked]
> <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> <[email-masked] <mailto:[email-masked]>>
> "backup FRR" will not have the topology to do a better job/faster than
> IGP can. So AFAIS the only real use case here is BIER without IGP
> signalling but correct me if I'm wrong
> 
>  
> 
> -- tony
> 
>  
> 
>  
> 
> On Tue, Mar 16, 2021 at 5:02 PM Huaimo Chen <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi Michael,
> 
>      
> 
>     ------------------------------------------------------------------------
> 
>     *From:*BIER <[email-masked] <mailto:[email-masked]>>
>     on behalf of Michael Menth <[email-masked]
>     <mailto:[email-masked]>>
>     *To:* [email-masked] <mailto:[email-masked]> <[email-masked]
>     <mailto:[email-masked]>>
>     https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CNKcultin43VrTAvr*2BFH7V1FrMALSvaSpfmEiHcKm*2Fg*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFKhaK3F2$>
>     (under
>     revision)
> 
>      
> 
>     <mailto:[email-masked]>
>     > <mailto:[email-masked] <mailto:[email-masked]>>>
>     wrote:
>     >
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFNWNaFXu$>
>     >    
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733100045*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=koqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFF8NiiJX$>>
>     >
>     >     Authors, please respond to the list indicating whether you are
>     aware
>     >     of any IPR that applies to this draft.
>     >
>     >     Thanks,
>     >
>     > [email-masked] <mailto:[email-masked]>
>     >
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMxV4XUQ$>
>     >
> 
>     -- 
>     mailto:[email-masked] <mailto:[email-masked]>
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=JxeRMSG7j*2FOyGLbPa*2BzGXw6kmFMVp5QqUTHjBEi69L8*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMoeJ9A-$>
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733119960*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=t3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFEmh99Af$>
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733129927*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=5GMZctOBdR6ynmvuwvZlL2O2*2FIFbQWVFmmk*2FJwKnHxE*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFLvTCBdE$>
> 
>

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 19:26:35 +0000

Hi Jeffrey,

    My responses are inline below with prefix [HC]:

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]> on behalf of Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
Sent: Tuesday, March 16, 2021 2:09 PM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

[HC]: The RFCs about IP FRR such as RFC 5286 are "Standards Track" and some other documents using IP FRR for fast protections without protocol extensions are "Standards Track".

[HC]: Adoption is just a starting point. I think it is ready. I will response to your another email.

Jeffrey

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C6bd7da06f2c3459dd75c08d8e8a6b69a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515150050100318%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZQpC99a5%2F3i%2B0cLzfTMS%2BO9rB8H8ioDVMBscUVOpj5k%3D&reserved=0>

Thanks,

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 19:51:28 +0000

Hi Jeffrey,

Best Regards,
Huaimo
________________________________
From: Jeffrey (Zhaohui) Zhang <[email-masked]>
Sent: Tuesday, March 16, 2021 2:23 PM
To: Huaimo Chen <[email-masked]>; Tony Przygienda <[email-masked]>
Cc: [email-masked] <[email-masked]>; Michael Menth <[email-masked]>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

[HC}: As you mentioned, there are two differences between BIFT and FIB. Are you going to combine the BIFT and FIB into one?

[HC]: There are different ways for BIER FRR such as two proposed in BIER WG. Even these two solutions are different in building their forwarding states. It seems not true as you said that you can just build the BIER FRR forwarding state the same way.

That’s why I keep saying that there is not much to standardize on BIER FRR. It seems that this topic keeps coming up, so perhaps I should write an information draft to elaborate the above principle and how it works with various protection mechanisms.

[HC]: Each solution seems have lots of details. There are lots of experiments that need to be done for each solution. I think that working out the details is useful and may benefit all.

Jeffrey

Hi Tony,

Best Regards,

Huaimo

-- tony

Hi Michael,

Best Regards,

Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%3A*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DCNKcultin43VrTAvr*2BFH7V1FrMALSvaSpfmEiHcKm*2Fg*3D%26reserved%3D0__%3BJSUlfiUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFKhaK3F2%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064306038%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=X%2F7B8dJlmp3kRb1oZtUtPYfNpHmMZLAAXLYj1BEpeNQ%3D&reserved=0> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3D4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFNWNaFXu%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064306038%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CP6oZMdo2%2Fdkml661pUymVu5n4caGBLEnW8RGgrR1so%3D&reserved=0>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733100045*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DkoqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFF8NiiJX%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064315994%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=FAcvHimLxoG6kRICoPPuYDdQhomEEfm4UHIRCo70gXo%3D&reserved=0>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3D54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMxV4XUQ%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064315994%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jKBEJPG%2FXDeZtvgBG1AirriDaHqspnlFujxLchJ5RwE%3D&reserved=0>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttp*3A*2F*2Fkn.inf.uni-tuebingen.de*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DJxeRMSG7j*2FOyGLbPa*2BzGXw6kmFMVp5QqUTHjBEi69L8*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMoeJ9A-%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064325944%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=55Jn%2FI7E%2Fsl1GiyEGSVGsUcwJbpkOTbk1C8%2BNjXi5r0%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733119960*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3Dt3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFEmh99Af%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064325944%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8pgjbrdhxlPdcQWx%2BbBX0mJn%2FbI%2FO%2FBmbFdrLuagHmk%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733129927*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3D5GMZctOBdR6ynmvuwvZlL2O2*2FIFbQWVFmmk*2FJwKnHxE*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFLvTCBdE%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C505ee9888f544baadef708d8e8a895f1%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515158064335916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=sL8DOAfnd8LTzYfbXcWslwy3UYBYgI5a%2BBg8EoFElZM%3D&reserved=0>

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 16 Mar 2021 20:56:34 +0000

Hi Tony,

    Under your assumption (controller is directly connected to every node in network and gets network topology faster than IGP), the controller seems better to compute and install/update BIER FRR BIFTs into every node regardless of whether the routing underlay FRR is provided in the network.

Best Regards,
Huaimo
Sent: Tuesday, March 16, 2021 1:15 PM

I correct myself a bit here ;-) _IF_ the assumption is that _every_ node is somehow directly connected to the controller and reports topology this can be faster than IGP. very expensive proposition and pretty fragile but no account for taste often. Bears all discussing out in a framework & spell use cases clearly AFAIS

-- tony

On Tue, Mar 16, 2021 at 5:58 PM Tony Przygienda <[email-masked]<mailto:[email-masked]>> wrote:
we need a framework here ;-)

-- tony

Best Regards,
Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641290417%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uxOikUQhKWWGaFNQuX0XNqSJEYGEHBqnHBQ4w17%2FiYQ%3D&reserved=0> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641300372%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=O89RXu2XDAI3QlCRIAsGIW8h68qgjw8V8JG%2FsGxFjcM%3D&reserved=0>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641310335%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ar717RD3d0BQVE70wyj44HZHBLimtnR4bBH%2F%2B8haA7U%3D&reserved=0>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641310335%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=zfmA8jNTRUEcLH2yZxoiJGWnKjsEmXbv9KMZJPj8I7I%3D&reserved=0>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641320288%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=zVp9CCcWSBRs4so8PyYaRWT8gDvBqq2LfG0Kw2lBmpg%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641330248%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FXN2zgU%2FYXvMijjpT6Ld3104fQX4AdUfc6NwRUS2Lig%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cf7a8a1750db14697222208d8e89f2ccc%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515117641330248%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=%2FXN2zgU%2FYXvMijjpT6Ld3104fQX4AdUfc6NwRUS2Lig%3D&reserved=0>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 16 Mar 2021 22:05:42 +0000

Hi Huaimo,

Please see zzh> below.

From: Huaimo Chen <[email-masked]>
Sent: Tuesday, March 16, 2021 3:51 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Tony Przygienda <[email-masked]>
Cc: [email-masked]; Michael Menth <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey,

Best Regards,
Huaimo
________________________________
From: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 16, 2021 2:23 PM
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Michael Menth <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

Zzh> No. I list the similarity just to show that BIFT can be arranged in a way similar to unicast FIB for both normal and FRR forwarding (I assume you don't have different unicast FIBs for normal and FRR forwarding - but I could be wrong).

Zzh> My point is, if your unicast FIB entry includes some ECMP/primary/backup branches, you can do it the same way for BIER.

Zzh> draft-merlin takes that approach, thought it has unnecessary limitations:

Zzh> - it only has one primary and one backup entry, but one could have multiple ECMP/primary/backup branches, and one could even have a backup branch for each ECMP branch.

Zzh> - it only considers tunneling to the original downstream nbr or its downstream. Going through a complete different downstream neighbor could also be done, which your draft covers (though the multiple per-nbr FRR BIFT idea seems to be flawed).

Zzh> This goes back to my comments even about draft-merlin when it first came about - these are implementation details that an informational draft is more appropriate for.

Zzh> As informational draft, that's fine. But I don't think draft-chen is ready for adoption yet. I had also suggested last time to work with draft-merlin co-authors on a single document. I think that would be a better direction.

Zzh> Jeffrey

Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Huaimo Chen
Sent: Tuesday, March 16, 2021 1:28 PM
To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Michael Menth <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony,

Best Regards,

Huaimo

-- tony

Hi Michael,

Best Regards,

Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3DCNKcultin43VrTAvr*2BFH7V1FrMALSvaSpfmEiHcKm*2Fg*3D*26reserved*3D0__*3BJSUlfiUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFKhaK3F2*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064306038*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=X*2F7B8dJlmp3kRb1oZtUtPYfNpHmMZLAAXLYj1BEpeNQ*3D&reserved=0__;JSUlJSUlJSUlJSUqKioqKiolJSoqKioqKioqKioqKiUlKioqJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFc-BTCNJ3$> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733090092*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3D4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFNWNaFXu*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064306038*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CP6oZMdo2*2Fdkml661pUymVu5n4caGBLEnW8RGgrR1so*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFcyFtI2-Q$>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733100045*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3DkoqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFF8NiiJX*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064315994*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=FAcvHimLxoG6kRICoPPuYDdQhomEEfm4UHIRCo70gXo*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFc6FecCxP$>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3D54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMxV4XUQ*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064315994*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=jKBEJPG*2FXDeZtvgBG1AirriDaHqspnlFujxLchJ5RwE*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFcxP58rRv$>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttp*3A*2F*2Fkn.inf.uni-tuebingen.de*2F*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733110014*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3DJxeRMSG7j*2FOyGLbPa*2BzGXw6kmFMVp5QqUTHjBEi69L8*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFMoeJ9A-*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064325944*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=55Jn*2FI7E*2Fsl1GiyEGSVGsUcwJbpkOTbk1C8*2BNjXi5r0*3D&reserved=0__;JSUlJSUlJSUlJSoqKiolJSoqKioqKioqKioqKiUlKioqJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFc3g53meL$>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733119960*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3Dt3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFEmh99Af*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064325944*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8pgjbrdhxlPdcQWx*2BbBX0mJn*2FbI*2FO*2FBmbFdrLuagHmk*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFc8HyCtQh$>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C2b86f5e805f04cf24c1008d8e89cdcd4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515107733129927*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3D5GMZctOBdR6ynmvuwvZlL2O2*2FIFbQWVFmmk*2FJwKnHxE*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!SBpWq7LIP13dlIX5P6U98cqIp8gTMP5_gelzA7rNyBrhf7h6mMn6N6YLFLvTCBdE*24&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C505ee9888f544baadef708d8e8a895f1*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515158064335916*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=sL8DOAfnd8LTzYfbXcWslwy3UYBYgI5a*2BBg8EoFElZM*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqKiolJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!UDTr378Rj_mIkbaCftMfztSDP8oG_2JlT0Z-syDJQxM_6_5acBYblrYFc8f9e-GA$>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 16 Mar 2021 22:16:10 +0000

Hi Michael,

We are on the same page. Progressing an informational draft on this topic is fine and seems to be even more necessary now. In fact, when draft-chen was presented last time I had suggested for some joint work.

Thanks.
Jeffrey

-----Original Message-----
From: Michael Menth <[email-masked]>
Sent: Tuesday, March 16, 2021 3:03 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Huaimo Chen <[email-masked]>; Tony Przygienda <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey, all,

https://urldefense.com/v3/__https://atlas.informatik.uni-tuebingen.de/*menth/papers/Menth20c.pdf__;fg!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUsxoFVJv$

Regards

Michael

Am 16.03.2021 um 19:23 schrieb Jeffrey (Zhaohui) Zhang:
> That's why I keep saying that there is not much to standardize on BIER
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUh_8_hxk$
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUjt7UD4f$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUjt7UD4f$
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUnaUrsWg$
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUt3QWHXy$
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUnaUrsWg$
>     https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUmTz4u5t$

https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!XVo5XuifwFLLaWFLD2OZmJq1fws1WhcSKnUU3bjUch1IhPPKhQgxjetcUk6GcMm1$

---

From: Michael Menth <[email-masked]>
Date: Tue, 16 Mar 2021 23:57:18 +0100

Hi Jeffrey,

I understand that informational is the right classification of such
documents. I see two options.
- A single document covering the entire topic.
- Two bier-frr docs (tunnel-based and lfa-based), preferentially using
similar laguage. Then one can talk about RFC 123 or RFC XYZ protection.
If the mechanisms are described within a single document, there is some
potential for confusion. Not sure if an overarching framework for
bier-frr is then still needed.

Regards,

Michael

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 17 Mar 2021 00:36:34 +0000

Hi Michael,

I think it's better to have a single document to cover both.

If my understanding of draf-chen is correct, then having separate FRR BIFTs will have problems so the baseline would be a single BIFT with each entry having ECMP/primary/backup branches. Whether a backup branch is tunnel based or LFA based does not matter and one can even mix and match. From that angle, it is better to cover both in the same document so that one can get a holistic view from a single document.

I had forgot that your work had progressed so much (beyond BIER WG). With that consideration and my perhaps biased view that draft-merling describes an optimal baseline model, I think it's good to extend the draft-merling work and there is no need for another framework document (even though I said earlier that I might write an information draft to elaborate my view).

Jeffrey

-----Original Message-----
From: Michael Menth <[email-masked]>
Sent: Tuesday, March 16, 2021 6:57 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Huaimo Chen <[email-masked]>; Tony Przygienda <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey,

Regards,

Michael

https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!QcKhVDqVL9BbhZgPMXxkZKxQeoAR8ukbhqsvoPa5uP-ppyV8gQp_AMF5sG6veauP$

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 17 Mar 2021 01:09:51 -0400

+1

As co-author I support WG adoption of this draft.

I think this is a valuable draft for operators

Kind Regards

Gyan

-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: "qinfengwei" <[email-masked]>
Date: Wed, 17 Mar 2021 16:02:25 +0800

Hi all,

      I support its adoption.

Thanks,

Fengwei Qin

发件人: BIER [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年3月16日 14:41
收件人: [email-masked]
抄送: [email-masked]
主题: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 17 Mar 2021 10:24:46 +0000

Hi,

I support WG adoption of the document.
The BIER FRR mechanism defined in this draft is reasonable and could help to enhance BIER reliability.

Here are some further comments about the discussions in the ML:
1.       Why BIER FRR is necessary when there is underlay IGP protection mechanism?
In my understanding, this is explained in the section 1 of the document:
“In normal operations…Before the primary bit mask is recomputed and updated, some of BIER packets may be forwarded incorrectly”
BIER FRR mechanism could work before IGP convergence completes.
2.       Does this document include too many internal implementation details, making it is supposed to be accepted as informational?
I don’t think so. I have reviewed the document, and find the document focuses on the mechanism. All the descriptions about generating FRR BIRT and FRR BIFT are very similar as the descriptions in RFC 8279 (which is also referred clearly in the document). This is necessary to explain how it works and not relevant to implementation.
3.       What is the relationship between this document and other existing BIER FRR document.
Tunnel based BIER FRR is mentioned in section 1. There is simple comparison between these 2 solutions about memory consumption. I would suggest adding some descriptions about the different scenarios that these 2 methods are suitable for, or different scope that can be covered. But I can’t see any conflictions about these 2 documents.

Here are some comments that authors could considered in the following version:
1.       There is some pseudo code in section 2.4. It seems to me that it should be used when FRR BIFT is activated. But it is also mentioned that “It can also be used with a BIFT on the BFR to forward multicast packets in normal operations.” This is a little confusing to me. Maybe more descriptions here will help.
2.       In figure 2 of section 3.1, the connection between node G and C, and the connection between H is D, look quite twisted. I don’t know whether it has some special meaning or just for fun…

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, March 16, 2021 2:41 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 17 Mar 2021 14:08:22 +0000

Please see zzh> below.

From: BIER <[email-masked]> On Behalf Of Gengxuesong (Geng Xuesong)
Sent: Wednesday, March 17, 2021 6:25 AM
To: [email-masked] <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi,

Zzh> Depending on implementation, when there is underlay IGP protection, BIER FRR can be achieved w/o any FRR constructs at BIFT level (we don’t even need ecmp/primary/backup branches in a single BIFT that I consider as a reference model). But that’s an implementation detail that I don’t need to get into here, and I’m not saying the above just to discount the usefulness of having an informational document about BIER FRR with BIFT level constructs (e.g. ecmp/primary/backup branches in a single BIFT as a reference model).
In my understanding, this is explained in the section 1 of the document:
“In normal operations…Before the primary bit mask is recomputed and updated, some of BIER packets may be forwarded incorrectly”
BIER FRR mechanism could work before IGP convergence completes.

Zzh> That statement is in the context of draft-merling, and I asked for elaboration. I don’t see a problem there.

  1.  Does this document include too many internal implementation details, making it is supposed to be accepted as informational?
I don’t think so. I have reviewed the document, and find the document focuses on the mechanism. All the descriptions about generating FRR BIRT and FRR BIFT are very similar as the descriptions in RFC 8279 (which is also referred clearly in the document). This is necessary to explain how it works and not relevant to implementation.

Zzh> Having per-nbr FRR BIFTs is implementation detail (and more importantly I believe there is actually a problem with it); description on how BIFTs are generated from BIRTs is just repeat from RFC8279.

  1.  What is the relationship between this document and other existing BIER FRR document.
Tunnel based BIER FRR is mentioned in section 1. There is simple comparison between these 2 solutions about memory consumption. I would suggest adding some descriptions about the different scenarios that these 2 methods are suitable for, or different scope that can be covered. But I can’t see any conflictions about these 2 documents.

Zzh> As I explained in other emails, if/once we agree the reference model of a single BIFT with ecmp/primary/backup branches, the rest is very straightforward and it’s good to include all aspects/options in a single document, and draft-merling is a good starting point for that.
Zzh> Thanks.
Zzh> Jeffrey

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, March 16, 2021 2:41 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-chen-bier-frr/__;!!NEt6yMaO-gk!WJo3gD7NYw6uW_5gLlMgWlb05AYbWcyLAoTlPK0_79B6LOJ7jGj4iAMGVy8P5SUV$>

Thanks,

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 17 Mar 2021 09:45:43 -0700

Hi Huaimo,
it seems that you are suggesting using IP FRR and BIER FRR in the same
domain. Is my understanding correct? Multi-layer protection in a network
may work but, in my opinion, overcomplicated network management and
operation. Would you expect that BIER FRR is more responsive to a network
failure than IP FRR? What benefits could be in such a scenario? Which
parameters, in your opinion, need to be coordinated between IP and BIER
layers? I think that if the document includes the concurrent use of IP FRR
and BIER FRR it should provide more detail on how such a scenario could be
realized.

Regards,
Greg

On Tue, Mar 16, 2021 at 10:27 AM Huaimo Chen <[email-masked]>
wrote:

> FRR is provided, the BIER FRR seems still needed. All the BIER packets are
> forwarded using the BIFTs. They are not forwarded using the normal FIBs
> with IP FRR support.  When a failure happens in the network, the BIER
> packets will still be forwarded using the old BIFTs without considering the
> failure until the old BIFT is recomputed and updated based on the new
> network topology after the failure. During this period (from the time of
> the failure to the time at which the BIFTs are updated), the BIER packets
> may be lost.
>
> Best Regards,
> Huaimo
> *From:* Tony Przygienda <[email-masked]>
> *To:* Huaimo Chen <[email-masked]>
> *Cc:* Michael Menth <[email-masked]>; [email-masked] <[email-masked]
> >
> <https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733090092%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CNKcultin43VrTAvr%2BFH7V1FrMALSvaSpfmEiHcKm%2Fg%3D&reserved=0>
> (under
> revision)
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733090092%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4v2q4ToPT83pQYu5Fdwpc04pIcWrlihqy5m8YjgkVMA%3D&reserved=0>
> >     <
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733100045%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=koqOJ4RFqPhBPl81t259PjxeQ6TxmcdtMMqgC0XXDzQ%3D&reserved=0>
> >
> >
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733110014%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=54DHmen2Kbqxu0LRWeuGlVBQbIepvbs1MqJHtfd6Wh8%3D&reserved=0>
> >
>
> --
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733110014%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=JxeRMSG7j%2FOyGLbPa%2BzGXw6kmFMVp5QqUTHjBEi69L8%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733119960%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=t3kSFKDwKsa46DGRbO8YW1nyUrPEFKa5JsBBFmOsoBU%3D&reserved=0>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C2b86f5e805f04cf24c1008d8e89cdcd4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515107733129927%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=5GMZctOBdR6ynmvuwvZlL2O2%2FIFbQWVFmmk%2FJwKnHxE%3D&reserved=0>
>

---

From: "Aijun Wang" <[email-masked]>
Date: Thu, 18 Mar 2021 10:56:10 +0800

Hi, All:

As co-author of this draft, I support its adoption. 

I am not aware of any IPR that applies to this draft.

Some technical discussions and clear statements for the implementation are necessary, standardize them can accomplish the consistent behavior across the network wide.

Best Regards

Aijun Wang

China Telecom

From: [email-masked] <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, March 16, 2021 2:41 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 18 Mar 2021 08:52:16 +0100

As others pointed out it's not clear we need to "standardize" this for the
simple reason this is _very_ implementation dependent. "Standardizing" is
important if interoperability is important, in this sense if this draft
talks about different schemes interoperating, gotchas etc, yes, there may
be an angle there. Starting from a model aligned with Menthe, describing
alternate techniques [like multiple BIFTs with compression etc] if the
technical problems/discussions with those can be ironed out is a good thing
since it will document possible approaches/issues etc but what track this
is best published on should be discussed bit down the road especially after
implementation/experience with different approaches.

-- tony

On Thu, Mar 18, 2021 at 3:56 AM Aijun Wang <[email-masked]>
wrote:

> Some technical discussions and clear statements for the implementation are
> necessary, standardize them can accomplish the consistent behavior across
> the network wide.
>
>
>
> Best Regards
>
>
>
> Aijun Wang
>
> China Telecom
>
>
>
> *From:* [email-masked] <[email-masked]> *On Behalf Of *
> [email-masked]
> *Sent:* Tuesday, March 16, 2021 2:41 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* [Bier] WG adoption call for draft-chen-bier-frr-02
>
>
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Thu, 18 Mar 2021 08:13:15 +0000

Hi Tony,

Sorry for stepping in. But I’m really confused why this document is called “implementation dependent”. Especially so many fast reroute algorithms have been standardized in history, as  RFC5286 or RFC7490.
LFA BIER FRR mechanism introduce multiple FRR BIFTs because calculating FRR BIRT makes the F-BM different for different BFR-NBR failure, if the problem is about “multiple BIFTs” . If there is any other concern, could you raise some examples from the document?

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Thursday, March 18, 2021 3:52 PM
To: Aijun Wang <[email-masked]>
Cc: BIER WG <[email-masked]>; zhang.zheng <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

As others pointed out it's not clear we need to "standardize" this for the simple reason this is _very_ implementation dependent. "Standardizing" is important if interoperability is important, in this sense if this draft talks about different schemes interoperating, gotchas etc, yes, there may be an angle there. Starting from a model aligned with Menthe, describing alternate techniques [like multiple BIFTs with compression etc] if the technical problems/discussions with those can be ironed out is a good thing since it will document possible approaches/issues etc but what track this is best published on should be discussed bit down the road especially after implementation/experience with different approaches.

-- tony

On Thu, Mar 18, 2021 at 3:56 AM Aijun Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi, All:

Best Regards

Aijun Wang
China Telecom

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>

Thanks,

---

From: <[email-masked]>
Date: Thu, 18 Mar 2021 17:57:20 +0800 (CST)

Hi WG,

I think it's an implementation issue, so I oppose the adoption.

Obviously, the implementation scheme, i.e, FRR-BIFT per neighbor, described in this document has serious scalability problems. That means that too many tables need to be updated when topology events occur. There may be a simpler implementation that doesn't have to be done in this way.

For example, we can let BIFT entry contain both primary NBR and backup path (note that the backup path may be direct NBR, or remote NBR, or segment-list, according to IGP TI-LFA result).

There are primary FBM and backup FBM. The primary FBM contains the Bit-Positions of those BFERs that has the same primary NBR, the backup FBM contains the Bit-Positions of those BFERs that has the same backup path. In this implementation, when a BFR received a BIER packet, and if the primary NBR fails, a copy will be sent to backup path, and the bitstring contained in the copy is the result of "original bitstring of the received packet" & "primary FBM" & "backup FBM".

Another implementation may let primary FBM and backup FBM of BIFT entry to be same, to contain the Bit-Positions of those BFERs when their primary NBR are same and their backup path are also same. However, this implementation couples the setting of primary FBM and backup FBM. It's not recommended.

Regards,

PSF

原始邮件

发件人：张征00007940
收件人：[email-masked];
抄送人：[email-masked];
日 期 ：2021年03月16日 14:41
主 题 ：[Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Thu, 18 Mar 2021 10:07:31 +0000

Hi Shaofu,

Maybe we should be more careful about the difference between “implementation dependent” and “scalability limitation ”. I think you are talking about the latter one, which could be another story.

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 18, 2021 5:57 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi WG,

Regards,

PSF

原始邮件
发件人：张征00007940
收件人：[email-masked]<mailto:[email-masked]>;
抄送人：[email-masked]<mailto:[email-masked]>;
日 期 ：2021年03月16日 14:41
主 题 ：[Bier] WG adoption call for draft-chen-bier-frr-02
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

Thanks,

---

From: <[email-masked]>
Date: Thu, 18 Mar 2021 19:11:07 +0800 (CST)

Hi Xuesong,

My expression is clear that this document introduces an internal implementation scheme but it is not a good one, and nothing need to be standardized. I provide another simple scheme that is based on the existing IGP LFA/TI-LFA to create FRR items for BIFT entry just like for traditional routing FIB entry. We only need to consider how to set FBM, and different setting methods have different packet processing rules, all this, I think, is local matter.

Regards,

PSF

原始邮件

发件人：Gengxuesong(GengXuesong)
收件人：彭少富10053815;张征00007940;
抄送人：[email-masked];[email-masked];
日 期 ：2021年03月18日 18:07
主 题 ：Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Shaofu,

 

Best

Xuesong

 

Hi WG,

Regards,

PSF

原始邮件

发件人：张征00007940

收件人：[email-masked];

日 期 ：2021年03月16日 14:41

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 18 Mar 2021 11:41:47 +0000

There is a difference between RFC5286 and this.

Even though LFA does not require signaling, it was a significantly new way of doing FRR. You can also notice the both RFCs are have rich content describing the principles and methods of LFA.

With BIER FRR, since it builds on top of mature tunnel or LFA based protection, once the principle is described with the reference model of “BIFT entries with ECMP/primary/backup branches” (which is similar to unicast case), there is really no need for additional specification. Whether using a single table or per-nbr table or other methods is implementation detail, and as we have seen, the per-nbr table method has its limitations.

As the co-authors of draft-merling can confirm, they looked into BIER FRR two years ago and we came to the same conclusion that there is no need for standardization. Even though draft-merling does not talk about LFA-to-BFER based protection, we actually also discussed that (because Juniper’s design actually supports both).

draft-merling was not even updated because of that conclusion. Now with the strong push for draft-chen, I agree that a joint informational draft is desired. Adding content of LFA-to-BFER and controller aspects does not change the fact that there is no need for standardization.

Jeffrey

From: BIER <[email-masked]> On Behalf Of Gengxuesong (Geng Xuesong)
Sent: Thursday, March 18, 2021 4:13 AM
To: Tony Przygienda <[email-masked]>; Aijun Wang <[email-masked]>
Cc: [email-masked] <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony,

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Thursday, March 18, 2021 3:52 PM
To: Aijun Wang <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; zhang.zheng <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

-- tony

Best Regards

Aijun Wang
China Telecom

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-chen-bier-frr/__;!!NEt6yMaO-gk!V5199OPdTs4Bxoq-lYOVeVZgmWre2iDBQdHYg41o0hcR3UFM0WtPoxyMFbfLA3Ox$>

Thanks,

---

From: "Bidgoli, Hooman (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 18 Mar 2021 14:28:25 +0000

After ready this draft, I am still not clear why we need standardization for BIER header bit manipulation in case of FRR.

BIER FRR can follow IGP decision (i.e. LFA, R-LFA, TI-LFA), the BIER header bit manipulation based on next hop or next next hop is PLR decision. The MP just acts based on the BIER header it receives from PLR. BIER header manipulation is implementation.

I think at best an informational draft with some algorithm suggestions.

Regards
Hooman
From: BIER <[email-masked]> On Behalf Of Tony Przygienda
Sent: Thursday, March 18, 2021 3:52 AM
To: Aijun Wang <[email-masked]>
Cc: BIER WG <[email-masked]>; zhang.zheng <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

-- tony

Best Regards

Aijun Wang
China Telecom

Thanks,

---

From: Michael McBride <[email-masked]>
Date: Thu, 18 Mar 2021 18:54:31 +0000

Support adoption.

Either experimental (current) or informational would be fine. Not aware of any IPR.

And would also support a call to adopt draft-merling-bier-frr as either a stand alone doc or merged with draft-chen-frr.

mike

From: BIER <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, March 15, 2021 11:41 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 19 Mar 2021 02:29:28 +0000

Hi Jeffrey,

I just want to avoid mixing all the discussions together and getting back again. Getting agreement to the following questions may be helpful (also could be found in my previous comments):

1.       Is BIER FRR necessary?

(It has been discussed in the discussion of draft-merling. And it is raised again. )

2.       Is BIER FRR implementation dependent so not supposed to be standardized?

(I think we all agree that fast reroute algorithms are kind of implementation dependent without signaling. Being simple or rich depends on the idea itself.)

3.       How to deal with 2 existing documents about BIER FRR?

( It depends on WG. When I read these 2 documents, I find they are reasonable and independent methods about implementing BIER FRR. They could be considered to be adopted together)

Best
Xuesong

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Thursday, March 18, 2021 7:42 PM
To: Gengxuesong (Geng Xuesong) <[email-masked]>; Tony Przygienda <[email-masked]>; Aijun Wang <[email-masked]>
Cc: [email-masked] <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Gengxuesong (Geng Xuesong)
Sent: Thursday, March 18, 2021 4:13 AM
To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>; Aijun Wang <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Tony,

Best
Xuesong

-- tony

Best Regards

Aijun Wang
China Telecom

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 19 Mar 2021 03:00:09 +0000

Hi Xuesong,

Please see zzh> below.

From: Gengxuesong (Geng Xuesong) <[email-masked]>
Sent: Thursday, March 18, 2021 10:29 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Tony Przygienda <[email-masked]>; Aijun Wang <[email-masked]>
Cc: [email-masked] <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey,

Zzh> Of course it is necessary.  Nobody is questioning that.

Zzh> How BIER FRR is achieved does not need standardization – that’s my view for years.

Zzh> I had explained my view on why a single merged informational document is better.

Zzh> Thanks.

Zzh> Jeffrey

Best
Xuesong

To: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; Aijun Wang <[email-masked]<mailto:[email-masked]>>

Jeffrey

Hi Tony,

Best
Xuesong

-- tony

Best Regards

Aijun Wang
China Telecom

Thanks,

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 19 Mar 2021 03:22:19 +0000

Hi Jeffrey,

It looks like we have different answers about the 2nd and 3rd questions with respective reasons. But still the discussion is much more clear now.

Thanks
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: Friday, March 19, 2021 11:00 AM
To: Gengxuesong (Geng Xuesong) <[email-masked]>; Tony Przygienda <[email-masked]>; Aijun Wang <[email-masked]>
Cc: BIER WG <[email-masked]>; [email-masked] <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Xuesong,

Please see zzh> below.

From: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 18, 2021 10:29 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; Aijun Wang <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey,

Zzh> Thanks.

Zzh> Jeffrey

Best
Xuesong

Jeffrey

Hi Tony,

Best
Xuesong

-- tony

Best Regards

Aijun Wang
China Telecom

Thanks,

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 19 Mar 2021 11:42:45 +0100

as parrticiapnt inline

Hi Jeffrey,
>
>
>
> I just want to avoid mixing all the discussions together and getting back
> again. Getting agreement to the following questions may be helpful (also
> could be found in my previous comments):
>
> *1.       **Is BIER FRR necessary? *
>
> *2.       **Is BIER FRR implementation dependent so not supposed to be
> standardized?*
>
> (I think we all agree that fast reroute algorithms are kind of
> implementation dependent without signaling. Being simple or rich depends on
> the idea itself.)
>
splitting hair a bit. either info or experimental and then write code &
present results & document. I would tend to have this ultimately
informational probably since it documents implementatoin techniques and
those are best not standardized albeit of high value. But I ain't gonna
throw stones given el.g. base BIER architecture is pretty handsy as well
talking about BIFTs and stuff already.
'

> *3.       **How to deal with 2 existing documents about BIER FRR?*
>
> ( It depends on WG. When I read these 2 documents, I find they are
> reasonable and independent methods about implementing BIER FRR. They could
> be considered to be adopted together)
>
I would prefer a single document on bier-frr as joined Menth and Xuesong
draft with the single BIFT mode & possibly multiple (again, modulo
technical comments on it right now) but it's up to the authros to sit down
and od the work and drink some beer together if they choose.

-- tony

---

From: Huaimo Chen <[email-masked]>
Date: Sat, 20 Mar 2021 04:47:39 +0000

Hi Greg,

    Thanks for your comments/questions.
    My responses to another email below should address/answer them.

https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/

Best Regards,
Huaimo
________________________________
From: Greg Mirsky <[email-masked]>
Sent: Wednesday, March 17, 2021 12:45 PM
To: Huaimo Chen <[email-masked]>
Cc: [email-masked] <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Huaimo,
it seems that you are suggesting using IP FRR and BIER FRR in the same domain. Is my understanding correct? Multi-layer protection in a network may work but, in my opinion, overcomplicated network management and operation. Would you expect that BIER FRR is more responsive to a network failure than IP FRR? What benefits could be in such a scenario? Which parameters, in your opinion, need to be coordinated between IP and BIER layers? I think that if the document includes the concurrent use of IP FRR and BIER FRR it should provide more detail on how such a scenario could be realized.

Regards,
Greg

On Tue, Mar 16, 2021 at 10:27 AM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tony,

Best Regards,
Huaimo

-- tony

Best Regards,
Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615768749%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oSLGnBnwcsrY2gaRZqG%2FLSMOYLNQcG0Mjm9NNVc6TUU%3D&reserved=0> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615778703%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4%3D&reserved=0>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615788657%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7%2B3Dogg%3D&reserved=0>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615788657%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm%2FCXw%3D&reserved=0>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615798609%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=dwQXPxovW3YS99oeGr3%2FdrYKfMFPSR94Xz1ihTfE2l4%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615798609%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=w5ocCaRoOrDQ%2BVSeW1%2Bl7MUnqp3TN6InBTmzXx00blc%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615808573%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE%2Fzys%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615808573%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE%2Fzys%3D&reserved=0>

---

From: Greg Mirsky <[email-masked]>
Date: Sun, 21 Mar 2021 10:05:48 -0700

Hi Huaimo,
perhaps my question was not clearly stated. Let me re-phrase it and add
more detail to the scenario.
As understand the discussion about using IP FRR and BIER FRR concurrently
in the same BIER domain, you are of the opinion that such a combination is
useful while others have expressed some reservation of its practicality. Do
I understand that part of the discussion correctly?
If we consider multi-layer protection schemes, using IP FRR and BIER FRR is
one of its examples, we should consider operational issues that a
multi-layer scenario introduces. Particularly, coordination of timers that
determine detection of the network failure and trigger the protection
switchover. Such coordination of OAM parameters and the expected switchover
intervals intended to avoid unnecessary loss of data packets caused by the
excessive of protection switchover in an overlay network.
I missed finding that being discussed in the e-mail you've pointed out.
Perhaps you can quote the part that you believe addressed my question.

Regards,
Greg

On Fri, Mar 19, 2021 at 9:47 PM Huaimo Chen <[email-masked]>
wrote:

> *From:* Greg Mirsky <[email-masked]>
> *Sent:* Wednesday, March 17, 2021 12:45 PM
> *Cc:* [email-masked] <[email-masked]>; BIER WG Chairs <[email-masked]>
> <https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615768749%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oSLGnBnwcsrY2gaRZqG%2FLSMOYLNQcG0Mjm9NNVc6TUU%3D&reserved=0>
> (under
> revision)
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615778703%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4%3D&reserved=0>
> >     <
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615788657%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7%2B3Dogg%3D&reserved=0>
> >
> >
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615788657%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm%2FCXw%3D&reserved=0>
> >
>
> --
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615798609%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=dwQXPxovW3YS99oeGr3%2FdrYKfMFPSR94Xz1ihTfE2l4%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615798609%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=w5ocCaRoOrDQ%2BVSeW1%2Bl7MUnqp3TN6InBTmzXx00blc%3D&reserved=0>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615808573%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE%2Fzys%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615808573%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE%2Fzys%3D&reserved=0>
>
>

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 21 Mar 2021 13:20:21 -0700

I have exactly same comment.
In the past we have witnessed complex and often quite harmful interactions of different protection schemes in multi-layer networking.
Think IPFRR on top of SDH/Optical protection. Unless properly coordinated, race conditions and unnecessary service degradation would often be observed.
Please spend some time on thinking how different surfaces interact and what would be required to make it work.

Regards,
Jeff

> On Mar 21, 2021, at 10:06, Greg Mirsky <[email-masked]> wrote:
> 
> 
> Hi Huaimo,
> perhaps my question was not clearly stated. Let me re-phrase it and add more detail to the scenario.
> As understand the discussion about using IP FRR and BIER FRR concurrently in the same BIER domain, you are of the opinion that such a combination is useful while others have expressed some reservation of its practicality. Do I understand that part of the discussion correctly?
> If we consider multi-layer protection schemes, using IP FRR and BIER FRR is one of its examples, we should consider operational issues that a multi-layer scenario introduces. Particularly, coordination of timers that determine detection of the network failure and trigger the protection switchover. Such coordination of OAM parameters and the expected switchover intervals intended to avoid unnecessary loss of data packets caused by the excessive of protection switchover in an overlay network.
> I missed finding that being discussed in the e-mail you've pointed out. Perhaps you can quote the part that you believe addressed my question.
> 
> Regards,
> Greg
> 
>> On Fri, Mar 19, 2021 at 9:47 PM Huaimo Chen <[email-masked]> wrote:
>> Hi Greg,
>> 
>> On Tue, Mar 16, 2021 at 10:27 AM Huaimo Chen <[email-masked]> wrote:
>> Hi Tony,
>> 
>> On Tue, Mar 16, 2021 at 5:02 PM Huaimo Chen <[email-masked]> wrote:
>> Hi Michael,
>>

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 22 Mar 2021 07:32:28 +0100

AFAIS couple parties pointed out that most useful are considerations for
BIER FRR in case there is no IGP with LFA in the network and for BIER-TE
where IGP protection doesn't latch on AFAIS. which I agree with ...

-- tony

On Sun, Mar 21, 2021 at 9:20 PM Jeff Tantsura <[email-masked]>
wrote:

> In the past we have witnessed complex and often quite harmful interactions
> of different protection schemes in multi-layer networking.
> Think IPFRR on top of SDH/Optical protection. Unless properly coordinated,
> race conditions and unnecessary service degradation would often be observed.
> If we consider multi-layer protection schemes, using IP FRR and BIER FRR
> is one of its examples, we should consider operational issues that a
>> *Cc:* [email-masked] <[email-masked]>; BIER WG Chairs <[email-masked]
>> >
>> *Cc:* Michael Menth <[email-masked]>; [email-masked] <
>> [email-masked]>

---

From: Michael Menth <[email-masked]>
Date: Mon, 22 Mar 2021 07:38:56 +0100

BIER-FRR is also needed if a BFR-NBR is down. Here, the IGP cannot help.

BR, Michael

Am 22.03.2021 um 07:32 schrieb Tony Przygienda:
> On Sun, Mar 21, 2021 at 9:20 PM Jeff Tantsura <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     In the past we have witnessed complex and often quite harmful
>     interactions of different protection schemes in multi-layer networking.
>     Think IPFRR on top of SDH/Optical protection. Unless properly
>     coordinated, race conditions and unnecessary service degradation
>     would often be observed.
>     Please spend some time on thinking how different surfaces interact
>     and what would be required to make it work.
> 
> 
>     Regards,
>     Jeff
> 
>>     On Mar 21, 2021, at 10:06, Greg Mirsky <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>
>>     
>>     Hi Huaimo,
>>     As understand the discussion about using IP FRR and BIER FRR
>>     concurrently in the same BIER domain, you are of the opinion that
>>     such a combination is useful while others have expressed some
>>     reservation of its practicality. Do I understand that part of the
>>     discussion correctly?
>>     If we consider multi-layer protection schemes, using IP FRR and
>>     BIER FRR is one of its examples, we should consider operational
>>     issues that a multi-layer scenario introduces. Particularly,
>>     coordination of timers that determine detection of the network
>>     failure and trigger the protection switchover. Such coordination
>>     of OAM parameters and the expected switchover intervals intended
>>     to avoid unnecessary loss of data packets caused by the excessive
>>     of protection switchover in an overlay network.
>>     I missed finding that being discussed in the e-mail you've pointed
>>     out. Perhaps you can quote the part that you believe addressed my
>>     question.
>>
>>     Regards,
>>     Greg
>>
>>     On Fri, Mar 19, 2021 at 9:47 PM Huaimo Chen
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Hi Greg,
>>
>>         <https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/>
>>
>>
>>         Best Regards,
>>         Huaimo
>>         *From:* Greg Mirsky <[email-masked]
>>         <mailto:[email-masked]>>
>>         *Cc:* [email-masked] <mailto:[email-masked]> <[email-masked]
>>         <mailto:[email-masked]>>; BIER WG Chairs <[email-masked]
>>         <mailto:[email-masked]>>
>>         it seems that you are suggesting using IP FRR and BIER FRR in
>>         the same domain. Is my understanding correct? Multi-layer
>>         protection in a network may work but, in my opinion,
>>         overcomplicated network management and operation. Would you
>>         expect that BIER FRR is more responsive to a network failure
>>         than IP FRR? What benefits could be in such a scenario? Which
>>         parameters, in your opinion, need to be coordinated between IP
>>         and BIER layers? I think that if the document includes the
>>         concurrent use of IP FRR and BIER FRR it should provide more
>>         detail on how such a scenario could be realized.
>>
>>         Regards,
>>         Greg
>>
>>         On Tue, Mar 16, 2021 at 10:27 AM Huaimo Chen
>>         <[email-masked] <mailto:[email-masked]>>
>>         wrote:
>>
>>             Hi Tony,
>>
>>                 Even though there is IGP running in the network and
>>             the underlay IP FRR is provided, the BIER FRR seems still
>>             needed. All the BIER packets are forwarded using the
>>             BIFTs. They are not forwarded using the normal FIBs with
>>             IP FRR support.  When a failure happens in the network,
>>             the BIER packets will still be forwarded using the old
>>             BIFTs without considering the failure until the old BIFT
>>             is recomputed and updated based on the new network
>>             topology after the failure. During this period (from the
>>             time of the failure to the time at which the BIFTs are
>>             *From:* Tony Przygienda <[email-masked]
>>             <mailto:[email-masked]>>
>>             <mailto:[email-masked]>>; [email-masked]
>>             <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>
>>             when IGP calculates the underlying FRR it's always a
>>             better solution. Nothing is faster than IGP and anything
>>             calculated as "better FRR" or "backup FRR" will not have
>>             the topology to do a better job/faster than IGP can. So
>>             AFAIS the only real use case here is BIER without IGP
>>                 *From:* BIER <[email-masked]
>>                 <mailto:[email-masked]>> on behalf of Michael
>>                 Menth <[email-masked]
>>                 *To:* [email-masked] <mailto:[email-masked]>
>>                 > On Tue, Mar 16, 2021 at 7:41 AM <[email-masked] <mailto:[email-masked]>
>>                 > <mailto:[email-masked]
>>                 <mailto:[email-masked]>>> wrote:
>>                 > 
>>                 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C3d527e94172b4e7234fb08d8e96422e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637515963615788657%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7%2B3Dogg%3D&reserved=0>>
>>                 > 
>>                 <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/bier>
> 
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 22 Mar 2021 13:21:36 +0000

Whether it is IP FRR, MPLS FRR, or BIER FRR, the key is that alternative/backup paths are pre-installed. Upon the detection of failure, the PLR uses alternative/backup path before global repair finishes.

The determination of alternative/backup path can be SPF based (e.g. LFA) which involves IGP, or controller based, or any other way (e.g. static configuration or pre-signaling in case of MPLS). That is not BIER specific.

Specifically for BIER FRR, when we say "BIER can take advantage of unicast FRR", there are two scenarios/aspects about that:

1. BIER does not do any FRR by itself at all (i.e. no primary/backup branches for BIFT entries), but rely on unicast FRR to each BFR neighbor. This only provide link protection not node protection (for the BFR neighbor), though.
2. BIER does have its own FRR constructs (i.e., ECMP/primary/backup branches for BIFT entries), but these are still determined based on "unicast" FRR, because we're using the alternative/backup paths to the BFERs. This is not "simply using unicast FRR" - because we do need to create BIER specific forwarding state for those alternative/backup paths (BIER label, F-BM, etc.). It either uses the unicast FRR state (when BIER does follow exact unicast paths) or uses unicast FRR mechanisms (but does not follow exact unicast paths - i.e. unicast and BIER are using incongruent topology or algorithm) - whether it is IGP based or not. This does provide node protection as well as link protection.

Jeffrey

-----Original Message-----
From: BIER <[email-masked]> On Behalf Of Michael Menth
Sent: Monday, March 22, 2021 2:39 AM
To: Tony Przygienda <[email-masked]>; Jeff Tantsura <[email-masked]>
Cc: Greg Mirsky <[email-masked]>; BIER WG <[email-masked]>; Huaimo Chen <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

BR, Michael

Am 22.03.2021 um 07:32 schrieb Tony Przygienda:
>>         https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$
>>         <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$ >
>>
>>
>>         Best Regards,
>>         Huaimo
>>                 https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$ >
>>                 (under
>>                 revision)
>>
>>                 >     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$ >
>>                 >     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$ >>
>>                 >
>>                 > https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$ >
>>                 >
>>
>>                 --
>>                 https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$ >
>>
>>                 https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$ >
>>                 https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$
>>                 <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$ >
>>
>>             https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$
>>             <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$ >
>>
>>     https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$
>>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$ >
>
>
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$
>

https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$

_______________________________________________
BIER mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$

---

From: Michael Menth <[email-masked]>
Date: Mon, 22 Mar 2021 14:40:48 +0100

Hi Jeffrey, all,

Am 22.03.2021 um 14:21 schrieb Jeffrey (Zhaohui) Zhang:
> 1. BIER does not do any FRR by itself at all (i.e. no primary/backup branches for BIFT entries), but rely on unicast FRR to each BFR neighbor. 

We still need some BIER-FRR in this case:
1) Recognize the failure
2) Reroute the packet over the underlay (encapsulation in underlay) as
the direct link no longer works. However, it not sending to another
neighbor.

This only provide link protection not node protection (for the BFR
neighbor), though.

There is also node protection with tunnel-based BIER-FRR that leverages
the protection of the underlay.

> 2. BIER does have its own FRR constructs (i.e., ECMP/primary/backup branches for BIFT entries), but these are still determined based on "unicast" FRR, because we're using the alternative/backup pat…

Here some caveats
- If the BIER topology does not contain all the nodes of the underlay,
LFAs on the BIER layer may be different.
- 100% failure coverage is not possible
- If rLFAs/TI-LFA are needed to complete failure coverage on the BIER
layer, we've got tunneling again with all its disadvantages, e.g.,
possibly redundant packets.

Best wishes,

Michael

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 22 Mar 2021 14:19:43 +0000

Hi Greg,

    It seems there are some misunderstandings.
    My responses/explanations in another way are inline below with prefix [HC].

Best Regards,
Huaimo
Sent: Sunday, March 21, 2021 1:05 PM

Hi Huaimo,
perhaps my question was not clearly stated. Let me re-phrase it and add more detail to the scenario.
As understand the discussion about using IP FRR and BIER FRR concurrently in the same BIER domain, you are of the opinion that such a combination is useful while others have expressed some reservation of its practicality. Do I understand that part of the discussion correctly?
[HC]: IP packets are forwarded using the normal FIB and its IP forwarding procedure.
BIER packets are forwarded using the BIFT and its BIER forwarding procedure.
Forwarding BIER packets is separated from forwarding IP packets.
BIER packets are not forwarded through using the normal FIB and its IP forwarding procedure.
IP FFR is for protecting IP packets through enhancing normal FIB and IP forwarding procedure.
BIER FRR is for protecting BIER packets through enhancing BIFT and BIER forwarding procedure.
BIER FRR is separated from IP FRR.
IP FRR will not protect any BIER packets.
BIER FRR can use x-LFA and IP FRR can use y-LFA. x-LFA and y-LFA can be different.

If we consider multi-layer protection schemes, using IP FRR and BIER FRR is one of its examples, we should consider operational issues that a multi-layer scenario introduces. Particularly, coordination of timers that determine detection of the network failure and trigger the protection switchover. Such coordination of OAM parameters and the expected switchover intervals intended to avoid unnecessary loss of data packets caused by the excessive of protection switchover in an overlay network.
[HC]: It seems that no coordination is needed since BIER FRR is separated from IP FRR.

Regards,
Greg

On Fri, Mar 19, 2021 at 9:47 PM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fbier%2FVsTPRmUi-26VSWrBPzdnLXzPvT0%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653338271%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SHRUO3CVl%2Fls%2B4UcwWhGVOhg1fJRQ9tz5wtWmMgmZVU%3D&reserved=0>

Best Regards,
Huaimo
________________________________
From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 17, 2021 12:45 PM
To: Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Huaimo,

Regards,
Greg

Best Regards,
Huaimo

-- tony

Best Regards,
Huaimo

Hi Tony, all,

[HC]: I agree too.

https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=03cc%2BIvdV%2BCg%2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653348226%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ge8zAv7lk6tfQJTY5IByDrytSUm5dMoPtEX%2B4VfJDO8%3D&reserved=0> (under
revision)

Regards,

Michael

>     https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653358181%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=fMg%2Bk522VU1Lcwm5JXmFI3guMPzN01vTF8Wx4wjb6YE%3D&reserved=0>
>     <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY%2BOU5x4%2F3w1FaSWfoF%2BC6pQ%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653358181%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=fMg%2Bk522VU1Lcwm5JXmFI3guMPzN01vTF8Wx4wjb6YE%3D&reserved=0>>
>
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653368139%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oKCUjhmsv7UOmbBmPT4PFf24NejSGXd9PuHsT6WaadY%3D&reserved=0>
>

https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653368139%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SZWIwISkow8RN1Dewm8WKrktjgEL%2FEUd0y0U6%2FhDLAg%3D&reserved=0>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C5d3cb8163c7f4a1557e608d8e86c408f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514898966623524%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=aZ6%2BjQBpo7k81fqf%2FnYdfer7mS45RlhB0lPT7%2B%2BVm6I%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653378096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m6lOWxJWqUM8ajoSPCZQxQpitaRdwt%2FmlVmc%2FFSXA0o%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653378096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m6lOWxJWqUM8ajoSPCZQxQpitaRdwt%2FmlVmc%2FFSXA0o%3D&reserved=0>
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653388053%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZugL4Z%2B%2B8G2vhXJnqjrz3rSiQvSVTYG5FmsDGwRIjfA%3D&reserved=0>

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Mar 2021 07:57:49 -0700

Hi Huaimo,
thank you for listing the differences between IP and BIER data planes.
Which method of network failure detection, in your opinion, exposes these
differences for local protection such as FRR?

Regards,
Greg

On Mon, Mar 22, 2021 at 7:19 AM Huaimo Chen <[email-masked]>
wrote:

> *Sent:* Sunday, March 21, 2021 1:05 PM
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fbier%2FVsTPRmUi-26VSWrBPzdnLXzPvT0%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653338271%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SHRUO3CVl%2Fls%2B4UcwWhGVOhg1fJRQ9tz5wtWmMgmZVU%3D&reserved=0>
>
>
> Best Regards,
> Huaimo
> <https://nam11.safelinks.protection.outlook.com/?url=https:%2F%2Fatlas.informatik.uni-tuebingen.de%2F~menth%2Fpapers%2FMenth20-Sub-6.pdf&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653348226%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ge8zAv7lk6tfQJTY5IByDrytSUm5dMoPtEX%2B4VfJDO8%3D&reserved=0>
> (under
> revision)
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653358181%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=fMg%2Bk522VU1Lcwm5JXmFI3guMPzN01vTF8Wx4wjb6YE%3D&reserved=0>
> >     <
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653358181%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=fMg%2Bk522VU1Lcwm5JXmFI3guMPzN01vTF8Wx4wjb6YE%3D&reserved=0>
> >
> >
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653368139%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oKCUjhmsv7UOmbBmPT4PFf24NejSGXd9PuHsT6WaadY%3D&reserved=0>
> >
>
> --
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fkn.inf.uni-tuebingen.de%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653368139%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SZWIwISkow8RN1Dewm8WKrktjgEL%2FEUd0y0U6%2FhDLAg%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653378096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m6lOWxJWqUM8ajoSPCZQxQpitaRdwt%2FmlVmc%2FFSXA0o%3D&reserved=0>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653378096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m6lOWxJWqUM8ajoSPCZQxQpitaRdwt%2FmlVmc%2FFSXA0o%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cdc2120c4087e4dceff9708d8ec8b9bb3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637519431653388053%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZugL4Z%2B%2B8G2vhXJnqjrz3rSiQvSVTYG5FmsDGwRIjfA%3D&reserved=0>
>
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 22 Mar 2021 14:59:58 +0000

Hi Michael

Please see zzh> below.

-----Original Message-----
From: Michael Menth <[email-masked]>
Sent: Monday, March 22, 2021 9:41 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Tony Przygienda <[email-masked]>; Jeff Tantsura <[email-masked]>
Cc: Greg Mirsky <[email-masked]>; BIER WG <[email-masked]>; Huaimo Chen <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey, all,

Zzh> Depending on implementation, the above can be done transparent to BIER.

Zzh> If you're talking about tunneling to the failed BFR neighbor's children (on the SPF tree), that needs backup paths and I consider that as part of the scenario #2.

Here some caveats

Zzh> That is what I mean by "uses FRR mechanisms (but does not follow exact unicast paths - i.e. unicast and BIER are using incongruent topology or algorithm)", compared to "uses the unicast FRR state".

Zzh> This is not BIER specific. It's just like unicast case.

zzh> This is not BIER specific. It's just like unicast case.

Zzh> I think this ok (not that a BFER is going to get duplicates). The key is that BIER-FRR based on alternative/backup paths provides link/node protection by using the same unicast FRR mechanism.
Zzh> Jeffrey

Best wishes,

Michael

https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!Wj1e9px9Ce8Xcz9rcHmfXeU8TVvbU8Lw3zyD4PcERboj1UQ2wJWv15ZrZm1PWGuf$

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Mar 2021 08:13:10 -0700

Hi Michael,
I have a question to what you see BIER-specific in detecting a failure in
the network for the local protection:

I think that the ability of OAM to exercise the specific path in the end
nodes is limited and might not be generally expected. As noted in RFC 5880
for BFD:

   ... a protocol intended to detect faults in the
   bidirectional path between two forwarding engines, including
   interfaces, data link(s), and to the extent possible the forwarding
   engines themselves ...

I think that detecting BIER failure between BIER neighbors is no different
from detecting the failure between these nodes in the underlay network.

Regards,
Greg

On Mon, Mar 22, 2021 at 6:40 AM Michael Menth <[email-masked]>
wrote:

> > Whether it is IP FRR, MPLS FRR, or BIER FRR, the key is that
> alternative/backup paths are pre-installed. Upon the detection of failure,
> the PLR uses alternative/backup path before global repair finishes.
> >
> > The determination of alternative/backup path can be SPF based (e.g. LFA)
> which involves IGP, or controller based, or any other way (e.g. static
> configuration or pre-signaling in case of MPLS). That is not BIER specific.
> >
> > Specifically for BIER FRR, when we say "BIER can take advantage of
> unicast FRR", there are two scenarios/aspects about that:
> >
> > 1. BIER does not do any FRR by itself at all (i.e. no primary/backup
> branches for BIFT entries), but rely on unicast FRR to each BFR neighbor.
>
> > 2. BIER does have its own FRR constructs (i.e., ECMP/primary/backup
> branches for BIFT entries), but these are still determined based on
> "unicast" FRR, because we're using the alternative/backup paths to the
> BFERs. This is not "simply using unicast FRR" - because we do need to
> create BIER specific forwarding state for those alternative/backup paths
> (BIER label, F-BM, etc.). It either uses the unicast FRR state (when BIER
> does follow exact unicast paths) or uses unicast FRR mechanisms (but does
> not follow exact unicast paths - i.e. unicast and BIER are using
> incongruent topology or algorithm) - whether it is IGP based or not. This
> does provide node protection as well as link protection.
>
> Here some caveats
> > Cc: Greg Mirsky <[email-masked]>; BIER WG <[email-masked]>;
> Huaimo Chen <[email-masked]>; BIER WG Chairs <
> [email-masked]>
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$
> >
> >>>                 (under
> >>>                 revision)
> >>>
> >>>                 > On Tue, Mar 16, 2021 at 7:41 AM <
> [email-masked] <mailto:[email-masked]>
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$
> >
> >>>                 >     <
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$
> >>
> >>>                 >
> >>>                 >     Authors, please respond to the list indicating
> whether you are aware
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$
> >
> >>>                 >
> >>>
> >>>                 --
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$
> >
> >>>
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$
> >
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$
> >
> >>>
> https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$
> >
> >>>

---

From: Michael Menth <[email-masked]>
Date: Mon, 22 Mar 2021 16:31:59 +0100

Hi Greg,

if the BFR-NBR is forward-connected, there should be some failure
notification mechanism in place whose functionality may be re-used
somehow. If the BFR-NBR is forward-routed, I am not sure whether its
reachability is monitored. I thought there is some draft onf bier-bfd
which does the job? I haven't looked into its details.

Best wishes,

Michael

Am 22.03.2021 um 16:13 schrieb Greg Mirsky:
> Hi Michael,
> I have a question to what you see BIER-specific in detecting a failure
> in the network for the local protection:
> 
> nodes is limited and might not be generally expected. As noted in RFC
> 5880 for BFD:
> 
> I think that detecting BIER failure between BIER neighbors is no
> different from detecting the failure between these nodes in the underlay
> network.
> 
> Regards,
> Greg
> 
> On Mon, Mar 22, 2021 at 6:40 AM Michael Menth <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi Jeffrey, all,
> 
>     alternative/backup paths are pre-installed. Upon the detection of
>     failure, the PLR uses alternative/backup path before global repair
>     finishes.
>     >
>     > The determination of alternative/backup path can be SPF based
>     (e.g. LFA) which involves IGP, or controller based, or any other way
>     (e.g. static configuration or pre-signaling in case of MPLS). That
>     is not BIER specific.
>     >
>     > 1. BIER does not do any FRR by itself at all (i.e. no
>     primary/backup branches for BIFT entries), but rely on unicast FRR
>     to each BFR neighbor.
> 
>     > 2. BIER does have its own FRR constructs (i.e.,
>     ECMP/primary/backup branches for BIFT entries), but these are still
>     determined based on "unicast" FRR, because we're using the
>     alternative/backup paths to the BFERs. This is not "simply using
>     unicast FRR" - because we do need to create BIER specific forwarding
>     state for those alternative/backup paths (BIER label, F-BM, etc.).
>     It either uses the unicast FRR state (when BIER does follow exact
>     unicast paths) or uses unicast FRR mechanisms (but does not follow
>     exact unicast paths - i.e. unicast and BIER are using incongruent
>     topology or algorithm) - whether it is IGP based or not. This does
>     provide node protection as well as link protection.
> 
>     Here some caveats
>     > From: BIER <[email-masked] <mailto:[email-masked]>>
>     On Behalf Of Michael Menth
>     > To: Tony Przygienda <[email-masked]
>     <mailto:[email-masked]>>; Jeff Tantsura
>     <[email-masked] <mailto:[email-masked]>>
>     > Cc: Greg Mirsky <[email-masked]
>     <mailto:[email-masked]>>; BIER WG <[email-masked]
>     <mailto:[email-masked]>>; Huaimo Chen <[email-masked]
>     <mailto:[email-masked]>>; BIER WG Chairs
>     <[email-masked] <mailto:[email-masked]>>
>     >> On Sun, Mar 21, 2021 at 9:20 PM Jeff Tantsura
>     <[email-masked] <mailto:[email-masked]>
>     >> <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>
>     >>>     On Mar 21, 2021, at 10:06, Greg Mirsky
>     <[email-masked] <mailto:[email-masked]>
>     >>>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>>
>     >>>     
>     >>>     Hi Huaimo,
>     >>>     <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>>
>     >>>         Hi Greg,
>     >>>
>     >>>             My responses to another email below should
>     address/answer
>     >>>         them.
>     >>>
>     >>>       
>     <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>
>     >>>       
>      <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$
>     <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>
>     >
>     >>>
>     >>>
>     >>>         Best Regards,
>     >>>         Huaimo
>     >>>       
>     <mailto:[email-masked]>
>     >>>         <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked]>
>     >>>         <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     >>>         *Cc:* [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>> <[email-masked]
>     <mailto:[email-masked]>
>     >>>         <mailto:[email-masked] <mailto:[email-masked]>>>; BIER WG
>     Chairs <[email-masked] <mailto:[email-masked]>
>     >>>         <mailto:[email-masked] <mailto:[email-masked]>>>
>     >>>         <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     >>>         wrote:
>     >>>
>     >>>             Hi Tony,
>     >>>
>     <mailto:[email-masked]>
>     >>>             <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked]>
>     >>>             <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     >>>             <mailto:[email-masked]
>     <mailto:[email-masked]>>>; [email-masked] <mailto:[email-masked]>
>     >>>             <mailto:[email-masked] <mailto:[email-masked]>>
>     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked]>
>     >>>             <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >>>
>     >>>                 Hi Michael,
>     >>>
>     <mailto:[email-masked]>
>     >>>                 <mailto:[email-masked]
>     <mailto:[email-masked]>>> on behalf of Michael
>     >>>                 <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>                 <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     >>>                 > I think it's a good addition within the
>     architecture for the case IGP is
>     >>>                 > not used for signalling, e.g. when controller
>     or static programming.
>     >>>
>     >>>                 provide BIER FRR since the BIER packets are
>     forwarded
>     >>>                 using the BIFTs.
>     >>>                 When failures happen in the network, the BIER
>     packets
>     >>>                 are still forwarded
>     >>>                 >
>     >>>                 > The draft must however explain in what
>     scenarios it is used and quote
>     >>>                 > the according IGP drafts to guarantee
>     loop-free behavior (well, BIER
>     >>>                 > will tie-break loops but we'll have 1x
>     microloop & possibly not deliver
>     >>>                 > payload if BIER FRR is not properly
>     computed/intsalled). With that the
>     >>>                 > draft should also pay attention to how the
>     function is deployed/updated
>     >>>                 > network-wide if IGP is not present
>     >>>
>     >>>                 [HC]: When IGP is running in the network, each
>     BFR in
>     >>>                 the network calculates,
>     >>>                 calculates, installs and/or updates the BIER FRR
>     BIFTs
>     >>>                 into BFRs in the network,
>     >>>                 for missing FRR on the routing underlay? If
>     there is a
>     >>>                 FRR on the
>     >>>                 routing underlay (also provided through a
>     controller),
>     >>>                 tunnel-based
>     >>>                 [HC]: The BIER FRR in the draft is independent
>     of the
>     >>>                 underlay IP FRR.
>     >>>                 (for routing underlays, not for BIER). Challenge
>     is to
>     >>>                 keep state low.
>     >>>                 LFA-based solutions help a lot and outperform
>     others.
>     >>>                 100% protection is
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$>
>     >
>     >>>                 (under
>     >>>                 revision)
>     >>>
>     >>>                 >
>     >>>                 > thanks
>     >>>                 >
>     >>>                 > -- tony
>     >>>                 >
>     >>>                 > On Tue, Mar 16, 2021 at 7:41 AM
>     <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>                 > <mailto:[email-masked]
>     <mailto:[email-masked]>>>> wrote:
>     >>>                 >
>     >>>                 >     A 2-week WG adoption call begins for the
>     following draft:
>     >>>                 >
>     >>>                 >   
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$>
>     >
>     >>>                 >   
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$>
>     >>
>     >>>                 >
>     >>>                 >     Please indicate your support or objection
>     by March 30th, 2021.
>     >>>                 >
>     >>>                 >     Authors, please respond to the list
>     indicating whether you are aware
>     >>>                 >     of any IPR that applies to this draft.
>     >>>                 >
>     >>>                 >     Thanks,
>     >>>                 >
>     >>>                 >     Sandy (As WG secretary, on behalf of
>     Greg/Tony)
>     >>>                 >
>     >>>                 >
>     >>>                 >
>     >>>                 > _______________________________________________
>     >>>                 > BIER mailing list
>     >>>                 > [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>                 >
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$>
>     >
>     >>>                 >
>     >>>
>     >>>                 --
>     >>>                 <mailto:[email-masked]
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$>
>     >
>     >>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>               
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$>
>     >
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>               
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >>>               
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>
>     >
>     >>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>>           
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >>>           
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>
>     >
>     >>>
>     >>>     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >>>   
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >>>   
>      <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >
>     >>
>     >>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >>
>     >
>     > --
>     <https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$>
>     >
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     >
>     http://kn.inf.uni-tuebingen.de <http://kn.inf.uni-tuebingen.de>
>

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 22 Mar 2021 08:51:19 -0700

Hi Michael,
thank you for your expedient clarification. To the best of my
understanding, draft-ietf-bier-bfd analyzes e2e monitoring of the
particular multicast distribution tree in a BIER domain using RFCs 8562 and
8563 as the base specifications of p2mp BFD. For the local protection p2p
BFD in Asynchronous mode is more common. For that scenario, each BFD system
periodically transmits BFD Control packets so that the remote peer can
detect the failure if the Detection Time expires or from the Diag field
value. I think that equally works in case BIER neighbors are on the same
underlay link or multiple links apart.

Regards,
Greg

On Mon, Mar 22, 2021 at 8:32 AM Michael Menth <[email-masked]>
wrote:

> >     >>>     perhaps my question was not clearly stated. Let me re-phrase
> it
> >     >>>     and add more detail to the scenario.
> >     >>>                 [HC]: When the routing underlay supports IP FRR,
> the
> >     >>>                 BIER should also
> >     >>>                 using the old BIFTs until the old BIFTs are
> updated
> >     >>>                 according to the
> >     >>>                 So, below the line, an applicability statement
> would
> >     >>>                 be helpful. What
> >     >>>                 are those cases?
> >     >>>                 installs and/or updates its BIER FRR BIFTs. The
> BIER
> >     >>>                 FRR in the draft is
> >     >>>                 However, if the controller takes care of
> BIER-FRR,
> >     >>>                 what could be reasons
> >     >>>                 > On Tue, Mar 16, 2021 at 7:41 AM
> >     >>>                 >     Authors, please respond to the list

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 22 Mar 2021 16:06:51 +0000

Indeed bier-bfd is for e2e detection and more useful for protection at overlay (e.g. the ingress redundancy).
For BIER FRR, link/neighbor failure detection should be no different from or additional to unicast case.

Jeffrey

From: Greg Mirsky <[email-masked]>
Sent: Monday, March 22, 2021 11:51 AM
To: Michael Menth <[email-masked]>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>; Tony Przygienda <[email-masked]>; Jeff Tantsura <[email-masked]>; BIER WG <[email-masked]>; Huaimo Chen <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Michael,
thank you for your expedient clarification. To the best of my understanding, draft-ietf-bier-bfd analyzes e2e monitoring of the particular multicast distribution tree in a BIER domain using RFCs 8562 and 8563 as the base specifications of p2mp BFD. For the local protection p2p BFD in Asynchronous mode is more common. For that scenario, each BFD system periodically transmits BFD Control packets so that the remote peer can detect the failure if the Detection Time expires or from the Diag field value. I think that equally works in case BIER neighbors are on the same underlay link or multiple links apart.

Regards,
Greg

On Mon, Mar 22, 2021 at 8:32 AM Michael Menth <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Best wishes,

Michael

Am 22.03.2021 um 16:13 schrieb Greg Mirsky:
> On Mon, Mar 22, 2021 at 6:40 AM Michael Menth <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     Hi Jeffrey, all,
>
>     > From: BIER <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     > To: Tony Przygienda <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; Jeff Tantsura
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     > Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; BIER WG <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; Huaimo Chen <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; BIER WG Chairs
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
>     >>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>     <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
>     >>>
>     >>>     
>     >>>     Hi Huaimo,
>     >>>     <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
>     >>>
>     >>>         Hi Greg,
>     >>>
>      https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>
>     <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>>
>     >>>
>      <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>
>     <https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bier/VsTPRmUi-26VSWrBPzdnLXzPvT0/__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD2kESs5M$>>
>     >
>     >>>
>     >>>
>     >>>         Best Regards,
>     >>>         Huaimo
>     >>>
>     >>>         *From:* Greg Mirsky <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>         <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>         *To:* Huaimo Chen <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>         <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>         *Cc:* [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>         <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>>; BIER WG
>     Chairs <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>         <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>         <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>         wrote:
>     >>>
>     >>>             Hi Tony,
>     >>>
>     >>>             *From:* Tony Przygienda <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>             <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>             *To:* Huaimo Chen <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>             <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>             *Cc:* Michael Menth <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>             <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>; [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>             <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>             On Tue, Mar 16, 2021 at 5:02 PM Huaimo Chen
>     >>>             <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>             <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>> wrote:
>     >>>
>     >>>                 Hi Michael,
>     >>>
>     >>>                 *From:* BIER <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>                 <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>> on behalf of Michael
>     >>>                 Menth <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>                 <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>
>     >>>                 *To:* [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>                 <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>>
>      https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=03cc*2BIvdV*2BCg*2F0PCFulWzuCa0h4I5sBqn8K5QPT5BR8*3D&amp;reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5dsMDr-$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https:*2F*2Fatlas.informatik.uni-tuebingen.de*2F*menth*2Fpapers*2FMenth20-Sub-6.pdf&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615768749*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=oSLGnBnwcsrY2gaRZqG*2FLSMOYLNQcG0Mjm9NNVc6TUU*3D&reserved=0__;JSUlfiUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD0qZVOwV$>>
>     >
>     >>>                 (under
>     >>>                 revision)
>     >>>
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>                 > <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>                 <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>>> wrote:
>     >>>                 >
>      https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615778703*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=8wxBypO3zOln7rLaSaXO446xFFfpJfOx4Lr6bKO15z4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-2jc53f$>>
>     >
>     >>>                 >
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=797z0ndM2IahVL2y9xPoY*2BOU5x4*2F3w1FaSWfoF*2BC6pQ*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD4kCzIbt$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=evcnoZLl57g4rLoio0gj2Q4XOa26a2cnX4Jt7*2B3Dogg*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVDy4GOze3$>>
>     >>
>     >>>                 >
>     >>>                 > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>                 >
>     https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615788657*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=7kv2BUZk34Y7k9amlOAcHzacQ5ZlDqjGzb4mZWm*2FCXw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3ncbA_Y$>>
>     >
>     >>>                 >
>     >>>
>     >>>                 --
>     >>>                 mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     >>>                 <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>
>      https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=2gozTq4XIXnxQu2P62mtFSGOEID93679cjqQeAQOPbo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-zyaVuE$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=http*3A*2F*2Fkn.inf.uni-tuebingen.de*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=dwQXPxovW3YS99oeGr3*2FdrYKfMFPSR94Xz1ihTfE2l4*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD1u5f6WA$>>
>     >
>     >>>
>     >>>                 [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>
>      https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&amp;data=04*7C01*7Chuaimo.chen*40futurewei.com*7C5d3cb8163c7f4a1557e608d8e86c408f*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514898966623524*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C3000&amp;sdata=aZ6*2BjQBpo7k81fqf*2FnYdfer7mS45RlhB0lPT7*2B*2BVm6I*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD6mgG2AP$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615798609*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=w5ocCaRoOrDQ*2BVSeW1*2Bl7MUnqp3TN6InBTmzXx00blc*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD5IrBvov$>>
>     >
>     >>>                 [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>
>      https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>>
>     >
>     >>>
>     >>>             [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>
>      https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >>>
>      <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>
>     <https://urldefense.com/v3/__https://nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Fmailman*2Flistinfo*2Fbier&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C3d527e94172b4e7234fb08d8e96422e4*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637515963615808573*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=CibFkXbi9yOCwGTwn8k8tIrMoZvvZgi8DL9EGHE*2Fzys*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSU!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD3LYsVdN$>>
>     >
>     >>>
>     >>>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>
>     >>>
>      https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >>>
>      <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >
>     >>
>     >>
>     >> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >>
>     https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >>
>     >
>     > --
>     > mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >
>     https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$<https://urldefense.com/v3/__http:/kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$>
>     <https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$<https://urldefense.com/v3/__http:/kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD8ejpIeg$>>
>     >
>     > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     >
>     https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>
>     <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!TaBu9R1NIxg6A2oUJwvqyklynKAhxVhSWyMJeXlLJF3k1QaTOWKRs_GVD-s1zfRz$>>
>     >
>     mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     http://kn.inf.uni-tuebingen.de<https://urldefense.com/v3/__http:/kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!T-BOlkllydFXdfP7D1I_5AJDqdVG3ZXUMyxVyTd_sobVF8GYNwgGO2H0XANmqwF5$> <http://kn.inf.uni-tuebingen.de<https://urldefense.com/v3/__http:/kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!T-BOlkllydFXdfP7D1I_5AJDqdVG3ZXUMyxVyTd_sobVF8GYNwgGO2H0XANmqwF5$>>
>

--
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]<mailto:[email-masked]>
http://kn.inf.uni-tuebingen.de<https://urldefense.com/v3/__http:/kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!T-BOlkllydFXdfP7D1I_5AJDqdVG3ZXUMyxVyTd_sobVF8GYNwgGO2H0XANmqwF5$>

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 22 Mar 2021 21:35:48 +0100

> and od the work and drink some beer together if they choose.

I stand corrected of course, it was Huaimo's draft

-- tony

---

From: <[email-masked]>
Date: Tue, 23 Mar 2021 09:54:42 +0800 (CST)

Hi Tony,

When primary NBR has failed, the following two schemes have the same logic, both of them limit the processing socpe to the failure of specific primary NBR.

1) Within the scope of specific FRR-BIFT for the primary NBR, when packet is steered to an FRR-BIFT entry, the bitstring contained in the outgoing copy is the result of "original bitstring of the received packet" & "FBM".

2) A single BIFT entry with primary NBR and backup path, when packet is steered to backup path, the bitstring contained in the outgoing copy is the result of "original bitstring of the received packet" & "primary FBM" & "backup FBM".

For example, BIFT entry 1 has primary NBR X, BIFT entry 2 has primary NBR Y, but they have the same backup path. When NBR X has failed, BIFT entry 1 need switch to backup path, but BIFT entry 2 need not.

If the above two schemes are equivalent,  I think the simple one is the better one. There is no need to maintain so many FRR-BIFT tables as draft-chen described.

Regards,

PSF

原始邮件

发件人：TonyPrzygienda
收件人：Gengxuesong (Geng Xuesong);
抄送人：Jeffrey (Zhaohui) Zhang;Aijun Wang;BIER WG;张征00007940;BIER WG Chairs;
日 期 ：2021年03月23日 04:36
主 题 ：Re: [Bier] WG adoption call for draft-chen-bier-frr-02

On Fri, Mar 19, 2021 at 11:42 AM Tony Przygienda <[email-masked]> wrote:

I would prefer a single document on bier-frr as joined Menth and Xuesong draft with the single BIFT mode & possibly multiple (again, modulo technical comments on it right now) but it's up to the authros to sit down and od the work and drink some beer together if they choose. 

-- tony

---

From: duanfanghong <[email-masked]>
Date: Tue, 23 Mar 2021 02:57:45 +0000

Hi all

I support the adoption.

Thanks,

Fanghong Duan.

Thanks,

---

From: Lizhenbin <[email-masked]>
Date: Wed, 24 Mar 2021 09:23:04 +0000

Hi All,
I support the adoption.

Best Regards,
Robin

--------------------------------------------------
李振斌 Li Zhenbin
Mobile: +86-13651017745<tel:+86-13651017745>/+968-91797068
Email: [email-masked]<mailto:[email-masked]>
发件人：zhang.zheng <[email-masked]>
收件人：bier <[email-masked]>
抄 送：bier-chairs <[email-masked]>
时 间：2021-03-16 14:41:49
主 题：[Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 24 Mar 2021 14:34:22 -0400

Support the adoption.
I am not aware of any IPR that applies to this draft.
The track for this draft to take, either experimental or informational, can
be decided later.

Thanks,
- Xufeng

On Wed, Mar 24, 2021 at 5:23 AM Lizhenbin <[email-masked]> wrote:

> Mobile: +86-13651017745/+968-91797068
> Email: [email-masked]
> *发件人：*zhang.zheng <[email-masked]>
> *收件人：*bier <[email-masked]>
> *抄 送：*bier-chairs <[email-masked]>
> *时 间：*2021-03-16 14:41:49
> *主 题：*[Bier] WG adoption call for draft-chen-bier-frr-02
>

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 25 Mar 2021 21:05:48 +0000

Hi Everyone,

    Michael, Steffan, Huaimo and Mike met to discuss the merge and we are in agreement that if draft-chen-bier-frr is adopted we will expand it to include a framework along with the tunnel and LFA based solutions.

Best Regards,
Huaimo

+1

thanks

-- tony

Thanks,

---

From: Michael Menth <[email-masked]>
Date: Thu, 25 Mar 2021 22:46:04 +0100

Hi all,

I support the adoption of this document.

Kind regards,

Michael

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 25 Mar 2021 21:36:28 -0400

Hi Huaimo

As co-author of BIER FRR I agree as well that it is a very good idea to add
to this draft the framework of IGP based native IP LFA / TI-LFA local
protection solution as well as tunnel based draft solution below.

https://tools.ietf.org/html/draft-merling-bier-frr-00

Kind Regards

Gyan
On Thu, Mar 25, 2021 at 5:06 PM Huaimo Chen <[email-masked]>
wrote:

> Hi Everyone,
>
>     Michael, Steffan, Huaimo and Mike met to discuss the merge and we are
> in agreement that if draft-chen-bier-frr is adopted we will expand it to
> include a framework along with the tunnel and LFA based solutions.
>
> Best Regards,
> Huaimo
> *From:* BIER <[email-masked]> on behalf of Tony Przygienda <
> [email-masked]>
> *Sent:* Tuesday, March 16, 2021 6:08 AM
> *To:* zhang.zheng <[email-masked]>
> *Cc:* BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C79ac63710b47427a558d08d8e8638df2%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637514861570555970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw%3D&reserved=0>
>
-- 

*Gyan Mishra*

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 26 Mar 2021 10:16:51 +0100

Excellent, having authors of multiple drafts in this area co-allesce and
colaborate on a single framework document would be a very positive and
productive development in my eyes. If it explains the IGP model e'one uses
today so far and the architecture kind of implies as default with IGP
signalling, the better.

Discussions around informational/experimental can happen later of course
but generally experimental will introduce the burden of two implementations
most likely (and with that many models that may not be trivial) and of
course experimental is needed in case we end up allocating codepoints or
need to agree on some on-the-wire formats (algorithms are not that clear).
We play it by the ear depending on the scope of the document as it evolves
and content would be my take for now.

thanks

-- tony

---

From: "zhangzhe (M)" <[email-masked]>
Date: Fri, 26 Mar 2021 13:25:21 +0000

Hi all.

I support the adoption.

Thanks,
Zhe Zhang

Thanks,

---

From: Steffen Lindner <[email-masked]>
Date: Fri, 26 Mar 2021 17:42:35 +0100

Hi all,

Kind regards

Steffen

>> Sandy (As WG secretary, on behalf of Greg/Tony)

----
Steffen Lindner, M.Sc.
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Room B303, Sand 13, 72076 Tuebingen, Germany
phone:  (+49)-7071/29-70545
mailto:  [email-masked]
http://kn.inf.uni-tuebingen.de

---

From: Daniel Merling <[email-masked]>
Date: Fri, 26 Mar 2021 17:45:52 +0100

Hi all,

Best regards

Daniel

---

From: Huaimo Chen <[email-masked]>
Date: Sat, 27 Mar 2021 01:56:10 +0000

Hi Everyone,

    I support the adoption as co-author and am aware of a provisional patent application (#63104985) that may apply to this draft and is in process of IPR disclosure.

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Tuesday, March 16, 2021 2:40 AM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,

---

From: Huaimo Chen <[email-masked]>
Date: Sat, 27 Mar 2021 02:10:47 +0000

Hi Tony,

    Thank you very much for your valuable suggestions, which will help us to make the document better.

Best Regards,
Huaimo
________________________________
From: Tony Przygienda <[email-masked]>
Sent: Friday, March 26, 2021 5:16 AM
To: Huaimo Chen <[email-masked]>
Cc: zhang.zheng <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Excellent, having authors of multiple drafts in this area co-allesce and colaborate on a single framework document would be a very positive and productive development in my eyes. If it explains the IGP model e'one uses today so far and the architecture kind of implies as default with IGP signalling, the better.

Discussions around informational/experimental can happen later of course but generally experimental will introduce the burden of two implementations most likely (and with that many models that may not be trivial) and of course experimental is needed in case we end up allocating codepoints or need to agree on some on-the-wire formats (algorithms are not that clear). We play it by the ear depending on the scope of the document as it evolves and content would be my take for now.

thanks

-- tony

On Thu, Mar 25, 2021 at 10:05 PM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Everyone,

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 16, 2021 6:08 AM
To: zhang.zheng <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-bier-frr%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C1e0e547abd8d47f7e26b08d8f037fa5a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637523470508327528%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=t8qPHEul9oXIfEyUj907PJCQ%2BHPEHqwARO8choKcmAU%3D&reserved=0>

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 30 Mar 2021 02:26:27 +0000

Shouldn't it be the other way around - expand/merge first and then adopt?

In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs, which I don't think should be included in the merged draft at all, for the following problems:

  1.  Scaling - we need one extra BIFT for each <neighbor, BIFT>. This not only means extra memory, but also additional processing overhead including downloading the tables to the forwarding plane.
  2.  If two neighbors fail simultaneously yet both can be protected by a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the first two neighbors. This is not an unusual situation - you could have two neighbors reached by the same link or the same line card, and the link/card fails.
  3.  Exactly when to switch back from a per-nbr FRR BIFT to the regular BIFT?

The draft says the following about #3:

   In general, when the routing protocol has re-converged on the new
   topology taking into account the failure of X, the BIRT is re-
   computed using the updated LSDB and the BIFT is re-derived from the
   BIRT.  Once the BIFT is installed ready for activation, it is
   activated to forward packets with BIER headers and the FRR-BIFT for X
   is de-activated.

Does that mean for each computation, you need to know and mark which failed neighbor that it takes care of, so that when the BIFT is sent down to forwarding plane you can decide if currently used FRR-BIFT can be switched back to the main BIFT?

Also consider the following:

  1.  At moment T you switch to FRR BIFT for nbr X
  2.  At moment T+1ms a new BIFT is calculated, which takes care of a remote failure but not nbr X (nbr X is still considered up in this calculation) - would you switch FRR BIFT to the newly calculated main BIFT? If you don't, the remote failure could lead to packet losses until the new main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.

Jeffrey

From: BIER <[email-masked]> On Behalf Of Huaimo Chen
Sent: Thursday, March 25, 2021 5:06 PM
To: Tony Przygienda <[email-masked]>; [email-masked] <[email-masked]>
Cc: BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F$>

Thanks,

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 30 Mar 2021 08:32:01 -0700

Dear WG Chairs,
I'm confused and hope you can clarify the state of the WG AP on
draft-chen-bier-frr.
It appears to me that in the course of the discussion a number of
significant problems with the draft were brought forward. Also, it was
proposed to revisit the scope, cooperate with the authors of
draft-merling-bier-frr on a document that discusses both mechanisms of FRR
in BIER (that brings RFC 4090 to my memory). A note from two groups of
authors that they will be working together is very encouraging. What I
think will be the result, regardless of the short name of that draft, will
be, in my opinion, a new individual draft. It probably will be presented to
the WG and the WG will discuss if it is ready for the WG adoption poll.
Said all that, I'm not sure what is the status of WG AP on
draft-chen-bier-frr.
Much appreciate your thoughts.
To clarify my position, I don't support wG adoption of the current version
of draft-chen-bier-frr. I will be happy to help in the work on the new
draft by reviewing it and, if authors find helpful, discussing OAM aspects
of FRR.

Regards,
Greg

On Fri, Mar 26, 2021 at 6:56 PM Huaimo Chen <[email-masked]>
wrote:

> Hi Everyone,
>
>     I support the adoption as co-author and am aware of a provisional
> patent application (#63104985) that may apply to this draft and is in
> process of IPR disclosure.
>
> Best Regards,
> Huaimo
> *From:* BIER <[email-masked]> on behalf of [email-masked] <
> [email-masked]>
> *Sent:* Tuesday, March 16, 2021 2:40 AM
> *Cc:* [email-masked] <[email-masked]>

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 30 Mar 2021 09:10:52 -0700

I agree with Jeffrey. The two drafts should be merged into a new draft,
which we will then call to adopt. I suggest that the authors of each of the
two docs:

https://tools.ietf.org/html/draft-merling-bier-frr-00
https://datatracker.ietf.org/doc/draft-chen-bier-frr

..contribute two authors to the merged doc effort, and have Jeffrey
hold the pen as editor/author.

All agreed?

Thanks,
Greg
(Chairs)

On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <[email-masked]>
wrote:

> Shouldn’t it be the other way around – expand/merge first and then adopt?
>
>
>
> In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs,
> which I don’t think should be included in the merged draft at all, for the
> following problems:
>
>
>
>    1. Scaling – we need one extra BIFT for each <neighbor, BIFT>. This
>    not only means extra memory, but also additional processing overhead
>    including downloading the tables to the forwarding plane.
>    2. If two neighbors fail simultaneously yet both can be protected by a
>    3rd neighbor, per-nbr FRR BIFTs can only give protection for one of
>    the first two neighbors. This is not an unusual situation – you could have
>    two neighbors reached by the same link or the same line card, and the
>    link/card fails.
> Does that mean for each computation, you need to know and mark which
> failed neighbor that it takes care of, so that when the BIFT is sent down
> to forwarding plane you can decide if currently used FRR-BIFT can be
> switched back to the main BIFT?
>
>
>
>    2. At moment T+1ms a new BIFT is calculated, which takes care of a
>    remote failure but not nbr X (nbr X is still considered up in this
>    calculation) – would you switch FRR BIFT to the newly calculated main BIFT?
>    If you don’t, the remote failure could lead to packet losses until the new
>    main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.
>
>
>
> Jeffrey
>
>
>
> *Sent:* Thursday, March 25, 2021 5:06 PM
> *To:* Tony Przygienda <[email-masked]>; [email-masked] <
> [email-masked]>
> <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F$>
>

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 30 Mar 2021 16:11:11 +0000

Hi Jeffrey,

    Thanks for your comments.
    My responses are inline below with prefix [HC].

Best Regards,
Huaimo
________________________________
From: Jeffrey (Zhaohui) Zhang <[email-masked]>
Sent: Monday, March 29, 2021 10:26 PM
To: Huaimo Chen <[email-masked]>; Tony Przygienda <[email-masked]>; [email-masked] <[email-masked]>
Cc: BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

[HC]: We will leave it to the chairs to decide whether we have consensus to adopt this draft.

In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs, which I don’t think should be included in the merged draft at all, for the following problems:

[HC]: I do not see the problems. See details below.

  1.  Scaling – we need one extra BIFT for each <neighbor, BIFT>. This not only means extra memory, but also additional processing overhead including downloading the tables to the forwarding plane.

[HC]: It seems that there is no scaling issue. The size of each BIFT is small and the number of neighbors of a BFR is also small. For example, for a network with 0.5k egress nodes (BFERs), and each BFR has 20 neighbors, the memory used on a BFR is about 0.5k * 20 = 10k (forwarding entries).

  1.  If two neighbors fail simultaneously yet both can be protected by a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the first two neighbors. This is not an unusual situation – you could have two neighbors reached by the same link or the same line card, and the link/card fails.

[HC]: This is the case where two or more failures occur at the same time. The existing methods for protecting two or more simultaneous failures can also be used in per-nbr BIFT to protect two or more simultaneous failures.

  1.  Exactly when to switch back from a per-nbr FRR BIFT to the regular BIFT?

[HC]: Refer to the text below from the draft.

   is de-activated.

[HC]: It seems that there are a few ways. One way is to keep track the failure. Another way is using a timer.

  1.  At moment T you switch to FRR BIFT for nbr X
  2.  At moment T+1ms a new BIFT is calculated, which takes care of a remote failure but not nbr X (nbr X is still considered up in this calculation) – would you switch FRR BIFT to the newly calculated main BIFT? If you don’t, the remote failure could lead to packet losses until the new main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.

[HC]: This is the case where two or more failures happen in the network in almost the same time. According to our switch back rule, it will not switch FRR BIFT back to main BIFT since the failure of nbr X is not considered yet. The main BIFT is recomputed considering the remote failure, the FRR BIFT is also recomputed considering the remote failure. Both the remote failure and local failure are protected.

Jeffrey

Hi Everyone,

Best Regards,

Huaimo

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F%24&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cc2be3c14c8ae4974448508d8f3233b24%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637526679941903109%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=o2%2Fs%2FQ%2BaGukBWCJgbA7%2FmPEZF0MG2euVpq41tq5YnBA%3D&reserved=0>

Thanks,

---

From: Michael McBride <[email-masked]>
Date: Tue, 30 Mar 2021 16:28:22 +0000

> I agree with Jeffrey. The two drafts should be merged into a new draft, which we will then call to adopt. I suggest that the authors of each of the two docs:

A difficult road getting a draft accepted in bier lately despite seemingly strong consensus. We will have an -03 published in the next day or two and if you feel the need to issue a new adoption call please do so.

> ..contribute two authors to the merged doc effort, and have Jeffrey hold the pen as editor/author.

Huh? All authors from both drafts will remain on the merged draft and, as much as we respect Jeffrey, he's not an author and certainly doesn't hold the pen.

Mike

All agreed?

Thanks,
Greg
(Chairs)

On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>> wrote:
Shouldn't it be the other way around - expand/merge first and then adopt?

Jeffrey

To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F%24&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C5fea93d60c124c38185908d8f3963c38%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527173876437352%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=EQ00DXiuZoBp3fYt7j2wl%2F0y%2FHhCRKZ8v4uONv3B7c8%3D&reserved=0>

Thanks,

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 30 Mar 2021 09:48:25 -0700

On Tue, Mar 30, 2021 at 9:28 AM Michael McBride <
[email-masked]> wrote:

> Huh? All authors from both drafts will remain on the merged draft
>

Pick them now or pick them later.

> and, as much as we respect Jeffrey, he’s not an author and certainly
> doesn’t hold the pen.
>

As the assigned Editor to work with the author of both drafts, yes he will
hold the pen. If you have another 3rd party Editor to suggest, please do
so. But from the current discussion on the list, I find no one more
qualified to work with the authors of both contributing drafts.

Thanks,
Greg

> Mike
>
>
>
>
>
> All agreed?
>
>
>
> Thanks,
>
> Greg
>
> (Chairs)
>
>
>
> On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <
> [email-masked]> wrote:
>
> *From:* BIER <[email-masked]> *On Behalf Of *Huaimo Chen
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F%24&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C5fea93d60c124c38185908d8f3963c38%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527173876437352%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=EQ00DXiuZoBp3fYt7j2wl%2F0y%2FHhCRKZ8v4uONv3B7c8%3D&reserved=0>
>

---

From: Michael McBride <[email-masked]>
Date: Tue, 30 Mar 2021 17:04:46 +0000

I'm honestly at a loss here. An assigned editor to take over our work? Is this even a thing in the ietf?

If this is the case we will continue working on this draft and keep it individual for now.

mike

From: Greg Shepherd <[email-masked]>
Sent: Tuesday, March 30, 2021 9:48 AM
To: Michael McBride <[email-masked]>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>; [email-masked] <[email-masked]>; Huaimo Chen <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

and, as much as we respect Jeffrey, he's not an author and certainly doesn't hold the pen.

As the assigned Editor to work with the author of both drafts, yes he will hold the pen. If you have another 3rd party Editor to suggest, please do so. But from the current discussion on the list, I find no one more qualified to work with the authors of both contributing drafts.

Thanks,
Greg

Mike

All agreed?

Thanks,
Greg
(Chairs)

Jeffrey

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F%26data%3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F%24&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C1c5fd4db18e2431f463f08d8f39b6caf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637527196165767516%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=rJEgGwKe3zvhltMwI7v12duGQm%2Bg08Kml%2Bum1SzOUAo%3D&reserved=0>

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 30 Mar 2021 17:43:03 +0000

Hi,

At the risk of being viewed as trying to steal the work or trying to squeeze in as a co-author, let me review some history and my position here.

Two years ago after draft-merling was first published, there were quite some discussions involving the Michael/Daniel and some vendors/operator, and both tunnel-to-neighbor and alternative-to-BFERs options were discussed. We concluded that we would not need to standardize it, and Michael/Daniel did not progress the work in BIER WG afterwards.

If I just wanted to squeeze in as co-author of another BIER draft, I assume I could have done that two years ago.

If we were not calling for adoption draft-chen-bier-frr, there would be no controversy.

Now that we're here, given my strong objection to have per-nbr FRR BIFTs in a WG document, I do want to speak up and I appreciate Greg's suggestion of me as editor, and I am confident that I would be the best person for it given the history and my insights on this matter.

As for whether I am eligible for the role process wise - I suppose I could also write a draft-zzhang on this topic and join the merge? In fact, that may be the best way to fully describe my view on BIER FRR.

In fact - process wise - if we talk about merging wouldn't it be merging into draft-merling given it's the earliest and it is more close to the unicast FRR model (not using separate FRR BIFTs)?

And finally, yes if this remains as an individual informational draft, I would not care so much.

Thanks.
Jeffrey

From: Michael McBride <[email-masked]>
Sent: Tuesday, March 30, 2021 1:05 PM
To: [email-masked]
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>; [email-masked] <[email-masked]>; Huaimo Chen <[email-masked]>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

mike

From: Greg Shepherd <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 30, 2021 9:48 AM
To: Michael McBride <[email-masked]<mailto:[email-masked]>>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Thanks,
Greg

Mike

All agreed?

Thanks,
Greg
(Chairs)

Jeffrey

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F*24&data=04*7C01*7Cmichael.mcbride*40futurewei.com*7C1c5fd4db18e2431f463f08d8f39b6caf*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637527196165767516*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=rJEgGwKe3zvhltMwI7v12duGQm*2Bg08Kml*2Bum1SzOUAo*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TgjeaofJrDC7_PaFdp5121nhpqbYPTuvoqq2taHHIFDUiNUmO2r2LHrrnuo6K9DY$>

Thanks,

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 30 Mar 2021 18:48:41 +0100

Mike,

I believe that the chairs are empowered to appoint editors for working group
drafts, although this is something I have only seen a very few times in my
IETF involvement. Normally, unless there is a breakdown of some sort, the
authors are left to self-organise.

However, before a draft is adopted, I don't think the chairs have such a
power. They can, of course, strongly recommend. 

And the chairs could start a design team to work on a new draft and appoint
whoever they want to that design team. If that new draft decided to reuse
substantial part of another active draft without the blessing of the authors
of the other draft, then that would be "bad form".

Cheers,

Adrian

From: BIER <[email-masked]> On Behalf Of Michael McBride
Sent: 30 March 2021 18:05
To: [email-masked]
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
<[email-masked]>; BIER WG <[email-masked]>; Huaimo Chen
<[email-masked]>; BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

I'm honestly at a loss here. An assigned editor to take over our work? Is
this even a thing in the ietf?

If this is the case we will continue working on this draft and keep it
individual for now.

mike

From: Greg Shepherd <[email-masked] <mailto:[email-masked]> > 
Sent: Tuesday, March 30, 2021 9:48 AM
To: Michael McBride <[email-masked]
<mailto:[email-masked]> >
Cc: Jeffrey (Zhaohui) Zhang <[email-masked] <mailto:[email-masked]>
>; BIER WG <[email-masked] <mailto:[email-masked]> >; BIER WG Chairs
<[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]>
<[email-masked] <mailto:[email-masked]> >; Huaimo Chen
<[email-masked] <mailto:[email-masked]> >
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

On Tue, Mar 30, 2021 at 9:28 AM Michael McBride
<[email-masked] <mailto:[email-masked]> >

and, as much as we respect Jeffrey, he's not an author and certainly doesn't
hold the pen.

As the assigned Editor to work with the author of both drafts, yes he will
hold the pen. If you have another 3rd party Editor to suggest, please do so.
But from the current discussion on the list, I find no one more qualified to
work with the authors of both contributing drafts.

Thanks,

Greg

Mike

All agreed?

Thanks,

Greg

(Chairs)

On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <[email-masked]
<mailto:[email-masked]> > wrote:

In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs, which
I don't think should be included in the merged draft at all, for the
following problems:

1.	Scaling - we need one extra BIFT for each <neighbor, BIFT>. This not
only means extra memory, but also additional processing overhead including
downloading the tables to the forwarding plane.
2.	If two neighbors fail simultaneously yet both can be protected by a
3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the
first two neighbors. This is not an unusual situation - you could have two
neighbors reached by the same link or the same line card, and the link/card
fails.
3.	Exactly when to switch back from a per-nbr FRR BIFT to the regular
BIFT?

   is de-activated.

Does that mean for each computation, you need to know and mark which failed
neighbor that it takes care of, so that when the BIFT is sent down to
forwarding plane you can decide if currently used FRR-BIFT can be switched
back to the main BIFT?

1.	At moment T you switch to FRR BIFT for nbr X
2.	At moment T+1ms a new BIFT is calculated, which takes care of a
remote failure but not nbr X (nbr X is still considered up in this
calculation) - would you switch FRR BIFT to the newly calculated main BIFT?
If you don't, the remote failure could lead to packet losses until the new
main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.

Jeffrey

From: BIER <[email-masked] <mailto:[email-masked]> > On Behalf
Of Huaimo Chen
Sent: Thursday, March 25, 2021 5:06 PM
To: Tony Przygienda <[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]>
<[email-masked] <mailto:[email-masked]> >
Cc: BIER WG <[email-masked] <mailto:[email-masked]> >; BIER WG Chairs
<[email-masked] <mailto:[email-masked]> >
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi Everyone,

    Michael, Steffan, Huaimo and Mike met to discuss the merge and we are in
agreement that if draft-chen-bier-frr is adopted we will expand it to
include a framework along with the tunnel and LFA based solutions.

Best Regards,

Huaimo

  _____  

From: BIER <[email-masked] <mailto:[email-masked]> > on behalf
of Tony Przygienda <[email-masked] <mailto:[email-masked]> >
Sent: Tuesday, March 16, 2021 6:08 AM
To: zhang.zheng <[email-masked] <mailto:[email-masked]> >
Cc: BIER WG <[email-masked] <mailto:[email-masked]> >; BIER WG Chairs
<[email-masked] <mailto:[email-masked]> >
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02 

+1 

I think it's a good addition within the architecture for the case IGP is not
used for signalling, e.g. when controller or static programming. 

thanks 

-- tony 

On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]
<mailto:[email-masked]> > wrote:

Authors, please respond to the list indicating whether you are aware of any
IPR that applies to this draft.

Thanks,

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 30 Mar 2021 20:31:37 +0200

On Tue, Mar 30, 2021 at 6:28 PM Michael McBride <
[email-masked]> wrote:

> A difficult road getting a draft accepted in bier lately despite seemingly
> strong consensus. We will have an -03 published in the next day or two and
> if you feel the need to issue a new adoption call please do so.
>
>
>

Mike, it's your interpretation AFAIS so please do not try to introduce
contention where I don't see any. Nothing "difficult" here. I think the
draft had a lot of interest and generally positive response. Not many
drafts get that, especially attention. Even better we get the previous
draft joined together so we can incorporate both models people pursue in a
clear framework. As to technical objections, they need be discussed and
resolved and/or documented clearly in the draft, that's the point of the
process.

As per my take as simplest way forward we should join previous drafts and
republish into -huaimo-frr which will become draft-ietf-bier-frr anyway
when adopted after the merge so really, what's the difference before one
individual draft or another ending up as ietf-bier-frr except bits of
history [although I admit this may be important to some people] ;-) And of
course authorship has to be apportioned fairly so people are given clear
credit for the work and ideas. That's important.

Since the drafts are being joined I would also like the authors of merged
draft to suggest one or max two committed editors or otherwise see a clear
pen holding here, especially, even if the draft ends up informational, this
is a framework that should be well written and written in a unified way
because it will get quite a lot of reading in the ongoing years I think.

thanks

-- tony

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 30 Mar 2021 15:04:41 -0400

With the merged document would we keep as informational or make standards
track.

Since BIER-FRR does provide FRR capability without an IGP using a separate
FRR-BIFT which could be envisioned as a SDN PCE CC control based solution
that would be new innovative solution that is not provided by the Merling
IGP tunnel based IP LFA  draft.

In that sense BIER-FRR could stand on its own for adoption strictly on
those grounds.

Another option could be to update Merling as informational for IGP based
tunnel or IP LFA local protection FRR and proceed with adoption of BIER-FRR
for non IGP based FRR solution.  That would circumvent any scalability
issues that are being asked as the non IGP based scenario would be
typically a smaller BIER domain.

Kind Regards

Gyan

On Tue, Mar 30, 2021 at 2:32 PM Tony Przygienda <[email-masked]> wrote:

>> A difficult road getting a draft accepted in bier lately despite
>> seemingly strong consensus. We will have an -03 published in the next day
>> or two and if you feel the need to issue a new adoption call please do so.
>>
>>
>>
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: <[email-masked]>
Date: Wed, 31 Mar 2021 09:29:39 +0800 (CST)

Hi Jeffrey, Chairs, All

Hope that the following single-BIFT based method can be adopted in the merged draft (I posted this idea a few days ago):

    we can let BIFT entry contain both primary NBR and backup path (note that the backup path may be direct NBR, or remote NBR, or segment-list, according to IGP TI-LFA result).

And, the following is a further explanation of the comparison between the single-BIFT based and FRR-BIFT based, they want to solve the same problem as example shows.

If we are not clear about the above single-BIFT based idea, maybe we can also write a separate informaitonal draft to describe it.

Regards,

PSF

原始邮件

发件人：Jeffrey(Zhaohui)Zhang
收件人：Michael McBride;[email-masked];
抄送人：张征00007940;BIER WG;Huaimo Chen;BIER WG Chairs;
日 期 ：2021年03月31日 01:43
主 题 ：Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Hi,

 

 

 

 

Now that we’re here, given my strong objection to have per-nbr FRR BIFTs in a WG document, I do want to speak up and I appreciate Greg’s suggestion of me as editor, and I am confident that I would be the best person for it given the history and my insights on this matter.

As for whether I am eligible for the role process wise – I suppose I could also write a draft-zzhang on this topic and join the merge? In fact, that may be the best way to fully describe my view on BIER FRR.

In fact - process wise – if we talk about merging wouldn’t it be merging into draft-merling given it’s the earliest and it is more close to the unicast FRR model (not using separate FRR BIFTs)?

 

Thanks.
 Jeffrey

 

 

I’m honestly at a loss here. An assigned editor to take over our work? Is this even a thing in the ietf?

 

mike

 

 

On Tue, Mar 30, 2021 at 9:28 AM Michael McBride <[email-masked]> wrote:

> .contribute two authors to the merged doc effort, and have Jeffrey hold the pen as editor/author. 

 

 

and, as much as we respect Jeffrey, he’s not an author and certainly doesn’t hold the pen.

 

Thanks,

Greg

Mike

 

All agreed?

Thanks,

Greg

(Chairs)

On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <[email-masked]> wrote:

 

 

Scaling – we need one extra BIFT for each <neighbor, BIFT>. This not only means extra memory, but also additional processing overhead including downloading the tables to the forwarding plane.

If two neighbors fail simultaneously yet both can be protected by a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the first two neighbors. This is not an unusual situation – you could have two neighbors reached by the same link or the same line card, and the link/card fails.

Exactly when to switch back from a per-nbr FRR BIFT to the regular BIFT?

 

   is de-activated.

 

 

At moment T you switch to FRR BIFT for nbr X

At moment T+1ms a new BIFT is calculated, which takes care of a remote failure but not nbr X (nbr X is still considered up in this calculation) – would you switch FRR BIFT to the newly calculated main BIFT? If you don’t, the remote failure could lead to packet losses until the new main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.

Jeffrey

 

 

Hi Everyone,

 

Best Regards,

Huaimo

--------------------------------------------------------------------------------

 

+1

 

 

thanks

-- tony

Thanks,

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 31 Mar 2021 02:04:17 +0000

Hi Greg,

I agree that Jeffery has quite rich experience in BIER WG and participates in ML discussions actively. However, I still think the answer of “who should be the author of the document” depends mostly on “who raises the idea and brings it to IETF”. This is a basic respect for the originality of the author.
Of course, if anyone is interested in this topic, he/she could contribute and co-author the document, when the existing authors would like to.

Best
Xuesong

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Wednesday, March 31, 2021 12:11 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>; [email-masked] <[email-masked]>; Huaimo Chen <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

All agreed?

Thanks,
Greg
(Chairs)

  1.  Scaling – we need one extra BIFT for each <neighbor, BIFT>. This not only means extra memory, but also additional processing overhead including downloading the tables to the forwarding plane.
  2.  If two neighbors fail simultaneously yet both can be protected by a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the first two neighbors. This is not an unusual situation – you could have two neighbors reached by the same link or the same line card, and the link/card fails.
  3.  Exactly when to switch back from a per-nbr FRR BIFT to the regular BIFT?

Jeffrey

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

Thanks,

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 31 Mar 2021 03:23:09 +0000

Hi Shaofu,

We’re on the same page wrt the single-BIFT method.

Thanks.
Jeffrey

From: [email-masked] <[email-masked]>
Sent: Tuesday, March 30, 2021 9:30 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked] <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re:[Bier] WG adoption call for draft-chen-bier-frr-02

Hi Jeffrey, Chairs, All

Regards,

PSF

原始邮件

Thanks.
Jeffrey

From: Michael McBride <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 30, 2021 1:05 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] WG adoption call for draft-chen-bier-frr-02

mike

Thanks,
Greg

Mike

All agreed?

Thanks,
Greg
(Chairs)

Jeffrey

Hi Everyone,

Best Regards,
Huaimo

+1

thanks

-- tony

Thanks,

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 31 Mar 2021 07:52:29 +0200

On Wed, Mar 31, 2021 at 4:04 AM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

> Hi Greg,
>
>
>
> I agree that Jeffery has quite rich experience in BIER WG and participates
> in ML discussions actively. However, I still think the answer of “who
> should be the author of the document” depends mostly on “who raises the
> idea and brings it to IETF”. This is a basic respect for the originality of
> the author.
>

Xuesong, fully acknowledged and originality of ideas overrides all other
considerations and has to be documented clearly IME.  Nevertheless, IME as
well, merged drafts (a very good thing here) benefit from clear author list
and editorship, the earlier in the process the better lest too many
feelings are hurt and unseemly wrangling ensues later. Especially, since
AFAIS this one ends up being read a lot no matter its status or whether it
really standardizes anything on the wire.

--- tony

---

From: Michael Menth <[email-masked]>
Date: Wed, 31 Mar 2021 08:53:29 +0200

Dear Peng, all,

the merged draft will have an implementation-neutral specification as
you describe. A shortcoming of this approach is that it may result in
redundant packets if a packet has been sent over a specific link and
then another packet must be sent over that link for protection purposes.
But that can be fixed with prioritization of backup entries. There are
various ways to achieve that, but that is an optimization issue and a
matter of implementation. This issue will be well documented with
examples, then it's easy to understand.

Implementation options may be mentioned as examples, but they are
platform-specific and the behaviour of bier-frr should be documented in
a similar, neutral style as normal BIER. That's what I understood from
the WG.

Kind regards,

Michael

Am 31.03.2021 um 03:29 schrieb [email-masked]:
> Hi Jeffrey, Chairs, All
> 
> 
> Hope that the following single-BIFT based method can be adopted in the
> merged draft (I posted this idea a few days ago):
> 
>     we can let BIFT entry contain both primary NBR and backup path (note
> that the backup path may be direct NBR, or remote NBR, or segment-list,
> according to IGP TI-LFA result).
> 
>     There are primary FBM and backup FBM. The primary FBM contains the
> Bit-Positions of those BFERs that has the same primary NBR, the backup
> FBM contains the Bit-Positions of those BFERs that has the same backup
> path. In this implementation, when a BFR received a BIER packet, and if
> the primary NBR fails, a copy will be sent to backup path, and *the
> bitstring contained in the copy is the result of "original bitstring of
> the received packet" & "primary FBM" & "backup FBM".*
> 
> 
> And, the following is a further explanation of the comparison between
> the single-BIFT based and FRR-BIFT based, they want to solve the same
> problem as example shows.
> 
>     When primary NBR has failed, the following two schemes have the same
> logic, both of them limit the processing socpe to the failure of
> specific primary NBR.
> 
>     1) Within the scope of specific FRR-BIFT for the primary NBR, when
> packet is steered to an FRR-BIFT entry, the bitstring contained in the
> outgoing copy is the result of "original bitstring of the received
> packet" & "FBM".
> 
>     2) A single BIFT entry with primary NBR and backup path, when packet
> is steered to backup path, the bitstring contained in the outgoing copy
> is the result of "original bitstring of the received packet" & "primary
> FBM" & "backup FBM".
> 
>     For example, BIFT entry 1 has primary NBR X, BIFT entry 2 has
> primary NBR Y, but they have the same backup path. When NBR X has
> failed, BIFT entry 1 need switch to backup path, but BIFT entry 2 need not.
> 
> 
> If we are not clear about the above single-BIFT based idea, maybe we can
> also write a separate informaitonal draft to describe it.
> 
> 
> Regards,
> 
> PSF
> 
> 
> 
> 原始邮件
> *发件人：*Jeffrey(Zhaohui)Zhang
> *收件人：*Michael McBride;[email-masked];
> *抄送人：*张征00007940;BIER WG;Huaimo Chen;BIER WG Chairs;
> *日 期 ：*2021年03月31日 01:43
> *主 题 ：**Re: [Bier] WG adoption call for draft-chen-bier-frr-02*
> At the risk of being viewed as trying to steal the work or trying to
> squeeze in as a co-author, let me review some history and my position here.
> 
>  
> 
> Two years ago after draft-merling was first published, there were quite
> some discussions involving the Michael/Daniel and some vendors/operator,
> and both tunnel-to-neighbor and alternative-to-BFERs options were
> discussed. We concluded that we would not need to standardize it, and
> Michael/Daniel did not progress the work in BIER WG afterwards.
> 
>  
> 
> If I just wanted to squeeze in as co-author of another BIER draft, I
> assume I could have done that two years ago.
> 
>  
> 
> Now that we’re here, given my strong objection to have per-nbr FRR BIFTs
> in a WG document, I do want to speak up and I appreciate Greg’s
> suggestion of me as editor, and I am confident that I would be the best
> person for it given the history and my insights on this matter.
> 
>  
> 
> As for whether I am eligible for the role process wise – I suppose I
> could also write a draft-zzhang on this topic and join the merge? In
> fact, that may be the best way to fully describe my view on BIER FRR.
> 
>  
> 
> In fact - process wise – if we talk about merging wouldn’t it be merging
> into draft-merling given it’s the earliest and it is more close to the
> unicast FRR model (not using separate FRR BIFTs)?
> 
>  
> 
> *From:* Michael McBride <[email-masked]>
> *Sent:* Tuesday, March 30, 2021 1:05 PM
> *To:* [email-masked]
> *Cc:* Jeffrey (Zhaohui) Zhang <[email-masked]>; BIER WG
> <[email-masked]>; BIER WG Chairs <[email-masked]>;
> [email-masked] <[email-masked]>; Huaimo Chen
> <[email-masked]>
> *Subject:* RE: [Bier] WG adoption call for draft-chen-bier-frr-02
> 
>  
> 
> *From:* Greg Shepherd <[email-masked] <mailto:[email-masked]>>
> *Sent:* Tuesday, March 30, 2021 9:48 AM
> *To:* Michael McBride <[email-masked]
> <mailto:[email-masked]>>
> *Cc:* Jeffrey (Zhaohui) Zhang <[email-masked]
> <mailto:[email-masked]>>; BIER WG <[email-masked]
> <mailto:[email-masked]>>; [email-masked]
> <mailto:[email-masked]> <[email-masked]
> <mailto:[email-masked]>>; Huaimo Chen <[email-masked]
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
> As the assigned Editor to work with the author of both drafts, yes he
> will hold the pen. If you have another 3rd party Editor to suggest,
> please do so. But from the current discussion on the list, I find no one
> more qualified to work with the authors of both contributing drafts.
> 
>  
> 
> Thanks,
> 
> Greg
> 
>  
> 
>     Mike
> 
>      
> 
>      
> 
>     All agreed?
> 
>      
> 
>     Thanks,
> 
>     Greg
> 
>     (Chairs)
> 
>      
> 
>     On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang
>     <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         In fact, the essence of draft-chen is the multiple per-nbr FRR
>         BIFTs, which I don’t think should be included in the merged
>         draft at all, for the following problems:
> 
>          
> 
>          1.
> 
>             Scaling – we need one extra BIFT for each <neighbor, BIFT>.
>             This not only means extra memory, but also additional
>             processing overhead including downloading the tables to the
>             forwarding plane.
> 
>          2.
> 
>             If two neighbors fail simultaneously yet both can be
>             protected by a 3^rd neighbor, per-nbr FRR BIFTs can only
>             give protection for one of the first two neighbors. This is
>             not an unusual situation – you could have two neighbors
>             reached by the same link or the same line card, and the
>             link/card fails.
> 
>          3.
> 
>         Does that mean for each computation, you need to know and mark
>         which failed neighbor that it takes care of, so that when the
>         BIFT is sent down to forwarding plane you can decide if
>         currently used FRR-BIFT can be switched back to the main BIFT?
> 
>          
> 
>          1.
>          2.
>             At moment T+1ms a new BIFT is calculated, which takes care
>             of a remote failure but not nbr X (nbr X is still considered
>             up in this calculation) – would you switch FRR BIFT to the
>             newly calculated main BIFT? If you don’t, the remote failure
>             could lead to packet losses until the new main BIFT is used.
>             If you do, you only get FRR protection for nbr X for 1ms.
> 
>          
> 
>         Jeffrey
> 
>          
> 
>         <mailto:[email-masked]>> *On Behalf Of *Huaimo Chen
>         *To:* Tony Przygienda <[email-masked]
>         <mailto:[email-masked]>>; [email-masked]
>         <mailto:[email-masked]> <[email-masked]
>         <mailto:[email-masked]>>
>         *Cc:* BIER WG <[email-masked] <mailto:[email-masked]>>; BIER WG
>         Chairs <[email-masked] <mailto:[email-masked]>>
>             Michael, Steffan, Huaimo and Mike met to discuss the merge
>         and we are in agreement that if draft-chen-bier-frr is adopted
>         we will expand it to include a framework along with the tunnel
>         and LFA based solutions.
> 
>          
> 
>         Best Regards,
> 
>         Huaimo
> 
>         *From:*BIER <[email-masked]
>         <mailto:[email-masked]>> on behalf of Tony Przygienda
>         <[email-masked] <mailto:[email-masked]>>
>         *To:* zhang.zheng <[email-masked]
>         <mailto:[email-masked]>>
>         *Cc:* BIER WG <[email-masked] <mailto:[email-masked]>>; BIER WG
>         Chairs <[email-masked] <mailto:[email-masked]>>
>         I think it's a good addition within the architecture for the
>         case IGP is not used for signalling, e.g. when controller or
>         static programming.
> 
>          
> 
>         The draft must however explain in what scenarios it is used and
>         quote the according IGP drafts to guarantee loop-free behavior
>         (well, BIER will tie-break loops but we'll have 1x microloop &
>         possibly not deliver payload if BIER FRR is not properly
>         computed/intsalled). With that the draft should also pay
>         attention to how the function is deployed/updated network-wide
>         if IGP is not present
> 
>          
> 
>         thanks
> 
>          
> 
>         -- tony
> 
>          
> 
>             <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.com*2Fv3*2F__https*3A*2Fnam11.safelinks.protection.outlook.com*2F*3Furl*3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F*26data*3D04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000*26sdata*3DDiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D*26reserved*3D0__*3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F*24&data=04*7C01*7Cmichael.mcbride*40futurewei.com*7C1c5fd4db18e2431f463f08d8f39b6caf*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637527196165767516*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=rJEgGwKe3zvhltMwI7v12duGQm*2Bg08Kml*2Bum1SzOUAo*3D&reserved=0__;JSUlJSUlJSUlJSoqKioqKiUlKioqKioqKioqKioqJSUqJSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TgjeaofJrDC7_PaFdp5121nhpqbYPTuvoqq2taHHIFDUiNUmO2r2LHrrnuo6K9DY$>
> 
>             Authors, please respond to the list indicating whether you
>             are aware of any IPR that applies to this draft.
> 
>             Thanks,
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 31 Mar 2021 07:28:12 +0000

Hi Tony,

Merging is great and clear authors list is necessary. I haven’t seen any clue that the current authors are not able to handle this well, especially they have started to work together.
If WG has any specific proposal, it could be discussed in the ML. If they need any further help from WG, I believe they will ask.

Best
Xuesong

From: Tony Przygienda [mailto:[email-masked]]
Sent: Wednesday, March 31, 2021 1:52 PM
To: Gengxuesong (Geng Xuesong) <[email-masked]>
Cc: [email-masked]; Jeffrey (Zhaohui) Zhang <[email-masked]>; BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>; [email-masked] <[email-masked]>; Huaimo Chen <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

On Wed, Mar 31, 2021 at 4:04 AM Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Xuesong, fully acknowledged and originality of ideas overrides all other considerations and has to be documented clearly IME.  Nevertheless, IME as well, merged drafts (a very good thing here) benefit from clear author list and editorship, the earlier in the process the better lest too many feelings are hurt and unseemly wrangling ensues later. Especially, since AFAIS this one ends up being read a lot no matter its status or whether it really standardizes anything on the wire.

--- tony

---

From: <[email-masked]>
Date: Wed, 31 Mar 2021 18:35:55 +0800 (CST)

Hi Michael,

You capture a point that can be optimized. Great.

I agree with you that there are various implementation ways. For example, one way is that the first outgoing packet is sent til the received bitstring is walked completely, that is, before sending the first copy, we can combine multiple outgong bitstrings (steering to the same link) to a single outgoing bitstring. 

Look forward to the merged draft and discuss it further.

Regards,

PSF

原始邮件

发件人：MichaelMenth
收件人：彭少富10053815;zzhang=[email-masked];
抄送人：[email-masked];[email-masked];张征00007940;[email-masked];[email-masked];[email-masked];
日 期 ：2021年03月31日 15:01
主 题 ：Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Dear Peng, all,

 
Kind regards,
 
Michael

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 31 Mar 2021 12:50:54 +0000

Talking about originality and basic respect for the originality of the author:

  1.  When draft-chen was first presented, I pointed out that draft-merling was already there: http://www.youtube.com/watch?v=AuzdpgePomA&t=33m51s and suggested to have a combined draft
  2.  While draft-merling does not talk about LFA based, the authors and some vendors/operator discussed about LFA based FRR back in 2019.  Michael mentioned it in this email https://mailarchive.ietf.org/arch/msg/bier/VRYfB7S7g7xuooIwV9XQDAW56hU/, and it was already covered in their paper https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth20c.pdf (the link was in that email as well).
  3.  Out of respect to Michael/Daniel, from the first presentation of draft-chen to the beginning of this round of discussion, I had been referring to draft-merling and suggested to merge with draft-merling (not the other way)

Thanks.
Jeffrey

Sent: Wednesday, March 31, 2021 1:52 AM

--- tony

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 31 Mar 2021 08:56:42 -0700

Editor is not Author.

On Tue, Mar 30, 2021 at 7:04 PM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

> Of course, if anyone is interested in this topic, he/she could contribute
> and co-author the document, when the existing authors would like to.
>
>
>
> Best
>
> Xuesong
>
>
>
>
>
> *From:* BIER [mailto:[email-masked]] *On Behalf Of *Greg Shepherd
> *Sent:* Wednesday, March 31, 2021 12:11 AM
> *To:* Jeffrey (Zhaohui) Zhang <[email-masked]>
> *Cc:* BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>;
> [email-masked] <[email-masked]>; Huaimo Chen <
> [email-masked]>