Subject: [Bier] Formal complaint about BIER IPv6 work in BIER WG

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Mon, 8 Mar 2021 02:01:23 +0000

Dear Alvaro,

This email is to formally complain about the actions of the BIER WG chairs and secretary on three counts: 1) abuse of authority, 2) fostering bias, 3) exacerbating conflicts when dealing with BIER IPv6 solutions in BIER Working Group.

Background Description
There are 2 competing BIER IPv6 solution documents: draft-xie-bier-ipv6-encapsulation (BIERv6) and draft-zhang-bier-bierin6 (BIERin6). During the past 3 years since the BIER IPv6 topic was raised in the BIER Working Group, one of the WG Chairs and the WG Secretary, as the authors of draft-zhang-bier-bierin6, together with another WG Chair, have blocked the progress of the other document, draft-xie-bier-ipv6-encapsulation, by abuse of authority.

Communication with the WG Chairs
Given the bad situation with the WG chairs and the authors of BIERv6, we do not think to talk with chairs any further is helpful. The relation is too bad and we feel threatened. This is unfortunate and so we cannot continue with them.

Evidence for complaint

1)       Abuse of authority
IETF 107: Ignore WG presentation request and refuse to upload slides
There were only 2 topics on the BIER WG agenda in IETF 107. The authors of the BIER IPv6 requirements document (draft-ietf-bier-ipv6-requirements) requested a time slot to present the progress. The chairs ignored the requirement and refused to upload the slides on the pretext of deferring the discussion to the next interim meeting. However, the WG chairs didn’t arrange another interim meeting and didn’t respond to enquiries about the interim meeting on the mailing list.

Reference: https://mailarchive.ietf.org/arch/msg/bier/Vp7Z235e-B9uo9RHyKX6R2fOKvk/

IETF 108: Lack of time management and the presentation of draft-xie-bier-ipv6-encapsulation was cut-off in the 1st minute
There were 8 topics in a 120 minutes BIER session in IETF 108, which were supposed to end up in 90 minutes based on the agenda. By encouraging a ”thorough” discussion and despite over-running by 15 minutes and ignoring the reminder from the people running meetecho, there was no time left for slides-108-bier-08-bier-encapsulation and the presenter was interrupted by meetecho to close the meeting in the 1st minute. In the face of the discontent of WG members about the situation, one WG chair responded that they were pleased with what had happened and did not offer any apologies.

Reference:       https://datatracker.ietf.org/doc/agenda-108-bier/
https://mailarchive.ietf.org/arch/msg/bier/LWjCh1wgHtcbQapSjbYvep9rTSw/

IETF 109: Interrupt presenters more than 3 times and compress presentation time of draft-xie-bier-ipv6-encapsulation
The WG chairs stated that the discussion of both BIER IPv6 solution should focus on what is updated in the documents.

・         In the presentation of BIERv6:
With plenty of time to spare, the presenter was interrupted by the chairs more than 3 times and rushed to finish presentation in 4 minutes, which was supposed to be finished in 10-15 minutes based on the agenda.

・         In the presentation of BIERin6:
Despite having said that the discussion should focus on what is updated in the document, but the WG chairs allowed this presentation to include misleading information about the existing solutions and unreasonable attacks towards the other solution.

Refer to 1:53 of https://www.youtube.com/watch?v=AuzdpgePomA

After IETF 109: Interfere co-authorship
Exert influence as to who should be primary authors of an individual draft (BIERin6) naming one of the people from the BIERv6 draft. This served to disrupt the BIERv6 team as well as to exert undue influence on the work on individual drafts.

Refer to: https://mailarchive.ietf.org/arch/msg/bier/IoIrg9EFWTMvR2OcmNDND6Oj-Ac/

2)       Fostering Bias
Before IETF 109: Force to replace authors of draft-ietf-bier-ipv6-requirements until put some authors from BIERin6 in the author’s list.
Refer to: https://mailarchive.ietf.org/arch/msg/bier/cD8W5fjNoMmqTmb6Gidr648BdGo/

After IETF 109: Use leading words to influence technical discussions
Refer to: https://mailarchive.ietf.org/arch/msg/bier/6pi4g7acZJa9aj1DEoJoLkYStFQ/

After IETF109: With strong individual technical opinion, help address comments to BIERin6 as WG chair and only respond to discussions relevant to BIERin6;
Refer to: https://mailarchive.ietf.org/arch/msg/bier/im1rf02rpfOhXVvG6Y8xLNzOX48/

IETF 108: Claim “nobody is interested in the document” to block adoption even though more than 80% of the discussion in BIER MLS is about BIER IPv6.
Refer to:
https://www.youtube.com/watch?v=t9AJ16hhmfU

3)       Exacerbating Conflicts
Before IETF108：Tell authors that they are not allowed to request the chairs to consider WG adoption on mailing lists
Refer to:
https://mailarchive.ietf.org/arch/msg/bier/TaTc5EBzb8KXWyD2z8MCLyrNqDs/

Before IETF 110: Start adoption poll on BIERin6 without consideration of BIERv6
With no conclusion of debate of BIER IPv6 requirements and solutions, no acknowledgement of comments in the ML, and no mention of the proposal to adopt both documents as Experimental, the BIER WG chair started a WG adoption poll of BIERin6.

Refer to: https://mailarchive.ietf.org/arch/msg/bier/m3XbUvnHSSj2D2wgbnurzFsoARc/

Requested Action by Area Director
It is requested that the AD discusses the situation with the WG chairs and:
1) Stop BIERin6 WG Adoption Poll
2) Give proper consideration to adopting both solutions as Experimental
3) Allow WG to evaluate BIERv6 and BIERin6 solutions based on technical criteria and implementation status

Thanks
Jingrong

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 8 Mar 2021 09:10:10 -0800

On March 7, 2021 at 9:01:32 PM, Xiejingrong (Jingrong) wrote:

Jingrong:

Hi!  I hope you're doing well.

> This email is to formally complain about the actions of the BIER WG chairs
> and secretary on three counts: 1) abuse of authority, 2) fostering bias, 3)
> exacerbating conflicts when dealing with BIER IPv6 solutions in BIER Working
> Group.

This note is to acknowledge that I received this message (and your
follow-up [1]).

As you know, this is a very busy week.  It will take me several days
to provide the needed attention to your messages -- it may not be
until next week that I can adequately respond.

In the meantime, please refrain from further discussing this topic --
this is a request to everyone in the WG.  Also, I have asked the
Chairs not to take other actions on this topic for now.

Thanks!

Alvaro.

[1] https://mailarchive.ietf.org/arch/msg/bier/SKdbXrm3e4IRfiheBn-QEnUASnE/