Subject: [Bier] bier-frr w/ a single bift

From: Michael Menth <[email-masked]>
Date: Wed, 17 Mar 2021 15:34:49 +0100

Hi all,

one of the advantages of LFA-based bier-frr is that duplicates may be
avoided. However, I think this is only true if we have either

1) failure-spedific bifts (which is not preferred?)

or

2) the possibility to first process BFERs which are affected by a failure

If assumption 2) is acceptable, I think a single-bift draft for all
bier-frr solution is feasible.

Comments?

Regards

Michael

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 17 Mar 2021 15:23:05 +0000

Michael clarified that the "duplicates" does not mean a BFER will receive duplicates, but that a packet may be sent out of a link multiple times - once for normally forwarded traffic and once for FRR'ed traffic. Given that ambiguity, let me call it "redundant" instead.

If the backup branch is the alternative path to the same BFR nbr as in the primary branch, then indeed you could send out redundant copies. If the backup branch is the alternative path to the BFER, and if the backup-nbr's F-BM also includes BFERs whose normal path is through the same nbr, then redundant copy won't happen only if one of the affected BFERs happens to have a lower id than the non-affected BFERs (that go through the same "backup" nbr).

I don't think we need to worry about that redundant copy even if it happens in the latter case (backup branch is an alternative path to the BFER) - it is transient anyway. In other words, condition 2) is not really necessary.

Jeffrey

-----Original Message-----
From: BIER <[email-masked]> On Behalf Of Michael Menth
Sent: Wednesday, March 17, 2021 10:35 AM
To: BIER WG <[email-masked]>
Subject: [Bier] bier-frr w/ a single bift

[External Email. Be cautious of content]

Hi all,

or

Comments?

Regards

Michael

https://urldefense.com/v3/__http://kn.inf.uni-tuebingen.de__;!!NEt6yMaO-gk!QgEyleDd8rFwSesZlYNnOW6nNZZcFvvN00x5qyJv2rIewxMirxNfzN0unVfUToR7$

_______________________________________________
BIER mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!QgEyleDd8rFwSesZlYNnOW6nNZZcFvvN00x5qyJv2rIewxMirxNfzN0unXKTPyhq$

Juniper Business Use Only