Subject: [Bier] FW: New Version Notification for draft-trossen-bier-frrm-00.txt

From: Dirk Trossen <[email-masked]>
Date: Mon, 21 Feb 2022 12:50:14 +0000

Dear all,

I've posted the below draft as a continuation of the efforts that went originally into the draft https://www.ietf.org/archive/id/draft-ietf-bier-multicast-http-response-06.txt. 

The latter draft had originally gone into WGLC and stirred very good discussions recently based on comments from Sandy, Jake, Gyan, Toerless, among others. However, in discussions with the co-authors of this draft, it became clear that this draft would not be pursued by the co-authors. 

Personally from my side, the focus on HTTP (as an application protocol) lowered my interest in pursuing the original draft. As a consequence, I made an attempt to generalize the previous draft around the underlying multicast communication semantic with the intention to allow for its usage beyond just HTTP. The result is the draft below. 

I would hope that this new draft will attract the interest of the wider community, including those who commented on the original HTTP-centric draft, which is why I include the mboned list in this announcement. If you have any interest to work with me on this draft, please drop me an email (and/or indicate on the list for others to see this wider interest). With this, I'd hope we could pursue this topic further and with wider applicability. 

Best,

Dirk

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 21 February 2022 13:38
To: Dirk Trossen <[email-masked]>
Subject: New Version Notification for draft-trossen-bier-frrm-00.txt

A new version of I-D, draft-trossen-bier-frrm-00.txt has been successfully submitted by Dirk Trossen and posted to the IETF repository.

Name:		draft-trossen-bier-frrm
Revision:	00
Title:		Realizing Forward Requests Return Multicast Semantic with BIER
Document date:	2022-02-21
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/archive/id/draft-trossen-bier-frrm-00.txt
Status:         https://datatracker.ietf.org/doc/draft-trossen-bier-frrm/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-trossen-bier-frrm

Abstract:
   This document introduces a semantic for multicast that is based on
   initiating forward requests, resulting in dynamic return multicast to
   the set of initiating clients.  The key dynamic nature here is
   represented in the return multicast being possibly different for
   every transmission.

   We introduce this semantic more formally, present exemplifying use
   cases and then focus on realizing this semantic using BIER
   technology.

   Although this document formally introduces the FRRM semantic as a new
   communication semantic, it does not intend to show the realization of
   it through any other means besides BIER.  This is left for separate
   documents, if desired.

The IETF Secretariat

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 21 Feb 2022 18:17:44 +0100

Thanks, Dirk, well said

I am a bit backlogged with other drafts, but i will be happy to re-join the draft,
especially with content that does include explanations about the BIER benefits to
also other applications, not necessarily only HTTP. Aka: If we overall turn this
from a descriptoin of one particular application which the old draft was, to
a more instructive informational document for more candidate application developers
to use BIER (and its variants ;-), then i think the pain of this evolution will
have been worth it in the end. I hope others here in the WG will also find this
attractive and maybe even are interested to join as co-authors!

Cheers
    Toerless

On Mon, Feb 21, 2022 at 12:50:14PM +0000, Dirk Trossen wrote:
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

-- 
---
[email-masked]